Subject: RE: [PCN] Kwok's notes for Thur 03/22/07 Mtg on PCN WG Initial WorkItems

From: "Georgios Karagiannis" <[email-masked]>
Date: Wed, 4 Apr 2007 15:04:34 +0200

Hi Kwok

A quick comment. Please note that I have volunteered to also work on 
"Flow Admission and Termination Architecture within a 
Diffserv Domain".

Best Regards,
Georgios

> -----Original Message-----
> From: Kwok-Ho Chan [mailto:[email-masked]] 
> Sent: donderdag 29 maart 2007 19:59
> To: [email-masked]
> Subject: [PCN] Kwok's notes for Thur 03/22/07 Mtg on PCN WG 
> Initial WorkItems
> 
> Hi all:
> We held the meeting mentioned (attached original E-Mail) on 
> Thur March 22, 2007 16:30 (Prague time).
> 
> We had a fruitful meeting.
> Please see my meeting notes below for details.
> 
> Please correct/add-to/delete-from the meeting notes as I may 
> have mis-interpreted, missed some points discussed during our meeting.
> 
> Attendees: please check your names+e-mail, I may have made 
> mistakes reading your writing on the attendees sheet.
> 
> We welcome additional volunteers who want to add their name 
> to the volunteers list.
> Thanks!
> -- Kwok --
> 
> 
> Kwok's Notes on the PCN Work Item Meeting on Thur March 22, 
> 2007 @ Prague
> 
> Attendees:
> Kwok Ho Chan ([email-masked]),
> Tina Tsou ([email-masked]),
> Ken Young ([email-masked]),
> Etsushi Ohyama ([email-masked])
> Michael Scharf ([email-masked]),
> Joe Babiarz ([email-masked])
> Shoichi Senda ([email-masked]),
> Ruediger Geib ([email-masked])
> Michael Menth ([email-masked]) (not present but 
> wanted to help)
> Georgios Karagiannis ([email-masked]),
> Philip Eardley ([email-masked])
> Anna Charny ([email-masked]),
> Bob Briscoe ([email-masked])
> Lars Eggert ([email-masked]) (attended the first half)
> 
> 
> Meeting Notes:
> We held this quick meeting for doing a start of the initial 
> PCN WG work items:
> 1. "Flow Admission and Termination Architecture within a 
> Diffserv Domain",
>      Informational RFC, Nov 2007.
> 2. "Survey of Encoding and Transport Choices of 
> (Pre-)Congestion Information
>      within a DiffServ Domain", Informational RFC, Nov 2007.
> 3. "(Pre-)Congestion Detection within a DiffServ Domain", Proposed 
> Standard RFC,
>      Mar 2008.
> 
> 
> Discussion Results: List of volunteers interested to work on this draft:
>    Kwok Ho Chan, Tina Tsou, Ken Young, Joe Babiarz, Ruediger Geib, 
> Micheal Menth,
>    Philip Eardley, Anna Charny
> 
> For "Flow Admission and Termination Architecture within a 
> Diffserv Domain":
> - We want this document to be at a high level, somewhere 
> between the current
>    Problem Statement draft and the CL Arch draft.
> -
> - Action Items:
>    1. Philip Eardley to take architectural sections from the current 
> CL-Arch draft and Problem
>        Statement draft to create the first cut of the new WG work 
> item #1.  This is to be at
>        a high level and should avoid the specific deployment model 
> from the CL-Arch draft.
>    2. Kwok Ho Chan to create the initial Terminology Section for the 
> WG work item #1.
>        During our meeting, we determined we should try to have the 
> terminology be part of
>        the Architecture document to start, and move it to another 
> draft later if we need to.
>        We should try to keep the terminology section short and try to 
> reuse previously defined
>        terms whenever possible.
>    3. The above action items should be completed in April 2007.  All 
> volunteers for WG work
>        item #1 (and others) should review/comment/add-to the 
> first cut version.
> - Goal: We should have the second version (-01) ready for WG review 
> before Chicago (69th) IETF.
> 
> 
> For "Survey of Encoding and Transport Choices of (Pre-)Congestion 
> Information within a DiffServ Domain":
> - Need to have the Chairs clarify the meaning of "Transport Choices" 
> for this WG work item.
>    May want to start by having a discussion of this on the WG list.
> - Need to work closely with Sally Floyd on this.  Need to use Sally's 
> RFC on this topic as guidance.
> - List of volunteers interested to work on this draft:
>    Kwok Ho Chan, Joe Babiarz, Georgios Karagiannis, Anna Charny
> - Action Items:
>    1. Georgios Karagiannis to take the Appendix C of current CL-PHB 
> draft and create the
>        first cut of the new WG work item #2.
>    2. All volunteers for WG work item #2 (and others) should 
> review/comment/add-to the
>        first cut version.
> - Goal: We should at least have the first version (-00) ready for WG 
> review before Chicago (69th) IETF.
> 
> 
> For "(Pre-)Congestion Detection within a DiffServ Domain":
> - We agreed this work item milestone is the hardest one to 
> meet because of the
>    technical complexity and detail work required to execute this work 
> item correctly.
> - During our discussion, we have identified that we may need another 
> draft (a new
>    WG Work Item) for the successful execution of this work item.
>    A draft on Criteria for Comparison of the different methods of 
> "(Pre-)Congestion Detection".
> - Joe Babiarz indicated there is a (Pre)Congestion Admission Control 
> Detection draft
>    (companion to the Explicit Marking (for Flow 
> Termination/Pre-emption) draft) coming.
> - Need to indicate/include dependencies between Detection and 
> Encoding.
> - Action Items:
>    1. Anna Charny to create the first cut of the "Criteria for 
> Comparing Detection Methods" draft.
>        Each methods' authors will provide Anna with list of criteria 
> each thinks is needed.
>        I think someone called this the "beauty contest rules" 
> draft.  :)
>        Goal: Have at least the first version (-00) of this new draft 
> ready before the Chicago (69th) IETF.
>    2. All "(Pre-)Congestion Detection Method" authors should continue 
> to improve on their individual
>        drafts.
>    3. Geogios Karagiannis, Shoichi Senda, and others may want to 
> consider adding other
>        Detection Method drafts.
> - Goal: Get the process started early for this difficult milestone.
> 
> End of Kwok's Notes on the PCN Work Item Meeting on Thur March 22, 
> 2007 @ Prague.
> 
> 
> At 12:18 AM 3/21/2007, Kwok-Ho Chan wrote:
> >Hi all:
> >Since the Monday PCN WG session at Prague IETF, couple of people
> >have approached me informally on the hall way, during breaks, etc,
> >indicated they would like to help in the PCN work items.
> >
> >I have talked to Steven (but did not get a chance to talk to 
> Scott yet)
> >on holding a quick meeting while most of us are at Prague,
> >to get the work on the first couple of PCN WG work items started.
> >Steven have given his support on this.
> >
> >Hence how about a quick meeting:
> >When:   Wed March 21, 2007  16:30 (20 minutes into the cookie break)
> >Where:  IETF Registration Desk
> >
> >This will give us half an hour to talk before Plenary starts.
> >Notice we may overflow into the Plenary if necessary.
> >
> >The topic will be to get a good sense on who wants to do what and
> >how we may divide and focus on the different pieces.
> >
> >For people who can not attend, please send mail to the PCN list, 
> >Chairs, or myself
> >if you choose to, on your interest and what, how you may 
> want to help.
> >
> >Thank you for all the energy and interest and hope to see you at the 
> >quick meeting
> >indicated above.
> >-- Kwok --
> >
> >
> >
> >
> >
> >_______________________________________________
> >PCN mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/pcn
> 
> 
> _______________________________________________
> PCN mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pcn
> 

_______________________________________________
PCN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pcn

---

From: "Kwok-Ho Chan" <[email-masked]>
Date: Wed, 04 Apr 2007 10:43:50 -0400

Georgios:
Sorry that I have missed it in my notes.  Please accept my apology.
As I was trying to listen, think, take notes, and maybe talk simultaneously
(some modes of time-slice :).
I will correct it.
Thanks!
-- Kwok --

---

From: "Tina TSOU" <[email-masked]>
Date: Thu, 26 Apr 2007 15:12:34 +0200

Hi Guys,
I thought about "Upgrade/Downgrade" QoS these days.
Downgrade QoS: "NGN be capable, in certain conditions, to change or 
"degrade" the current QoS enforcement settings associated with an ongoing 
reservation in order to admit new flows beyond the available QoS levels."
In PCN, besides admission control, there is pre-emption, to cast off 
selectively the existing service packet in the edge node. 
 "Upgrade/Downgrade" is a good QoS control mechanism.
Does someone have similar thought as I do?

B. R.
Tina
Messengers:
MSN: [email-masked]   Yahoo: tina_tsou    Skype: tinaTSOU    Jabber: 
[email-masked]    Google talk: [email-masked]

---

From: "Jozef Babiarz" <[email-masked]>
Date: Thu, 26 Apr 2007 09:58:03 -0400

Tina, 
Yes, PCN can be used to do other things besides flow block and flow
termination. However, the current scope of the PCN WG as stated in our
charter is to focus on two reactions mechanisms, admission control and
flow termination. The Upgrade/Downgrade concept can be brought for
consideration when the WG re-charters. 

Regards, Joe
email:[email-masked]
Telephone:613-763-6098
-----Original Message-----
From: Tina TSOU [mailto:[email-masked]] 
Sent: April 26, 2007 9:13 AM
To: [email-masked]
Subject: [PCN] Upgrade/Downgrade QoS

Hi Guys,
I thought about "Upgrade/Downgrade" QoS these days.
Downgrade QoS: "NGN be capable, in certain conditions, to change or 
"degrade" the current QoS enforcement settings associated with an
ongoing 
reservation in order to admit new flows beyond the available QoS
levels."
In PCN, besides admission control, there is pre-emption, to cast off 
selectively the existing service packet in the edge node. 
 "Upgrade/Downgrade" is a good QoS control mechanism.
Does someone have similar thought as I do?

B. R.
Tina
Messengers:
MSN: [email-masked]   Yahoo: tina_tsou    Skype: tinaTSOU
Jabber: 
[email-masked]    Google talk: [email-masked]

---

From: "Wei Gengyu" <[email-masked]>
Date: Thu, 26 Apr 2007 22:13:15 +0800

I think that people often pay what they want;
sometimes, they pay what they have got.

If the QoS is what they want, the network should guarantee that.
And if the QoS is paid by what they have got, downgrade QoS may work. 

Regards, 

Gengyu

---

From: Fred Baker <[email-masked]>
Date: Thu, 26 Apr 2007 10:07:56 -0700

On Apr 26, 2007, at 6:12 AM, Tina TSOU wrote:

> In PCN, besides admission control, there is pre-emption, to cast  
> off selectively the existing service packet in the edge node.  

Not all networks allow preemption. For civilian networks in the  
United States, you will want to not allow the data flow in, not shut  
it down after it has occurred.

Also, while some networks (I'm thinking radio, including 802.11)  
change rates dynamically and so might change their admission  
parameters dynamically, in the general case I would expect admission  
parameters to remain stable. The thing that is likely to happen in  
which sessions degrade is the thing that stopped Morita-san's  
Priority Promotion Scheme

    http://www3.ietf.org/proceedings/03jul/slides/tsvwg-2.pdf
    http://tools.ietf.org/id/draft-morita-tsvwg-pps

He wanted to use this scheme for both voice and video in the NTT  
network. For rate-variable video like MPEG-4, he found that it was  
very possible to have the video stream accepted during a relatively  
quiet period, and at a commercial break has bandwidth usage across  
all channels simultaneously jump by an order of magnitude, which had  
some pretty serious consequences.

---

From: "Geib, Ruediger" <[email-masked]>
Date: Fri, 27 Apr 2007 08:40:59 +0200

Tina,

to my understanding PCN delivers a trigger to indicate some state of approaching or existing congestion. Whether an operator interprets such a trigger as "start preemption" or as "start downgrade to best effort" may be up to him (and to the technical capabilities of the operated equipment).

Demotion to best effort would enable interesting business models. A service provider could claim to support QoS and limit each links PCN resources to a couple of kbit/s. The quality demotion during "congestion" could be covered in a contracts small print. 
This mode of operation can't be adopted easily, if the reaction on a congestion indication is a busy sign. But in the end, decisions like that are up to the providers operating services.

Regards,

Ruediger

|-----Original Message-----
|From: Tina TSOU [mailto:[email-masked]]
|Sent: Thursday, April 26, 2007 3:13 PM
|To: [email-masked]
|Subject: [PCN] Upgrade/Downgrade QoS
|
|
|Hi Guys,
|I thought about "Upgrade/Downgrade" QoS these days.
|Downgrade QoS: "NGN be capable, in certain conditions, to change or 
|"degrade" the current QoS enforcement settings associated with 
|an ongoing 
|reservation in order to admit new flows beyond the available 
|QoS levels."
|In PCN, besides admission control, there is pre-emption, to cast off 
|selectively the existing service packet in the edge node. 
| "Upgrade/Downgrade" is a good QoS control mechanism.
|Does someone have similar thought as I do?
|
|B. R.
|Tina
|Messengers:
|MSN: [email-masked]   Yahoo: tina_tsou    Skype: 
|tinaTSOU    Jabber: 
[email-masked]    Google talk: [email-masked] 
|
|
|
|_______________________________________________
|PCN mailing list
[email-masked]
|https://www1.ietf.org/mailman/listinfo/pcn
|