Subject: [pcp] AD review of draft-ietf-pcp-base (part 1)

From: Jari Arkko <[email-masked]>
Date: Mon, 30 Jan 2012 17:14:57 +0200

I have reviewed the first part of this draft, up until about page 30. Here are  my comments:

In general, I have found that the spec is very well written and I found no technical issues. It was a pleasure to read, and while I made some notes as I read it on, I was mostly able to delete my notes as I found the answers later. Thank you for writing this well.

Technical:

None

Editorial:

>    Checking nits according to http://www.ietf.org/id-info/checklist :
>    ----------------------------------------------------------------------------
>
>    == There are 2 instances of lines with non-RFC5735-compliant IPv4 addresses
>       in the document.  If these are example addresses, they should be changed.
>
>    == There are 2 instances of lines with multicast IPv4 addresses in the
>       document.  If these are generic example addresses, they should be changed
>       to use the 233.252.0.x range defined in RFC 5771
>
>
>    Miscellaneous warnings:
>    ----------------------------------------------------------------------------
>
>    == Line 1260 has weird spacing: '...nternal  exter...'

Please check these.

>   Each error code below is classified as either a 'long
>     lifetime' error or a 'short lifetime' error, which provides guidance
>     to PCP server developers for the value of the Lifetime field for
>     these errors.  It is RECOMMENDED that short lifetime errors use a 30
>     second lifetime and long lifetime errors use a 30 minute lifetime.
>
>     0  SUCCESS: Success.
>
>     1  UNSUPP_VERSION: Unsupported protocol version.
>
>     2  NOT_AUTHORIZED: The requested operation is disabled for this PCP
>        client, or the PCP client requested an operation that cannot be
>        fulfilled by the PCP server's security policy.  This is a long
>        lifetime error.
>
>     3  MALFORMED_REQUEST: The request could not be successfully parsed.
>
>     4  UNSUPP_OPCODE: Unsupported Opcode.
>
>     5  UNSUPP_OPTION: Unsupported Option.  This error only occurs if the
>        Option is in the mandatory-to-process range.
>
>     6  MALFORMED_OPTION: Malformed Option (e.g., appears too many times,
>        invalid length).
>
>     7  NETWORK_FAILURE: The PCP server or the device it controls are
>        experiencing a network failure of some sort (e.g., has not
>        obtained an External IP address).  This is a short lifetime error.
>

The error codes have not all been categorized to short/long. Please clarify.

>     For as long as the client still desires the indicated mapping, if no
>     response is received before the timer expires then the request is re-
>     transmitted and the timer is doubled (to 4 seconds).

The last part should be "... first to 4 seconds ...", I think.

Jari

---

From: Dave Thaler <[email-masked]>
Date: Mon, 30 Jan 2012 17:50:25 +0000

> >    == Line 1260 has weird spacing: '...nternal  exter...'

Please see (1.g) of the PROTO writeup.

-Dave

---

From: Jari Arkko <[email-masked]>
Date: Tue, 31 Jan 2012 01:59:50 +0200

Dave,

> Please see (1.g) of the PROTO writeup.

Ok, good.

Jari

---

From: Jari Arkko <[email-masked]>
Date: Tue, 31 Jan 2012 03:20:04 +0200

I am continuing with my review, and have read until about page 50. I have no suggested improvements at this point.

I will complete the last part of the review tomorrow.

Jari