Subject: [pcp] I-D.ietf-pcp-base needs UNSAF Consideration, c.f. RFC 3424

From: james woodyatt <[email-masked]>
Date: Mon, 13 Aug 2012 14:33:22 -0700

everyone--

In every usage scenario other than the RFC 6092 IPv6 Simple Security one, Port Control Protocol (PCP) is an UNSAF system, according to the terminology in RFC 3424.

The predecessor specification to the PCP Base draft, the NAT Port Mapping Protocol [I-D.cheshire-nat-pmp], has three pages of UNSAF Considerations in Section 4, and I don't understand why the PCP Base draft doesn't contain a similar section.

Was this an oversight, or is it a deliberate omission?  Was there a discussion on the list leading up to a working group decision to omit the UNSAF Considerations section from the draft?  If so, then I would like to review that discussion for my own personal edification.

--
james woodyatt <[email-masked]>
member of technical staff, core os networking

---

From: Sam Hartman <[email-masked]>
Date: Tue, 14 Aug 2012 14:46:33 -0400

>>>>> "james" == james woodyatt <[email-masked]> writes:
    james> The predecessor specification to the PCP Base draft, the NAT
    james> Port Mapping Protocol [I-D.cheshire-nat-pmp], has three pages
    james> of UNSAF Considerations in Section 4, and I don't understand
    james> why the PCP Base draft doesn't contain a similar section.

I don't know how this came about.
However as a matter a process, I don't think it appropriate to add this
to the PCP base spec nor hold up the PCP base spec for this issue post
iesg-review.
If you brought this up as an IETF last call comment, a WGLC comment or
earlier, I'd probably agree we should address it.

However as specs get more and more done I think the bar for changes
needs to get higher and higher.  I mean I guess someone could file an
appeal based on that issue and the IESG would have to consider such an
appeal.  However I'd suggest a more constructive approach than either
appealing the approval of the base spec when it happens or delaying the
base spec would be to write up a draft about UNSAF considerations for
PCP and see if people are interested in publishing it.

--Sam

---

From: james woodyatt <[email-masked]>
Date: Tue, 14 Aug 2012 13:21:23 -0700

On Aug 14, 2012, at 11:46 , Sam Hartman <[email-masked]> wrote:
> 
> I don't know how this came about. However as a matter a process, I don't think it appropriate to add this to the PCP base spec nor hold up the PCP base spec for this issue post iesg-review.

Concur.  I'm just interested in finding out how the UNSAF considerations section, which appeared in the predecessor specification, was omitted from the PCP base draft.

Was there a discussion about it, or did it happen without discussion?  Whatever the case, I'm thinking the story about how it happened should be brought to the attention of IAB with a request to consider moving RFC 3424 to Historic.