Subject: [plasma] S/MIME for document control

From: Phillip Hallam-Baker <[email-masked]>
Date: Fri, 4 Feb 2011 11:03:08 -0500

I have been thinking for a while that S/MIME is probably less useful as a
mail security feature as a document security feature.

Imagine that I could tag a file from Word or Excel with a security policy so
that it woud be automatically saved in an encrypted CMS package with
decryption keys for both me and a document server.

That would be the best way to make sure that the document is encrypted
end-to-end which these days means securing the document in the end point
mobile device as at least as great a priority as on the wire.

There are CMS systems for inside enterprises, but use seems to be marginal
at best and the most interesting/confidential documents in a commercial
environment are almost exclusively those that have to be passed to other
companies to fullfil their function. I.e. the ones exchanged with lawyers,
customers etc. Even patient records need to be exchanged with specialists
from other hospitals.

There is a relevant patent that covers the efficient way to do this -
http://www.freepatentsonline.com/5481613.html, issued in 1994. Currently
assigned to Entrust I believe. Thats only three years and a few months.

-- 
Website: http://hallambaker.com/

---

From: Trevor Freeman <[email-masked]>
Date: Fri, 4 Feb 2011 18:01:01 +0000

Hi Phil,

I think document or files are a good direction to go as an extension of the work. Ultimately the goal is to be able to provide consistent policy enforcement of polices on information regardless where that information is in email or in a file. As a byproduct we have to be able to use a much broader set of credential types e.g. this must work if the user just has a password.  The motivation to split the WS-trust piece out was that it can be reused for other scenarios such as document protection. We have discussed drafting how to use CMS with OPC which would deliver both generic file protection as well as cover the major document format standards. We felt stating with email was a good first step. There are a lot of scenarios playing out today where email would be the logical chose IF it could deliver higher assurance on the privacy front. My bank cannot send be my statement via email, nor can my doctor send me test results.

Just protecting documents and files is not a good paradigm. Users would have to understand that the information they type in the message was insecure but the information in the attachment was secure. That is way too much of a leap of trust in the user. If we start with email they that will cover the attachments which makes things better than they are today. If we have enough volunteers to draft specs we can look to add documents and files using the same approach sooner rather than later. We need to get the first set of deliverables underway before we extend the scope.

Trevor

From: [email-masked] [mailto:[email-masked]] On Behalf Of Phillip Hallam-Baker
Sent: Friday, February 04, 2011 8:03 AM
To: [email-masked]
Subject: [plasma] S/MIME for document control

I have been thinking for a while that S/MIME is probably less useful as a mail security feature as a document security feature.

Imagine that I could tag a file from Word or Excel with a security policy so that it woud be automatically saved in an encrypted CMS package with decryption keys for both me and a document server.

That would be the best way to make sure that the document is encrypted end-to-end which these days means securing the document in the end point mobile device as at least as great a priority as on the wire.

There are CMS systems for inside enterprises, but use seems to be marginal at best and the most interesting/confidential documents in a commercial environment are almost exclusively those that have to be passed to other companies to fullfil their function. I.e. the ones exchanged with lawyers, customers etc. Even patient records need to be exchanged with specialists from other hospitals.

There is a relevant patent that covers the efficient way to do this -  http://www.freepatentsonline.com/5481613.html, issued in 1994. Currently assigned to Entrust I believe. Thats only three years and a few months.