Subject: RE:

From: [email-masked]
Date: Mon, 3 Jan 2000 15:54:10 -0500

Spelling "raleigh" correctly this time....

Regards,
Bob

Bob Moore
IBM Networking Software
+1-919-254-4436
[email-masked]

---------------------- Forwarded by Robert Moore/Raleigh/IBM on 01/03/2000
03:53 PM ---------------------------

Robert Moore
01/03/2000 03:52 PM

To:   [email-masked]
cc:   [email-masked]
From: Robert Moore/Raleigh/IBM@IBMUS
Subject:

John,

> 5. PolicyInstance. This will be corrected, per the mail list discussion,
to
> include a structural policyInstance class that inherits from the abstract
> Policy class, as well as two structural classes, policyConditionInstance
and
> policyActionInstance. It will also leave room for defining additional
> policySomethingElseInstance classes from the ppolicyInstance class in the
> future, if we need to.

Just to make sure I'm not missing something, this item from your "ed
hamlin"
note applies only to the LDAP version of the Core Policy Schema, right?  So
there's nothing I need to do about it for the update to the Information
Model
document.

Thanks.

Regards,
Bob

Bob Moore
IBM Networking Software
+1-919-254-4436
[email-masked]

---

From: "Yoram Snir" <[email-masked]>
Date: Tue, 4 Jan 2000 10:38:02 +0200

Bob
In order to keep the model consistent, please keep the PolicyInstance
definition as it was in previously, i.e., extending the Policy class.

A question regarding the policyRuleConditionAssociation and
policyRuleActionAssociation definition, why is the policyConditionName,
policyActionName, respectively,  attributes defined? why are they MUST
attributes?
There are cases when an ad-hoc (not reusable) condition will be name less.

The Policy class supplies a naming attribute (CN) as a MAY attribute, and it
seems to be enough since Policy is the superior class of
policyRuleConditionAssociation, policyRuleActionAssociation, PolicyInstance,
policyActionInstance, policyConditionInstance.

If the idea is that reusable object must have a name and we want to enforce
this via the schema, then I would suggest that the policyActionInstance,
policyConditionInstance will have a single MUST attribute that is the CN.

Thanks.

Yoram Snir
Cisco Systems
Tel.   972-9-9700085
Mobile 972-54-970085

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of [email-masked]
> Sent: Monday, January 03, 2000 10:54 PM
> To: [email-masked]
> Subject:
>
>
>
>