Subject: RE:

From: [email-masked]
Date: Wed, 5 Jan 2000 10:51:39 -0500

Hi Yoram,

See my responses below.

Regards,
Bob

Bob Moore
IBM Networking Software
+1-919-254-4436
[email-masked]

"Yoram Snir" <[email-masked]> on 01/04/2000 03:38:02 AM

Please respond to <[email-masked]>

To:   Robert Moore/Raleigh/IBM@IBMUS, <[email-masked]>, "John
      Strassner (E-mail)" <[email-masked]>
cc:
Subject:  RE:

Bob
In order to keep the model consistent, please keep the PolicyInstance
definition as it was in previously, i.e., extending the Policy class.
<Bob>
Yes, that's what I was intending to do when I get back to the LDAP Core
Schema document.  Currently, though, that document is in a holding
pattern, waiting for the Core Info Model document to land first.
</Bob>

A question regarding the policyRuleConditionAssociation and
policyRuleActionAssociation definition, why is the policyConditionName,
policyActionName, respectively,  attributes defined? why are they MUST
attributes?
There are cases when an ad-hoc (not reusable) condition will be name less.

The Policy class supplies a naming attribute (CN) as a MAY attribute, and
it
seems to be enough since Policy is the superior class of
policyRuleConditionAssociation, policyRuleActionAssociation,
PolicyInstance,
policyActionInstance, policyConditionInstance.

If the idea is that reusable object must have a name and we want to enforce
this via the schema, then I would suggest that the policyActionInstance,
policyConditionInstance will have a single MUST attribute that is the CN.
<Bob>
I have no problem with downgrading the policy*Name attributes to MAY in
all four of these structural classes, so that an instance that's named with
CN doesn't need to have the policy*Name attribute at all.  Does anybody
else see a problem with this change?
</Bob>

Thanks.

Yoram Snir
Cisco Systems
Tel.   972-9-9700085
Mobile 972-54-970085

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of [email-masked]
> Sent: Monday, January 03, 2000 10:54 PM
> To: [email-masked]
> Subject:
>
>
>
>
> Spelling "raleigh" correctly this time....
>
> Regards,
> Bob
>
> Bob Moore
> IBM Networking Software
> +1-919-254-4436
> [email-masked]
>
>
> ---------------------- Forwarded by Robert Moore/Raleigh/IBM
> on 01/03/2000
> 03:53 PM ---------------------------
>
> Robert Moore
> 01/03/2000 03:52 PM
>
> To:   [email-masked]
> cc:   [email-masked]
> From: Robert Moore/Raleigh/IBM@IBMUS
> Subject:
>
>
> John,
>
> > 5. PolicyInstance. This will be corrected, per the mail
> list discussion,
> to
> > include a structural policyInstance class that inherits
> from the abstract
> > Policy class, as well as two structural classes,
> policyConditionInstance
> and
> > policyActionInstance. It will also leave room for defining
> additional
> > policySomethingElseInstance classes from the
> ppolicyInstance class in the
> > future, if we need to.
>
> Just to make sure I'm not missing something, this item from your "ed
> hamlin"
> note applies only to the LDAP version of the Core Policy
> Schema, right?  So
> there's nothing I need to do about it for the update to the
> Information
> Model
> document.
>
> Thanks.
>
> Regards,
> Bob
>
> Bob Moore
> IBM Networking Software
> +1-919-254-4436
> [email-masked]
>
>
>
>
>
>

---

From: "Yoram Snir" <[email-masked]>
Date: Wed, 5 Jan 2000 18:37:22 +0200

Thanks.

Yoram Snir
Cisco Systems
Tel.   972-9-9700085
Mobile 972-54-970085 

> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, January 05, 2000 5:52 PM
> To: [email-masked]
> Cc: [email-masked]; John Strassner (E-mail)
> Subject: RE:
> 
> 
> 
> 
> Hi Yoram,
> 
> See my responses below.
> 
> Regards,
> Bob
> 
> Bob Moore
> IBM Networking Software
> +1-919-254-4436
> [email-masked]
> 
> 
>