Subject: RE: Policy issues: definition of Roles

From: Francis Reichmeyer -NJ <[email-masked]>
Date: Fri, 28 Jan 2000 12:57:21 -0500

Hi Jon,

> 
> I like Shai's definition, with one minor tweak:
> 
> > "A Role represent an attribute of a network node or an interface
> > that reflect physical or logical functionality. Those 
> attribute may be
> > used by policy systems to determine the appropriate policy that
> > should be constructed for that node or interface."
> >
> Or :
> "A Role represents an attribute of a network element that 
> reflects physical
> or logical functionality...should be constructed for that 
> network element."
> An element could be as low level as an interface or as high level as a
> firewall.  In fact, it seems that a high level role could be 
> defined by an
> aggregation of role combinations.

With regards to your tweak:
By "high level role" do you mean a role that represents what you are
calling a high level element or are you implying there are different
types of roles: low level and high level, plus role combinations?

Thanks,
-Fran

---

From: "Jon Sjoberg" <[email-masked]>
Date: Fri, 28 Jan 2000 13:17:05 -0500

Sorry, mixed my terms.

By "high level role" I meant a complex role.  It occurs to me that we talk
about general roles such as "security" and "QoS", but these could actually
be composites of more specific roles.  So "security" could be a composite of
roles such as "Intrusion Detection", "Authentication", "Authorization",
"Traffic Filter", etc.  The role of "QoS" could likewise contain composites,
including "Traffic Filter".

Just a thought.

> -----Original Message-----
> From: Francis Reichmeyer -NJ [mailto:[email-masked]]
> Sent: Friday, January 28, 2000 12:57 PM
> To: 'Jon Sjoberg'; Shai Herzog - NJ; Jon Saperia; Weiss, Walter
> Cc: [email-masked]
> Subject: RE: Policy issues: definition of Roles
>
>
> Hi Jon,
>
> >