Subject: RE: Why is there no week of month facility in policyTimePeriodCon ditionAuxClass?

From: [email-masked]
Date: Wed, 1 Mar 2000 11:44:15 -0500

> More clearly understandable may be the business case for:
>
>        The first weekday of a month
>
> I think this would entail an evaluation such as:
>
>        ((day = Monday) AND (monthdate <=3)) OR
>         ((Tuesday <= day <= Friday) AND (monthdate = 1))
>
>Is there any way of expressing and evaluating this using
>the standard attributes?

Yes, but it will require two instances of the
PolicyTimePeriodCondition class (which are ORed together):

PtpCondition1:
  DayOfWeekMask = { Monday }
  DayOfMonthMask = { 1,2,3 }

PtpCondition2:
  DayOfWeekMask = { Tuesday, Wednesday, Thursday, Friday }
  DayOfMonthMask = { 1 }

Regards,
Bob

Bob Moore
IBM Networking Software
+1-919-254-4436
[email-masked]

---

From: "David Lowndes" <[email-masked]>
Date: Fri, 3 Mar 2000 10:56:23 -0000

<

In an application that doesn't expose individual time period conditions that
may be a solution, but I can't help feeling it would be very difficult to
present in a usable manner to a user.

However, in our application we want to expose each time period condition to
the user, so having 2 conditions for what a user perceives as 1 condition
isn't an option.

Does anyone have any thoughts on extending the schema class definition to
allow these real-world business periods to be expressed in a single
condition object?

David Lowndes