Subject: RE: Core Model Last Call Issue: Execution Semantics

From: Andrew Smith <[email-masked]>
Date: Tue, 18 Apr 2000 11:15:27 -0700

Right, so that section of the QoS PIM has nothing (or very little) to do
with QoS: either this is a general problem (move Yoram's text to the core
model) or it is not a problem (remove the text completely and save it for a
rainy day when we realise we need it again). Otherwise we have 2 documents
that are inconsistent and that just reflect the differing opinions of their
authors, rather than an IETF rough consensus (JohnSt - your name is on both
docs!).

Please fix this inconsistency (this message directed at the WG, not at you
Yoram).

Andrew

> -----Original Message-----
> From: Yoram Snir [mailto:[email-masked]]
> Sent: Tuesday, April 18, 2000 1:29 AM
> To: 'Andrew Smith'
> Cc: [email-masked]
> Subject: RE: Core Model Last Call Issue: Execution Semantics
...
> Maybe, the QoS PIM clearly defines a consistent model of 
> decision making.
> Quating from the QoS PIM: ( I am sorry for the length of the 
> section but it
> covers the whole subject and include examples that clear up 
> the relevant
> issues)
> 
> -------------- From the QoS PIM ---------------
> Section 3.2.4:
> "Each policy container is assigned a "match strategy", which is a name
> of a method to interpret the order of its rules (see section 1.2.1.5).
> For example, a FirstMatch strategy means that the rules will be
> "matched" according to ascending order of their Priority attribute.
> Decision strategy is explained in section 5."
>

---

From: "John Strassner" <[email-masked]>
Date: Tue, 18 Apr 2000 22:58:09 -0700

Hi Andrew,

it actually is NOT inconsistent at all. The WG had decided
that for the generic policy case, they did NOT want these
additional semantics. In fact, some people wanted the
ability to say "evaluate this (third) set of policy rules
after this (first) set before this other (second) set."

So the PCIM strove to be as general as possible. This was
NOT suitable for the application-specific constraints of QoS
Policies, so we added this information in the QoS PIM.

regards,
John

---

From: "Yoram Snir" <[email-masked]>
Date: Mon, 24 Apr 2000 14:10:48 +0200

I tend to agree with John on this.
The current situation is not inconsistent. There is no inconsistency between
the PCIM and the QOSIM.
The generality of the PCIM has strengths and weaknesses and it is up to
specific domains to extend it to cover for these weaknesses, as the QOSIM
has done.
In order to preserve the applicability of PCIM to different domains we
should not restrict it but keep it general.
IMO, the PCIM should be an RFC as soon as possible in its current state.

Yoram Snir
Cisco Systems
Tel.   972-9-9700085
Mobile 972-54-970085

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of John Strassner
> Sent: Wednesday, April 19, 2000 7:58 AM
> To: Andrew Smith; [email-masked]
> Subject: Re: Core Model Last Call Issue: Execution Semantics
>
>
> Hi Andrew,
>