Subject: Re: Policy Information Model for MPLS Traffic Engineering

From: Ritu Chadha <[email-masked]>
Date: Tue, 18 Jul 2000 11:16:01 -0400 (EDT)

Tom,

>         Hi,
>
>>The definition of such policy information models is the
>>whole raison d'etre of the Policy Framework WG. The following
>>snippet from "Requirements for a Policy Management System",
>>draft-ietf-policy-req-01.txt,
>>summarizes the need for a standardized common information model:
>
>         I thought that the purpose of the MPLS WG was to define
>protocols (and MIBs to manage them) not policy, but I may be
>mistaken here. ;) I can understand holding topological information
>or such network-wide things, but the inclusion of other information
>into this standard object model seems redundant, doesn't it?
>Isn't this why we have the MIBs and PIBs? That is, to define
>what is manageable, and how some of those managed objects are
>provisioned via a defined policy?  Why should we spend time
>defining an object model which has basically already been
>defined for MPLS?
>
>         --Tom

You may be right about this work not belonging to the MPLS WG.
It may fit more naturally into the Policy WG. However, I thought
it was appropriate to cross-post to both mailing lists because
(a) we need to get feedback from the MPLS WG since that's where the
subject matter experts are; and (b) there was a discussion about
policy at the MPLS meeting in Adelaide where people agreed that
MPLS policy work was of interest to this WG (this was during 
S. Wright's presentation of draft-wright-policy-mpls-00.txt).
George Swallow stated that policy and MPLS are two things 
that have a lot in common and therefore was worth working on. 
The consensus in the WG seemed to be that contributions in 
this area should be brought to the MPLS WG. 
  
Ritu

---

From: "Steven Wright" <[email-masked]>
Date: Tue, 18 Jul 2000 12:07:34 -0400

Sending the information model to both groups seems the right thing to do for
now,
as both groups need some understanding of the progress of the work.

I look forward to some interesting discussions in Pittsburgh on the
appropriate scope of mpls working group documents related to the mpls policy
topic.

my 2c opinion - anything mpls specific belongs in the mpls wg, anything
policy generic belongs in the policy wg. crosspost the stuff in the middle
until we get some stable (RFC) documents to reference.

regards
Steven Wright

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of Ritu
> Chadha
> Sent: Tuesday, July 18, 2000 11:16 AM
> To: [email-masked]; [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked];
> [email-masked]
> Subject: Re: Policy Information Model for MPLS Traffic Engineering
>
>
> Tom,
>
> >         Hi,
> >

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 18 Jul 2000 13:31:42 -0400

Hi,

         I just want to add my 2 cents here. First, I
agree as I have all along, that this stuff does not belong
in the MPLS WG. Second, there is a BOF in Pittsburgh which
is designed specifically to coordinate the specification
of object models (for policy or otherwise). The BOF
is called Network Information Modeling (NIM). You
can join the discussion list by sending email to
[email-masked]  I believe that Walter Weiss
is coordinating the BOF.

         --Tom

>There's a problem with sound bites.  I also said that I didn't think
>the work belonged in MPLS.
>
>I didn't agree with this consensus because the request was too general
>and thus overlaps with other work groups.  Though our revised charter
>is still being worked out with the IESG, there will be no general
>policy item in it.  If specific items are needed in RSVP, LDP and
>CR-LDP to glue things together, these are appropriate.
>
>Given that the MPLS agenda is tight, I would like both
>
>   draft-chadha-policy-mpls-te-00.txt
>   draft-isoyama-policy-mpls-info-model-00.txt
>
>present only in the policy wg.
>
>...George
>
>
>==================================================================
>George Swallow       Cisco Systems                   (978) 244-8143
>                      250 Apollo Drive
>                      Chelmsford, Ma 01824