Subject: Policy Description Language?

From: Morris Sloman <[email-masked]>
Date: Mon, 10 Jul 2000 13:04:32 +0100

>From: Dave Kosiur <[email-masked]>
>To: Policy Mailing List <[email-masked]>
>Subject: Policy Description Language?
>Date: Sun, 9 Jul 2000 13:47:16 -0600
>Mime-Version: 1.0
>X-Mailer: Internet Mail Service (5.5.2650.21)
>Content-Type: text/plain
>Sender: [email-masked]
>Precedence: bulk
>Reply-To: Dave Kosiur <[email-masked]>
>Status:
>
>What, if any, work has been done on defining a PDL for describing and
>exchanging policies between policy-based systems? I know Strassner had
>submitted an internet draft more than a year ago, but I'm not aware of
>anything since. Is some form of XML going to be the answer?
>
>Dave

We have defined Ponder - a declarative, object-oriented language for 
specifying Management and security policies.

see  http://www-dse.doc.ic.ac.uk/policies/ponder.html

We are working on an XML back-end

There has been some discussions,  with some members in the group,  on using 
this language.

Morris Sloman
__________________________________________________
**** Note new phone numbers

Professor Morris Sloman
Imperial College of Science Technology and Medicine
Department of Computing
180 Queen's Gate
London SW7 2BZ, U.K.
Phone: +44 20 7594 8279    Fax: +44 20 7581 8024
Email: [email-masked]
WWW: http://www-dse.doc.ic.ac.uk/~mss

---

From: "sheri li" <[email-masked]>
Date: Mon, 10 Jul 2000 15:00:18 PDT

Suppose there is a XML DTD defined for Policy Description Language. What 
would ponder provide more than a XML DTD could to policy definition and 
validation? Thanks.

Sheri Li
Aventail Corp.

>From: Morris Sloman <[email-masked]>
>Reply-To: Morris Sloman <[email-masked]>
>Date: Mon, 10 Jul 2000 13:04:32 +0100
>
>

________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com