Subject: RE: QDIM issue: the SchedulingService classes

From: "Weiss, Walter" <[email-masked]>
Date: Mon, 21 Aug 2000 13:40:27 -0400

Bob,
> 
> Here's the fundamental issue we need to resolve:
> 
> -- Bob:
> >> An instance of any of the scheduling service classes
> >> represents a scheduler, which is a component that
> >> services a set of queues according to the parameters
> >> of some scheduling algorithm.

This is where the real problem is. All the parameters for the scheduler
apply to specific individual instances of particular queues. However, they
are parameters of the scheduler, not the queue, and not the binding of the
queue and scheduler.

> >> A priority scheduler
> >> services queues based on static priority values
> >> associated with each queue.
> >
> --Walter:
> >This is a slightly inaccurate description. Each Scheduling Service
> instance represents >the scheduling parameters associated 
> with a single
> queue. The bandwidth scheduler >determines that a single 
> queue is entitled
> to. This is why the cardinality for >SchedulerUsed is 0..1.
> 
> Let's drop the names for a minute, and just look at
> a picture:
> 
> 
> Q1 --- A1 ---+     B1
>              |   +----+
>              +-->|    |
> Q2 --- A2 ------>|    |----> outbound link
>              +-->|    |
>              |   +----+
> Q3 --- A3 ---+
> 
> This figure shows three queues, some A's that are
> one-to-one with the queues, and a B that takes
> the packets from the three queues and places them
> on the outbound link.  If this is priority
> queuing, then the priorities must be in the A's:
> the one B doesn't have the right cardinality,
> and you've already argued (correctly, I think)
> that the priorities don't belong on the queues
> themselves.
> 
> If *appears*, then, that our disagreement is
> really one of semantics / terminology:
> 
> Bob:
>   A = SchedulerUsed association
>   B = PacketSchedulingService
> 
> Walter:
>   A = PacketSchedulingService
>   B = (not explicitly modeled)
> 
In your proposal, is it possible to model a multi-queue environment where
some of the queues use one scheduling discipline and other queues use a
completely different one? If you have only a single PacketSchedulingService,
but you have moved all the parameters to the association, what is the
Service modeling. What are the local properties? How do you propose to
distinguish priority bandwidth scheduling from bandwidth priority
scheduling? How do you propose to address excess capacity scheduling for
bandwidth schedulers when the excess capacity could be allocated either
using priorities, packet ratios or bandwidth ratios? This particular issue
was solved rather elegantly with the old model.

> If this is really the crux of our disagreement,
> then I think that the Diffserv Conceptual Model
> very clearly supports my interpretation rather
> than yours.  Look specifically at Figure 7, but
> also, more generally, at all of the text that
> talks about the multiple inputs of a scheduler.

I already said that it is better to fix a problem at the source than
perpetuating the problem.

regards,

-Walter

---

From: John Schnizlein <[email-masked]>
Date: Mon, 21 Aug 2000 21:28:41 -0400

At 01:40 PM 08/21/2000 -0400, Weiss, Walter wrote: 
>
> ... How do you propose to distinguish priority bandwidth scheduling from
> bandwidth priority scheduling? 

Could you please specify the distinction you mean here?