Subject: QDIM: Changing two QoS Model properties to uint64, units = nanoseconds

From: "Robert Moore/Raleigh/IBM" <[email-masked]>
Date: Tue, 24 Oct 2000 10:54:28 -0400

In looking further at the QDIM draft, it appears that the
DeltaInterval properties in AverageRateMeter and EWMAMeter
don't have a fine enough granularity.  These properties
were defined in QDIM-01 to have units = microseconds.
In fact, though, they need to have units = nanoseconds.

Furthermore, if we change the units to nanoseconds, then
the uint32 syntax doesn't have enough bits.  So we (the
authors of the draft) propose to change the units for
these two properties to nanoseconds, and change their
syntax from uint32 to uint64.

Regards,
Bob

Bob Moore
IBM Networking Software
+1-919-254-4436
[email-masked]

---

From: John Schnizlein <[email-masked]>
Date: Tue, 24 Oct 2000 15:19:29 -0400

>In fact, though, they need to have units = nanoseconds.

Could you say a little about why microseconds are insufficient,
please?