Subject: RE: PQIM draft issues

From: Mahadevan Iyer <[email-masked]>
Date: Sun, 12 Nov 2000 21:13:17 -0800 (PST)

> My recommendation would be to start with the nouns
> and verbs, decide what
> you want to model and affect - and then start on the
> Policy
> (condition/action pairs). 

The nouns are a relatively static set
The verbs are an infinitely extensible set

My recommendation is that lets focus on integrating
the nouns(condition). The value we bring is that new
verbs can be plugged in and instantly benefit from the
noun set.

Note, having the same base classes or even the same
sub classes(in each of the information models) is not
sufficient, we need to have a single containment tree.
So the solution will have to allow for new verbs to be
seamlessly "plugged in" into the containment tree.

If you wait for the nouns and the verbs to be
finalized and keep building separate information
models, you will end up with stove pipe model models
for the verbs. I am sure that there will be some
attempt to integrate the stove pipes but the longer we
wait, the more specialized each model becomes, the
harder it gets.

Andrea,

Just to avoid any confusion ...

I quote from your draft
---------------------------------------------
"While this iteration of this draft concentrates on
defining an information model that can represent
DiffServ QoS services, the ultimate goal is to be able
to apply policies that control these services in
network devices. "
---------------------------------------------
I am in full agreement of the efforts to flush things
out QoS and I think this QoS work will serve as a much
needed example of how far policies can go.

All I am saying that the WG could also look at work
such as the IPVPN draft and keep both tracks moving.
We could start work on looking at common information
models for all possible IP services.

Thanks

__________________________________________________
Do You Yahoo!?
Yahoo! Calendar - Get organized for the holidays!
http://calendar.yahoo.com/

---

From: "Andrea Westerinen" <[email-masked]>
Date: Sun, 12 Nov 2000 21:30:52 -0800

Comments inline.
Andrea

-----Original Message-----
From: Mahadevan Iyer [mailto:[email-masked]]
Sent: Sunday, November 12, 2000 9:13 PM
To: Andrea Westerinen; [email-masked]
Cc: Policy Mailing List
Subject: RE: PQIM draft issues

<arw> Are the verbs infinitely extensible or are their implementations
extensible?  If the verbs are extensible, then how do you benefit from
conditions/actions?  Yes, I agree that you can add more actions, but you can
also add subclasses with additional verbs.  Objects have basic operations.

<arw> My only feedback on this comes from experience.  If you define your
nouns in isolation from how you want to use them, then you often-times end
up with the wrong design of the nouns.  If you design them from the context
of widely ranging verbs (with some forethought given to what those verbs can
be), then you are more likely to have a better noun set.

<arw> I do not believe that all implementations will want a single
containment tree.  So, to design to this point may cause problems.

<arw> I did not say wait for the nouns and verbs, but think first about the
nouns and  your "infinitely extensible" set of verbs before jumping into
automating them.  Also, I did not say that the info models are separately
built.  They are built as one overlapping, inter-related model - reusing the
class hierarchy as much as possible.  I would argue instead that building
isolated condition/action sets is much more likely to lead to stove piped
policy.

Andrea,

I quote from your draft

Thanks