Subject: Re: PQIM draft issues

From: Marcus Brunner <[email-masked]>
Date: Thu, 02 Nov 2000 17:43:11 +0100

Mahadevan Iyer wrote:

> >
> > Also - in the last IETF (Pittsburgh) two new drafts
> > were presented to model
> > TE policy. Should you consider merging the efforts
> > there? Should you absorb
> > TE policy into ipvpn policy? Note I'm not proposing,
> > only asking. You're
> > the experts and I'd like to here your opinions.
> 
> I have tried to get in touch with one of them and
> explained why, but there hasn't been a whole lot of
> response.

Mahadevan,

As one of the co-authers of one of the MPLS drafts, I can tell you that
MPLS VPNs are very hot also form a policy-based management point of
view. However, I have not really understand, what your model tries to
do. Nor what the new actions, conditions are, you want to introduce,
which are not available in QPIM, MLPS, etc.

Marcus 
-- 

Dr. Marcus Brunner
C&C Research Laboratories
NEC Europe Ltd.

E-Mail: [email-masked]
WWW:    http://www.ccrle.nec.de/
personal home page: http://www.tik.ee.ethz.ch/~brunner

Adenauerplatz 6
D-69115 Heidelberg
Germany

Phone: +49 (0)6221/ 9051129
Fax:   +49 (0)6221/ 9051155

---

From: Mahadevan Iyer <[email-masked]>
Date: Sun, 12 Nov 2000 22:01:44 -0800 (PST)

> <arw> My only feedback on this comes from
> experience.  If you define your
> nouns in isolation from how you want to use them,
> then you often-times end
> up with the wrong design of the nouns.  If you
> design them from the context
> of widely ranging verbs (with some forethought given
> to what those verbs can
> be), then you are more likely to have a better noun
> set.

<iyer>
I agree that it is difficult.
I think that the nouns will also evolve in response to
new verbs.
I also believe that there is significant understanding
of the key IP services(mentioned in the IPVPN draft)
to come up with a common noun set.
</iyer>

> <arw> I do not believe that all implementations will
> want a single
> containment tree.  So, to design to this point may
> cause problems.

<iyer>
I can tell you from practical experience of having to
deploy a multi function box, we would very much like
to see a single containment tree for common IP
functions.

It will certainly cause problems if not done right.
If done right I believe it will add significant value.

I understand that what we choose, what integrate and
what we leave out is something that is open to
discussion.
</iyer>

> 
> If you wait for the nouns and the verbs to be
> finalized and keep building separate information
> models, you will end up with stove pipe model models
> for the verbs. I am sure that there will be some
> attempt to integrate the stove pipes but the longer
> we
> wait, the more specialized each model becomes, the
> harder it gets.
> 
> <arw> I did not say wait for the nouns and verbs,
> but think first about the
> nouns and  your "infinitely extensible" set of verbs
> before jumping into
> automating them.

<iyer>
I don't want to jump into anything :-)
I would welcome further thinking and discussions on
the details of this problem.
</iyer>

  Also, I did not say that the info
> models are separately
> built.  They are built as one overlapping,
> inter-related model - reusing the
> class hierarchy as much as possible.  I would argue
> instead that building
> isolated condition/action sets is much more likely
> to lead to stove piped
> policy.

<iyer>
I think we can agree to disagree :-)
</iyer>

__________________________________________________
Do You Yahoo!?
Yahoo! Calendar - Get organized for the holidays!
http://calendar.yahoo.com/