Subject: cardinality of policyRuleSequencedActions

From: "Mircea Pana" <[email-masked]>
Date: Wed, 6 Dec 2000 17:51:35 -0500

Wrt. the cardinality of some LDAP attributes defined in
"draft-ietf-policy-core-schema-08":

1. Isn't the "policyRuleSequencedActions" attribute supposed to be
single-valued (in "policyRule")? The document does not specify this
attribute's cardinality, which implies as default: multi-value.

2. Same comment for "ptpConditionTimeOfDayMask" attribute (in
"policyTimePeriodConditionAuxClass").
However, if this last one should be multi-valued, by extrapolation,
shouldn't the "ptpConditionTime" be multi-valued as well?

Thanks,  
Mircea Pana.

---

From: "Mircea Pana" <[email-masked]>
Date: Thu, 7 Dec 2000 12:29:33 -0500

Bob,

For consistency I would have both attributes (ptpConditionTime and
ptpConditionTimeOfDayMask) with the same cardinality.

If these attributes are single-value, this may lead to a higher number of
policyTimePeriodCondition[AuxClass] entries necessary to specify the
validity period.
On the other hand, if they are multi-valued, the semantics of the
policyTimePeriodCondition[AuxClass] are overloaded. Therefore, an increase
in complexity of the provisioning and consumption activities.

I tend to be in favor of the single-valued option due to its reduced
complexity.

However, in an environment where the "LDAP Control for a Duplicate Entry
Representation of Search Results"
(http://www.ietf.org/internet-drafts/draft-ietf-ldapext-ldapv3-dupent-06.txt
) is used, the client experience could be similar in both cases.

Regards,
Mircea.

> -----Original Message-----
> From: Robert Moore [mailto:[email-masked]]
> Sent: Thursday, December 07, 2000 10:38 AM
> To: Pana, Mircea [CAR:5E10:EXCH]
> Cc: [email-masked]'
> Subject: Re: cardinality of policyRuleSequencedActions
> 
> 
> Mircea,
> 
> You're definitely right about #1 -- I've already changed
> this in the PCLS source file.
> 
> For #2, I *think* that having it multi-valued was
> intentional, but I'm not really sure.  The idea would be
> to allow us to represent in a single object a schedule
> like 0800 to 1200 AND 1300 to 1700.  I don't know if such
> schedules will be common enough to warrant the extra
> complexity.
> 
> One further factor:  both of the ptpCondition properties
> in PCIM that correspond to these two attributes are
> single-valued.  So we either need to change
> ptpConditionTimeOfDayMask to single-valued (and leave
> ptpConditionTime single-valued), or else make one or both
> of them multi-valued, and track the corresponding change
> to PCIM as our first piece of Proposed Standard
> implementation experience.  I could go either way, but my
> vote would be to make the two attributes single-valued,
> on the grounds that in general we've applied more careful
> thought to PCIM than we have to PCLS.
> 
> Regards,
> Bob
> 
> Bob Moore
> IBM Networking Software
> +1-919-254-4436
> [email-masked]
> 
> 
> 
> "Mircea Pana" <[email-masked]>@raleigh.ibm.com on 12/06/2000
> 05:51:35 PM
> 
> Please respond to "Mircea Pana" <[email-masked]>
> 
> Sent by:  [email-masked]
> 
> 
> To:   "[email-masked]'" <[email-masked]>
> cc:
> Subject:  cardinality of policyRuleSequencedActions
> 
> 
> 
> 
>

---

From: "Robert Moore" <[email-masked]>
Date: Thu, 7 Dec 2000 10:37:47 -0500

Mircea,

Regards,
Bob

Bob Moore
IBM Networking Software
+1-919-254-4436
[email-masked]

Thanks,
Mircea Pana.