Subject: Re: gpsPolicyGroup class in qos info model

From: Mahadevan Iyer <[email-masked]>
Date: Sun, 10 Dec 2000 20:26:41 -0800 (PST)

--- John Strassner <[email-masked]> wrote:
> Hi Mahadevan,
> 
> I'm still not quite sure I understand your reasoning
> for the
> putting an aggregate condition in the gpsPolicyRule
> class. 

Hello John,

there are 2 parts to this reply :

  1. Issues raised in your response, 
  2. Explanation of the requirement.

Issues raised in your response ...

  1. There is no "peeking" inside the rules, it is an
administrator generated condition. This should answer
most of your issues related to aggregating conditions
and decisions.

  2. The PolicyRuleInPolicyRule can satisfy the
requirement. I have explained my reservations
regarding using this class in my earlier email.

Explanation of the requirement ...

  1. The requirements is driven from the practical
issues at the PDP. I have a whole tree of policies and
nothing but the priority to decide how I traverse the
tree(at the group level). This could be a very
expensive. I need to have a quick way of narrowing
down the possibilities at the top of the tree(where
the policyGroups are defined). It is a lot more than
an optimization, it would be a requirement when
defining policy trees for a carrier network.

Do you see this as a problem that needs to be
addressed at this level ?

Thanks

__________________________________________________
Do You Yahoo!?
Yahoo! Shopping - Thousands of Stores. Millions of Products.
http://shopping.yahoo.com/

---

From: Mahadevan Iyer <[email-masked]>
Date: Thu, 14 Dec 2000 20:27:26 -0800 (PST)

--- "Luis A. Sanchez" <[email-masked]> wrote:
> Folks, lets keep this discussion to the Policy
> Framework mailing list
> only.

Interestingly enough this discussion is relevant to
them in the context of supporting nested VPN's in
their policy information model. However we can leave
them out of this for now.

Regards