Subject: gpsPolicyGroup class in qos info model

From: Mahadevan Iyer <[email-masked]>
Date: Wed, 6 Dec 2000 22:36:36 -0800 (PST)

I would like to suggest an update to the
gpsPolicyGroup class.
This also relates to the PolicyRuleInPolicyRule usage.

I need to indicate that a group of policy rules should
be checked only if the traffic matches some aggregate
conditions. These aggregate conditions summarize the
conditions within the policy rules.

I would like to specify the aggregate conditions at
the level of the gpsPolicyGroup. An alternative is to
use the PolicyRule + PolicyRuleInPolicyRule instead of
the gpsPolicyGroup. However I prefer to use the
gpsPolicyGroup.

I would suggest adding an aggregate policy condition
to the gpsPolicyGroup. This condition would typically
be a gpsPolicyCompoundCondition.

Thanks

__________________________________________________
Do You Yahoo!?
Yahoo! Shopping - Thousands of Stores. Millions of Products.
http://shopping.yahoo.com/

---

From: Ron Cohen <[email-masked]>
Date: Thu, 07 Dec 2000 00:33:15 -0800

Mahadevan,

Can you provide more details why you prefer to change the gpsPolicyGroup 
than using the current policyRuleInPolicyRule method?

Thanks
Ron

---

From: Marcus Brunner <[email-masked]>
Date: Fri, 8 Dec 2000 06:29:55 +0100 (CET)

Ron,

I agree with Mahadevan, that I do not like the policyRuleInPolicyRule method, 
because 
a) there are now two different grouping models,
b) it is unclear what happens to the context when the ruleInrule is executed 
(full new start of execution engine or reuse the context)
c) I do not see the need for rulesInrules, what makes them different compared to 
the grouping already available

However, I do not agree to add a condition to the group. I think what is 
available is enough.

Marcus  

> >be a gpsPolicyCompoundCondition.

Dr. Marcus Brunner
C&C Research Laboratories
NEC Europe Ltd.

E-Mail: [email-masked]
WWW:    http://www.ccrle.nec.de/
personal home page: http://www.tik.ee.ethz.ch/~brunner

Adenauerplatz 6
D-69115 Heidelberg
Germany

Phone: +49 (0)6221/ 9051129
Fax:   +49 (0)6221/ 9051155

---

From: "John Strassner" <[email-masked]>
Date: Sat, 9 Dec 2000 17:56:14 -0800

PolicyRuleInPolicyRule is used to build sub-rules. We also
allow for PolicyGroupInPolicyRule to build a sub-rule, with
a policyGroup as a nested container. This capability is not
in PCIM.

As far as the context, sub-rules execute before their
containing rules, as explained in the draft.

I not only don't like conditions in gpsPolicyGroup, I don't
think they work.

regards,
John
----- Original Message -----
From: "Marcus Brunner" <[email-masked]>
To: "Ron Cohen" <[email-masked]>
Cc: "Mahadevan Iyer" <[email-masked]>;
<[email-masked]>; <[email-masked]>
Sent: Thursday, December 07, 2000 9:29 PM
Subject: Re: gpsPolicyGroup class in qos info model

---

From: "John Strassner" <[email-masked]>
Date: Sat, 9 Dec 2000 17:56:14 -0800

regards,
John

---

From: Marcus Brunner <[email-masked]>
Date: Mon, 11 Dec 2000 22:42:18 +0100

John,

> a policyGroup as a nested container. This capability is not

Do you have an example, motivating why the rule in the rule is useful?
Is there a specific application of this modeling for QPIM?
I personally do not like having a rule playing so many different role.
The containment is dealt with in the policy group, why should a policy
rule also be a container for sub-rules?
 
> containing rules, as explained in the draft.

Thank you, I have not found this in the draft.
 
> I not only don't like conditions in gpsPolicyGroup, I don't

I do not like the as well.

Marcus

---

From: "Luis A. Sanchez" <[email-masked]>
Date: Wed, 13 Dec 2000 20:29:13 -0500

Folks, lets keep this discussion to the Policy Framework mailing list
only.

Luis