Subject: [Policy] Querry regarding MarkerService in QDDIM

From: "Girish Pujari" <[email-masked]>
Date: Tue, 21 Jan 2003 15:07:15 +0530

We are refering to the class MarkerService [QDDIM]  in the 
document  <draft-ietf-policy-qos-device-info-model-08.txt>.

We are unable to associate the MarkerService with its type.

We feel that a property MarkerServiceType needs to be added to 
MarkerService Class with enumerations for the following

1. PreambleMarkerService
2. ToSMarkerService
3. DSCPMarkerService
4. 8021QMarkerService

Does any association will relate these classes ? 

The DropperService has properties DropperType, OtherDropperType, DropFrom.
Can MarkerService class also have similar properties ?. 

Kindly inform,if there is any latest draft on this. 

Thanx
Regards

Girish Pujari
Mahindra British Telecom
Pune - INDIA

*********************************************************
Disclaimer

This message (including any attachments) contains 
confidential information intended for a specific 
individual and purpose, and is protected by law. 
If you are not the intended recipient, you should 
delete this message and are hereby notified that 
any disclosure, copying, or distribution of this
message, or the taking of any action based on it, 
is strictly prohibited.

*********************************************************
Visit us at http://www.mahindrabt.com

---

From: "Andrea Westerinen" <[email-masked]>
Date: Tue, 28 Jan 2003 23:22:20 -0800

Girish, A "type" property is not defined on the MarkerService class,
since it is necessary to instantiate a subclass in all cases, in order
to define the appropriate data.  The text for the class reads:
"MarkerService is a concrete class because its superclass
(ConditioningService) is concrete. While this class can be instantiated,
an instance of it does not accomplish anything, because both the field
to be marked and the value used to mark it are defined in subclasses."

Andrea  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Girish Pujari
Sent: Tuesday, January 21, 2003 1:37 AM
To: [email-masked]
Subject: [Policy] Querry regarding MarkerService in QDDIM

 
 
1. PreambleMarkerService
2. ToSMarkerService
3. DSCPMarkerService
4. 8021QMarkerService

The DropperService has properties DropperType, OtherDropperType,
DropFrom.
Can MarkerService class also have similar properties ?. 

Thanx
Regards
 
Girish Pujari
Mahindra British Telecom
Pune - INDIA