Subject: IDLE Timer

From: Manikandan A <[email-masked]>
Date: Fri, 2 Jun 2000 19:58:53 +0530

Hi All,

      What is the recommended IDLE timer value for the link ?. I could n't find anything in RFC 1661. 

TIA

Regards,
Mani.

---

From: James Carlson <[email-masked]>
Date: Fri, 2 Jun 2000 10:46:02 -0400 (EDT)

> find anything in RFC 1661. 

It's implementation dependent and can't be specified in the documents.
You should set something that makes sense for your particular
situation.

In general, it depends on the speed of recovery of the link and the
cost of link establishment.  For links that come back up very quickly
and do not incur additional costs for each call (such as centrex ISDN
in some cases), a short timer of a few seconds is probably good.  For
links that charge per call or have very long set-up times (such as
modems faster than 2400 bps), a longer timer of a minute or more might
be appropriate.

-- 
James Carlson, Internet Engineering       <[email-masked]>
SUN Microsystems / 1 Network Drive         71.234W   Vox +1 781 442 2084
MS UBUR02-212 / Burlington MA 01803-2757   42.497N   Fax +1 781 442 1677
"PPP Design and Debugging" --- http://people.ne.mediaone.net/carlson/ppp

---

From: Karl Fox <[email-masked]>
Date: Fri, 02 Jun 2000 10:53:43 -0400

Hi Mani,

If you're talking about a timer used to shut down a link when traffic has quiesced, there isn't any default, requirement or specification.  Each implementation chooses to do as it pleases, using (hopefully) Terminate-Request to shut down the link.

There are also many different algorithms; here are a few of the many features out there:

1) Fixed timer, optionally configurable by the user

2) A so-called "split timer" which keeps track of open TCP sessions, with 
   one (longer) timer used when one or more TCP sessions are open and another 
   (shorter) timer used when no TCP sessions are open.  For example, a 300/10 
   split timer will hang up after a TELNET session goes unused for five 
   minutes, but will hang up within ten seconds of logging out the last session

3) Packet filters which select which traffic types should reset the idle 
   timer.  For example, TELNET packets reset, but NTP packets don't.

I hope this helps,

Karl

>      What is the recommended IDLE timer value for the link ?. I could n't find anything in RFC 1661. 

Karl Fox <[email-masked]>
Key fingerprint = 5B15 7260 D55E D680 0B93  4953 8A3B AB0E C05D 77A3