Subject: Reg PPOA Implementation in Linux.

From: "Thiagarajan Venkatachalam" <[email-masked]>
Date: Fri, 4 Jan 2002 17:31:52 +0530

hi  ,

PPPOA in Linux  , the packet has to be accessed from  the datalink layer .
Usually , In   Linux the packet is captured from the sk_buff. 
But this sk_buff will  contain PPP frames also  in the PPP supported  kernel image .

 In Kernel  space from which file we  have  to capture the PPP frames  so 
that we will  call  our PPPOA module  to change the PPP frames to PPPOA  frames ?  

One more question .

In skbbuff.h  

 /* Link layer header */
 union 
 { 
    struct ethhdr *ethernet;
    unsigned char  *raw;  
 } mac

the raw pointer will  hold the PPP frames .  Am i correct ?

Thanks in advance
Thiagarajan

---

From: Vivek Pandey <[email-masked]>
Date: Fri, 4 Jan 2002 18:37:10 +0530

Go thru ppp_generic.c It exports a function ppp_input. This function is the
entry point for all ppp pckts. It is called when pkt is recvd over physical
layer...(called from ppp_async..ppp_sync...in case of tty interface over
serial or ppoe.c in case of pppoe).
I guess this solves your problem.

-----Original Message-----
From: Thiagarajan Venkatachalam [mailto:[email-masked]]
Sent: Friday, January 04, 2002 5:32 PM
To: [email-masked]
Subject: Reg PPOA Implementation in Linux.

hi  ,
 
PPPOA in Linux  , the packet has to be accessed from the datalink layer .
Usually , In  Linux the packet is captured from the sk_buff. 
But this sk_buff will  contain PPP frames also  in the PPP supported  kernel
image .
 
 In Kernel  space from which file we  have  to capture the PPP frames  so 
that we will  call  our PPPOA module  to change the PPP frames to PPPOA
frames ?  
 
One more question .
 
In skbbuff.h  
 
 /* Link layer header */
 union 
 { 
    struct ethhdr *ethernet;
    unsigned char  *raw;  
 } mac

Thanks in advance
Thiagarajan