Subject: Configuration of remote routers (IPCP vs DHCP)

From: "Glardy" <[email-masked]>
Date: Thu, 29 May 2003 22:11:03 +1000

The recent discussions about using IPCP to pass static routes to a PPP peer, negotiate a netmask etc, suggest that a lot of people are trying to work out how to address the problem of configuring remote routers over a PPP connection (dial-up or xDSL mostly I would guess).

Summary:  Check out RFC 3442 and draft-ietf-dhc-subnet-alloc-00.txt for how to do this with DHCP.

Long version:

The context where I have faced this problem is where I have a large number of small remote sites connecting up to my central access server using PPP.  Each remote site generally has a router with a small network behind it, and I want my central server to be able to send the router a subnet to use in addition to the IP address it got for the PPP link.  It could then give itself an address out of that subnet and set itself up as a DHCP server (or possibly a relay) to allow other hosts on the remote network to get an IP address, netmask and default gateway.  In more complex scenarios there may be multiple subnets involved and perhaps a couple of static routes required as well.

Many small routers have a DHCP server and/or relay agent built-in already, and RADIUS gives me the ability to send the necessary addressing and routing information to the access server.  What is lacking is a protocol to transport that information from the server to the remote router for it to set up its DHCP server.

Given the general consensus on the list that DHCP is a better protocol than IPCP for this function, I have had a quick look at the dhc working group's list of work completed and in progress.

The problem I have just outlined appears to have been solved there.  The option to pass classless static routes in DHCP is in RFC 3442 (Standards track) and the option to allocate multiple subnets to a host is currently a dhc working group draft (draft-ietf-dhc-subnet-alloc-00.txt).

Looks like I will have to implement DHCP on my access server.  I don't suppose anyone knows of an ISDN/ADSL router that implements a DHCP client for remote configuration?

Cheers,

Greg Lampard

---

From: Bernard Aboba <[email-masked]>
Date: Thu, 29 May 2003 05:41:44 -0700 (PDT)

> Many small routers have a DHCP server and/or relay agent built-in already, and RADIUS
>gives me the ability to send the necessary addressing and routing
>information to the access server.  What is lacking is a protocol to
>transport that information from the server to the remote router for it to
>set up its DHCP server.

RADIUS has Framed-Route and Framed-Routing. You can use these to setup a
routing protocol such as RIP, to operate between your Access Server and the clients.

> Given the general consensus on the list that DHCP is a better protocol than IPCP for this

I don't think that the concensus was that either was a subsitute for a routing protocol.

---

From: James Carlson <[email-masked]>
Date: Thu, 29 May 2003 10:05:04 -0400

> I don't think that the concensus was that either was a subsitute for a routing protocol.

It all depends on what you're trying to accomplish.

If you're delegating address assignment authority for a subnet from
one DHCP server to another, then a DHCP-specific mechanism sounds like
the best way to go about doing this.

If you're just configuring an Ethernet interface that happens to be
attached to some CPE box with a PPP link on the other side, then
BOOTP, DHCP, or just DHCPINFORM would probably be about right.

If all that you're doing is ferrying routes around (and not
specifically configuring an interface), then ICMP Router Discovery or
RIP-2 are good choices.

In any event, the one thing that does *NOT* make sense is to pass a
subnet mask along via IPCP and have that mask be somehow applied to
either a remote DHCP server, some interface unrelated to the PPP link
itself, or to a forwarding table.

-- 
James Carlson, Solaris Networking         <[email-masked]>
Sun Microsystems / 1 Network Drive         71.234W   Vox +1 781 442 2084
MS UBUR02-212 / Burlington MA 01803-2757   42.497N   Fax +1 781 442 1677