Subject: RE: [Pppext] (resend) Working group last call: PWE3 PPP assignmen t

From: "David Allan" <[email-masked]>
Date: Tue, 20 Apr 2004 09:30:45 -0400

Hi Vernon:

We had a problem in the MPLS space where existing implementations snooped
payload in do Equal Cost Multi-Path (ECMP) and simultaneously preserve flow
ordering. If it looked like an IP packet, use IP address information in
doing the path choice. Most implementations also use the label stack. Normal
mode of operation being to hash a path selection out of label stack and
payload information.

Net result of this was if the payload was not IP, (as in a psuedo wire) then
all mechanisms for distinguishing OAM flows were impacted. If you used a
reserved label, your OAM PDU would not have the same forwarding as the
payload flow of interest. If you used an IP packet, the forwarding would not
follow the payload flow of interest. 

So the PW group came up with the PW PID which would allow OAM PDUs to be
multiplexed with a PW flow without appearing as an IP packet to deployed
ECMP LSRs, and not requiring a reserved label. Hence where we are today...

hope this helps
Dave

> -----Original Message-----
> From: Vernon Schryver [mailto:[email-masked]] 
> Sent: Monday, April 19, 2004 8:02 PM
> To: Allan, David [CAR:NS00:EXCH]; [email-masked]
> Cc: [email-masked]; [email-masked]; 
> [email-masked]
> Subject: RE: [Pppext] (resend) Working group last call: PWE3 
> PPP assignmen t
> 
> 
> > From: "David Allan" <[email-masked]>
> > To: "'Vernon Schryver'" <[email-masked]>, [email-masked]
> > Cc: [email-masked], [email-masked], 
> > [email-masked]
> 
> > Sorry for the confusion, I upped the rev number of the 
> draft without 
> > checking that the appropriate text was still there (there are other 
> > drafts that use this). Section 5.4.3 of version 6 of the draft 
> > contains the appropriate text. I'll check where it has gone.
> 
> > FYI Lloyd Wood has an archived version... 
> > 
> http://www.ee.surrey.ac.uk/Personal/L.Wood/pub> lications/internet-draft
> > s/draf
> > t-ietf-pwe3-arch-06.txt
> 
> That version only raises more questions for me.
> 
> What is the purpose of the PPP DLL number in that header?
> What is demultiplexing using that PPP DLL number?  What are 
> the other values that might someday be in that field?
> 
> Except in the likely case that I'm completely confused about 
> which protocols are being tunneled in which other protocols, 
> a PPP DLL number seems like the wrong thing.
> 
> 
> Vernon Schryver    [email-masked]
> 

_______________________________________________
Pppext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pppext

---

From: Vernon Schryver <[email-masked]>
Date: Tue, 20 Apr 2004 08:41:18 -0600 (MDT)

> Cc: [email-masked], [email-masked], [email-masked]

> ECMP LSRs, and not requiring a reserved label. Hence where we are today...

That's nice, I guess, but what does it have to do with PPP?  As far
as I can tell, you are saying that a PW PID is needed, and since
PPP has a completely unrelated space of date link layer numbers, you
should use one of them.

I must not understand that explanation or analogy with MPLS flow
labelling.  From your document, all occurance of your PW PIDs will
always be identical, always this new PPP DLL number.