Subject: Re: [Pppext] Is there a IPv6 Configuration Protocol Options for DNS IP address?

From: Mykim <[email-masked]>
Date: Tue, 11 May 2004 09:03:59 +0900

Thank you for your reply.

In CDMA 2000 environmant, MS(Mobile
Station) that uses IPv6 gets IPv6 address by  negotiating
PPP(IPv6CP) with PDSN(Packet Data Serving Node).
In this
case, how can MS get IPv6 DNS address? (If MS not use DHCP)
If
MS has to get IPv6 DNS address by using DHCP, does DHCP
server have to exist in CDMA 2000 network?

--------- Original Message --------
sender:
"John Bray" <[email-masked]>
To: "Mykim"
<[email-masked]>
Cc: [email-masked]
subject: Re:
[Pppext] Is there a IPv6 Configuration Protocol Options for DNS IP
address?
Date: 11/05/04 10:23

At
01:42 AM 5/10/2004, Mykim wrote:
>Hello all,
>Is there a
IPv6 Configuration Protocol Options in IPv6CP?
>If there is no IPv6
Configuration Protocol Option then I'd like to know
>how to get IPv6
DNS address when negotiate PPP.

Use DHCP.

>(I found draft
document which is filed as "PPP IPV6 Control Protocol
>Extensions for
DNS Server Addresses". But, it was expired at December 2004
>and not
published as RFC.)

It was rejected by the working group. The
consensus was that it duplicated
the existing capability already
provided by DHCP.

John

>I expect your prompt
reply.
>_______________________________________________ Pppext mailing
list
>[email-masked] https://www1.ietf.org/mailman/listinfo/pppext

_______________________________________________
Pppext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pppext

---

From: James Carlson <[email-masked]>
Date: Tue, 11 May 2004 06:45:05 -0400

Mykim writes:
> Thank you for your reply.<BR><BR>In CDMA 2000 environmant, MS(Mobile
> Station) that uses IPv6 gets IPv6 address&nbsp;by&nbsp; negotiating
> PPP(IPv6CP) with PDSN(Packet Data Serving Node).<BR>In this
> case,&nbsp;how&nbsp;can MS get IPv6 DNS address? (If MS not use DHCP)<BR>If

Why doesn't it use DHCP?

> MS has to get IPv6 DNS address by using DHCP, does&nbsp;DHCP
> server&nbsp;have to exist&nbsp;in CDMA 2000 network?<BR><BR>

The "server" in this case is extraordinarily trivial: all it needs to
be able to do is receive a DHCPINFORM message from the client and send
DHCPACK in response.

Having the same system that terminates the PPP connection also
providing DHCP service would make a lot of sense -- no extra hardware,
and a trivial amount of software; likely the same amount of software
that would have been required to add the DNS server address options to
PPP.

-- 
James Carlson, IP Systems Group                <[email-masked]>
Sun Microsystems / 1 Network Drive         71.234W   Vox +1 781 442 2084
MS UBUR02-212 / Burlington MA 01803-2757   42.497N   Fax +1 781 442 1677