Subject: [ppsp] ppsp charter and problem statement draft

From: "zhangyunfei" <[email-masked]>
Date: Wed, 27 May 2009 19:06:35 +0800

Dear all,
    Attached is the initial version of ppsp charter.I've also submitted a new version of PPSP problem statement draft to IETF website in the following link.(http://www.ietf.org/internet-drafts/draft-zhang-ppsp-problem-statement-03.txt) .Any comments and suggestions are highly welcome.
       The abstract is as follows:
We propose to develop an open peer-to-peer (P2P) streaming protocol named PPSP. This document describes the problems related to PPSP and outlines considerations that have to be taken in account when arriving at equitable solutions.

Yunfei
  Best regards!
  Sincerely yours,
      Yunfei 
       2009-05-27
*****************************************************
Yunfei Zhang, Ph.D.
R&D, CHINA MOBILE COMMUNICATIONS CORPORATION
Tel: +86 10 158016966688 ext. 3247
Fax: +86 10 63601087
MOBILE: 1360-1032-119
*****************************************************

zhangyunfei
2009-05-27

---

From: "zhangyunfei" <[email-masked]>
Date: Mon, 1 Jun 2009 09:57:17 +0800

Hi Salvatore,
   Thanks for your questions.Please see inline for the reply.

                              Yunfei

zhangyunfei
2009-06-01

发件人： Salvatore Loreto
发送时间： 2009-05-28 19:23:55
收件人： zhangyunfei
抄送： 
主题： Re: [ppsp] ppsp charter and problem statement draft

Hi  Yunfei,

I  have  read  the  draft,  and  I  have  a  perhaps  a  more  research  relate  question,
actually  two  questions

1)  you  state  that  is  well  demonstrated  that  P2P  streaming  works,  but  it
is  not  clear  if  you  are
talking  of  stored  streaming,  or  live  streaming  and  if  there  are  any
difference  to  deliver  this
two  kind  of  stream  in  a  P2P  network

Reply:PPSP is now focusing on live streaming for the reason to concentrate the scope. If we find there exist the common foudations in live streaming and stored streaming after PPSP discusses throughly live streaming protocols, there is much probabilty that we seek for building stored streaming protocols.

2)  the  second  question  is  about  the  congestion  that  the  delivery  of  such
stream  can  cause  on  the  network
LEDBAT  wg  is  working  on  a  congestion  mechanism  developed  on  top  of  UDP,
but  I  don't  think  that  the  less  than  best  effort  approach  that  they  are
considering  would  be  good
for  a  live  stream.  I'd  like  read  you  thoughts  about  it.
Reply: Good question.I share the same idea as you.As stated in last SF PPSP bar bof,current most P2P streaming uses
UDP for simple and efficenct delivery.However we are worrying about the Internet collapse for UDP is un-obedient and consumes
bandwidth greedly in case video traffic dominates Internet.
So in the research aspect, although we won't include this mechanism in PPSP which is focusing on signaling part, we are considering a protocol that combines UDP's bandwidth utilization with TCP's obedience in one-to-many communcaitons. Highly welcome to discuss this problem in more detail.

best  regards
Sal

www.sloreto.com

zhangyunfei  wrote:
>  Dear  all,
>  Attached  is  the  initial  version  of  ppsp  charter.I've  also  submitted  a
>  new  version  of  PPSP  problem  statement  draft  to  IETF  website  in  the
>  following
>  link.(http://www.ietf.org/internet-drafts/draft-zhang-ppsp-problem-statement-03.txt)
>   <http://www.ietf.org/internet-drafts/draft-zhang-ppsp-problem-statement-03.txt >.Any
>  comments  and  suggestions  are  highly  welcome.
>  We  propose  to  develop  an  open  peer-to-peer  (P2P)  streaming  protocol
>  named  PPSP.  This  document  describes  the  problems  related  to  PPSP  and
>  outlines  considerations  that  have  to  be  taken  in  account  when  arriving
>  at  equitable  solutions.
>
>  Yunfei
>
>  Best  regards!
>  Sincerely  yours,
>  Yunfei
>  2009-05-27
>  ------------------------------------------------------------------------
>  zhangyunfei
>  2009-05-27
>  ------------------------------------------------------------------------
>
>  _______________________________________________
>  ppsp  mailing  list
>  [email-masked]
>  https://www.ietf.org/mailman/listinfo/ppsp
>

---

From: "Y. R. Yang" <[email-masked]>
Date: Sun, 31 May 2009 23:09:41 -0400 (EDT)

Hi Salvatore,

Just to add some to Yunfei's reply. Please see below.

On Mon, 1 Jun 2009, 9:57am +0800, zhangyunfei wrote:

> ???: Salvatore Loreto
> ????: 2009-05-28 19:23:55
> ???: zhangyunfei
> ??: 
> ??: Re: [ppsp] ppsp charter and problem statement draft
> 
> Hi  Yunfei,
> 
> I have read the draft, and I have a perhaps a more research relate 

The Problem Statement draft is in rough draft. Any comments are greatly 
appriated. I think Yunfei will upload a newer version this week.

> question, actually two questions
> 
>    is not clear if you are talking of stored streaming, or live 
>    streaming and if there are any difference to deliver this two kind of 
>    stream in a P2P network
> 
> Reply:PPSP is now focusing on live streaming for the reason to 
> concentrate the scope. If we find there exist the common foudations in 
> live streaming and stored streaming after PPSP discusses throughly live 
> streaming protocols, there is much probabilty that we seek for building 
> stored streaming protocols.

[YRY] I think the focus is on Live. Stored media (VoD) can be quite 
different from Live, in particular, in terms of algorithms. For example, 
for stored media, a more capable node can download faster (you can see the 
slider bar moves way beyond the current play point) and then serve others. 
For Live, this is impossible. For VoD, you can fast forward; for Live, so 
far physics says that we cannot :-)

> 2)  the second question is about the congestion that the delivery of 
>    such stream can cause on the network LEDBAT wg is working on a 
>    congestion mechanism developed on top of UDP, but I don't think that 
>    the less than best effort approach that they are considering would be 
>    good for a live stream.  I'd like read you thoughts about it.

> Reply: Good question. I share the same idea as you. As stated in last SF 
> PPSP bar bof, current most P2P streaming uses UDP for simple and 
> efficenct delivery. However we are worrying about the Internet collapse 
> for UDP is un-obedient and consumes bandwidth greedly in case video 
> traffic dominates Internet. So in the research aspect, although we won't 
> include this mechanism in PPSP which is focusing on signaling part, we 
> are considering a protocol that combines UDP's bandwidth utilization 
> with TCP's obedience in one-to-many communcaitons. Highly welcome to 
> discuss this problem in more detail.

[YRY] I am not sure congestion control will be in-scope for PPSP. Either 
Live or VoD, after you start the play, you have to keep the pace; 
otherwise, the video freezes. So the issue applies to both Live and VoD 
(at least for a long VoD session). It sure is an interesting question.

Richard