Subject: Re: [ppsp] ppsp charter and problem statement draft

From: Lars Eggert <[email-masked]>
Date: Thu, 4 Jun 2009 09:47:24 +0200

Hi,

I've tentatively listed PPSP as BOF proposal at http://trac.tools.ietf.org/bof/trac/wiki/WikiStart 
, but I haven't received an explicit BOF request yet. There are only a  
few days left for this; should I expect one?

Lars

PS: See
http://tools.ietf.org/html/rfc5434
http://www.ietf.org/ietf/1bof-procedures.txt
http://www.ietf.org/instructions/MTG-SLOTS.html

On 2009-5-27, at 13:06, zhangyunfei wrote:

> Dear all,
>    Attached is the initial version of ppsp charter.I've also  
> submitted a new version of PPSP problem statement draft to IETF  
> website in the following link.(http://www.ietf.org/internet-drafts/draft-zhang-ppsp-problem-statement-03.txt 
> ) <http://www.ietf.org/internet-drafts/draft-zhang-ppsp-problem-statement-03.txt 
> > .Any comments and suggestions are highly welcome.
>       The abstract is as follows:
> We propose to develop an open peer-to-peer (P2P) streaming protocol  
> named PPSP. This document describes the problems related to PPSP and  
> outlines considerations that have to be taken in account when  
> arriving at equitable solutions.
>
> Yunfei
>  Best regards!
>  Sincerely yours,
>      Yunfei
>       2009-05-27
> *****************************************************
> Yunfei Zhang, Ph.D.
> R&D, CHINA MOBILE COMMUNICATIONS CORPORATION
> Tel: +86 10 158016966688 ext. 3247
> Fax: +86 10 63601087
> MOBILE: 1360-1032-119
> *****************************************************
>
>
> ________________________________
> zhangyunfei
> 2009-05-27
> <ppsp-charter.txt>

---

From: "Softgear Ko" <[email-masked]>
Date: Mon, 22 Jun 2009 20:50:20 +0900

Hello, Yunfei.

I have some comments. 

In 3.4

 In korea, the mobilTV subscriber is 17 million.  - May I get a reference or
document about this?  I have never heard about this.

In 4.2.1,

I don't understand that Figure 2 P2PSIP process. We need update it and
explain some more.

About NAT traversal  in RELOAD, TURN server usage for RELOAD in P2PSIP is
not proximity aware. It means peer get a TURN server randomly in the whole
Internet. It may be far from the requesting peer. Therefore, we can't reuse
it directly.

As you mentioned, we focus on live streaming.  I think pure live streaming
has no buffer for other(child in tree). But, according to the draft, peer
exchange bitmap. This means each peer (which is a parent or child) must have
buffer for other peer. If peer have buffer and other peer use it, the
delivered data has more latency. This is not a pure live streaming.
Therefore, there is two types of live streaming - pure live streaming and
buffered live streaming. I think we focus on buffered live streaming than
pure live streaming. But I think we need discuss whether we focus on pure
live streaming.

In 8,

Where can I get [MobileTV] ?

Additionally, I think, we have to place emphasis on flash crowd situation of
P2P IPTV service.

Best regards,

-      Softgear Ko

From: [email-masked] [mailto:[email-masked]] On Behalf Of
zhangyunfei
Sent: Wednesday, May 27, 2009 8:07 PM
To: [email-masked]
Subject: [ppsp] ppsp charter and problem statement draft

Dear all,

    Attached is the initial version of ppsp charter.I've also submitted a
new version of PPSP problem statement draft to IETF website in the following
link.(
<http://www.ietf.org/internet-drafts/draft-zhang-ppsp-problem-statement-03.t
xt>
http://www.ietf.org/internet-drafts/draft-zhang-ppsp-problem-statement-03.tx
t) .Any comments and suggestions are highly welcome.

We propose to develop an open peer-to-peer (P2P) streaming protocol named
PPSP. This document describes the problems related to PPSP and outlines
considerations that have to be taken in account when arriving at equitable
solutions.

Yunfei

  Best regards!
  Sincerely yours,
      Yunfei 
       2009-05-27

Yunfei Zhang, Ph.D.

Fax: +86 10 63601087

MOBILE: 1360-1032-119

 

  _____  

zhangyunfei

2009-05-27

---

From: "zhangyunfei" <[email-masked]>
Date: Tue, 23 Jun 2009 18:31:30 +0800

Hi Softgear,
  Thanks for your comments.Please see inline about the reply.

             Best regards,
                 Yunfei

zhangyunfei
2009-06-23

发件人： Softgear Ko
发送时间： 2009-06-22 19:50:10
收件人： 'zhangyunfei'; [email-masked]
抄送： 
主题： RE: [ppsp] ppsp charter and problem statement draft

Hello, Yunfei.
 
I have some comments. 
 
In 3.4
 In korea, the mobilTV subscriber is 17 million.  – May I get a reference or document about this?  I have never heard about this.
I read the report of Mobile TV-Tuning in or Switching off from Arthur D Little about this figure. You can visit http://www.adl.com/reports.html?view=366 to download the report.
 
In 4.2.1,
I don’t understand that Figure 2 P2PSIP process. We need update it and explain some more.

This figure is to tell the routing process of P2PSIP.Do you have some suggestions on amending this?

About NAT traversal  in RELOAD, TURN server usage for RELOAD in P2PSIP is not proximity aware. It means peer get a TURN server randomly in the whole Internet. It may be far from the requesting peer. Therefore, we can’t reuse it directly.
I agree with you.So we can involve it in PPSP protocol if people in the mailing list think there are some extra protocols we need to define.
 
As you mentioned, we focus on live streaming.  I think pure live streaming has no buffer for other(child in tree). But, according to the draft, peer exchange bitmap. This means each peer (which is a parent or child) must have buffer for other peer. If peer have buffer and other peer use it, the delivered data has more latency. This is not a pure live streaming. Therefore, there is two types of live streaming – pure live streaming and buffered live streaming. I think we focus on buffered live streaming than pure live streaming. But I think we need discuss whether we focus on pure live streaming.

We need to update the text to make it more clear.Bascailly there are two kinds of solutions in live streaming,push based (tree based) and pull based(mesh based). In the latter, there is no doubt that peer cache exist. Even in pure tree-based streaming, as I propose in the latest PPSP component architecture, there are some communcations between neigbor peers to avoid loop.So peer exchange exists both in tree based or mesh based solutions. We may update the text to make it more clear.
There are some options for PPSP as you mentioned.One is to choose one as the baseline and the other is to involve both. We think both possibilities exist.I agree with you that we need more disscussion on this.

In 8,
Where can I get [MobileTV] ?
You can visit http://www.adl.com/reports.html?view=366 to download the report.
 
Additionally, I think, we have to place emphasis on flash crowd situation of P2P IPTV service.
PPSP should solve flash crowd in the term of scalability.Besides interoperabilty is aslo what we need, esp in the case where different edge infrastructure can offer p2p streaming services.
 
Best regards,
 
-      Softgear Ko

From: [email-masked] [mailto:[email-masked]] On Behalf Of zhangyunfei
Sent: Wednesday, May 27, 2009 8:07 PM
To: [email-masked]
Subject: [ppsp] ppsp charter and problem statement draft
 
Dear all,
    Attached is the initial version of ppsp charter.I've also submitted a new version of PPSP problem statement draft to IETF website in the following link.(http://www.ietf.org/internet-drafts/draft-zhang-ppsp-problem-statement-03.txt) .Any comments and suggestions are highly welcome.
       The abstract is as follows:
We propose to develop an open peer-to-peer (P2P) streaming protocol named PPSP. This document describes the problems related to PPSP and outlines considerations that have to be taken in account when arriving at equitable solutions.
 
Yunfei
  Best regards!
  Sincerely yours,
      Yunfei 
       2009-05-27

zhangyunfei
2009-05-27

---

From: "Softgear Ko" <[email-masked]>
Date: Tue, 23 Jun 2009 23:31:45 +0900

Hello, Yunfei.

What about this figure ? I think this would be better than Figure 2 in the problem statement draft.
This figure describes how P2PSIP process well. Of course, We have to modify some sentences in Sec 4.2.1 as replacing the figure.

  Alice
  (5678)
   |                  +----------------------+
   | FetchReq(Alice)  |                      |
   |----------------->|  P2PSIP DHT overlay  |
   | FetchAns(1234)   |     (RELOAD)         |
   |<-----------------|                      |
   |                  |                      |          Bob
   | AppAttach(1234)  |                      |        (1234)
   |----------------->| -- -- -- -- -- -- -- | --------> |
   |<-----------------| -- -- -- -- -- -- -- | <-------- |
   |                  +----------------------+           |
   |                                                     |
   | <------------------ ICE Checks ----------------->   |
   |  INVITE ----------------------------------------->  |

- Softgear Ko

________________________________________
From: zhangyunfei [mailto:[email-masked]] 
Sent: Tuesday, June 23, 2009 7:32 PM
To: Softgear Ko; [email-masked]
Subject: Re: RE: [ppsp] ppsp charter and problem statement draft

Hi Softgear,
 
             Best regards,
                 Yunfei
 
________________________________________
zhangyunfei
2009-06-23
________________________________________
发件人： Softgear Ko
发送时间： 2009-06-22 19:50:10
收件人： 'zhangyunfei'; [email-masked]
抄送： 
主题： RE: [ppsp] ppsp charter and problem statement draft
 
Hello, Yunfei.
 
I have some comments. 
 
In 3.4
 
In 4.2.1,

 

In 8,

Best regards,
 
-      Softgear Ko

Dear all,
 
Yunfei
  Best regards!
  Sincerely yours,
      Yunfei 
       2009-05-27

________________________________________
zhangyunfei
2009-05-27

---

From: "Softgear Ko" <[email-masked]>
Date: Wed, 24 Jun 2009 09:47:19 +0900

Hello Yunfei.

Oh, There was some errors.
I fixed it as the following figure.

Alice                                                 Bob
  (5678)                                               (1234)  
   |                  +----------------------+           |
   | FetchReq(Bob)    |                      |           |
   |----------------->|  P2PSIP DHT overlay  |           |
   | FetchAns(1234)   |     (RELOAD)         |           |
   |<-----------------|                      |           |
   |                  |                      |           |
   | AppAttach(1234)  |                      |           |
   |----------------->| -- -- -- -- -- -- -- | --------> |
   | AppAttach(5678)  |                      |           |
   |<-----------------| -- -- -- -- -- -- -- | <-------- |
   |                  +----------------------+           |
   |                                                     |
   | <------------------ ICE Checks ----------------->   |
   |  INVITE ----------------------------------------->  |
   |                                                     |

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Softgear Ko
Sent: Tuesday, June 23, 2009 11:32 PM
To: 'zhangyunfei'; [email-masked]
Subject: Re: [ppsp] ppsp charter and problem statement draft

Hello, Yunfei.

  Alice
  (5678)

- Softgear Ko

Hi Softgear,
 
             Best regards,
                 Yunfei

Hello, Yunfei.
 
I have some comments. 
 
In 3.4
 
In 4.2.1,

 

In 8,

Best regards,
 
-      Softgear Ko

Dear all,
 
Yunfei
  Best regards!
  Sincerely yours,
      Yunfei 
       2009-05-27

_______________________________________________
ppsp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ppsp

---

From: "zhangyunfei" <[email-masked]>
Date: Thu, 25 Jun 2009 17:17:31 +0800

Hi,Softgear,
   Thanks for your contribution.Is it more clear if we can replace P2PSIP DHT overlay part by the orginial figure2 to stress two routing procedure(recursive and iterative routing) of P2PSIP as follows?
  (5678)
   |                  +------------------------+
   |                  |   P2PSIP DHT overlay   |
   |                  |        (RELOAD)        |
   |  FetchReq(Alice) |     +---------------+  |
   |----------------->|---->|      Peer     |  |
   |                  |  +--|               |  |
   |                  |  |  +---------------+  |
   |                  |  |     ^         ^     |
   |                  |  |    1|2       3|4    |
   |                  |  |     V         V     |
   |                  |  |   +----+   +----+   |
   |                  |  |   |Peer|   |Peer|   |
   |                  |  |   +----+   +----+   |
   |  FetchAns(1234)  |  |                     |
   |<-----------------|<-+                     |
   |                  |                        |          Bob
   | AppAttach(1234)  |                        |        (1234)
   |----------------->| -- -- -- -- -- -- -- --| --------> |
   |<-----------------| -- -- -- -- -- -- -- --| <-------- |
   |                  +------------------------+           |
   |                                                       |
   | <------------------ ICE Checks ------------------->   |
   |  INVITE ------------------------------------------->  |

  (5678)
   |                  +------------------------+
   |                  |   P2PSIP DHT overlay   |
   |                  |        (RELOAD)        |
   |  FetchReq(Alice) |     +---------------+  |
   |----------------->|---->|      Peer     |  |
   |                  |  +--|               |  |
   |                  |  |  +---------------+  |
   |                  |  |     |         |     |
   |                  |  |    1|         |3    |
   |                  |  |     V         V     |
   |                  |  |   +----+ 2 +----+   |
   |                  |  |   |Peer|-->|Peer|   |
   |                  |  |   +----+   +----+   |
   |  FetchAns(1234)  |  |                     |
   |<-----------------|<-+                     |
   |                  |                        |          Bob
   | AppAttach(1234)  |                        |        (1234)
   |----------------->| -- -- -- -- -- -- -- --| --------> |
   |<-----------------| -- -- -- -- -- -- -- --| <-------- |
   |                  +------------------------+           |
   |                                                       |
   | <------------------ ICE Checks ------------------->   |
   |  INVITE ------------------------------------------->  |

            BR
             yunfei
2009-06-25

发件人： Softgear Ko
发送时间： 2009-06-24 08:47:25
收件人： 'zhangyunfei'; [email-masked]
抄送： 
主题： RE: [ppsp] ppsp charter and problem statement draft

Hello  Yunfei.

Alice                                                                                                  Bob
   (5678)                                                                                              (1234)    
     |                                    +----------------------+                      |
     |  FetchReq(Bob)        |                                            |                      |
     |----------------- >|    P2PSIP  DHT  overlay    |                      |
     |  FetchAns(1234)      |          (RELOAD)                  |                      |
     | <-----------------|                                            |                      |
     |                                    |                                            |                      |
     |  AppAttach(1234)    |                                            |                      |
     |----------------- >|  --  --  --  --  --  --  --  |  -------- >  |
     |  AppAttach(5678)    |                                            |                      |
     | <-----------------|  --  --  --  --  --  --  --  |   <--------  |
     |                                    +----------------------+                      |
     |                                                                                                          |
     |   <------------------  ICE  Checks  ----------------- >      |
     |    INVITE  ----------------------------------------- >    |
     |                                                                                                          |

-----Original  Message-----
From:  [email-masked]  [mailto:[email-masked]]  On  Behalf  Of  Softgear  Ko
Sent:  Tuesday,  June  23,  2009  11:32  PM
To:  'zhangyunfei';  [email-masked]
Subject:  Re:  [ppsp]  ppsp  charter  and  problem  statement  draft

Hello,  Yunfei.

   Alice
   (5678)
     |                                    +----------------------+
     |  FetchReq(Alice)    |                                            |
     |----------------- >|    P2PSIP  DHT  overlay    |
     |  FetchAns(1234)      |          (RELOAD)                  |
     | <-----------------|                                            |
     |                                    |                                            |                    Bob
     |  AppAttach(1234)    |                                            |                (1234)
     |----------------- >|  --  --  --  --  --  --  --  |  -------- >  |
     | <-----------------|  --  --  --  --  --  --  --  |   <--------  |
     |                                    +----------------------+                      |
     |                                                                                                          |
     |   <------------------  ICE  Checks  ----------------- >      |
     |    INVITE  ----------------------------------------- >    |

-  Softgear  Ko

Hi  Softgear,

                         Best  regards,
                                 Yunfei

Hello,  Yunfei.

I  have  some  comments.  

In  3.4

In  4.2.1,

In  8,

Best  regards,

-            Softgear  Ko

Dear  all,

Yunfei
   Best  regards!
   Sincerely  yours,
           Yunfei  
             2009-05-27

---

From: "zhangyunfei" <[email-masked]>
Date: Thu, 25 Jun 2009 17:28:50 +0800

Hi,Softgear,
     Thanks  for  your  contribution.Is  it  more  clear  if  we  can  replace  P2PSIP  DHT  overlay  part  by  the  orginial  figure2  to  stress  two  routing  procedure(recursive  and  iterative  routing)  of  P2PSIP  as  follows?
   (5678)
     |                                    +------------------------+
     |                                    |      P2PSIP  DHT  overlay      |
     |                                    |                (RELOAD)                |
     |    FetchReq(Alice)  |          +---------------+    |
     |----------------- >|---- >|            Peer          |    |
     |                                    |    +--|                              |    |
     |                                    |    |    +---------------+    |
     |                                    |    |          ^                  ^          |
     |                                    |    |        1|2              3|4        |
     |                                    |    |          V                  V          |
     |                                    |    |      +----+      +----+      |
     |                                    |    |      |Peer|      |Peer|      |
     |                                    |    |      +----+      +----+      |
     |    FetchAns(1234)    |    |                                          |
     | <-----------------| <-+                                          |
     |                                    |                                                |                    Bob
     |  AppAttach(1234)    |                                                |                (1234)
     |----------------- >|  --  --  --  --  --  --  --  --|  -------- >  |
     | <-----------------|  --  --  --  --  --  --  --  --|   <--------  |
     |                                    +------------------------+                      |
     |                                                                                                              |
     |   <------------------  ICE  Checks  ------------------- >      |
     |    INVITE  ------------------------------------------- >    |

   (5678)
     |                                    +------------------------+
     |                                    |      P2PSIP  DHT  overlay      |
     |                                    |                (RELOAD)                |
     |    FetchReq(Alice)  |          +---------------+    |
     |----------------- >|---- >|            Peer          |    |
     |                                    |    +--|                              |    |
     |                                    |    |    +---------------+    |
     |                                    |    |          |                  |          |
     |                                    |    |        1|                  |3        |
     |                                    |    |          V                  V          |
     |                                    |    |      +----+  2  +----+      |
     |                                    |    |      |Peer|-- >|Peer|      |
     |                                    |    |      +----+      +----+      |
     |    FetchAns(1234)    |    |                                          |
     | <-----------------| <-+                                          |
     |                                    |                                                |                    Bob
     |  AppAttach(1234)    |                                                |                (1234)
     |----------------- >|  --  --  --  --  --  --  --  --|  -------- >  |
     | <-----------------|  --  --  --  --  --  --  --  --|   <--------  |
     |                                    +------------------------+                      |
     |                                                                                                              |
     |   <------------------  ICE  Checks  ------------------- >      |
     |    INVITE  ------------------------------------------- >    |

                       BR
                         yunfei
2009-06-25

发件人：  Softgear  Ko

Hello    Yunfei.

Alice                                                                                                                                                                                                    Bob
     (5678)                                                                                                                                                                                            (1234)        

-----Original    Message-----
From:    [email-masked]    [mailto:[email-masked]]    On    Behalf    Of    Softgear    Ko
Sent:    Tuesday,    June    23,    2009    11:32    PM
To:    'zhangyunfei';    [email-masked]
Subject:    Re:    [ppsp]    ppsp    charter    and    problem    statement    draft

Hello,    Yunfei.

     Alice
     (5678)

-    Softgear    Ko

Hi    Softgear,

                                                 Best    regards,
                                                                 Yunfei

Hello,    Yunfei.

I    have    some    comments.    

In    3.4

In    4.2.1,

In    8,

Best    regards,

-                        Softgear    Ko

Dear    all,

Yunfei
     Best    regards!
     Sincerely    yours,
                     Yunfei    
                         2009-05-27

---

From: "SoftgearKo" <[email-masked]>
Date: Fri, 26 Jun 2009 11:15:21 +0900

(I apologize if this email is duplicated.)

Hello, yunfei.

Your figure looks better. But, your figure is based on my first figure which has some mistakes as I mentioned in second email. Please redraw it with my second figure. Or, I'll redraw it on the next week because I'm out of office in this week. (My web based emailer doesn't support a plain text well.)
In the iterative routing , the requester (alice) should send request again after it receives first response from the first peer.
In the recursive routing, the arrow #3 should be removed and the response message should be go back to the requester through the reverse path of the requesting path.
Additionally, as I know, P2PSIP choosed the recursive routing as default. I don't think that we need explain iterative routing in the problem state draft.

- Softgear Ko

-------------------------

From: [email-masked] [mailto:[email-masked]] On Behalf Of zhangyunfei
Sent: Thursday, June 25, 2009 6:29 PM
To: [email-masked]
Subject: [ppsp] Fw: Re: RE: ppsp charter and problem statement draft

Hi,Softgear,

   (5678)

                       BR
                         yunfei
2009-06-25

发件人：  Softgear  Ko
 
Hello    Yunfei.

Alice                                                                                                                                                                                                    Bob
     (5678)                                                                                                                                                                                            (1234)        

-----Original    Message-----
From:    [email-masked]    [mailto:[email-masked]]    On    Behalf    Of    Softgear    Ko
Sent:    Tuesday,    June    23,    2009    11:32    PM
To:    'zhangyunfei';    [email-masked]
Subject:    Re:    [ppsp]    ppsp    charter    and    problem    statement    draft
 
Hello,    Yunfei.

     Alice
     (5678)

-    Softgear    Ko

 
Hi    Softgear,
 
                                                 Best    regards,
                                                                 Yunfei

Hello,    Yunfei.
 
I    have    some    comments.    
 
In    3.4
 
In    4.2.1,

 

In    8,

Best    regards,
 
-                        Softgear    Ko

Dear    all,
 
Yunfei
     Best    regards!
     Sincerely    yours,
                     Yunfei    
                         2009-05-27

---

From: "zhangyunfei" <[email-masked]>
Date: Fri, 26 Jun 2009 12:01:51 +0800

.kr>
Subject: Re: RE: [ppsp] Fw: Re: RE:  ppsp charter and problem statement draft
Message-ID: <[email-masked]>
X-mailer: Foxmail 6, 2, 103, 20 [cn]
Mime-Version: 1.0
Content-Type: text/plain;
	charset="gb2312"
Content-Transfer-Encoding: base64

---

From: "zhangyunfei" <[email-masked]>
Date: Fri, 26 Jun 2009 13:41:08 +0800

Seems the email is not sent rightly.Resent it.

Hi,  
     The  figure  is  revised.Actually  here  we  take  Alice  and  BoB  p2p  client  and  the  first  peer  in  the  overlay  acts  as  the  proxy.Then  the  iterative  routing  works  as  the  figure  shows.
     The  P2PSIP  routing  clarification  is  to  state  that  it  may  don't  suit  with  tracker  based  topology(tree  or  meshed).So  we  draw  both  routings.

Alice
   (5678)
     |    FetchReq(Bob)      |          +---------------+    |

   Alice
   (5678)
     |    FetchReq(Bob)      |          +---------------+    |
     |                                    |    |          ^                              |
     |                                    |    |        1|4                            |
     |                                    |    |          V                              |
     |                                    |    |      |Peer| <- >|Peer|      |
     |                                    |    |      +----+  3  +----+      |

zhangyunfei
2009-06-26

发件人：  SoftgearKo
发送时间：  2009-06-26  10:15:33
收件人：  'zhangyunfei';  [email-masked]
抄送：  
主题：  RE:  [ppsp]  Fw:  Re:  RE:  ppsp  charter  and  problem  statement  draft

Hello,    yunfei.

-    Softgear    Ko

Hi,Softgear,

         (5678)

                                                                                         BR
                                                                                                 yunfei
2009-06-25

发件人：        Softgear        Ko

Hello                Yunfei.

Alice                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                Bob
                 (5678)                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                (1234)                                

-----Original                Message-----
From:                [email-masked]                [mailto:[email-masked]]                On                Behalf                Of                Softgear                Ko
Sent:                Tuesday,                June                23,                2009                11:32                PM
To:                'zhangyunfei';                [email-masked]
Subject:                Re:                [ppsp]                ppsp                charter                and                problem                statement                draft

Hello,                Yunfei.

                 Alice
                 (5678)

-                Softgear                Ko

Hi                Softgear,

                                                                                                                                                                                                 Best                regards,
                                                                                                                                                                                                                                                                 Yunfei

Hello,                Yunfei.

I                have                some                comments.                

In                3.4

In                4.2.1,

In                8,

Best                regards,

-                                                                                                Softgear                Ko

Dear                all,

Yunfei
                 Best                regards!
                 Sincerely                yours,
                                                                                 Yunfei                
                                                                                                 2009-05-27

---

From: Reinaldo Penno <[email-masked]>
Date: Fri, 26 Jun 2009 02:49:55 -0400

Is it possible to put this picture on a text file and attach it? At least in
my email reader the formatting is gone.

Thanks,

On 6/25/09 10:41 PM, "zhangyunfei" <[email-masked]> wrote:

>      The  figure  is  revised.Actually  here  we  take  Alice  and  BoB  p2p
> client  and  the  first  peer  in  the  overlay  acts  as  the  proxy.Then
> the  iterative  routing  works  as  the  figure  shows.
>      The  P2PSIP  routing  clarification  is  to  state  that  it  may  don't
> suit  with  tracker  based  topology(tree  or  meshed).So  we  draw  both
> routings.
>
>
>
> Alice
>    (5678)
>      |                                    |                (RELOAD)
> |
>      |                                    |    +--|
>      |                                    |    |          ^                  ^
> |
>      |                                    |    |        1|2              3|4
> |
>      |                                    |    |          V                  V
> |
>      |                                    |    |      +----+      +----+
> |
>      |                                    |    |      |Peer|      |Peer|
> |
>      |                                    |    |      +----+      +----+
> |
> |                    Bob
> |
>      |
> |
>      |                                    |                (RELOAD)
> |
>      |                                    |    +--|
>      |                                    |    |          ^
> |
>      |                                    |                |
> |
>      |                                    |    |        1|4
> |
>      |                                    |    |          V
> |
> |                    Bob
> |
>      |
> |
> Your    figure    looks    better.    But,    your    figure    is    based
> on    my    first    figure    which    has    some    mistakes    as    I
> mentioned    in    second    email.    Please    redraw    it    with    my
> second    figure.    Or,    I'll    redraw    it    on    the    next    week
> because    I'm    out    of    office    in    this    week.    (My    web
> based    emailer    doesn't    support    a    plain    text    well.)
> In    the    iterative    routing    ,    the    requester    (alice)
> should    send    request    again    after    it    receives    first
> response    from    the    first    peer.
> In    the    recursive    routing,    the    arrow    #3    should    be
> removed    and    the    response    message    should    be    go    back
> to    the    requester    through    the    reverse    path    of    the
> requesting    path.
> Additionally,    as    I    know,    P2PSIP    choosed    the    recursive
> routing    as    default.    I    don't    think    that    we    need
> explain    iterative    routing    in    the    problem    state    draft.
>
> -    Softgear    Ko
>
>
>                  Thanks        for        your        contribution.Is
> it        more        clear        if        we        can        replace
> P2PSIP        DHT        overlay        part        by        the
> orginial        figure2        to        stress        two        routing
> procedure(recursive        and        iterative        routing)        of
> P2PSIP        as        follows?
>          (5678)
>                  |
>                  |
> |                        P2PSIP        DHT        overlay
> |
>                  |
> |                                                                (RELOAD)
> |
>                  |
> |                +--|
>                  |
> |                |                +---------------+                |
>                  |
> |                |                                        ^
> ^                                        |
>                  |
> |                |                                1|2
> 3|4                                |
>                  |
> |                |                                        V
> V                                        |
>                  |
> |                |                        +----+                        +----+
> |
>                  |
> |                |                        |Peer|                        |Peer|
> |
>                  |
> |                |                        +----+                        +----+
> |
>                  |                FetchAns(1234)                |
> |
> |
>                  |
> |
> |
> Bob
> |
>                  |
> |
>                  |                INVITE
> -------------------------------------------       >                |
>
>
>          (5678)
>                  |
>                  |
> |                        P2PSIP        DHT        overlay
> |
>                  |
> |                                                                (RELOAD)
> |
>                  |
> |                +--|
>                  |
> |                |                +---------------+                |
>                  |
> |                |                                        |
>                  |
> |                |                                1|
> |3                                |
>                  |
> |                |                                        V
> V                                        |
>                  |
> |                |                        +----+        2        +----+
> |
>                  |
> |                |                        |Peer|--       >|Peer|
> |
>                  |
> |                |                        +----+                        +----+
> |
>                  |                FetchAns(1234)                |
> |
> |
>                  |
> |
> |
> Bob
> |
>                  |
> |
>                  |                INVITE
> -------------------------------------------       >                |
>
>
>
>
> BR
>
> yunfei
> 2009-06-25
>
>
>
> 发件人：        Softgear        Ko
> Bob
> (1234)
> |
>                                  |                FetchReq(Bob)
> |
> |
> |
>                                  |-----------------               >|
> P2PSIP                DHT                overlay
> |
> |
>                                  |                FetchAns(1234)
> |
> (RELOAD)
> |
> |
>                                  |               <-----------------|
> |
> |
>                                  |
> |
> |
> |
>                                  |                AppAttach(1234)
> |
> |
> |
>                                  |-----------------               >|
> --                --                --                --                --
> --                --                |                --------               >
> |
>                                  |                AppAttach(5678)
> |
> |
> |
>                                  |               <-----------------|
> --                --                --                --                --
> --                --                |                               <--------
> |
> |
>                                  |
> |
>                                  |
> <------------------                ICE                Checks
> -----------------               >
> |
>                                  |                                INVITE
> -----------------------------------------               >
> |
>                                  |
> |
>
>
>
> From:                [email-masked]
> [mailto:[email-masked]]                On                Behalf
> Of                Softgear                Ko
> Sent:                Tuesday,                June                23,
> 2009                11:32                PM
> Subject:                Re:                [ppsp]                ppsp
> charter                and                problem                statement
> draft
>
> Hello,                Yunfei.
>
>
> What                about                this                figure
> ?                I                think                this
> would                be                better                than
> Figure                2                in                the
> problem                statement                draft.
> This                figure                describes                how
> P2PSIP                process                well.                Of
> course,                We                have                to
> modify                some                sentences                in
> Sec                4.2.1                as                replacing
> the                figure.
>
>
>                  Alice
>                  (5678)
>                                  |
> +----------------------+
>                                  |                FetchReq(Alice)
> |
> |
>                                  |-----------------               >|
> P2PSIP                DHT                overlay
> |
>                                  |                FetchAns(1234)
> |
> (RELOAD)
> |
>                                  |               <-----------------|
> |
>                                  |
> |
> |
> Bob
>                                  |                AppAttach(1234)
> |
> |
> (1234)
>                                  |-----------------               >|
> --                --                --                --                --
> --                --                |                --------               >
> |
>                                  |               <-----------------|
> --                --                --                --                --
> --                --                |                               <--------
> |
>                                  |
> +----------------------+
> |
>                                  |
> |
>                                  |
> <------------------                ICE                Checks
> -----------------               >
> |
>                                  |                                INVITE
> -----------------------------------------               >
> |
>
>
>
> -                Softgear                Ko
>
>
>
> Subject:                Re:                RE:                [ppsp]
> ppsp                charter                and                problem
> statement                draft
>                  Thanks                for                your
> comments.Please                see                inline                about
> the                reply.
>
>
> Best                regards,
>
> Yunfei
>
> 主题：                RE:                [ppsp]                ppsp
> charter                and                problem                statement
> draft
>
> Hello,                Yunfei.
>
> I                have                some                comments.
>
> In                3.4
>  In                korea,                the                mobilTV
> subscriber                is                17                million.
> –                May                I                get                a
> reference                or                document                about
> this?                                I                have
> never                heard                about                this.
> I                read                the                report
> of                Mobile                TV-Tuning                in
> or                Switching                off                from
> Arthur                D                Little                about
> this                figure.                You                can
> visit                http://www.adl.com/reports.html?view=366
> to                download                the                report.
>
> In                4.2.1,
>  I                don’t                understand                that
> Figure                2                P2PSIP                process.
> We                need                update                it
> and                explain                some                more.
>
>  This                figure                is                to
> tell                the                routing                process
> of                P2PSIP.Do                you                have
> some                suggestions                on                amending
> this?
>
>  About                NAT                traversal
> in                RELOAD,                TURN                server
> usage                for                RELOAD                in
> P2PSIP                is                not                proximity
> aware.                It                means                peer
> get                a                TURN                server
> randomly                in                the                whole
> Internet.                It                may                be
> far                from                the                requesting
> peer.                Therefore,                we                can’t
> reuse                it                directly.
>  I                agree                with                you.So
> we                can                involve                it
> in                PPSP                protocol                if
> people                in                the                mailing
> list                think                there                are
> some                extra                protocols                we
> need                to                define.
>
> As                you                mentioned,                we
> focus                on                live                streaming.
> I                think                pure                live
> streaming                has                no                buffer
> for                other(child                in                tree).
> But,                according                to                the
> draft,                peer                exchange                bitmap.
> This                means                each                peer
> (which                is                a                parent
> or                child)                must                have
> buffer                for                other                peer.
> If                peer                have                buffer
> and                other                peer                use
> it,                the                delivered                data
> has                more                latency.                This
> is                not                a                pure                live
> streaming.                Therefore,                there                is
> two                types                of                live
> streaming                –                pure                live
> streaming                and                buffered                live
> streaming.                I                think                we
> focus                on                buffered                live
> streaming                than                pure                live
> streaming.                But                I                think
> we                need                discuss                whether
> we                focus                on                pure
> live                streaming.
>
> We                need                to                update
> the                text                to                make
> it                more                clear.Bascailly                there
> are                two                kinds                of
> solutions                in                live                streaming,push
> based                (tree                based)                and
> pull                based(mesh                based).                In
> the                latter,                there                is
> no                doubt                that                peer
> cache                exist.                Even                in
> pure                tree-based                streaming,                as
> I                propose                in                the
> latest                PPSP                component
> architecture,                there                are                some
> communcations                between                neigbor
> peers                to                avoid                loop.So
> peer                exchange                exists                both
> in                tree                based                or
> mesh                based                solutions.                We
> may                update                the                text
> to                make                it                more
> clear.
> There                are                some                options
> for                PPSP                as                you
> mentioned.One                is                to                choose
> one                as                the                baseline
> and                the                other                is
> to                involve                both.                We
> think                both                possibilities                exist.I
> agree                with                you                that
> we                need                more                disscussion
> on                this.
>
>
> In                8,
> Where                can                I                get
> [MobileTV]                ?
> You                can                visit
> http://www.adl.com/reports.html?view=366                to
> download                the                report.
>
> Additionally,                I                think,                we
> have                to                place                emphasis
> on                flash                crowd                situation
> of                P2P                IPTV                service.
> PPSP                should                solve                flash
> crowd                in                the                term
> of                scalability.Besides                interoperabilty
> is                aslo                what                we
> need,                esp                in                the
> case                where                different                edge
> infrastructure                can                offer                p2p
> streaming                services.
>
> Best                regards,
>
> -
> Softgear                Ko
>
>
> From:                [email-masked]
> [mailto:[email-masked]]                On                Behalf
> Of                zhangyunfei
> Sent:                Wednesday,                May                27,
> 2009                8:07                PM
> To:                [email-masked]
>                                                  Attached                is
> the                initial                version                of
> ppsp                charter.I've                also                submitted
> a                new                version                of
> PPSP                problem                statement                draft
> to                IETF                website                in
> the                following
> link.(http://www.ietf.org/internet-drafts/draft-zhang-ppsp-problem-statement-0
> 3.txt)                .Any                comments                and
> suggestions                are                highly                welcome.
>
> The                abstract                is                as
> follows:
> We                propose                to                develop
> an                open                peer-to-peer                (P2P)
> streaming                protocol                named                PPSP.
> This                document                describes                the
> problems                related                to                PPSP
> and                outlines                considerations                that
> have                to                be                taken
> in                account                when                arriving
> at                equitable                solutions.
>
> Yunfei
>                  Best                regards!
>                  Sincerely                yours,
>
> Yunfei
>
> 2009-05-27