Subject: [ppsp] Draft for Introduction of Olive and Grid Delivery

From: "Softgear Ko" <[email-masked]>
Date: Mon, 19 Oct 2009 23:19:29 +0900

Dear all:

We have just posted a draft to Introduction of Olive and Grid Delivery.

http://www.ietf.org/internet-drafts/draft-softgear-ppsp-olive-griddelivery-intro-00.txt

Welcome to your comments. Thank you.

- Softgear Ko @ ETRI

-----Original Message-----
From: IETF I-D Submission Tool [mailto:[email-masked]] 
Sent: Monday, October 19, 2009 11:14 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: New Version Notification for draft-softgear-ppsp-olive-griddelivery-intro-00 

A new version of I-D, draft-softgear-ppsp-olive-griddelivery-intro-00.txt has been successfuly submitted by Seok-Kap Ko and posted to the IETF repository.

Filename:	 draft-softgear-ppsp-olive-griddelivery-intro
Revision:	 00
Title:		 Introduction of Olive and Grid Delivery
Creation_date:	 2009-10-18
WG ID:		 Independent Submission
Number_of_pages: 19

Abstract:
This draft briefly introduces Olive distributed media platform and 
Grid Delivery solution. Olive platform, which is built by ETRI, 
provides live peer-to-peer streaming service. Grid Delivery solution, 
which is built by Peering Portal, is one of the most popular Peer-to-
Peer solutions for VoD, AoD, live streaming, and file download 
service in Korea.

The IETF Secretariat.

---

From: "Y.J. Gu" <[email-masked]>
Date: Tue, 20 Oct 2009 10:46:43 +0800

Hi everyone,
We submitted a survey draft for ppsp.

Abstract:
This document presents a survey of popular Peer-to-Peer streaming
applications on the Internet.  We focus on the Architecture and Peer
Protocol/Tracker Signaling Protocol description in the presentation, and
study a selection of well-known P2P streaming systems, including Joost,
PPlive, and more.  Through the survey, we summarize a common P2P streaming
process model and the correspondent signaling process for P2P Streaming
Protocol standardization.

The URL for this draft is:
http://www.ietf.org/id/draft-gu-ppsp-survey-00.txt

We appreciate your comments.
Thanks.

Regards

Yingjie Gu

---

From: "Y.J. Gu" <[email-masked]>
Date: Tue, 20 Oct 2009 10:54:51 +0800

Hi everyone,

Abstract:
This document presents a survey of popular Peer-to-Peer 
streaming applications on the Internet.  We focus on the 
Architecture and Peer Protocol/Tracker Signaling Protocol 
description in the presentation, and study a selection of 
well-known P2P streaming systems, including Joost, PPlive, 
and more.  Through the survey, we summarize a common P2P 
streaming process model and the correspondent signaling 
process for P2P Streaming Protocol standardization.

Regards
 
Yingjie Gu

---

From: Minh Nguyen <[email-masked]>
Date: Tue, 20 Oct 2009 11:43:26 +0200

Dear all,
I wonder that does PPSP work for not only Internet but also Wireless Ad hoc
networks.
If it's not the case, does anyone work on PPSP and Ad hoc networks?
Does anyone have the suggestions in this topic?

Thanks,
-Minh

On Tue, Oct 20, 2009 at 4:54 AM, Y.J. Gu <[email-masked]> wrote:

> _______________________________________________
> ppsp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ppsp
>

-- 
Minh Nguyen
+33 6 65 76 44 60

---

From: "zhangyunfei" <[email-masked]>
Date: Tue, 20 Oct 2009 17:48:17 +0800

Hi Minh，
 PPSP is intended to support both envirnments, including the wireless ad hoc network.However there isn't much large scale PPSP practice in ad hoc networks to the best of our knowledge.If you have such information, welcome to contribute it.

Thanks,
Yunfei

zhangyunfei
2009-10-20

发件人： Minh Nguyen
发送时间： 2009-10-20 17:48:15
收件人： Y.J. Gu
抄送： [email-masked]
主题： Re: [ppsp] Draft for PPSP Survey

Dear all,
I wonder that does PPSP work for not only Internet but also Wireless Ad hoc networks.
If it's not the case, does anyone work on PPSP and Ad hoc networks?
Does anyone have the suggestions in this topic?

Thanks,
-Minh

Hi everyone,

Abstract:
This document presents a survey of popular Peer-to-Peer
streaming applications on the Internet. ?We focus on the
Architecture and Peer Protocol/Tracker Signaling Protocol
description in the presentation, and study a selection of
well-known P2P streaming systems, including Joost, PPlive,
and more. ?Through the survey, we summarize a common P2P
streaming process model and the correspondent signaling
process for P2P Streaming Protocol standardization.

Regards

Yingjie Gu

-- 
Minh Nguyen
+33 6 65 76 44 60

---

From: Minh Nguyen <[email-masked]>
Date: Tue, 20 Oct 2009 13:00:54 +0200

Hi Yunfei,
I have just started the works for P2P video streaming over Ad hoc networks
in which P2P streaming need to be operated efficiently on top of OLSR ad hoc
routing layer.

As I have seen PPSP would be IETF's standard protocol for P2P streaming, It
was a good choice if PPSP could be adapted for Ad hoc/Mesh networks
accordingly.
Do you have any recommend for that? for example, is it possible to extend or
adapt PPSP according to the network environment?

Thanks,
Minh

2009/10/20 zhangyunfei <[email-masked]>

>  Hi Minh，
>  PPSP is intended to support both envirnments, including the wireless ad
> hoc network.However there isn't much large scale PPSP practice in ad hoc
> networks to the best of our knowledge.If you have such information, welcome
> to contribute it.
>
> Thanks,
> Yunfei
>
>  ------------------------------
>  zhangyunfei
> 2009-10-20
>  ------------------------------
>  *发件人：* Minh Nguyen
> *发送时间：* 2009-10-20 17:48:15
> *收件人：* Y.J. Gu
> *抄送：* [email-masked]
> *主题：* Re: [ppsp] Draft for PPSP Survey
>
> Dear all,

-- 
Minh Nguyen
+33 6 65 76 44 60

---

From: Victor Pascual Avila <[email-masked]>
Date: Tue, 20 Oct 2009 13:11:28 +0200

Hi,

On Tue, Oct 20, 2009 at 1:00 PM, Minh Nguyen <[email-masked]> wrote:
(snip)
> is it possible to extend or

Could you please elaborate this approach?

Cheers,
-- 
Victor Pascual Ávila

---

From: "zhangyunfei" <[email-masked]>
Date: Tue, 20 Oct 2009 20:39:12 +0800

Good point!We have a PPSP requirement draft to enumerate the what factors PPSP protocols need to address.The new version of the draft will come out soon.You may refer to it and contribute in this draft about your concerns.

BR
Yunfei

zhangyunfei
2009-10-20

发件人： Minh Nguyen
发送时间： 2009-10-20 19:05:35
收件人： zhangyunfei
抄送： Y.J. Gu; [email-masked]
主题： Re: Re: [ppsp] Draft for PPSP Survey

Hi Yunfei,
I have just started the works for P2P video streaming over Ad hoc networks in which P2P streaming need to be operated efficiently on top of OLSR ad hoc routing layer.

As I have seen PPSP would be IETF's standard protocol for P2P streaming, It was a good choice if PPSP could be adapted for Ad hoc/Mesh networks accordingly.
Do you have any recommend for that? for example, is it possible to extend or adapt PPSP according to the network environment?

Thanks,
Minh

Hi Minh，
?PPSP?is intended to support both?envirnments, including the wireless ad hoc network.However there isn't much large scale PPSP practice in ad hoc networks to the best of our knowledge.If you have such information, welcome to contribute it.
?
Thanks,
Yunfei
?

zhangyunfei
2009-10-20

发件人： Minh Nguyen
发送时间： 2009-10-20?17:48:15
收件人： Y.J. Gu
抄送： [email-masked]
?

Thanks,
-Minh

Hi everyone,

Abstract:

Regards

Yingjie Gu

-- 
Minh Nguyen
+33 6 65 76 44 60

-- 
Minh Nguyen
+33 6 65 76 44 60

---

From: zongning 63316 <[email-masked]>
Date: Wed, 21 Oct 2009 09:18:32 +0800

Hi, Minh

Thank you for offering new use cases of PPSP. I think the design of PPSP protocols including basic functionalities and message encoding will be flexible and extensible enough to adopt as many P2P streaming applications as possible. Just like RTP, we have seen many RTP extensions to emergent new Audio/Video codecs.
So any type of P2P streaming applications are ecouraged to be discussed in mailing list and we will see how much we can incorporate into PPSP design.

BR,
Ning Zong

----- 原邮件 -----
发件人: Minh Nguyen <[email-masked]>
日期: 星期二, 十月 20日, 2009 下午7:02
主题: Re: [ppsp] Draft for PPSP Survey
收件人: zhangyunfei <[email-masked]>
抄送: "[email-masked]" <[email-masked]>

> Hi Yunfei,
> I have just started the works for P2P video streaming over Ad hoc 
> networksin which P2P streaming need to be operated efficiently on 
> top of OLSR ad hoc
> routing layer.
> 
> > On Tue, Oct 20, 2009 at 4:54 AM, Y.J. Gu <[email-masked]> 
> wrote:>
> >> Hi everyone,

---

From: Minh Nguyen <[email-masked]>
Date: Wed, 21 Oct 2009 17:35:27 +0200

Hi All,
To the best of my knowledge, one of the critical issues for multimedia
transport through network diversity is to provide multipath transmission,
especially wireless ad hoc networks. This is due in wireless networks, the
high broken-link and interference make it is sensitive to delay, lost.. P2P
streaming in this networks therefore need to use both multisource and
multipath technique.
RTP is a good example, it is started designing of single transmission from
the beginning, but find it is then difficultly to use many single flows
solely in the needs of using multipath. As the result, standard RTP has been
modified to non-standard MRTP, which is mentioned in this
paper<http://ieeexplore.ieee.org/xpl/freeabs_all.jsp?arnumber=1286033>to
support multi flow. Moreover, the usage of multipath in Internet can
improve significantly the quality of streaming media in P2P overlay.
I was not clear yet about PPSP transmission, and it seems that the
requirement of PPSP transmission in the PPSP's draft is still in progress. I
think we can put the requirement of multipath transmission into this part
as well. Hence, we can avoid the same problem which came from RTP protocol.

BR,
Minh

2009/10/21 zongning 63316 <[email-masked]>

> Hi, Minh
>
> Thank you for offering new use cases of PPSP. I think the design of PPSP
> protocols including basic functionalities and message encoding will be
> flexible and extensible enough to adopt as many P2P streaming applications
> as possible. Just like RTP, we have seen many RTP extensions to emergent new
> Audio/Video codecs.
> So any type of P2P streaming applications are ecouraged to be discussed in
> mailing list and we will see how much we can incorporate into PPSP design.
>
> BR,
> Ning Zong
>
> ----- 原邮件 -----

-- 
Minh Nguyen
+33 6 65 76 44 60

---

From: "Y.J. Gu" <[email-masked]>
Date: Thu, 22 Oct 2009 11:33:29 +0800

Hi Minh,
I'm interested in this topic too. Thank you very much for involving
multipath transport.
You said that multipath transmission is one of the critical issues for
multimedia transport. Could you please disclose more specific information on
this topic? Is there any applications that using multipath transmission? How
they implement and what's the problem they met with? It will be a good
instance for survey draft and we can extract specific requirements for the
requirement draft.
 
Thank you very much :)

Regards

Yingjie Gu

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of Minh
Nguyen
Sent: Wednesday, October 21, 2009 11:35 PM
To: zongning 63316
Cc: [email-masked]; [email-masked]
Subject: Re: [ppsp] Draft for PPSP Survey

Hi All,
<http://ieeexplore.ieee.org/xpl/freeabs_all.jsp?arnumber=1286033> paper to
support multi flow. Moreover, the usage of multipath in Internet can improve
significantly the quality of streaming media in P2P overlay.

BR,
Minh

Hi, Minh

BR,
Ning Zong

----- 原邮件 -----
发件人: Minh Nguyen <[email-masked]>
日期: 星期二, 十月 20日, 2009 下午7:02

-- 
Minh Nguyen
+33 6 65 76 44 60

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Wed, 21 Oct 2009 21:13:19 -0700

A few notes here.

Multipath transport can be used for different purposes. One is to increase the throughput. Assuming that the client is not the bottleneck, by connecting to multiple servers, one can download a content faster (or stream at a higher bitrate). The second purpose is to improve reliability. Assuming the physical links are disjoint (or at least they don’t share the point of congestion), using two paths to receive the same data twice will reduce the effective loss rate (from p to p^2). 

In a p2p environment, the first purpose makes sense (actually it is mostly needed) since often the upload speeds of ordinary peers are pretty low for the average service bandwidth. A peer needs to connect to multiple peers to increase the throughput. It is also good for unexpected events like peer churns. But as for the second purpose, it is a difficult task to make sure that the underlying links are indeed not sharing the point of congestion. In an overlay network, this is pretty difficult. One needs to do a lot of correlation computations to figure out whether congested locations are shared or not (Search for PoC sharing, congestion correlation, etc. in google and look for nossdav/sigmetrics/etc. papers).

In majority of the papers, multipath transport has been overrated due to the simplified assumptions on loss events/correlations. In wireless world, things are not easier (especially in ad hoc networks). If not properly designed and run, multipath transport can create catastrophic results in such environments.

Cheers,
-acbegen

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Y.J. Gu
> Sent: Wednesday, October 21, 2009 11:33 PM
> To: 'Minh Nguyen'; 'zongning 63316'
> I'm interested in this topic too. Thank you very much for involving multipath transport.
> You said that multipath transmission is one of the critical issues for multimedia
> transport. Could you please disclose more specific information on this topic? Is there any
> applications that using multipath transmission? How they implement and what's the problem
> they met with? It will be a good instance for survey draft and we can extract specific
> requirements for the requirement draft.
> 
> Thank you very much :)
> 
> Regards
> 
> Yingjie Gu
> 
> 
> 
> 
> ________________________________
> 
> 	From: [email-masked] [mailto:[email-masked]] On Behalf Of Minh Nguyen
> 	To the best of my knowledge, one of the critical issues for multimedia transport
> through network diversity is to provide multipath transmission, especially wireless ad hoc
> networks. This is due in wireless networks, the high broken-link and interference make it
> is sensitive to delay, lost.. P2P streaming in this networks therefore need to use both
> multisource and multipath technique.
> 	RTP is a good example, it is started designing of single transmission from the
> beginning, but find it is then difficultly to use many single flows solely in the needs of
> using multipath. As the result, standard RTP has been modified to non-standard MRTP, which
> is mentioned in this paper
> <http://ieeexplore.ieee.org/xpl/freeabs_all.jsp?arnumber=1286033>  to support multi flow.
> Moreover, the usage of multipath in Internet can improve significantly the quality of
> streaming media in P2P overlay.
> 	I was not clear yet about PPSP transmission, and it seems that the requirement of
> PPSP transmission in the PPSP's draft is still in progress. I think we can put the
> requirement of multipath transmission into this part  as well. Hence, we can avoid the
> same problem which came from RTP protocol.
> 
> 	BR,
> 	Minh
> 
> 
> 
> protocols including basic functionalities and message encoding will be flexible and
> extensible enough to adopt as many P2P streaming applications as possible. Just like RTP,
> we have seen many RTP extensions to emergent new Audio/Video codecs.