Subject: [ppsp] comment about PPSP requirement

From: "Ko, Seokkap" <[email-masked]>
Date: Tue, 10 Nov 2009 14:48:59 +0900

Hello.

To consider proximity between peer or to select better peer list in the swarm, peer provides additional information than just IP address. For example, network coordination. The current PPSP requirement (draft-zong-ppsp-reqs-02) doesn't mention about this. Of course, map from IP address to network coordination is possible. but, providing its network coordinate to tracker or peers is better and faster. For generality, I don't say just network coordinate information. It also includes bandwidth, capacity, constraints, and so on. These additional information helps the tracker to give better initial peer to new peer. And, it can be for peer selection.

PPSP.TP.REQ-6: PPSP tracker protocol MAY be able to carry the configuration and the status of the peer, e.g. work load, capacity, bandwidth limitation, virtual/physical location etc. A peer MAY report its status to the tracker.

PPSP.PP.REQ-4: PPSP peer protocol MAY carry the virtual/physical location of the peer. It could be used to select better peers.

- Softgear Ko

---

From: "SoftgearKo" <[email-masked]>
Date: Tue, 10 Nov 2009 18:12:14 +0900

Hi,

Oops. PPSP.TP.REQ-6 carry the configuration and the status of the peer was already in PPSP.TP.REQ-4. Sorry for confusing. However, I think the virtual/physical location of the peer should be carried between the tracker and peers 

- Softgear Ko

-----------------------------------------------------------------------------------
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ko, Seokkap
Sent: Tuesday, November 10, 2009 2:49 PM
To: [email-masked]
Subject: [ppsp] comment about PPSP requirement

Hello.

 
 
- Softgear Ko