Subject: [ppsp] charter discussion

From: "zhangyunfei" <[email-masked]>
Date: Tue, 10 Nov 2009 13:14:52 +0900

Dear all,
   The following is the latest verion of the charter, which is one of the most important documents we need to discuss in the BOF. Suggestions and comments are highly appreciated.

BR
Yunfei
------------------------------------------------------------------------------------------------
Description of PPSP Working Group:
The Peer-to-Peer (P2P) Streaming Protocol working group (PPSP WG) is chartered to develop standard signaling protocols (called PPSP protocols) for multiple types of entities (e.g. intelligent endpoints, caches, content distribution network nodes, and/or other edge devices) to participate in P2P streaming systems in both fixed and mobile Internet.

PPSP protocols include the PPSP tracker protocol – a signaling protocol between “PPSP trackers” and “PPSP peers”, and the PPSP peer protocol – a signaling protocol among “PPSP peers”. A PPSP tracker maintains lists of participating PPSP peers, each for a specific channel or streaming file, and answers the queries from PPSP peers for candidate PPSP peers. PPSP peers inform their status information to PPSP trackers, exchange their chunk availability with other PPSP peers and/or PPSP trackers, and ask other PPSP peers for wanted data. 
 
This WG's primary tasks are to produce:
1. A “problem statement” document describing the problems, incentives, and scope of developing the PPSP protocols, as well as common terminologies and concepts.
 
2. A “requirements” document listing the requirements on the designed PPSP protocols (e.g., general functionality and performance requirements of PPSP protocols or basic types of information that PPSP protocols should communicate to facilitate P2P streaming).

3. An "architectural survey" document explaining the current P2P streaming architectures, in particular tracker-based P2P streaming, and key issues in best practice.

4. A proposed standard defining the PPSP peer protocol. This protocol will define how PPSP peers advertise chunk availability. The protocol will also define the requests and responses of chunks among PPSP peers.
 
5. A proposed standard defining the PPSP tracker protocol. This protocol will define how PPSP peers inform and request information from PPSP trackers and how PPSP trackers reply to the requests.
 
6. A “usage document” explaining how the protocols defined above, along with existing IETF protocols, such as RELAOD, ALTO and RTSP, can inter-operate; and how they may be integrated together to produce complete P2P streaming systems.
 
7. Optionally a ”mobile usage document” (PPSP mobile BCP document) to evaluate PPSP with and without Mobile IP support when there are a lot of mobile peers in the system.

The work planned for the PPSP WG is distinct from, but requires close participation with, work in other IETF WGs, particularly P2PSIP, ALTO and MMUSIC. The PPSP WG assumes that it cannot modify baseline P2PSIP, ALTO, and MMUSIC behaviors. If PPSP determines that extensions to P2PSIP, ALTO, MMUSIC are needed, PPSP will seek to define such extensions and present to the respective working groups.

The design of PPSP has to consider security/privacy issues. The protocol document will contain a complete description of the security/privacy issues that PPSP should address.
 
The following topics are excluded from this WG's scope:
1. Transport mechanisms for data transmission among PPSP peers, e.g. using TCP or UDP, unicast or multicast, etc.

2. Network coding mechanisms in P2P streaming. Network coding may be used in P2P streaming, but its support is beyond the scope of current charter.
 
3. Play-out mechanisms including streaming control (e.g., pause, fast-forward, and rewind).
 
4. Algorithms that may be different in different deployments (e.g., chunk selection, local storage strategies).
 
5. Research type questions related to P2P streaming. This WG will instead forward such questions to the IRTF P2PRG or other RG as appropriate. Examples include cache management.
Goals and Milestones:
Apr 2010Working Group Last Call for problem statement
Jun 2010Submit problem statement to IESG as Informational document
Aug 2010Working Group Last Call for architecture survey
Aug 2010Working Group Last Call for requirements
Oct 
2010Submit architecture survey to IESG as Informational document
Oct 2010Submit requirements to IESG as Informational document
Apr 2011Working Group Last Call for PPSP peer protocol
Apr
2011Working Group Last Call for PPSP tracker protocol
Aug 2011Submit PPSP peer protocol to IESG as Proposed Standard
Aug 2011Submit PPSP tracker protocol to IESG as Proposed Standard
Nov 2011Working Group Last Call of usage document
Nov 2011Working Group Last Call of mobility BCP document
Jan 2012Submit usage document to IESG as Informational document
Jan 2012Submit mobility BCP document to IESG as Informational document
Apr 2012Dissolve or re-charter 

zhangyunfei
2009-11-10

---

From: "Schmidt, Christian 1. (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 10 Nov 2009 06:04:50 +0100

Hi Yunfei,
I like the text, nevertheless I would like to make the following text
proposal and 2 questions for clarifications.
 
Best Regards
Christian Schmidt

Proposed new text for more transparency in main description:

Old text:

The Peer-to-Peer (P2P) Streaming Protocol working group (PPSP WG) is
chartered to develop standard signaling protocols (called PPSP
protocols) for multiple types of entities (e.g. intelligent endpoints,
caches, content distribution network nodes, and/or other edge devices)
to participate in P2P streaming systems in both fixed and mobile
Internet.

PPSP protocols include the PPSP tracker protocol - a signaling protocol
between "PPSP trackers" and "PPSP peers", and the PPSP peer protocol - a
signaling protocol among "PPSP peers". A PPSP tracker maintains lists of
participating PPSP peers, each for a specific channel or streaming file,
and answers the queries from PPSP peers for candidate PPSP peers. PPSP
peers inform their status information to PPSP trackers, exchange their
chunk availability with other PPSP peers and/or PPSP trackers, and ask
other PPSP peers for wanted data. 

New text:

The Peer-to-Peer (P2P) Streaming Protocol working group (PPSP WG) is
chartered to develop standard signaling protocols (called PPSP
protocols) for P2P streaming systems in both fixed and mobile Internet.
Participating entities could be intelligent endpoints, caches, content
distribution network nodes, and/or other edge devices.

For a specific channel or streaming file, a PPSP tracker maintains lists
of particiating PPSP peers. The PPSP tracker answers queries from PPSP
peers for candidate PPSP peers. PPSP peers provide their status
information to PPSP trackers, exchange their chunk availability with
other PPSP peers and/or PPSP trackers, and ask other PPSP peers for
wanted data. PPSP protocols include the PPSP tracker protocol - a
signaling protocol between "PPSP trackers" and "PPSP peers", and the
PPSP peer protocol - a signaling protocol among "PPSP peers". 
 
Architectural survey
3. An "architectural survey" document explaining the current P2P
streaming architectures, in particular tracker-based P2P streaming, and
key issues in best practice.
It is good to have a description of the current P2P streaming
architecture. What is missing is the relation to the PPSP work. Will it
contain a proposal for the PPSP architecture?
 
Usage document
6. A "usage document" explaining how the protocols defined above, along
with existing IETF protocols, such as RELAOD, ALTO and RTSP, can
inter-operate; and how they may be integrated together to produce
complete P2P streaming systems.
This sounds more like a "interop document". Was this the intention?

________________________________

Von: [email-masked] [mailto:[email-masked]] Im Auftrag von
ext zhangyunfei
Gesendet: Dienstag, 10. November 2009 13:15
An: [email-masked]
Betreff: [ppsp] charter discussion

Dear all,
   The following is the latest verion of the charter, which is one of
the most important documents we need to discuss in the BOF. Suggestions
and comments are highly appreciated.
 
BR
Yunfei
------------------------------------------------------------------------
------------------------
Description of PPSP Working Group:

The Peer-to-Peer (P2P) Streaming Protocol working group (PPSP WG) is
chartered to develop standard signaling protocols (called PPSP
protocols) for multiple types of entities (e.g. intelligent endpoints,
caches, content distribution network nodes, and/or other edge devices)
to participate in P2P streaming systems in both fixed and mobile
Internet.

PPSP protocols include the PPSP tracker protocol - a signaling protocol
between "PPSP trackers" and "PPSP peers", and the PPSP peer protocol - a
signaling protocol among "PPSP peers". A PPSP tracker maintains lists of
participating PPSP peers, each for a specific channel or streaming file,
and answers the queries from PPSP peers for candidate PPSP peers. PPSP
peers inform their status information to PPSP trackers, exchange their
chunk availability with other PPSP peers and/or PPSP trackers, and ask
other PPSP peers for wanted data. 

This WG's primary tasks are to produce:
1. A "problem statement" document describing the problems, incentives,
and scope of developing the PPSP protocols, as well as common
terminologies and concepts.

2. A "requirements" document listing the requirements on the designed
PPSP protocols (e.g., general functionality and performance requirements
of PPSP protocols or basic types of information that PPSP protocols
should communicate to facilitate P2P streaming).

3. An "architectural survey" document explaining the current P2P
streaming architectures, in particular tracker-based P2P streaming, and
key issues in best practice.

4. A proposed standard defining the PPSP peer protocol. This protocol
will define how PPSP peers advertise chunk availability. The protocol
will also define the requests and responses of chunks among PPSP peers.

5. A proposed standard defining the PPSP tracker protocol. This protocol
will define how PPSP peers inform and request information from PPSP
trackers and how PPSP trackers reply to the requests.

6. A "usage document" explaining how the protocols defined above, along
with existing IETF protocols, such as RELAOD, ALTO and RTSP, can
inter-operate; and how they may be integrated together to produce
complete P2P streaming systems.

7. Optionally a "mobile usage document" (PPSP mobile BCP document) to
evaluate PPSP with and without Mobile IP support when there are a lot of
mobile peers in the system.

The work planned for the PPSP WG is distinct from, but requires close
participation with, work in other IETF WGs, particularly P2PSIP, ALTO
and MMUSIC. The PPSP WG assumes that it cannot modify baseline P2PSIP,
ALTO, and MMUSIC behaviors. If PPSP determines that extensions to
P2PSIP, ALTO, MMUSIC are needed, PPSP will seek to define such
extensions and present to the respective working groups.

The design of PPSP has to consider security/privacy issues. The protocol
document will contain a complete description of the security/privacy
issues that PPSP should address.

The following topics are excluded from this WG's scope:
1. Transport mechanisms for data transmission among PPSP peers, e.g.
using TCP or UDP, unicast or multicast, etc.

2. Network coding mechanisms in P2P streaming. Network coding may be
used in P2P streaming, but its support is beyond the scope of current
charter.

3. Play-out mechanisms including streaming control (e.g., pause,
fast-forward, and rewind).

4. Algorithms that may be different in different deployments (e.g.,
chunk selection, local storage strategies).

5. Research type questions related to P2P streaming. This WG will
instead forward such questions to the IRTF P2PRG or other RG as
appropriate. Examples include cache management.

Goals and Milestones:

Apr 2010

Working Group Last Call for problem statement

Jun 2010

Submit problem statement to IESG as Informational document

Aug 2010

Working Group Last Call for architecture survey

Aug 2010

Working Group Last Call for requirements

Oct 

2010

Submit architecture survey to IESG as Informational document

Oct 2010

Submit requirements to IESG as Informational document

Apr 2011

Working Group Last Call for PPSP peer protocol

Apr

2011

Working Group Last Call for PPSP tracker protocol

Aug 2011

Submit PPSP peer protocol to IESG as Proposed Standard

Aug 2011

Submit PPSP tracker protocol to IESG as Proposed Standard

Nov 2011

Working Group Last Call of usage document

Nov 2011

Working Group Last Call of mobility BCP document

Jan 2012

Submit usage document to IESG as Informational document

Jan 2012

Submit mobility BCP document to IESG as Informational document

Apr 2012

Dissolve or re-charter 

________________________________

zhangyunfei
2009-11-10

---

From: "zhangyunfei" <[email-masked]>
Date: Tue, 10 Nov 2009 23:42:43 +0900

Hi Christian,
   Thanks for the suggestion.Please see inline for the reply.

BR
Yunfei

zhangyunfei
2009-11-10

发件人： Schmidt, Christian 1. (NSN - DE/Munich)
发送时间： 2009-11-10 14:11:23
收件人： ext zhangyunfei; [email-masked]
抄送： 
主题： AW: [ppsp] charter discussion

Hi Yunfei,
I like the text, nevertheless I would like to make the following text proposal and 2 questions for clarifications.

Best Regards
Christian Schmidt

New text:
The Peer-to-Peer (P2P) Streaming Protocol working group (PPSP WG) is chartered to develop standard signaling protocols (called PPSP protocols) for P2P streaming systems in both fixed and mobile Internet. Participating entities could be intelligent endpoints, caches, content distribution network nodes, and/or other edge devices.
I am okay for this modification.

For a specific channel or streaming file, a PPSP tracker maintains lists of particiating PPSP peers. The PPSP tracker answers queries from PPSP peers for candidate PPSP peers. PPSP peers provide their status information to PPSP trackers, exchange their chunk availability with other PPSP peers and/or PPSP trackers, and ask other PPSP peers for wanted data. PPSP protocols include the PPSP tracker protocol – a signaling protocol between “PPSP trackers” and “PPSP peers”, and the PPSP peer protocol – a signaling protocol among “PPSP peers”. 
To make the scope clear,it would be better to state that we have tracker protocol and peer protocol and then explain what each of them acts.

Architectural survey
3. An "architectural survey" document explaining the current P2P streaming architectures, in particular tracker-based P2P streaming, and key issues in best practice.
It is good to have a description of the current P2P streaming architecture. What is missing is the relation to the PPSP work. Will it contain a proposal for the PPSP architecture?
Good suggestion.We may contain a proposal for the PPSP architecture(although which is almostly included in the survey)in the end of the architectural survey draft.

Usage document
6. A “usage document” explaining how the protocols defined above, along with existing IETF protocols, such as RELAOD, ALTO and RTSP, can inter-operate; and how they may be integrated together to produce complete P2P streaming systems.
This sounds more like a "interop document". Was this the intention?
Actually we want to give the readers a whole picture of how a p2p streaming system will be constructed with the exisiting and PPSP protocols.It just wants to fill in these protcols to all the components in the architecture figure we proposed in last bar bof.

Von: [email-masked] [mailto:[email-masked]] Im Auftrag von ext zhangyunfei
Gesendet: Dienstag, 10. November 2009 13:15
An: [email-masked]
Betreff: [ppsp] charter discussion

Dear all,

BR
Yunfei

 

 

 

 

zhangyunfei
2009-11-10

---

From: "zhangyunfei" <[email-masked]>
Date: Tue, 10 Nov 2009 23:47:51 +0900

Hi Soek-kap,
   Thanks for the comments.Please see inline for the reply.

zhangyunfei
2009-11-10

发件人： Ko, Seokkap
发送时间： 2009-11-10 16:12:04
收件人： Schmidt, Christian 1. \(NSN - DE/Munich\); ext zhangyunfei; [email-masked]
抄送： 
主题： RE: Re: [ppsp] charter discussion

Hi all.

About comment for architectural survey,
Currently, The problem statement draft describes PPSP architecture because it contains PPSP concepts. However, the charter doesn't mention it.
I think that making a seperated architecture document from problem statement is better. Or the charter should mention it.
I think this is a similar suggestion as Christian's.I think that we can add a section in the survey document in the following version to state clearly PPSP architecture.

About comment for Usage document,
Interoperation document is not bad. But, interoperation document can contain only interoperation issues. However, Usage document can contain many case. e.g. very simple scenario, which doesn't have interoperation issue.
Good suggestion.We may add some scenarios in the usage document.

- Softgear Ko.

-----?? ???-----
From: "Schmidt, Christian 1. (NSN - DE/Munich)" <[email-masked]>
From Date: 2009-11-10 ?? 2:04:50
To: "ext zhangyunfei" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: 
Subject: Re: [ppsp] charter discussion

Hi Yunfei,

Best Regards
Christian Schmidt

New text:

Architectural survey

Usage document

Dear all,

BR
Yunfei

 

 

 

 

zhangyunfei
2009-11-10

---

From: Victor Pascual Avila <[email-masked]>
Date: Tue, 10 Nov 2009 18:11:38 +0100

Hi,

I'm fine with the proposed modifications. I do support the charter.

Cheers,
-Victor

2009/11/10 zhangyunfei <[email-masked]>

>  ------------------------------
>  zhangyunfei
> 2009-11-10
>  ------------------------------
>  *发件人：* Schmidt, Christian 1. (NSN - DE/Munich)
> *发送时间：* 2009-11-10 14:11:23
> *收件人：* ext zhangyunfei; [email-masked]
> *抄送：*
> *主题：* AW: [ppsp] charter discussion
>
>   Hi Yunfei,
> chartered to develop standard signaling protocols (called PPSP protocols)
> for multiple types of entities (e.g. intelligent endpoints, caches, content
> distribution network nodes, and/or other edge devices) to participate in P2P
> streaming systems in both fixed and mobile Internet.
>
>
> PPSP protocols include the PPSP tracker protocol – a signaling protocol
> between “PPSP trackers” and “PPSP peers”, and the PPSP peer protocol – a
> signaling protocol among “PPSP peers”. A PPSP tracker maintains lists of
> participating PPSP peers, each for a specific channel or streaming file, and
> answers the queries from PPSP peers for candidate PPSP peers. PPSP peers
> inform their status information to PPSP trackers, exchange their chunk
> availability with other PPSP peers and/or PPSP trackers, and ask other PPSP
> peers for wanted data.
>
>
>
> New text:
>
> chartered to develop standard signaling protocols (called PPSP protocols) for
> P2P streaming systems in both fixed and mobile Internet. Participating
> entities could be intelligent endpoints, caches, content distribution
> network nodes, and/or other edge devices.
>
> For a specific channel or streaming file, a PPSP tracker maintains lists of
> particiating PPSP peers. The PPSP tracker answers queries from PPSP peers
> for candidate PPSP peers. PPSP peers provide their status information to
> PPSP trackers, exchange their chunk availability with other PPSP peers
> and/or PPSP trackers, and ask other PPSP peers for wanted data. PPSP
> protocols include the PPSP tracker protocol – a signaling protocol between
> “PPSP trackers” and “PPSP peers”, and the PPSP peer protocol – a signaling
> protocol among “PPSP peers”.
> To make the scope clear,it would be better to state that we have tracker
> protocol and peer protocol and then explain what each of them acts.
>
> Architectural survey
> 3. An "architectural survey" document explaining the current P2P streaming
> architectures, in particular tracker-based P2P streaming, and key issues in
> best practice.
> It is good to have a description of the current P2P streaming architecture.
> What is missing is the relation to the PPSP work. Will it contain a proposal
> for the PPSP architecture?
> Good suggestion.We may contain a proposal for the PPSP
> architecture(although which is almostly included in the survey)in the end of
> the architectural survey draft.
>
> Usage document
>  6. A “usage document” explaining how the protocols defined above, along
> inter-operate; and how they may be integrated together to produce complete
> P2P streaming systems.
> Actually we want to give the readers a whole picture of how a p2p streaming
> system will be constructed with the exisiting and PPSP protocols.It just
> wants to fill in these protcols to all the components in the architecture
> figure we proposed in last bar bof.
>
>  ------------------------------
> *Von:* [email-masked] [mailto:[email-masked]] *Im Auftrag
> von *ext zhangyunfei
> *Gesendet:* Dienstag, 10. November 2009 13:15
> *An:* [email-masked]
> *Betreff:* [ppsp] charter discussion
>
>  Dear all,
>    The following is the latest verion of the charter, which is one of the
> most important documents we need to discuss in the BOF. Suggestions and
> comments are highly appreciated.
>
> BR
> Yunfei
>
> ***Description of PPSP Working Group:*
>
> chartered to develop standard signaling protocols (called PPSP protocols)
> for multiple types of entities (e.g. intelligent endpoints, caches, content
> distribution network nodes, and/or other edge devices) to participate in P2P
> streaming systems in both fixed and mobile Internet.
>
>
> PPSP protocols include the PPSP tracker protocol – a signaling protocol
> between “PPSP trackers” and “PPSP peers”, and the PPSP peer protocol – a
> signaling protocol among “PPSP peers”. A PPSP tracker maintains lists of
> participating PPSP peers, each for a specific channel or streaming file, and
> answers the queries from PPSP peers for candidate PPSP peers. PPSP peers
> inform their status information to PPSP trackers, exchange their chunk
> availability with other PPSP peers and/or PPSP trackers, and ask other PPSP
> peers for wanted data.
>
>
>
> 1. A “problem statement” document describing the problems, incentives, and
> scope of developing the PPSP protocols, as well as common terminologies and
> concepts.
>
>
>
> 2. A “requirements” document listing the requirements on the designed PPSP
> protocols (e.g., general functionality and performance requirements of PPSP
> protocols or basic types of information that PPSP protocols should
> communicate to facilitate P2P streaming).
>
>
> 3. An "architectural survey" document explaining the current P2P streaming
> architectures, in particular tracker-based P2P streaming, and key issues in
> best practice.
>
>
> 4. A proposed standard defining the PPSP peer protocol. This protocol will
> define how PPSP peers advertise chunk availability. The protocol will also
> define the requests and responses of chunks among PPSP peers.
>
>
>
> will define how PPSP peers inform and request information from PPSP trackers
> and how PPSP trackers reply to the requests.
>
>
>
> 6. A “usage document” explaining how the protocols defined above, along
> inter-operate; and how they may be integrated together to produce complete
> P2P streaming systems.
>
>
>
> 7. Optionally a ”mobile usage document” (PPSP mobile BCP document) to
> participation with, work in other IETF WGs, particularly P2PSIP, ALTO and
> MMUSIC. The PPSP WG assumes that it cannot modify baseline P2PSIP, ALTO, and
> MMUSIC behaviors. If PPSP determines that extensions to P2PSIP, ALTO, MMUSIC
> are needed, PPSP will seek to define such extensions and present to the
> respective working groups.
>
>
> document will contain a complete description of the security/privacy issues
> that PPSP should address.
>
>
>
> 2. Network coding mechanisms in P2P streaming. Network coding may be used
> in P2P streaming, but its support is beyond the scope of current charter.
>
>
>
> 5. Research type questions related to P2P streaming. This WG will instead
> forward such questions to the IRTF P2PRG or other RG as appropriate.
> Examples include cache management.
>
> *Goals and Milestones:*
>
> Apr 2010
>
>  ------------------------------
>  zhangyunfei
> 2009-11-10
>
> _______________________________________________
> ppsp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ppsp
>
>

-- 
Victor Pascual Ávila