Subject: Re: [ppsp] charter discussion, peer<->tracker protocol

From: "zhangyunfei" <[email-masked]>
Date: Fri, 11 Dec 2009 10:46:07 +0800

Hi Kent,
    I agree with your points.One point to stress is that the trackers may be a "cluster"of nodes or "distributed"node sets. So the bottleneck problem can be avoided in some sense.And the "additional resource recruting"is the complementary means. Basically we rely on the peers to find the resource themselves.
    The evalution of how much the workload such intelligent algorithm can bring to the tracker is an interesting point for PPSP group and we need more detailed work to support.

BR
Yunfei

zhangyunfei
2009-12-11

发件人： Kang Heng WU
发送时间： 2009-12-11 10:43:18
收件人： zhangyunfei; Omer Luzzatti; [email-masked]
抄送： 
主题： RE: [ppsp] charter discussion, peer<->tracker protocol

Hi Yunfei and Omer,

Tracker will be a bottleneck in p2p network. If the intelligence algorithm runs in tracker side, the startup performance of peer will be good. But the supporting users of the tracker will be small. Maybe some intelligence algorithm can run in peer side. The peers can gossip each other and find out a good solution. My detail comments are as follows.

Thanks,
Kent

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of zhangyunfei
Sent: Friday, December 11, 2009 10:04 AM
To: Omer Luzzatti; [email-masked]
Subject: Re: [ppsp] charter discussion, peer<->tracker protocol

Dear Omer,
   Thanks for your comments.It's very informative and instructive.Please see inline for the reply.Thanks again!

BR
Yunfei

zhangyunfei
2009-12-11

发件人： Omer Luzzatti
发送时间： 2009-12-10 22:08:12
收件人： [email-masked]
抄送： 
主题： [ppsp] charter discussion, peer<->tracker protocol

Dear all,
A few comments/questions regarding the peer<->tracker protocol:
 
1.    I believe that the protocol should reflect the fact that sometimes the tracker may ‘recruit’ additional resources to the swarm. This ability to ‘recruit’ nodes helps facilitating the streaming in most p2p existing live streaming platforms. These recruited nodes may be ‘super-nodes’ (hosted by the provider or identified as such by the platform), or regular nodes called to hold some segments of data.
 Sound interesting.If we have such mechanism, the streaming quality in the starting time may be better.The key is how to balance this "proactive" message and the "feedback" periodic message from the peer to the tracker. Do they have the same effect?Or better if combined? 
             
2.    Related to the above and yet somewhat more delicate question is whether different nodes have different ‘roles’. The most obvious example, related to super-nodes, is the need of a consumer node to be aware of the fact that in the retrieved peer-list some of the nodes are indeed super-nodes (thus are reliable, have all data, etc…). In a different example the recruited nodes may be called to behave differently and e.g. not to fetch the entire media stream/file but only parts of it (VOD p2p streaming is an obvious case for this).
I think the peer tracker protocol shall covers this message. 
 
3.  The tracker peer list might also include additional information about the peers in the peer list. Common additional information is the ‘zone’ the peers are from (be a ‘zone’ the country, or the actual ISP), LAN information, NAT types, ‘role’ (see my previous point), and so on. This has to be somehow combined with ALTO which most probably will contribute an In-ISP information. Another related point is whether the peers in the peer-list are ‘ordered’.
We share the same opinion on this. Some "zone" or "network location"info shall be reflected in PPSP information.
As for the "order"of the peers in the peerlist, this seems a problem out of the scope of PPSP.PPSP just deals with information exchange. The following action done by the tracker seems vendor dependent,e.g, what order of the returned peers . Different p2p streaming vendors can do this differently.
            Kent: The tracker provides the simple statistic information. The peer can use this kind simple statistic to find out a set of good peers.
 4  4. I’m less sure how this should be tackled (and if at all under this scope) but to my experience, sometimes, the tracker should be able to ‘redirect’ the peer to another channel/swarm. Example: the same channel/event is being broadcasted from multiple encoders (for redundancy and scalability) and the tracker acts also as a ‘balancer’ to spread the viewers among the swarms. In some other cases, such as in multiple stream qualities for ‘adaptive bandwidth’ (not SVC but multiple channels in different qualities thus the way it is done in Silverlight) the tracker ‘picks’ the channel according to pre-defined rules or strategies (e.g. customers that paid for the service will be redirected to a high-quality channel while the non-paying customers to a lower-quality channel). 
      Very interesting!I think this can be a very good feather if the tracker has such ability when we want to run a real P2P streaming system.I'd like to see more discussion about this in the mailing list.
Kent: About the “redirect”, can the tracker reply “several qualities channels” to peer. The peer can select the suitable channel according to its network environment or user habit. 
 
5. To some extent the tracker should also, directly or indirectly, receive feedback, such as status and statistics, from the peers. Basic example is the peer’s viewing quality. This information, usually, is not being used to help the specific peer but the aggregation of such information helps the platform/tracker to identify ‘starvation’ cases and as a result to allocate additional resources to the swarm.

I agree.We address the same point in the problem statement draft and I think this can be done in the second stage.
 
Regards,
Omer

************************************************************************************
This footnote confirms that this email message has been scanned by
PineApp Mail-SeCure for the presence of malicious code, vandals & computer viruses.
************************************************************************************

This message (including any attachments) is for the named addressee(s)'s use only. It may contain sensitive, confidential, private proprietary or legally privileged information intended for a specific individual and purpose, and is protected by law. If you are not the intended recipient, please immediately delete it and all copies of it from your system, destroy any hard copies of it and notify the sender. Any use, disclosure, copying, or distribution of this message and/or any attachments is strictly prohi bited.

---

From: "Omer Luzzatti" <[email-masked]>
Date: Fri, 11 Dec 2009 15:20:17 +0200

I agree with Kent as well and indeed gossip protocols could be utilized.

Moreover, indeed building a scalable multi-channel environment solution with specific QoS (delays, startup times, quality) is a challenge on the tracker side as well. Yunfei, if you’d like I can try and sketch the components/algorithms/architecture of such a ‘tracker’ for the March meeting.

Regards

Omer

From: zhangyunfei [mailto:[email-masked]] 
Sent: Friday, December 11, 2009 4:46 AM
To: Kang Heng WU; Omer Luzzatti; [email-masked]
Subject: Re: RE: [ppsp] charter discussion, peer<->tracker protocol

Hi Kent,

BR

Yunfei

________________________________

zhangyunfei

2009-12-11

________________________________

发件人： Kang Heng WU

抄送： 

Hi Yunfei and Omer,

Thanks,

Kent

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of zhangyunfei
Sent: Friday, December 11, 2009 10:04 AM
To: Omer Luzzatti; [email-masked]
Subject: Re: [ppsp] charter discussion, peer<->tracker protocol

Dear Omer,

BR

Yunfei

________________________________

zhangyunfei

2009-12-11

________________________________

发件人： Omer Luzzatti

收件人： [email-masked]

抄送： 

Dear all,

Regards,

Omer

________________________________

________________________________

---

From: "Y.J. Gu" <[email-masked]>
Date: Mon, 14 Dec 2009 09:17:21 +0800

Hi all,
I am now working on the PPSP Tracker protocol draft and I sincerely hope
more people would contribute to the draft. Are there anybody else would like
to work together on the draft? 
Thank you very much.

Regards

Yingjie Gu

---

From: "zhangyunfei" <[email-masked]>
Date: Mon, 14 Dec 2009 10:28:17 +0800

Hi,
    I think this is a very good start for real PPSP protocol design.We can see from the mailing list that many people are participating actively for the charter discussion. Many of the parts are related to PPSP protocols design.
    It would be great if we can see many parties involve in the protocol design, including the p2p streaming vendors like pplive, uusee, coolruc and Goalbit who is running practical p2p streaming systems.We also hope to see other participants like opertors, network and terminal vendors, as well as school and research institutes.

         BR
           Yunfei

zhangyunfei
2009-12-14

发件人： Y.J. Gu
发送时间： 2009-12-14 09:26:16
收件人： [email-masked]
抄送： 'zhangyunfei'
主题： Call for contribution.

Hi all,
I am now working on the PPSP Tracker protocol draft and I sincerely hope more people would contribute to the draft. Are there anybody else would like to work together on the draft? 
Thank you very much.

Regards
Yingjie Gu

---

From: "zhangyunfei" <[email-masked]>
Date: Mon, 14 Dec 2009 10:33:15 +0800

Hi Omer,
   It would be great if we can hear more things in the tracker part for March meeting.It's helpful for tracker protocol design.Thanks so much for your contribution.

BR
Yunfei

zhangyunfei
2009-12-14

发件人： Omer Luzzatti
发送时间： 2009-12-11 22:06:05
收件人： zhangyunfei; Kang Heng WU; [email-masked]
抄送： 
主题： RE: RE: [ppsp] charter discussion, peer<->tracker protocol

 
Regards
Omer

Hi Kent,
 
BR
Yunfei

zhangyunfei
2009-12-11

发件人： Kang Heng WU
 
Hi Yunfei and Omer,

Thanks,
Kent
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of zhangyunfei
Sent: Friday, December 11, 2009 10:04 AM
To: Omer Luzzatti; [email-masked]
Subject: Re: [ppsp] charter discussion, peer<->tracker protocol
 
Dear Omer,
 
BR
Yunfei

zhangyunfei
2009-12-11

发件人： Omer Luzzatti
 
Dear all,

 

 
Regards,
Omer