Subject: Re: [ppsp] charter discussion

From: Alberto José González Cela <[email-masked]>
Date: Wed, 2 Dec 2009 22:21:24 +0100

Hi all,

Just one comment.

I would generalize the following:

[new] The design of PPSP will investigate various media coding
mechanisms (e.g. SVC, MDC) to incorporate their features into media
description (e.g. chunk description in peer protocol).

According to the following:

[new] The design of PPSP will consider transmission of multiple
streams (layered media). This includes to investigate various media
coding mechanisms (e.g. SVC, MDC) to incorporate their features into
media description (e.g. chunk description in peer protocol).

This way, we don't focus only on media coding techniques and we leave
the door open for other approaches such as media synchronization
(audio, video, etc.).

BR,

-- 
Alberto Jose Gonzalez Cela
Universitat Politecnica de Catalunya / i2CAT Foundation

---

From: "zhangyunfei" <[email-masked]>
Date: Thu, 10 Dec 2009 11:08:06 +0800

Hi Alberto,
   I agree that it's very important to think over media description with media coding into consideration.But I suggest to modify the sentence as follows:

[Update]
>>The  design  of  PPSP  will  consider  the senario of transmission  of  multiple
streams  (layered  media).  This  includes considering variou media descriptions 
(e.g. chunk description in peer protocol) after investigating different media coding 
mechanisms (e.g. SVC, MDC) to incorporate their features in the protocol.

This way,we leave room for some other approches while keep the scope in the signaling domain.

BR
Yunfei

zhangyunfei
2009-12-10

发件人： Alberto_Jos開Gonz醠ez_Cela
发送时间： 2009-12-03 05:29:32
收件人： [email-masked]
抄送： 
主题： Re: [ppsp] charter discussion

Hi  all,

Just  one  comment.

BR,

--  
Alberto  Jose  Gonzalez  Cela
Universitat  Politecnica  de  Catalunya  /  i2CAT  Foundation
_______________________________________________
ppsp  mailing  list
[email-masked]
https://www.ietf.org/mailman/listinfo/ppsp

---

From: "Y.J. Gu" <[email-masked]>
Date: Thu, 10 Dec 2009 11:39:55 +0800

Hi,
I agree that research in media coding is meaningful in PPSP, as we have
discussed in the early posts.
However, transmission IMHO is out the scope of PPSP. The main aim of PPSP,
either Tracker protocol or peer protocol, is to help peers find where to get
(parts of )the stream.  The transmission, including synchronization, can be
guaranteed by other Protocol, e.g. RTSP. We don't restrict which protocol a
peer should use to get the stream, as long as both sides of the session come
to a consensus. 
At this stage, I think we'd better not make the scope too wide and
amphibolous, except that there are evidences that transmission will impact
P2P streaming protocol.
Can anybody give some clues?

Regards

Yingjie Gu

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
zhangyunfei
Sent: Thursday, December 10, 2009 11:08 AM
To: Alberto_Jos開Gonz醠ez_Cela; [email-masked]
Subject: Re: [ppsp] charter discussion

Hi Alberto,
   I agree that it's very important to think over media description with
media coding into consideration.But I suggest to modify the sentence as
follows:

[new]  The  design  of  PPSP  will  consider  transmission  of  multiple
streams  (layered  media).  This  includes  to  investigate  various  media
coding  mechanisms  (e.g.  SVC,  MDC)  to  incorporate  their  features
into
media  description  (e.g.  chunk  description  in  peer  protocol).
 
[Update]
>>The  design  of  PPSP  will  consider  the senario of transmission  of
multiple 
streams  (layered  media).  This  includes considering variou media
descriptions 
(e.g. chunk description in peer protocol) after investigating different
media coding 
mechanisms (e.g. SVC, MDC) to incorporate their features in the protocol.
 
This way,we leave room for some other approches while keep the scope in the
signaling domain.
 
BR
Yunfei

  _____  

zhangyunfei
2009-12-10

  _____  

Hi  all,
 
Just  one  comment.

 
 
[new]  The  design  of  PPSP  will  consider  transmission  of  multiple
streams  (layered  media).  This  includes  to  investigate  various  media
coding  mechanisms  (e.g.  SVC,  MDC)  to  incorporate  their  features
into
media  description  (e.g.  chunk  description  in  peer  protocol).
 
This  way,  we  don't  focus  only  on  media  coding  techniques  and  we
leave
the  door  open  for  other  approaches  such  as  media  synchronization
(audio,  video,  etc.).
 
BR,

---

From: "zhangyunfei" <[email-masked]>
Date: Thu, 10 Dec 2009 11:50:36 +0800

Cannot agree more with Yingjie.We'd better narrow the scope as the BOF suggested.

BR
Yunfei

zhangyunfei
2009-12-10

发件人： Y.J. Gu
发送时间： 2009-12-10 11:49:43
收件人： 'zhangyunfei'; 'Alberto_Jos開Gonz醠ez_Cela'; [email-masked]
抄送： 
主题： RE: [ppsp] charter discussion

Hi,
I agree that research in media coding is meaningful in PPSP, as we have discussed in the early posts.
However, transmission IMHO is out the scope of PPSP. The main aim of PPSP, either Tracker protocol or peer protocol, is to help peers find where to get (parts of )the stream.  The transmission, including synchronization, can be guaranteed by other Protocol, e.g. RTSP. We don't restrict which protocol a peer should use to get the stream, as long as both sides of the session come to a consensus. 
At this stage, I think we'd better not make the scope too wide and amphibolous, except that there are evidences that transmission will impact P2P streaming protocol.
Can anybody give some clues?

Regards
Yingjie Gu

From: [email-masked] [mailto:[email-masked]] On Behalf Of zhangyunfei
Sent: Thursday, December 10, 2009 11:08 AM
To: Alberto_Jos開Gonz醠ez_Cela; [email-masked]
Subject: Re: [ppsp] charter discussion

Hi Alberto,

[Update]

BR
Yunfei

zhangyunfei
2009-12-10

Hi  all,

Just  one  comment.

BR,

---

From: Ping Pan <[email-masked]>
Date: Wed, 9 Dec 2009 20:01:41 -0800

Agree. Don't think ingest, streaming and delivery should be a part of PPSP.
Leave them open as each has multiple options.

2009/12/9 Y.J. Gu <[email-masked]>

>  ------------------------------
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of
> *zhangyunfei
> *Sent:* Thursday, December 10, 2009 11:08 AM
> *To:* Alberto_Jos開Gonz醠ez_Cela; [email-masked]
> *Subject:* Re: [ppsp] charter discussion
>
>  Hi Alberto,
>  ------------------------------
>  zhangyunfei
> 2009-12-10
>  ------------------------------
>  *发件人：* Alberto_Jos開Gonz醠ez_Cela
> *发送时间：* 2009-12-03 05:29:32
> *收件人：* [email-masked]
> *抄送：*
> *主题：* Re: [ppsp] charter discussion
>
>  Hi  all,
>
> Just  one  comment.
>

---

From: Alberto José González Cela <[email-masked]>
Date: Thu, 10 Dec 2009 11:10:08 +0100

Hi all,

I think that media coding techniques is not an issue within the scope of
PPSP, as it is a particular case. However, I think that the idea of
considering the transmission of multiple streams can be considered during
the design and protocol definition of PPSP as it allows to extend the
protocol in an easy manner. I think that to have this in mind doesn't make
the scope wider while offers the possibility to create a more flexible
protocol.

BR,

Alberto.

2009/12/10 zhangyunfei <[email-masked]>

---

From: "zhangyunfei" <[email-masked]>
Date: Thu, 10 Dec 2009 18:20:58 +0800

I agree with your opinion.Then I think we have achieved consensus on this point.I'll reflect this in the modified charter.

BR,
Yunfei

zhangyunfei
2009-12-10

发件人： Alberto_Jos開Gonz醠ez_Cela
发送时间： 2009-12-10 18:24:36
收件人： zhangyunfei
抄送： [email-masked]
主题： Re: Re: [ppsp] charter discussion

Hi all,

I think that media coding techniques is not an issue within the scope of PPSP, as it is a particular case. However, I think that the idea of considering the transmission of multiple streams can be considered during the design and protocol definition of PPSP as it allows to extend the protocol in an easy manner. I think that to have this in mind doesn't make the scope wider while offers the possibility to create a more flexible protocol.

BR,

Alberto.

Hi Alberto,

[Update]

BR
Yunfei

zhangyunfei
2009-12-10

Hi  all,

Just  one  comment.

BR,

---

From: Gyorgy Dan <[email-masked]>
Date: Thu, 10 Dec 2009 11:35:33 +0100

Hi all,

I would also argue for not including media coding techniques in PPSP.

One can treat the problem of media coding at a higher level:
- single layer,
- multiple layers of equal importance (balanced MDC) and
- multiple layers of different importance (non-balanced MDC)
- multiple layers of different importance and dependence (LC)

It would be enough for PPSP to be able to express this structure: the
importance and the possible dependence between the layers. The
particular media encoding format used is then rather irrelevant.

Regards,
 Gyo"rgy

Alberto José González Cela wrote:
> 2009/12/10 zhangyunfei <[email-masked]<mailto:[email-masked]>>
> Hi Alberto,
> ________________________________
> zhangyunfei
> 2009-12-10
> ________________________________
> 收件人： [email-masked]<mailto:[email-masked]>
> 抄送：
> [email-masked]<mailto:[email-masked]>

-- 
Gyo"rgy Dán
School of Electrical Engineering
KTH Royal Institute of Technology
Stockholm, Sweden
http://www.ee.kth.se/~gyuri

---

From: Alberto José González Cela <[email-masked]>
Date: Thu, 10 Dec 2009 11:38:37 +0100

Exactly, this is the key idea.

Alberto.

2009/12/10 Gyorgy Dan <[email-masked]>

---

From: "Y.J. Gu" <[email-masked]>
Date: Thu, 10 Dec 2009 20:33:12 +0800

I agree.

Regards

Yingjie Gu

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Alberto José González Cela
Sent: Thursday, December 10, 2009 6:39 PM
To: Gyorgy Dan
Cc: [email-masked]
Subject: Re: [ppsp] charter discussion

Alberto.

Hi all,

Regards,
 Gyo"rgy

> 2009/12/10 zhangyunfei
<[email-masked]<mailto:[email-masked]>>

into
descriptions
media coding

into
leave