Subject: Re: [ppsp] Fw: RE: New draft for usage of PPSP

From: Di Wu <[email-masked]>
Date: Fri, 04 Jul 2014 10:25:11 +0800

Hi, Dear Rachel,

Thank you for your suggestion. Please see my respond in line.

Best,
Di Wu

> FROM: Huangyihong (Rachel)
> DATE: 2014-07-02 10:23
> TO: 邓灵莉/Lingli Deng; 'fsong'; Zongning; [email-masked]
> CC: [email-masked]
> SUBJECT: RE: [ppsp] New draft for usage of PPSP
> 
> Hi Fei,
> 
> As Lingli said, issue 4 and issue 5 have been addressed in the
> extended tracker protocol. Extended tracker protocol extends the JOIN
> message and STAT_REPORT message to include content information.
> We'll submit the new version of extended tracker protocol soon before
> the deadline.
As I mentioned before, these usage of PPSP system are based on the 
current tracker and peer protocol, so as the gap part. We are looking 
forward to your new version of extended tracker protocol.

> As for issue 6, I'm not sure that PPSP system should provide message
> to change its PeerMode when the peer gets the whole content. If it
> wants to become SEED, it can leave the swarm and join the swarm again
> as SEED.
As for issue 6, we think PPSP system should consider it to provided a 
better service for peers. However, I'm not sure of the real motivation 
for putting the PeerMode into system.
> BR,
> Rachel
> 
>> -----Original Message-----
>> From: ppsp [mailto:[email-masked]] On Behalf Of
> 邓灵莉/Lingli Deng
>> Sent: Wednesday, July 02, 2014 9:45 AM
>> To: 'fsong'; Zongning; [email-masked]
>> Cc: [email-masked]
>> Subject: Re: [ppsp] New draft for usage of PPSP
>> 
>> Hi Fei,
>> 
>> This is an interesting draft. Thanks for set up this discussion for
> PPSP operation.
>> As for the parameter recommendations, I am wondering if it would
> help if more
>> information about the system you are targeting is provided? Would
> the
>> recommendations be dependent on the system settings, like the scale
> of the
>> system, etc.?
>> You might also want to take a look at the extended tracker protocol,
> which I
>> believe aims to solve at least some of the issues you raised in
> terms of the base
>> tracker protocol.
>> 
>> Lingli
>> 
>> > -----Original Message-----
>> > From: ppsp [mailto:[email-masked]] On Behalf Of Fei Song
>> > Sent: Wednesday, July 02, 2014 8:49 AM
>> > To: Zongning; [email-masked]
>> > Cc: [email-masked]
>> > Subject: [ppsp] New draft for usage of PPSP
>> >
>> > Dear all：
>> >
>> > We have submitted a new draft about usage of PPSP.
>> > http://www.ietf.org/id/draft-zhang-ppsp-usage-00.txt
>> > Comments and suggestions are more than welcome.
>> > Thank you very much！
>> >
>> > --------------
>> > Fei Song
>> > >Dear all,
>> > >
>> > >Please let Yunfei and I know if you plan to present any drafts in
> the
>> > >PPSP
>> > WG session in Toronto.
>> > >We have put Tracker Base Protocol and Tracker Extended Protocol
> into
>> > >the
>> > agenda, but obviously have enough time to accommodate more topics
> &
>> > drafts...
>> > >
>> > >Thanks.
>> > >
>> > >-Yunfei & Ning
>> > >
>> > _______________________________________________
>> > ppsp mailing list
>> > [email-masked]
>> > https://www.ietf.org/mailman/listinfo/ppsp
>> 
>> 
>> 
>> _______________________________________________
>> ppsp mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/ppsp

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Fri, 4 Jul 2014 06:09:43 +0000

Hi Di Wu,

Please see inline.

BR,
Rachel

> From: Di Wu [mailto:[email-masked]]
> Sent: Friday, July 04, 2014 10:25 AM
> To: fsong; Huangyihong (Rachel); [email-masked]
> Subject: Re: Fw: RE: [ppsp] New draft for usage of PPSP
> 
> Hi, Dear Rachel,
> 
> As I mentioned before, these usage of PPSP system are based on the current
> tracker and peer protocol, so as the gap part. We are looking forward to your
> new version of extended tracker protocol.

[Rachel]: Extended tracker protocol has been updated. Your comments are welcomed.
> As for issue 6, we think PPSP system should consider it to provided a better
> service for peers.
[Rachel]: Sure. I'm just explaining that base protocol could do it in another way. Some peers may not want to share their content when they finish downloading. If the ppsp system change it automatically. It will be against those people's will. Let's see what WG thinks of it.

> However, I'm not sure of the real motivation for putting the
> PeerMode into system.

[Rachel]: PeerMode could distinguish peers. When a peer connects to the tracker, the tracker has to understand if it is to provide the content sharing or it asks for the peer list to exchange content. They are different process (see section 5.1 of base tracker protocol).

---

From: Di Wu <[email-masked]>
Date: Fri, 04 Jul 2014 14:54:00 +0800

Hi again,

Thank you very much! Please see below.

Best,
Di Wu
On 2014-07-04 14:09, Huangyihong (Rachel) wrote:
>> current
>> better
> [Rachel]: Sure. I'm just explaining that base protocol could do it in
> another way. Some peers may not want to share their content when they
> finish downloading. If the ppsp system change it automatically. It
> will be against those people's will. Let's see what WG thinks of it.
> 
Yeah, you are right. But the way you illustrated is a little bit 
complex. That's why we put it into the limitation and gaps part. And as 
you explained below, the PeerMode usually used when a peer firstly 
connected to the tracker. Once they login to ppsp system and finished 
data transmission, the PeerMode may not represent their status. We are 
hoping to provide a simple way to solve this problem, which not defends 
peer's willing. For example, peers may change their PeerMode once they 
gets the whole content and are willing to share it with others via 
STAT_REPORT message. While another option is that PPSP system change it 
automatically (Just as you mentioned). For those people who are not 
willing to share the content, they could send CHONKE message to express 
their willing.

> [Rachel]: PeerMode could distinguish peers. When a peer connects to
> the tracker, the tracker has to understand if it is to provide the
> content sharing or it asks for the peer list to exchange content. They
> are different process (see section 5.1 of base tracker protocol).
> 
Thanks. I just read this part again.

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Fri, 4 Jul 2014 07:23:17 +0000

Hi Di Wu,

I take out the parts we agree on. Please see Inline.

BR,
Rachel
> >> > As for issue 6, I'm not sure that PPSP system should provide
> >> > message to change its PeerMode when the peer gets the whole
> >> > content. If it wants to become SEED, it can leave the swarm and
> >> > join the swarm again as SEED.
> >> better service for peers.
> Yeah, you are right. But the way you illustrated is a little bit complex. That's
> why we put it into the limitation and gaps part. And as you explained below, the
> PeerMode usually used when a peer firstly connected to the tracker. Once they
> login to ppsp system and finished data transmission, the PeerMode may not
> represent their status. We are hoping to provide a simple way to solve this
> problem, which not defends peer's willing. For example, peers may change
> their PeerMode once they gets the whole content and are willing to share it
> with others via STAT_REPORT message. While another option is that PPSP
> system change it automatically (Just as you mentioned). For those people who
> are not willing to share the content, they could send CHONKE message to
> express their willing.
> 
[Rachel] It's a implementation v.s. protocol issue. IMO, we don't have to complex the protocol in order to simplify the implementation. So I think my option and your last option is acceptable, while the option to change STAT_REPORT is unnecessary.

---

From: "Fei Song" <[email-masked]>
Date: Fri, 4 Jul 2014 18:34:07 +0800

Hi Rachel:

Thanks for your kind reply~

About changing the PeerMode automatically, It might be good if the peers could decide whether they wanna change. 

--------------
Fei Song

---

From: 邓灵莉/Lingli Deng <[email-masked]>
Date: Fri, 4 Jul 2014 19:06:47 +0800

> From: ppsp [mailto:[email-masked]] On Behalf Of Huangyihong
> (Rachel)
> Sent: Friday, July 04, 2014 3:23 PM
> To: Di Wu; Fei Song; PPSP
> Subject: Re: [ppsp] Fw: RE: New draft for usage of PPSP
> 
> Hi Di Wu,
> 
> [Rachel] It's a implementation v.s. protocol issue. IMO, we don't have to
> complex the protocol in order to simplify the implementation. So I think my
> option and your last option is acceptable, while the option to change
> STAT_REPORT is unnecessary.
[邓灵莉/Lingli Deng] Just for discussion, I am afraid that I don't like the option by sending CHOKE, which means that the peer is being visible to other peers against its explicit will.