Subject: [ppsp] New draft for usage of PPSP

From: "Fei Song" <[email-masked]>
Date: Wed, 2 Jul 2014 08:49:24 +0800

Dear all：

We have submitted a new draft about usage of PPSP.
http://www.ietf.org/id/draft-zhang-ppsp-usage-00.txt
Comments and suggestions are more than welcome.
Thank you very much！

--------------
Fei Song
>Dear all,
>
>Please let Yunfei and I know if you plan to present any drafts in the PPSP WG session in Toronto.
>We have put Tracker Base Protocol and Tracker Extended Protocol into the agenda, but obviously have enough time to accommodate more topics & drafts...
>
>Thanks.
>
>-Yunfei & Ning
>

---

From: 邓灵莉/Lingli Deng <[email-masked]>
Date: Wed, 2 Jul 2014 09:44:36 +0800

Hi Fei,

This is an interesting draft. Thanks for set up this discussion for PPSP operation.
As for the parameter recommendations, I am wondering if it would help if more information about the system you are targeting is provided? Would the recommendations be dependent on the system settings, like the scale of the system, etc.?
You might also want to take a look at the extended tracker protocol, which I believe aims to solve at least some of the issues you raised in terms of the base tracker protocol.

Lingli

> -----Original Message-----
> From: ppsp [mailto:[email-masked]] On Behalf Of Fei Song
> Sent: Wednesday, July 02, 2014 8:49 AM
> To: Zongning; [email-masked]
> Cc: [email-masked]
> Subject: [ppsp] New draft for usage of PPSP
> 
> Dear all：
> 
> >We have put Tracker Base Protocol and Tracker Extended Protocol into the
> agenda, but obviously have enough time to accommodate more topics &
> drafts...
> >
> >Thanks.
> >
> >-Yunfei & Ning
> >
> _______________________________________________
> ppsp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ppsp

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Wed, 2 Jul 2014 02:23:59 +0000

Hi Fei,

As Lingli said, issue 4 and issue 5 have been addressed in the extended tracker protocol. Extended tracker protocol extends the JOIN message and STAT_REPORT message to include content information.
We'll submit the new version of extended tracker protocol soon before the deadline.

As for issue 6, I'm not sure that PPSP system should provide message to change its PeerMode when the peer gets the whole content. If it wants to become SEED, it can leave the swarm and join the swarm again as SEED.

BR,
Rachel

> From: ppsp [mailto:[email-masked]] On Behalf Of 邓灵莉/Lingli Deng
> Sent: Wednesday, July 02, 2014 9:45 AM
> To: 'fsong'; Zongning; [email-masked]
> Cc: [email-masked]
> Subject: Re: [ppsp] New draft for usage of PPSP
> 
> Hi Fei,
> 
> As for the parameter recommendations, I am wondering if it would help if more
> information about the system you are targeting is provided? Would the
> recommendations be dependent on the system settings, like the scale of the
> system, etc.?
> You might also want to take a look at the extended tracker protocol, which I
> believe aims to solve at least some of the issues you raised in terms of the base
> tracker protocol.
> 
> Lingli
> 
> > >Please let Yunfei and I know if you plan to present any drafts in the
> > >PPSP
> > WG session in Toronto.