Subject: eth0 and VRFs

From: John Smith <[email-masked]>
Date: Mon, 24 Mar 2003 05:52:39 +0000 (GMT)

Hello,
We can put each of our serial links in unique VRFs. Can we do the same for our ethernet
links?

Let me clarify.

I can give a following configuration on my router if i have two p2p links from which i
want to connect my two BGP VPN routers.

!
interface serial0
ip vrf forwarding XXXXX
ip address xx.xx.xx.x m.m.m.m
!
interface serial1
ip vrf forwarding ZZZZZ
ip address zz.zz.z.z m.m.m.m
!

NOw  how can i achieve the same using ethernet links. Suppose my router has just one
ethernet card and i want to connect to two BGP VPN routers. How can i do that?

My setup is as following:

          ______
          | A  |
          ------
             |eth0
             |
         __________
         |(eth0)  | eth1
       -----    -----
       | B  |   | C  |
       ------   ------

I would be very grateful if somebody can help me out or give some pointers.

Thanks and Waiting,
Warm Regards,
Smith

__________________________________________________
Do You Yahoo!?
Everything you'll ever need on one web page
from News and Sport to Email and Music Charts
http://uk.my.yahoo.com

---

From: Ives Dekoninck <[email-masked]>
Date: Mon, 24 Mar 2003 08:50:17 +0100

Hi, John 

You can do that though you need two different Ethernet interfaces. Of course
this can be done on physical interface or logical interfaces (dot1q).

The thing is that one interface can only be assigned to one VRF.

Cheers,

-Ives-

-----Original Message-----
From: John Smith [mailto:[email-masked]]
Sent: lundi 24 mars 2003 7:53
To: [email-masked]
Subject: Re: eth0 and VRFs

I am sorry for some ambiguity .. what i had wanted to ask was that can i put
two routers
connected to my router (on an ethernet) in different VPNs or can i assign
them different
VRF IDs. 

AFAIK i need to have two different ethernets to do that wherein each
ethernet is assigned
a unique VRF.

Is my understanding correct?

Thanks,
Smith