Subject: Re: eth0 and VRFs

From: John Smith <[email-masked]>
Date: Mon, 24 Mar 2003 06:52:48 +0000 (GMT)

I am sorry for some ambiguity .. what i had wanted to ask was that can i put two routers
connected to my router (on an ethernet) in different VPNs or can i assign them different
VRF IDs. 

AFAIK i need to have two different ethernets to do that wherein each ethernet is assigned
a unique VRF.

Is my understanding correct?

Thanks,
Smith

----- Original Message ----- 
From: "John Smith" <[email-masked]>
To: <[email-masked]>
Sent: Monday, March 24, 2003 11:22 AM
Subject: eth0 and VRFs

> Hello,
> We can put each of our serial links in unique VRFs. Can we do the same for our ethernet
> links?
> 
> Let me clarify.
> 
> I can give a following configuration on my router if i have two p2p links from which i
> want to connect my two BGP VPN routers.
> 
> !
> interface serial0
> ip vrf forwarding XXXXX
> ip address xx.xx.xx.x m.m.m.m
> !
> interface serial1
> ip vrf forwarding ZZZZZ
> ip address zz.zz.z.z m.m.m.m
> !
> 
> NOw  how can i achieve the same using ethernet links. Suppose my router has just one
> ethernet card and i want to connect to two BGP VPN routers. How can i do that?
> 
> My setup is as following:
> 
>           ______
>           | A  |
>           ------
>              |eth0
>              |
>          __________
>          |(eth0)  | eth1
>        -----    -----
>        | B  |   | C  |
>        ------   ------
> 
> I would be very grateful if somebody can help me out or give some pointers.
> 
> Thanks and Waiting,
> Warm Regards,
> Smith
>         

__________________________________________________
Do You Yahoo!?
Everything you'll ever need on one web page
from News and Sport to Email and Music Charts
http://uk.my.yahoo.com

---

From: Chris Sieber <[email-masked]>
Date: Mon, 24 Mar 2003 09:05:49 -0700 (MST)

Not sure if I am understanding, but if you want a single ethernet to
multiple vpns, have you tried binding 802.1q to a VRF? Not sure if Cisco
does this, but other vendors do.