Subject: RE: Question regdg. MPLS/BGP VPN MIB

From: "Shiv Agarwal" <[email-masked]>
Date: Mon, 28 Apr 2003 15:10:36 -0700

inline:

-----Original Message-----
From: Siddharth Aanand [mailto:[email-masked]]
Sent: Monday, April 28, 2003 3:03 PM
To: Shiv Agarwal
Cc: [email-masked]
Subject: RE: Question regdg. MPLS/BGP VPN MIB

Shiv,

>
> Without this additional index how else can you determine as to which
> interface is mapped to which VRF?

>>I am assuming that at the interface creation time it gets assigned to a
>>VRF. 

Shiv >> why is this necessary. you may just create an interface and not assign it to any VRF.

>>For rest of the VPN related configuration (which is what this
>>table seems to be used for), having the interface index is sufficient to
>>determine the VRF as well.

Shiv >> organizing it per VRF wise makes the management efficient. So if you want to find out all the interfaces that belong to a VRF, you can do a walk on this table with a partial index of that VRF and thus you don't have to scan the entire mib and do a search. There are other management advantages also.

-Sidd

>
> Though if a VRF is modeled like a VR with a separate context, then this information may not be necessary as the VRF can then be determined by the SNMP context.
>
> Shiv.
>
> -----Original Message-----
> From: Siddharth Aanand [mailto:[email-masked]]
> Sent: Monday, April 28, 2003 2:37 PM
> To: [email-masked]
> Subject: Question regdg. MPLS/BGP VPN MIB
>
>
>
> The draft-ietf-ppvpn-mpls-vpn-mib-05.txt defines mplsVpnVrfName and
> mplsVpnIfConfIndex as keys to the mplsVpnIfConfTable. The question I had
> was, isn't the ifIndex (mplsVpnIfConfIndex) sufficient to uniquely
> identify a row in this table ? Under what circumstances do we need both
> the vrfName as well as the ifIndex as keys?
>
> thanks,
> -Sidd
>
>
>
>
>

---

From: "Shmunis, Gregory" <[email-masked]>
Date: Wed, 30 Apr 2003 15:25:58 -0400

Tom,

can you please point to a previous thread where concrete operational
scenarios with an interface belonging to more than one VRF were discussed ?
If it is simpler for you, can you just mention a case or two ?

thank you,

Greg.

-----Original Message-----
From: Thomas D. Nadeau [mailto:[email-masked]]
Sent: Tuesday, April 29, 2003 11:00 AM
To: Siddharth Aanand
Cc: [email-masked]; "Harmen Van der Linde"[email-masked]
Subject: Re: Question regdg. MPLS/BGP VPN MIB

At 10:46 AM 4/29/2003 -0400, Siddharth Aanand wrote:
> >          Yes, but the operational feedback was that operators
> > wanted to cycle through interfaces belonging to each VRF.
> > We need to update this slightly because there are cases where
> > one interface may belong to multiple VRFs.
>
>Yes. If one interface belongs to multiple VRFs then we'd need the vrfName
>as a key. Do you know what distinguishing feature of the incoming traffic,
>on that interface, would be used to decide which VRF to use?

         I think that is orthogonal to the discussion at hand.
What is important is that the MIB can handle these
cases without regard to how the choice is being made.
The reason being that it is often a proprietary feature/configuration
that does the choosing. My implementation for instance,
uses several rules to make this determination.  I know of
another that makes a simple choice based on source
address.

         --Tom

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 30 Apr 2003 16:47:13 -0400

>If it is simpler for you, can you just mention a case or two ?

         I have two examples. First, Yacine pointed out
a case a while back that we discussed -- perhaps
he can explain his scenario.  In my case, my products
allow for multiple VRFs to be associated with the same
interface, and then based on the source address, one
of the VRFs is chosen to do the route lookup. Admittedly,
this is not a widely used case, but I think it is still one
that is used enough that the standard MIB should handle
it.

         --Tom

---

From: "Shmunis, Gregory" <[email-masked]>
Date: Wed, 30 Apr 2003 17:26:13 -0400

Tom,

thanks. I understand the technical aspect of using various criteria
(including the source address) in the PE-incoming traffic to identify the
right lookup VRF. What I'm trying to figure out is a concrete deployment
case where sharing of a PE interface between VRFs would be required, and
also - what are potential side-effects of such use. For instance, the
example of using the source address alone on a VRF-shared interface implies
that the VRFs that share the interface cannot use overlapping address spaces
- otherwise the traffic in the reverse (PE-to-CE) direction would be
untreatable.

Perhaps Yasin can give his example. Having said all the above I want to make
it clear that the question is less of a MIB nature - it pertains to the
general operational aspect of 2547bis.

greg.

-----Original Message-----
From: Thomas D. Nadeau [mailto:[email-masked]]
Sent: Wednesday, April 30, 2003 4:47 PM
To: Shmunis, Gregory
Cc: [email-masked]; [email-masked]
Subject: RE: Question regdg. MPLS/BGP VPN MIB

         --Tom

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 30 Apr 2003 17:49:43 -0400

>- otherwise the traffic in the reverse (PE-to-CE) direction would be

         Go to www.cisco.com and search for "multi-vrf" or "vrf lite".

         --Tom