Subject: Re: [MPLS-OPS]: multiple VRFs association

From: "M. ELK" <[email-masked]>
Date: Mon, 07 Apr 2003 07:46:15 +0000

AFAIK ,a single sub-interface have to be associated with single
VRF .
The only exception is the cisco feature where they could assign
recieved packet over a sub-interface to a specific VRF based on
source address .
http://www.cisco.com/en/US/partner/products/sw/iosswrel/ps1829/products_feature_guide09186a008012db6a.html

Quote
Feature Overview
The VRF Selection feature allows packets arriving on an interface to be 
switched into the appropriate VRF table based upon the source IP address of 
the packets. Once the packets have been "selected" into the correct VRF 
routing table, they are processed normally based upon the destination 
address and forwarded through the rest of the Multiprotocol Label Switching 
(MPLS) VPN.

In most cases, the VRF Selection feature is a "one way" feature; it works on 
packets coming from the end users to the PE router.

Unquote

Note : may be using the wording "Sub-interface" is more appropriate
than using "PORT" as the physical port could support several
logical port (ex: VLAN , FR ,ATM ..etc ) .

Brgds

>From: John Smith <[email-masked]>
>To: [email-masked]
>CC: [email-masked]
>Subject: [MPLS-OPS]: multiple VRFs association Date: Mon, 7 Apr 2003 
>06:51:17 +0100 (BST)
>
>Hello,
>What i understand till now is that the VRF is not mapped to individual 
>sites in the VPN
>but to the ports on the PE router. This is so because i can have 
>overlapping VPNs wherein
>i would want the two different sites to share the same VRF. Thus multiple 
>ports on the PE
>router can be associated with a single VRF.
>
>My doubt is that can i have it the other way around OR putting it in a 
>different way can
>the same PE router port be associated with two different VRFs?
>
>I think is is *only* possible with ethernets where using the concept of 
>VLANs i can have
>the same physical port be associated with multiple VRFs.
>
>PLease let me know if i am correct in my understanding.
>
>Thanks a lot !
>
>Regards,
>John Smith
>
>
>
>__________________________________________________
>Do You Yahoo!?
>Everything you'll ever need on one web page
>from News and Sport to Email and Music Charts
>http://uk.my.yahoo.com
>
>-------
>The MPLS-OPS Mailing List
>Subscribe/Unsubscribe:  http://www.mplsrc.com/mplsops.shtml
>Archive: http://www.mplsrc.com/mpls-ops_archive.shtml

_________________________________________________________________
Tired of spam? Get advanced junk mail protection with MSN 8. 
http://join.msn.com/?page=features/junkmail

---

From: Du Wenhua <[email-masked]>
Date: Mon, 07 Apr 2003 16:20:27 +0800

Hi,M. ELK,

True.
Much more, some router can do VRF selection based on classification(5 tuples).

>-----Original Message-----
>From: M. ELK <[email-masked]>
>Sent: 07:46:00,2003-04-07
>To: jsmith4112003 <[email-masked]>
>Subject: Re: [MPLS-OPS]: multiple VRFs association

>>PLease let me know if i am correct in my understanding.
= = = = = = = = = = = = = = = = = = = =