Subject: RE: Support for draft-kompella-ppvpn-vpls-01.txt

From: "Nagarajan, Ananth [CC]" <[email-masked]>
Date: Tue, 29 Apr 2003 09:18:32 -0500

> And what that has to do with Mourad's observation that BGP, and
Yakov,

> > In an ideal world, one would use a washing machine that 
> > also washes dishes (stealing an example from an esteemed 
> colleague), but 
> > that hasn't happened practically.
> 
> Should this argument then be applied against using LDP for VPLS
> signaling (even if it is used for MPLS signaling) ?
> 

It could.  I guess operators would have to determine which is the lesser of the evils - and I am not denying that you would find operators on both sides of the equation.  My point was that one size doesn't fit all - so neither BGP nor LDP is the absolute best solution. We've got to determine which one makes most sense, and that answer is not as immediately obvious as some of the comments on this thread make it out to be.

Ananth

---

From: Yakov Rekhter <[email-masked]>
Date: Tue, 29 Apr 2003 07:29:51 -0700

Ananth,

> Yakov,
> 
> > > In an ideal world, one would use a washing machine that=20
> > > also washes dishes (stealing an example from an esteemed=20
> > colleague), but
> It could.  I guess operators would have to determine which is the lesser 
> of the evils - and I am not denying that you would find operators on 
> both sides of the equation.  My point was that one size doesn't fit all 
> - so neither BGP nor LDP is the absolute best solution. We've got to 
> determine which one makes most sense, and that answer is not as 
> immediately obvious as some of the comments on this thread make it out 
> to be.

If you agree that there will be "operators on both sides of the
equation" and that "one size doesn't fit all", then you would
probably also agree that what "makes most sense" for one operator
may not necessarily make most sense for another operator. With
this in mind should "we" really "got to determine which one makes
most sense" ?

Yakov.

> 
> Ananth
> 
> >=20
> 
> ------_=_NextPart_001_01C30E5A.36CB5F0C
> Content-Type: text/html;
> 	charset="iso-8859-1"
> Content-Transfer-Encoding: quoted-printable
> 
> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
<HTML>
> <HEAD>
> <META HTTP-EQUIV=3D"Content-Type" CONTENT=3D"text/html; =
> charset=3Diso-8859-1">
> <META NAME=3D"Generator" CONTENT=3D"MS Exchange Server version =
> 6.0.6389.0">
> <TITLE>RE: Support for draft-kompella-ppvpn-vpls-01.txt </TITLE>
> </HEAD>
> <BODY>
> <!-- Converted from text/plain format -->
> 
> <P><FONT SIZE=3D2>&gt; And what that has to do with Mourad's observation =
> that BGP, and</FONT>
> 
> <BR><FONT SIZE=3D2>Yakov,</FONT>
> </P>
> <BR>
> 
> <P><FONT SIZE=3D2>&gt; &gt; In an ideal world, one would use a washing =
> machine that </FONT>
> 
> <BR><FONT SIZE=3D2>&gt; &gt; also washes dishes (stealing an example =
> from an esteemed </FONT>
> 
> <BR><FONT SIZE=3D2>&gt; colleague), but </FONT>
> 
> <BR><FONT SIZE=3D2>&gt; &gt; that hasn't happened practically.</FONT>
> 
> <BR><FONT SIZE=3D2>&gt; </FONT>
> 
> <BR><FONT SIZE=3D2>&gt; Should this argument then be applied against =
> using LDP for VPLS</FONT>
> 
> <BR><FONT SIZE=3D2>&gt; signaling (even if it is used for MPLS =
> signaling) ?</FONT>
> 
> <BR><FONT SIZE=3D2>&gt; </FONT>
> </P>
> 
> <P><FONT SIZE=3D2>It could.&nbsp; I guess operators would have to =
> determine which is the lesser of the evils - and I am not denying that =
> you would find operators on both sides of the equation.&nbsp; My point =
> was that one size doesn't fit all - so neither BGP nor LDP is the =
> absolute best solution. We've got to determine which one makes most =
> sense, and that answer is not as immediately obvious as some of the =
> comments on this thread make it out to be.</FONT></P>
> 
> <P><FONT SIZE=3D2>Ananth</FONT>
> </P>
> 
> <P><FONT SIZE=3D2>&gt; </FONT>
> </P>
> 
> </BODY>
> </HTML>
> ------_=_NextPart_001_01C30E5A.36CB5F0C--

---

From: Juha Heinanen <[email-masked]>
Date: Tue, 29 Apr 2003 18:55:04 +0300

Nagarajan, Ananth [CC] writes:

 > I guess operators would have to determine which is the
 > lesser of the evils - and I am not denying that you would find
 > operators on both sides of the equation.  My point was that one size
 > doesn't fit all - so neither BGP nor LDP is the absolute best
 > solution. We've got to determine which one makes most sense, and that
 > answer is not as immediately obvious as some of the comments on this
 > thread make it out to be.

rather than choosing a lesser evil, how about choosing the good
solution: radius + l2tp.  should be a perfect match especially for
sprint, which recently announced an l2tp based vpn solution.

-- juha