Subject: Re: Draft-kpmpella-ppvpn-vpls-01

From: "Hector Avalos" <[email-masked]>
Date: Wed, 23 Apr 2003 22:25:31 +0200

Well, that's the nice thing of mp-bgp. 
Which in addition provide us support for inter-as an CoC, which several
SPs would like to implement for vpls. 
But my point about ldp in 2547bis is that it is only used  for
tunneling, not for signaling or autodiscovery. That is the reason why
2547bis works over gre, ipsec,ldp and rsvp tunneling, even in
'parallel'. 

Yes, SPs may have several tunneling protocols, even for vpls. But they
do not require 'complex' interaction with the autodiscovery and
signaling protocols. 

Using bgp for these two fuctions for multipoint vpns simplifies SPs
work. 

Cheers
Hector
--------------------------
Sent from my Wireless Handheld

-----Original Message-----
From: Vach Kompella <[email-masked]>
To: Hector Avalos <[email-masked]>; [email-masked]
<[email-masked]>; [email-masked] <[email-masked]>
CC: [email-masked] <[email-masked]>;
[email-masked] <[email-masked]>
Sent: Wed Apr 23 20:40:04 2003
Subject: RE: Draft-kpmpella-ppvpn-vpls-01

Hector,

If you want to qualify the LDP usage by saying that it is targeted LDP
(which is
different from regular LDP), then let's not pretend that BGP NLRIs for
IPv4,
2547 and L2VPNs are similar at all.

-Vach

> -----Original Message-----
> From: Hector Avalos [mailto:[email-masked]]
> Sent: Wednesday, April 23, 2003 12:21 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: Draft-kpmpella-ppvpn-vpls-01
>
>
> Jim
>
> 2547bis does not use directed ldp, but std ldp. And it is not used for
> signaling nor autodiscovery.
> 2547b and vpls requires autodiscovery, and bgp has already been
> sucessfuly implemented by SPs.
> PW does not need autodiscovery, so using directed ldp makes sense.
>
> Cheers
> Hector
>
> --------------------------
> Sent from my Wireless Handheld
>
>
> -----Original Message-----
> From: Jim Guichard <[email-masked]>
> To: Hector Avalos <[email-masked]>; [email-masked]
> <[email-masked]>
> CC: [email-masked] <[email-masked]>;
> [email-masked] <[email-masked]>
> Sent: Wed Apr 23 19:59:16 2003
> Subject: RE: Draft-kpmpella-ppvpn-vpls-01
>
> Hector - it is also fair to say that the chances are they are using
LDP
> for
> their 2547 service. This means they already have two protocols in
> operation.
> I think it is also fair to say that anyone with experience of running
a
> 2547
> service will understand the complexity of controlling route
distribution
> -
> extending this to also cover L2VPN service seems to me to be
> questionable
> considering the fact that a point-to-point protocol has already been
> deployed. Jim
>
> > >-----Original Message-----
> > >From: Hector Avalos [mailto:[email-masked]]
> > >Sent: Wednesday, April 23, 2003 2:08 PM
> > >To: [email-masked]; [email-masked]
> > >Cc: [email-masked]; [email-masked]
> > >Subject: Re: Draft-kpmpella-ppvpn-vpls-01
> > >
> > >
> > >Ali
> > >
> > >If the sp provides 2547bis vpns they already use bgp for signaling.
> So
> > >if they use directed ldp for vpls they will also end with two
> signaling
> > >protocols.
> > >
> > >Using bgp for signaling in multipoint vpns simplifies sp work.
> > >
> > >Cheers
> > >Hector
> > >--------------------------
> > >Sent from my Wireless Handheld
> > >
> > >
> > >-----Original Message-----
> > >From: Ali Sajassi <[email-masked]>
> > >To: [email-masked] <[email-masked]>; Ali Sajassi
> <[email-masked]>
> > >CC: Andrea Ferrarese <[email-masked]>;
> > >[email-masked] <[email-masked]>
> > >Sent: Wed Apr 23 17:30:28 2003
> > >Subject: Re: Draft-kpmpella-ppvpn-vpls-01
> > >
> > >Hi Robert,
> > >
> > >That was not the conclusion that I was arriving at. The way I look
at
> it
> > >is
> > >if a service provider needs to support both type of services
> (Multipoint
> > >
> > >and PtP), then we know that BGP is not suited well for PtP
> applications;
> > >
> > >therefore, the service provider needs to support directed LDP (as
> > >specified
> > >in PWE3). Now if the service provider insists in using BGP as
> signaling
> > >mechanism for Multipoint application (VPLS), then they end up
> supporting
> > >
> > >and maintaining both types of signaling mechanisms in their
networks
> !!
> > >
> > >Also I don't like to tie up the signaling to the auto-discovery
> because
> > >they are independent. Therefore, a SP who wants to use BGP as
> > >auto-discovery, can do that and still use LDP as signaling and the
> SPs
> > >who
> > >want to use directory-based auto-discovery, can do that with the
same
> > >LDP
> > >signaling.
> > >
> > >The argument between BGP and LDP signaling is that the BGP-camp
> assumes
> > >that there is nothing else to be distributed to VPLS members except
> > >labels;
> > >whereas, LDP camp doesn't want to impose such a big constraint as
> there
> > >are
> > >PW characteristics (such as QoS, sequencing, OOB OAM) that require
> > >additional info exchanges. LDP signaling offers a more flexible
> approach
> > >to
> > >carry PW specific info and with the state of VPLS and data-plane
> still
> > >being evolved, I would like to have a flexible signaling. Besides,
as
> > >mentioned before, you have to use the same signaling for PtP
> application
> > >
> > >anyway.
> > >
> > >-Ali
> > >
> > >
> > >At 09:06 AM 4/23/2003 +0200, Robert Raszuk wrote:
> > >>Hi Ali,
> > >>
> > >>Very valid question ;) ...
> > >>
> > >>Even more valid would be to rephrase it to say: "Do all service
> > >>providers which support the draft-kompella-ppvpn-vpls-xx for VPLS
> and
> > >>plan to offer some other forms of L2 p2p trasport would have
> objections
> > >>to run both signalling menthods for setting them up (BGP for VPLS
> and
> > >>targeted LDP for all other VPWS)" ?
> > >>
> > >>My personal _individual_ opinion is that vendors should support
both
> > >>signalling options as it seems quite common that a proper and fine
> > >tuned
> > >>tool for any work produces better results :).
> > >>
> > >>Another spin on this thread is that if Juha's Radius propsal would
> be
> > >>selected as an auto-discovery option clearly there should be no
need
> to
> > >>mess with BGP at all and signalling could be done with LDP in all
> > >cases.
> > >>But if one selects to use BGP for VPLS autodiscovery adding few
more
> > >>bytes there with encoded very clever way of distributing label
> > >>informations especially for VPLS services seems very reasonable.
> > >>
> > >>R.
> > >>
> > >>
> > >> > Ali Sajassi wrote:
> > >> >
> > >> > I'd like to know how many of the service providers who support
> this
> > >draft,
> > >> > only plan to offer multi-point Ethernet service (VPLS) and do
NOT
> > >plan to
> > >> > offer point-to-point Ethernet service?
> > >> >
> > >> > If a service provider plans to offer both types of services,
then
> do
> > >they
> > >> > plan to use BGP for PW signaling of PtP Ethernet service ?
> > >> >
> > >> > Thanks,
> > >> > Ali
> > >> >
> > >> > At 06:15 PM 4/22/2003 +0200, Andrea Ferrarese wrote:
> > >> > >We support draft-kompella-ppvpn-vpls-01
> > >> > >
> > >> > >We found that BGP control plane give scalability and
> flexibility.
> > >We
> > >> > >like
> > >> > >the possibility to maintain the actual config and VPN
> > >infrastructure
> > >> > >for
> > >> > >both l2 and l3 VPN.
> > >> > >
> > >> > >Thank you
> > >
> > >
> > >
> > >
> > >
>
>
>
>

---

From: "Jim Guichard" <[email-masked]>
Date: Wed, 23 Apr 2003 16:28:17 -0400

Hector,

> >Sent: Wednesday, April 23, 2003 4:26 PM
> >To: [email-masked]; [email-masked]; [email-masked]

good luck 8^)

> >do not require 'complex' interaction with the autodiscovery and

what exactly is complex about using the results of autodiscovery to
automagically setup directed LDP sessions and exchange label space ? Jim

---

From: "Vach Kompella" <[email-masked]>
Date: Wed, 23 Apr 2003 16:13:46 -0700

Hi Hector,

> do not require 'complex' interaction with the autodiscovery and

Do you auto-discover the site IDs for each PE participating in an L2VPN (whether
pt2pt or VPLS)?

From what I understand, you don't.  Then isn't configuring them, more or less
sequentially to avoid unnecessary label waste, pretty much the same as
identifying the PEs that are part of the VPN?  You obviously don't want to
accidentally make two PEs have the same site ID since they will end up using the
same label in a label range.

Do you think that configuring PE A to be site ID 1 in VPN 100 and site ID 5 in
VPN 101 is confusing?  You unfortunately cannot make the site ID unique to a PE,
because it is an index into the label range.

Would you prefer to use PE loopback or router ID as an ID, independently of the
VPN, as is the case in the LDP signaling approach?

-Vach