Subject: Re: two BGP best routes with different RD, but same IPv4 prefix

From: John Smith <[email-masked]>
Date: Wed, 16 Apr 2003 09:46:54 +0100 (BST)

Rajiv,
Can you please explain this to us some more. I think it is illegal to advertise the same
IPv4 prefix using different RDs. What use will it be?

Thanks,
JS

----- Original Message ----- 
From: "Rajiv Asati" <[email-masked]>
To: "alok" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, April 16, 2003 11:59 AM
Subject: Re: two BGP best routes with different RD, but same IPv4 prefix

> Alok,
> 
> This requirement usually comes when the customer site is multihomed to the 
> provider's network.
> One such topology shown below -
> 
> x.x.x.x------CE1----PE1----------mpls-----PE3------CE3
>                  |___PE2---------|
> 
> Cheers,
> Rajiv
> 
> At 02:24 AM 4/16/2003, alok wrote:
> >if ur doing that, u are assuming that you can have 2 hosts with IP
> >a.b.c.d/32 in ur network...
> >
> >i dont think its right to be doing so in the 1st place.
> >
> >-rgds
> >Alok
> >----- Original Message -----
> >From: Ju, Yu <[email-masked]>
> >To: <[email-masked]>
> >Sent: Tuesday, April 15, 2003 10:03 PM
> >Subject: two BGP best routes with different RD, but same IPv4 prefix
> >
> >
> > > Hi,
> > >
> > > If a PE router receive two VPN-IPv4 routes with different RD and the same
> > > IPv4 prefix, suppose both pass the RT import checking and both are the
> >best
> > > BGP route, should BGP install both routes (have the same IPv4 prefix) in
> >the
> > > VRF routing table?
> > >
> > > Thanks,
> > >
> > > Yu
> > >
> > >
> 
> 
> 
> 
> 

__________________________________________________
Do You Yahoo!?
Everything you'll ever need on one web page
from News and Sport to Email and Music Charts
http://uk.my.yahoo.com

---

From: Eric Rosen <[email-masked]>
Date: Wed, 16 Apr 2003 08:46:04 -0400

The RD does  not in any way  identify the VPN the customer  belongs to.  One
possible deployment methodology is to use  a distinct RD for each VRF.  Then
if a customer  site is multi-homed, each IPv4 address  prefix from that site
will appear  in the BGP  tables as two  VPN-IP address prefixes.   Those two
VPN-IP prefixes  likely have the same  set of RTs, and  hence are importable
into the same set of VRFs.  

Of  course,  they   can't  both  be  imported  into   any  given  VRF.   The
relevant internet-drafts are  not quite explicit about how  you choose which
one gets into the VRF.  Perhaps this is something that needs to be clarified.