Subject: Question regdg. MPLS/BGP VPN MIB

From: Siddharth Aanand <[email-masked]>
Date: Mon, 28 Apr 2003 17:37:19 -0400 (EDT)

The draft-ietf-ppvpn-mpls-vpn-mib-05.txt defines mplsVpnVrfName and
mplsVpnIfConfIndex as keys to the mplsVpnIfConfTable. The question I had
was, isn't the ifIndex (mplsVpnIfConfIndex) sufficient to uniquely
identify a row in this table ? Under what circumstances do we need both
the vrfName as well as the ifIndex as keys?

thanks,
-Sidd

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 29 Apr 2003 10:18:54 -0400

>the vrfName as well as the ifIndex as keys?

         Yes, but the operational feedback was that operators
wanted to cycle through interfaces belonging to each VRF.
We need to update this slightly because there are cases where
one interface may belong to multiple VRFs.

         --Tom

---

From: Siddharth Aanand <[email-masked]>
Date: Tue, 29 Apr 2003 10:46:55 -0400 (EDT)

> one interface may belong to multiple VRFs.

Yes. If one interface belongs to multiple VRFs then we'd need the vrfName
as a key. Do you know what distinguishing feature of the incoming traffic,
on that interface, would be used to decide which VRF to use?

-Sidd

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 29 Apr 2003 10:59:36 -0400

>on that interface, would be used to decide which VRF to use?

         I think that is orthogonal to the discussion at hand.
What is important is that the MIB can handle these
cases without regard to how the choice is being made.
The reason being that it is often a proprietary feature/configuration
that does the choosing. My implementation for instance,
uses several rules to make this determination.  I know of
another that makes a simple choice based on source
address.

         --Tom