Subject: RE: PE-CE addressing draft

From: "Schliesser, Benson" <[email-masked]>
Date: Tue, 22 Apr 2003 11:42:08 -0500

To say this in the politically correct fashion...
I am from a Service Provider, and I believe that this draft should be made a
working-group document.

My only suggestion is that it be generalized to less-specific 'PPVPNs'
instead of '2547bis VPNs', since it is useful also to the VR and CE-CE
models.

-Benson

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, April 22, 2003 10:38 AM
> To: [email-masked]; Marco Carugi; [email-masked]
> Subject: PE-CE addressing draft
> 
> 
> This is to inform you that the draft-guichard-pe-ce-addr has 
> been updated :
> http://www.ietf.org/internet-drafts/draft-guichard-pe-ce-addr-02.txt
> I invite you to read through this new version and give your 
> feedback to the
> list.
> 
> The main motivation for this proposal is to simplify the 
> Service Providers
> operations in the scenario where they monitor CE-PE links, and/or CE
> routers, while at the same time conserving IPV4 address space.
> Large Service Providers such as Equant, ATT and Arcor are 
> supporting this
> draft and are requesting that it becomes a working group document.
> 
> Vincent Parfait
> Equant
> 
> 
>

---

From: "Aleksey Tolchinskiy" <[email-masked]>
Date: Tue, 22 Apr 2003 13:07:37 -0400

I would like to support the "draft-guichard-pe-ce-addr-02.txt" becoming
a WG document. 

This is a personal opinion and is not expressed on behalf of the company
I work for.

Aleksey

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, April 22, 2003 11:38 AM
To: [email-masked]; Marco Carugi; [email-masked]
Subject: PE-CE addressing draft

This is to inform you that the draft-guichard-pe-ce-addr has been
updated :
http://www.ietf.org/internet-drafts/draft-guichard-pe-ce-addr-02.txt
I invite you to read through this new version and give your feedback to
the
list.

The main motivation for this proposal is to simplify the Service
Providers
operations in the scenario where they monitor CE-PE links, and/or CE
routers, while at the same time conserving IPV4 address space.
Large Service Providers such as Equant, ATT and Arcor are supporting
this
draft and are requesting that it becomes a working group document.

Vincent Parfait
Equant

---

From: Ives Dekoninck <[email-masked]>
Date: Wed, 23 Apr 2003 10:11:45 +0200

Hi,

I would also like to support the "draft-guichard-pe-ce-addr-02.txt" to
become a workgroup document. 

An additional advantage of not having to coordinate addresses with the
client is that we can summarise a block towards the management VPN which
makes configuration more scalable and simpler.

I am doing an implementation for a customer of ours and he also is in favour
of this draft document.

-Ives-

-----Original Message-----
From: Aleksey Tolchinskiy [mailto:[email-masked]]
Sent: mardi 22 avril 2003 19:08
To: [email-masked]; [email-masked]
Subject: RE: PE-CE addressing draft

Aleksey

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, April 22, 2003 11:38 AM
To: [email-masked]; Marco Carugi; [email-masked]
Subject: PE-CE addressing draft

Vincent Parfait
Equant

---

From: Ives Dekoninck <[email-masked]>
Date: Wed, 23 Apr 2003 09:06:35 +0200

Hi,

-Ives-

-----Original Message-----
From: Aleksey Tolchinskiy [mailto:[email-masked]]
Sent: mardi 22 avril 2003 19:08
To: [email-masked]; [email-masked]
Subject: RE: PE-CE addressing draft

Aleksey

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, April 22, 2003 11:38 AM
To: [email-masked]; Marco Carugi; [email-masked]
Subject: PE-CE addressing draft

Vincent Parfait
Equant

---

From: [email-masked]
Date: Wed, 23 Apr 2003 17:58:45 +0200

Zidan,

Thanks for your comments. Regarding the alternatives your propose :

- use of RFC- 1918 addresses :
As already explained in the draft  (3.1), this approach is time consuming
and intensive in terms of address management.  With large customers this
can even reveal impossible. As an example we have a customer with 20K VPN
routing entries part of RFC-1918. Since these entries are  very scattered
the use of 2 alternate blocks would be far from being enough, in fact we
would need hundreds of such blocks ! Then we would meet serious issues in
term of management and performance : complexity of access lists, no
possibility to summarize towards the management VPN ...

- use of /8 blocks currently reserved like 1.0.0.0/8 or 100.0.0.0/8
To my knowledge these are public resources that we should not use. The
purpose of this draft is exactly to get an official assigment of these
resources by IANA to Service Providers.

Vincent

            "LIAN Franklin FTLD/IAP"                                                                                                 
            <[email-masked]                                                                                          
            m>                                   To: [email-masked]                                                      
            23/04/2003 16:11                     cc: [email-masked], Marco Carugi <[email-masked]>,       
                                                    [email-masked]                                                              
                                                 bcc:                                                                                
                                                 Subject:  Re: PE-CE addressing draft                                                

This message represents my personal opinions only.

I agree that it makes sense to ask all SPs use the same IP pool for
allocating addresses to PE-CE links and CE router loopback.

In the draft, there is no detail information regarding which /8 IP
block will be reserved, and I assume the /8 will come from an
unassinged registered IP space.  It will be great if IANA can approve
such a /8 request because it makes the SP's life much easier.

However, without the new /8 block approval, I think we may still get
around the address problem with alternative solutions.

In the current practice of allocating IP addresses from [RFC-1918] to
the PE-CE link, the SP has to negoicate with the customer to see which
private IP blocks from [RFC-1918] have been implemented in the
customer's network and avoid those blocks by assinging IP from other
private IP blocks.  To do this, the SP has reserved several private IP
blocks from [FRC-1918], and switch from one block to another when
conflicts are found between the SP and customer.

I think the same practice can be applied to the draft.  Instead of
allocating one /8 block, two /8 blocks can be recommended, and these
/8 blocks do not have to be approved by IANA.  For example, a SP can
pickup 1.0.0.0/8 and 100.0.0.0/8 for the IP provisioning.  If one
customer does not fit in 1.0.0.0/8, the SP can use the IP from
100.0.0.0/8 for the customer.

Well, I still like to have one dedicated /8 registered IP from IANA.
I guess we can live without one.

Zidan

[email-masked] wrote:
>
> This is to inform you that the draft-guichard-pe-ce-addr has been updated
the
Providers
> Large Service Providers such as Equant, ATT and Arcor are supporting this

---

From: [email-masked]
Date: Fri, 25 Apr 2003 11:09:52 +0200

In the case of Equant we manage more than 20K connections and should reach
50K connections by 2004. We have about the same figures for Transpac (the
French domestic network).
Considering that a class B allows for addressing 16K connections, we
definitely need multiple class B.  16 class B (-> /12) will allow to
support 260K ccts, which should be enough for the coming years. So for
Equant this can be seen as a possible option.
Another approach can be to request a larger range to provide enough margin
for longer term evolution, in which case a  /10 would be more adequate for
large Service Providers -> more case studies wellcome
Another argument for asking for a large range is that it lowers the
possibility of conflicts between SPs for VPNs that span more than one
Service Provider (in the case when one of the Service Provider must manage
all the VPN connections).

Vincent

            "Jim Guichard"                                                                                                         
            <[email-masked]>                                                                                                   
            23/04/2003 21:11                   To: <[email-masked]>, <[email-masked]>               
                                               cc:                                                                                 
                                               bcc:                                                                                
                                               Subject:  RE: PE-CE addressing draft                                                

Hi Carlos,

I think the size of the block is part of what the working group should
evaluate. A /16 is already not enough for some networks. Jim

> >From: [email-masked]
> >[mailto:[email-masked]]
> >Sent: Wednesday, April 23, 2003 2:55 PM
> >To: [email-masked]
> >I think this is something that will make administration of VPN
> >networks much
> >easier, so that being a workgroup document is something good for service
> >providers.
> >
> >Knowing current policies of address assignment, is it
> >foreseeable that IANA can
> >grant so much address space (if any)?
> >
> >Clearly, the draft is missing some calculations that justify the
> >amout of space
> >needed.
> >
> >I don't know the size of the networks of Equant, France Telecom
> >or ATT, but the
> >request assumes VPNs with about 16 million management addresses.
> >With high
> >assignment efficiency, that could be enough for about 4-8
> >million connections.
> >Having a real amount of points of presence (thousands), and assigning
256
> >address blocks, a 25-50% efficiency seems achievable (as there
> >would be about
> >500-1000 connections per PoP), obviously with smaller networks
> >efficiency could
> >be much less... but that is not a problem.
> >
> >Current limits for scalability of VPNs stand at about 1 million,
> >but I doubt
> >management systems can handle that much load, so with partitioning of
the
> >management system in some independent VPNs, smaller addressing
> >requirements
> >(what about a /12?) could also work. Clearly a /16 would be
> >inconvenient, but
> >it's probably on the limit of the workable (needs management
> >system partitioning
> >for DSL-scale networks).
> >
> >Regards,
> >
> >                              Carlos.
> >
> >>From: Ives Dekoninck <[email-masked]>
> >>To: "[email-masked]'" <[email-masked]>,
> >"[email-masked]'" <[email-masked]>
> >>Date: Wed, 23 Apr 2003 09:06:35 +0200
> >>
> >>Hi,
> >>
> >Esperamos su visita en http://www.telefonica-data.es
> >
> >Este mensaje se dirige exclusivamente a su destinatario y puede contener
> >informacion privilegiada o confidencial cuya divulgacion esta
> >prohibida en
> >virtud de la legislacion vigente. Si ha recibido este mensaje
> >por error, le
> >rogamos que nos lo comunique inmediatamente por esta misma via y
> >proceda a su
> >destruccion.
> >
> >
> >

---

From: "Schliesser, Benson" <[email-masked]>
Date: Fri, 25 Apr 2003 08:55:23 -0500

> In the case of Equant we manage more than 20K connections and 
> should reach 50K connections by 2004.

Savvis has a similar number of connections, as well as some value-added
services, that would be addressed by this draft.

Adding these requirements together, I still agree with Vincent that a /12
would be adequate for near term growth, but a /16 would be entirely too
small.

(but a /8 would help hedge bets for IPv6 on the CE-PE link...)

-Benson