Subject: Re: RD in 2547 bis

From: "alok" <[email-masked]>
Date: Tue, 15 Apr 2003 20:44:13 +0530

...and incase RD is not scalable, why not just RT and no RD?

-rgds
Alok
----- Original Message -----
From: alok <[email-masked]>
To: John Smith <[email-masked]>; Apcar, Jeff <[email-masked]>;
<[email-masked]>
Sent: Tuesday, April 15, 2003 7:08 PM
Subject: Re: RD in 2547 bis

> Yes,
>
> thanks for articulating it John,
>
> Thats my confusion.
>
> -rgds
> Alok
> ----- Original Message -----
> From: John Smith <[email-masked]>
> To: Apcar, Jeff <[email-masked]>; alok <[email-masked]>;
> <[email-masked]>
> Sent: Tuesday, April 15, 2003 6:58 PM
> Subject: RE: RD in 2547 bis
>
>
> > Jeff,
> > > MultiProtocol-BGP. MP-BGP's job is to exchange the VPN routes, but it
is
> not
> > > interested  in what VPN these addresses belong to. YOu need the RD to
> make
> > > the VPN addresses unique to MP-BGP, and consequently to the SP domain.
> >
> > Very Right.
> >
> > >
> > > You need the RD to make the VPN addresses to unique MP-BGP you need
the
> RT
> > > to select which VPN to include the address (the RT allows you to
create
> >
> > Instead of using the RT why cant RD work out as the RT. One can decide
> which route goes
> > into which VRF by looking at the RD rather than at the RT.
> >
> > I guess this is the confusion which Mr. Alok has.
> >
> > JS
> >
> >
> > __________________________________________________
> > Do You Yahoo!?
> > Everything you'll ever need on one web page
> > from News and Sport to Email and Music Charts
> > http://uk.my.yahoo.com
> >
>
>

---

From: Robert Raszuk <[email-masked]>
Date: Tue, 15 Apr 2003 18:12:09 +0200

Alok,

Yes you could use only one, yes you could filter with RDs etc ... but
you will have to bind A) making the prefix uniqe with B) the
import/export policy which would be much less flexible in assinging
routes to VPN memberships then using RD just to make the vpn prefix
uniqe (mostly on RRs/ASBRs) and a list of route-targets attached to each
vpn route to decide where this route should be imported to. 

No magic behind just more flexibility and decomposition of functions.

Cheers,
R.

> alok wrote: