Subject: RE: Support for draft-kompella-ppvpn-vpls-01.txt

From: Mark Seery <[email-masked]>
Date: Wed, 30 Apr 2003 09:01:11 -0700 (PDT)

Giles,

>> in fact there are a few carriers who offer L2
services only...  In that
environment LDP seems like a good choice for VPLS -
since it is already
in use for VPWS (and in some cases for setting up the
PE to PE LSPs). <<

Yes, but there are a number of carriers who offer
these services on different networks. Some offer them
in different business units, and in some cases one set
of services are offered on the regulated side and
another set on the unregulated side which "Chinese
Wall" dividers. We can argue the appropriateness of
such arrangements, but to say carriers offer both
services and lead it at that is misleading (IMO).

The point being, that each of these services may be in
a different operational domain, and an operations
staff may choose to implement the
technology/architecture which they feel is most
appropriate for what they are doing.

Not making an argument against LDP.

Mark

---

From: "Amit Singh" <[email-masked]>
Date: Wed, 30 Apr 2003 12:52:39 -0700

Mark,
L3 VPN services will be needed if that is one of the services you are
mentioning
but in big network deployments

no Service Provider customer is willingly interested in handling its
customers routing table

no Service Provider customer wants to run mVPN on stupid non-standard they
rather have the customer handle thier multicast network

In Metro ethernet deployments the customer will have Minimum 200-300
customers coming via l2 switches i dont want to be putting 200 static routes
or  run ospf with one customer rip with another and screw around with
already unstable vendors boxes

Finally point to point is really useless no customer will have only 2 sites
and i dont want to build multiple vc's they will have multiple sites VPLS
seems to be a gr8 thing for it as far as cheap services to a customer goes
using BGP or LDP goes from what i have read LDP looks fine too me but then i
leave it to the experts like the eric rosens the vach's and sajassi's

Finally I hope VPLS gets standardized with martini flavour and we go ahead
and focuss on issues like giving restricted access to other vpls domains
so that restricted internet access (like one port in a customer vpls dom and
the same port also in a l2 vpls dom which gives internet access)

Thanks & Regards
Amit S

---

From: Mark Seery <[email-masked]>
Date: Wed, 30 Apr 2003 14:02:57 -0700 (PDT)

Hi Amit,

--- Amit Singh <[email-masked]> wrote:
> Mark,
> L3 VPN services will be needed if that is one of the
> services you are mentioning but.......<

I am not entirely sure how to parse your email, but it
came across (to me) as a list of problems you see with
layer 3 VPNs (perhaps u wre suggesting VPLS is the
only thing anyone would ever run?). Happy to discuss
offline; not sure if that is pertinent to this working
group; other than to observe that the more we attempt
to turn VPLS into Ethernet switches running atop
routers, the more attractive layer 3 VPNs begin to
look ;-)

> .....focuss on issues like giving restricted access
> to other vpls domains

I think this is an idea worth exploring, I have
discussed already with at least one carrier, and think
it could provide value. There are some philisophical
issues to be considered such as if all the attached
service networks are IP-based then what is the best
solution etc (i.e. multiprotocol transport is needed
for enterprise LAN interconnection but not for
IP-service interconnection, so how to mix the best of
VPLS and IPLS or indeed L3VPN).

I believe someone today has already called for
separation of intra and inter-domain work. Seems like
this would be another reason to do so.

Mark