Subject: RE: RD in 2547 bis

From: "Apcar, Jeff" <[email-masked]>
Date: Tue, 15 Apr 2003 21:31:27 +1000

In 2547bis the mechansim to pass VPN addresses with between PE routers is
MultiProtocol-BGP. MP-BGP's job is to exchange the VPN routes, but it is not
interested  in what VPN these addresses belong to. YOu need the RD to make
the VPN addresses unique to MP-BGP, and consequently to the SP domain. For
example, suppose you had VPN RED and VPN GREEN on different PE-routers and
they both originated an address from RFC1918, like 10.2.1.0/24, then if they
were not uniquely identified by an RD, when the two 10.2.1.0/24 addresses
arrived at the same remote PE-router, BGP would simply do its best path
selection algorithm on the two addresses and only pick one. Hence you would
lose the other. If they are both unique with an RD then it is called a VPNv4
address. BGP will see them as unique and the MP-BGP peer on the remote
PE-router would accept both. Then to decide which VPN to place the received
address in we use the RT, which is an extended community attribute.

You need the RD to make the VPN addresses to unique MP-BGP you need the RT
to select which VPN to include the address (the RT allows you to create
Intranets, Extranets etc...)

> -----Original Message-----
> From: alok [mailto:[email-masked]]
> Sent: Tuesday, 15 April 2003 9:08 PM
> To: [email-masked]
> Subject: Re: RD in 2547 bis
> 
> 
> lets assume there was no RT
> 
> could we filter on RD?
> 
> if we can do that, then why not vice versa?
> 
> ----- Original Message -----
> From: <[email-masked]>
> To: <[email-masked]>; <[email-masked]>
> Sent: Tuesday, April 15, 2003 4:31 PM
> Subject: RE: RD in 2547 bis
> 
> 
> > Hi,
> >
> > The overlapping address problem is that different VPNs that 
> is provided
> > by one operator can have the same private address space. 
> For instance,
> > two VPNs may have several identical addresses.  The RD 
> makes VPN routes
> > unique for each VPN.
> >
> > The RT is used to determine how to import and export the 
> VPN routes into
> > the relevant VRFs.
> >
> > There are many in mailing list who can answer better and 
> more pedogical
> > then me.
> >
> > Regards,
> >
> > Nhat Thanh
> >
> > -----Original Message-----
> > From: alok [mailto:[email-masked]]
> > Sent: den 15 april 2003 12:55
> > To: [email-masked]
> > Subject: Re: RD in 2547 bis
> >
> >
> > what is the "overlapping address problem"?
> >
> > why isnt RT sufficient to identify the ipv4 prefix uniquely?
> >
> > why "both"?
> >
> > ----- Original Message -----
> > From: <[email-masked]>
> > To: <[email-masked]>; <[email-masked]>
> > Sent: Tuesday, April 15, 2003 4:20 PM
> > Subject: RE: RD in 2547 bis
> >
> >
> > > Hi,
> > >
> > > The purpose of RD is simply resolve the overlapping 
> address problem
> > > in VPN context.
> > >
> > > regards,
> > >
> > > /Nhat Thanh
> > >
> > > -----Original Message-----
> > > From: alok [mailto:[email-masked]]
> > > Sent: den 15 april 2003 12:37
> > > To: [email-masked]
> > > Subject: RD in 2547 bis
> > >
> > >
> > > Hi,
> > >
> > > I know this has been asked time and again, but its still 
> confusing me
> > >
> > > what is the purpose of RD ?
> > >
> > > -rgds
> > > Alok
> > >
> > >
> > >
> > >
> >
> >
> >
> >
> 
> 
> 
>

---

From: "alok" <[email-masked]>
Date: Tue, 15 Apr 2003 17:29:34 +0530

hi,

am still confused....

I would like to know
1. can RD be used to filter ...if not why....
2. i say a VPNv4 route = IPv4+RT ... why not?

-rgds
Alok

---

From: John Smith <[email-masked]>
Date: Tue, 15 Apr 2003 14:28:08 +0100 (BST)

Jeff,
> the VPN addresses unique to MP-BGP, and consequently to the SP domain. 

Very Right.

> to select which VPN to include the address (the RT allows you to create

Instead of using the RT why cant RD work out as the RT. One can decide which route goes
into which VRF by looking at the RD rather than at the RT.

I guess this is the confusion which Mr. Alok has.

JS

__________________________________________________
Do You Yahoo!?
Everything you'll ever need on one web page
from News and Sport to Email and Music Charts
http://uk.my.yahoo.com

---

From: "alok" <[email-masked]>
Date: Tue, 15 Apr 2003 19:08:03 +0530

Yes,

thanks for articulating it John,

Thats my confusion.

-rgds
Alok
----- Original Message -----
From: John Smith <[email-masked]>
To: Apcar, Jeff <[email-masked]>; alok <[email-masked]>;
<[email-masked]>
Sent: Tuesday, April 15, 2003 6:58 PM
Subject: RE: RD in 2547 bis

---

From: Rajiv Asati <[email-masked]>
Date: Tue, 15 Apr 2003 12:28:42 -0400

John,

>I guess this is the confusion which Mr. Alok has.

Please keep in mind that RD is unique to a customer.
Now, when we get to the extranet, in which the customer1 and customer2 
exchange the routing information, it becomes much easier to control the 
routing information based on RT.

Also, with RT, we can simply check for one RT attribute and decide whether 
we want 100s of MP_NLRI or not (the way BGP update is packed). If we had to 
do this based on RD, then we really would have to go through each VPNv4 
prefix to find out whether it was a candidate for the import or not.

I think it comes down to what gives us more granularity and control over 
what we want to do.

Cheers,
Rajiv

---

From: "alok" <[email-masked]>
Date: Wed, 16 Apr 2003 11:40:30 +0530

Hi Rajiv/Robert,

thanks for your reply,

please see inline....

> routing information based on RT.

agreed....so it means you never use RD at *any point* but the local routing
table?

> prefix to find out whether it was a candidate for the import or not.

i agree... so essentially, lets reframe my question as "why do we need to
*propogate* both RD and RT to the MBGP peers, why not just RD"?

RD is local to the router /used to distinguish VPNv4 routes locally, is my
understanding.

If an implementation choose to use a different "key" other than RD to
identify a route locally, then? (you could say i am not

for Robert's comments:

> Alok,
>
> Yes you could use only one, yes you could filter with RDs etc ... but
> you will have to bind A) making the prefix uniqe with B) the
> import/export policy which would be much less flexible in assinging
> routes to VPN memberships then using RD just to make the vpn prefix
> uniqe (mostly on RRs/ASBRs) and a list of route-targets attached to each
> vpn route to decide where this route should be imported to.
>
isnt the use of "RD"  local to the router? if an implementation choose a
different "key" to uniquely identify the route, would it be wrong......?

i still cant see why does one need to advertise RD? it may have a local
significance in the router, but thats about it......

-Alok

---

From: Rajiv Asati <[email-masked]>
Date: Wed, 16 Apr 2003 02:23:59 -0400

Alok,

>agreed....so it means you never use RD at *any point* but the local routing

We shouldn't forget the presence of Route-Reflector in the network, and the 
RR also runs the best-path algorithm to select one best path before 
reflecting to its clients.

>*propogate* both RD and RT to the MBGP peers, why not just RD"?

Keep in mind that RD is not an attribute, where RT is.

>RD is local to the router /used to distinguish VPNv4 routes locally, is my

RD becomes crucial with the presence of RRs.

>identify a route locally, then? (you could say i am not

As long as you can carry that all the way to the RR, so that even RR can 
treat each of the overlapping prefix distinctively, you should be fine.

Let me repeat what I said earlier -

> > I think it comes down to what gives us more granularity and control over

Hope this helps.

Cheers,
Rajiv

---

From: "alok" <[email-masked]>
Date: Wed, 16 Apr 2003 12:20:59 +0530

Hi Rajiv,

> reflecting to its clients.

agreed.........

but RD is a key "local" to the router?
its just a "router's local way" of distinguishing routes?

could you elaborate your "best path algorithm"...

> > > we want 100s of MP_NLRI or not (the way BGP update is packed). If we
had
> >to

this point got me thinking....

are you saying that BGP decisions are made solely on NLRI values and not on
attributes?

and AFAIK, the ADJ_RIB_IN defination says "it contains all *unprocessed*
information learnt from peers.

> RD becomes crucial with the presence of RRs.

please explain

please tell me what happens if i dont "propogate" RD?

isnt the RD nothing but a "local KEY" to identify routes? which are anyways
propogated/imported/exported with RT?

cant i use a different "key" which is "local to the router"...

my point being that since the significance of RD is local to the router (as
far as my understanding goes) why should it be "propogated" or even
mentioned in a signalling draft?

> treat each of the overlapping prefix distinctively, you should be fine.

err no, the RR would have RT to look at, wouldnt it? and then use a "local"
tag/key?

my point is that why should it be "carried at all"

are you planning to have multiple hosts in the same VPN with the same IPv4
address???

> > > I think it comes down to what gives us more granularity and control
over

why does one need to carry the same? i would tag via "RT" (since RD is too
small as stated in 2547)...

i understand and appreciate the point that "more parameters" mean "more
flexibility".... but i want to know how RT doesnt give one the same
flexibility...

would appreciate if you could clarify...

-thanks & rgds
Alok