Subject: RD in 2547 bis

From: "alok" <[email-masked]>
Date: Tue, 15 Apr 2003 16:06:43 +0530

Hi,

I know this has been asked time and again, but its still confusing me

what is the purpose of RD ?

-rgds
Alok

---

From: John Smith <[email-masked]>
Date: Wed, 16 Apr 2003 09:43:07 +0100 (BST)

Rajiv,
comments inline .. 
 
> 
> We shouldn't forget the presence of Route-Reflector in the network, and the 
> RR also runs the best-path algorithm to select one best path before 
> reflecting to its clients.

AFAIK there are no special requirements which arise in case of Route Reflector
deployments wrt RDs. All we need to ensure is that we must have no unneccessary
advertisements of routes to any PE routers which dont import any one of them.

We need to split the network into multiple RR clusters, each servicing some number of
VPNs. The PE router clients of these RRs will then receive only routes that belong to the
relevant VPNs that they service.

> 
> 
> > >
> > > Also, with RT, we can simply check for one RT attribute and decide whether
> > > we want 100s of MP_NLRI or not (the way BGP update is packed). If we had
> >to
> > > do this based on RD, then we really would have to go through each VPNv4
> > > prefix to find out whether it was a candidate for the import or not.
> >

Agree with this point of yours.

> 
> 
> >RD is local to the router /used to distinguish VPNv4 routes locally, is my
> >understanding.
> 
> RD becomes crucial with the presence of RRs.

How come? Can you please give me some pointers as to how RD becomes "crucial" in presence
of RRs.

> 
> > > I think it comes down to what gives us more granularity and control over
> > > what we want to do.

I think this is it. And nothing else. We can also work out with having just one RT but
then having both gives us some greater control over what we want to do!

JS

__________________________________________________
Do You Yahoo!?
Everything you'll ever need on one web page
from News and Sport to Email and Music Charts
http://uk.my.yahoo.com