Subject: RE: Comments on the L2 VPN framework and solutions documents

From: "Mark Seery" <[email-masked]>
Date: Sun, 27 Apr 2003 13:42:09 -0700

Hi Muneyoshi,

Just looking through some of your comments I was wondering which of the
below "logical" networks is more preferable to you:

1) Emulated multipoint wire (where SP network is completely transparent)

     -------
     | CE1 |----------------------------
     -------          |                |
                      |                |
                      |                |
                   -------          -------
                   | CE2 |          | CE3 |
                   -------          -------

 2) Emulated switch (where the entire network looks like one switch)

     -------        --------------------------
     | CE1 |--------| Ethernet Switch/Bridge |
     -------        --------------------------
                      |                |
                      |                |
                   -------          -------
                   | CE2 |          | CE3 |
                   -------          -------

3) Network of switches (where each PE behaves like an Ethernet switch)

     -------        -------                 -------       -------
     | CE1 |--------| SW1 |-----------------| SW2 |-------| CE2 |
     -------        -------                 -------       -------
                       |                       |
                        |                     |
                          |                  |
                            |               |
                              |           |
                                |        |
                                 -------
                                 | SW3 |
                                 -------
                                    |
                                    |
                                 -------
                                 | CE3 |
                                 -------

Mark

---

From: Muneyoshi Suzuki <[email-masked]>
Date: Wed, 30 Apr 2003 18:40:13 +0900 (JST)

Mark,

> below "logical" networks is more preferable to you:

Thanks.

> 1) Emulated multipoint wire (where SP network is completely transparent)

I'm not sure what is a logical wire in the LAN technology area.
Is it a LAN segment? I don't understand meaning of the following diagram.

>  2) Emulated switch (where the entire network looks like one switch)

Could you clarify what is Bridge in the above contexts. Is it Bridge
defined in 802.1D-1998 or VLAN-aware Bridge defined in 802.1Q-1998?
(please see page 2 in 
http://www.ietf.org/proceedings/02nov/slides/ppvpn-1.pdf )

Otherwise, is it 1982-style Bridge or VLAN-aware Bridge without the 
Bridge Protocol Entity? In these case, it is not much meaningful to
distinguish 2) and 3).

Thanks,

Muneyoshi Suzuki
Nippon Telegraph and Telephone Corp.

---

From: Mark Seery <[email-masked]>
Date: Wed, 30 Apr 2003 08:46:47 -0700 (PDT)

--- Muneyoshi Suzuki <[email-masked]>
wrote:
> Is it a LAN segment? I don't understand meaning of
> the following diagram. <

Yes - LAN segment.

> defined in 802.1D-1998 or VLAN-aware Bridge defined
http://www.ietf.org/proceedings/02nov/slides/ppvpn-1.pdf
> )

For the purposes of what I was inquiry about I don't
think it makes difference - more interesting in the
spanning tree processing points you are interested in.
But, for the sake of argument lets assume it is a
VLAN-aware Bridge (I realize there are important
differnces based on installed based interoperability)

> Otherwise, is it 1982-style Bridge or VLAN-aware
> Bridge without the Bridge Protocol Entity?
> In these case, it is not
> much meaningful to
> distinguish 2) and 3).
> 

I was assuming with the Bridge Protocol Entity, in
which case there would be a difference, I believe. In
3) Spanning tree may influence routing within the
VPLS, whereas it would not in 2) and obviously not in
1)

Mark