Subject: RE: Question regdg. MPLS/BGP VPN MIB

From: "Shiv Agarwal" <[email-masked]>
Date: Mon, 28 Apr 2003 14:48:46 -0700

Without this additional index how else can you determine as to which interface is mapped to which VRF?

Though if a VRF is modeled like a VR with a separate context, then this information may not be necessary as the VRF can then be determined by the SNMP context.

Shiv.

-----Original Message-----
From: Siddharth Aanand [mailto:[email-masked]]
Sent: Monday, April 28, 2003 2:37 PM
To: [email-masked]
Subject: Question regdg. MPLS/BGP VPN MIB

The draft-ietf-ppvpn-mpls-vpn-mib-05.txt defines mplsVpnVrfName and
mplsVpnIfConfIndex as keys to the mplsVpnIfConfTable. The question I had
was, isn't the ifIndex (mplsVpnIfConfIndex) sufficient to uniquely
identify a row in this table ? Under what circumstances do we need both
the vrfName as well as the ifIndex as keys?

thanks,
-Sidd

---

From: Siddharth Aanand <[email-masked]>
Date: Mon, 28 Apr 2003 18:03:15 -0400 (EDT)

Shiv,

> interface is mapped to which VRF?

I am assuming that at the interface creation time it gets assigned to a
VRF. For rest of the VPN related configuration (which is what this
table seems to be used for), having the interface index is sufficient to
determine the VRF as well.

-Sidd

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 29 Apr 2003 10:20:41 -0400

At 06:03 PM 4/28/2003 -0400, Siddharth Aanand wrote:
>VRF.

         This is not a correct assumption. Interfaces (or sub-interfaces)
may be bound to or associated with a VRF much later.  It depends on
the configuration. Also, associations may change.

         --Tom

>For rest of the VPN related configuration (which is what this

>-Sidd
>
> >
> > Though if a VRF is modeled like a VR with a separate context, then this 
> information may not be necessary as the VRF can then be determined by the 
> SNMP context.
> >
> > Shiv.
> >