Subject: Route Distinguisher and Route Target

From: John Smith <[email-masked]>
Date: Thu, 10 Apr 2003 12:49:16 +0100 (BST)

Hello,
Is there any direct co-relation between the Route Distinguisher (RD) that i configure on
my system with the ROute targets that i may set in the VRF?

My question is - does the RD automatically get inserted in my import route target list? 

Also, suppose i advertise a VPN4 route using BGP from PE1 to PE2. Also suppose that PE2
accepts this because of the import Route Target configured on it. Now what does it do
with the RD which has been inserted in front of the actual IPv4 prefix? 

AFAIK it will simply throw it away and advertise that route to all the CE routers in that
VRF.

Am i correct in my understanding?

Thanks for any help in this!

Regards,
Smith

__________________________________________________
Do You Yahoo!?
Everything you'll ever need on one web page
from News and Sport to Email and Music Charts
http://uk.my.yahoo.com

---

From: Siddharth Aanand <[email-masked]>
Date: Thu, 10 Apr 2003 11:00:44 -0400 (EDT)

Smith

> AFAIK it will simply throw it away and advertise that route to
> all the CE routers in that VRF.
>

Yes. The last paragraph of section 4.3 of the RFC says that on the far-end
PEs, the received VPN-IPv4 addresses are converted back to IP routes and
"imported" into the VRFs.

-Sidd Aanand
Marconi Comms.