Subject: RE: WG split: why and how?

From: "Ash, Gerald R (Jerry), ALABS" <[email-masked]>
Date: Mon, 12 May 2003 14:33:08 -0500

> 3. Problem statement.
> 
>    As seen by ADs: slow progress on L3 and L2 VPN work (see section 2
>    above) caused by comparatively wide problem space with unusually
>    big number of correlated technologies (L2, bridging, tunneling,
>    routing, signalling, etc.) that in turn results in a big number of
>    tasks and documents within the WG.

Granted that there is a large number of tasks and documents to manage, which is one reason why work has not been completed.  However, this problem has only recently been identified for discussion on the list, and apparently has not been discussed to any great extent with the WG chairs (Marco's input).  

The PPVPN chairs have ably managed the large workload, e.g., see Marco's very thorough update on 'PPVPN WG Status' at IETF-56 http://ietf.org/proceedings/03mar/slides/ppvpn-1.pdf and comprehensive summary in the minutes http://ietf.org/proceedings/03mar/minutes/ppvpn.htm.  The PPVPN work across the ITU and IETF is well coordinated without any issues (such as have arisen with ITU-IETF interactions in other WGs).

As such, it would be very useful to get the WG chairs' input on the identified issues, and have them propose solution alternatives, rather than taking their comments 'off line' (as Alex has decreed).  This could be the basis for more concrete discussion of solution alternatives, rather than just one alternative.

> 4. Summary of the solution under consideration
> 
>    1. Put L3 and L2 work in separate WGs
>       Analysis of the L3 and L2 remaining and potential future work items
>       has shown that there is a sufficient amount of work in each area to
>       warrant a separate WG. Smaller and more focused WGs tend to be
>       more efficient in terms of achieving consensus and completing
>       their tasks.
> ...
>
> 6.7 Have you considered other alternatives to the split?
> 
>     Yes. The alternative to the split would be to organize work within
>     the WG in the form of design teams and have more than one WG
>     session at the face-to-face meetings. However, the WG already has
>     a number of DTs inside of it, so we can consider that this method
>     has been tried already. Increasing the number of WG sessions alone
>     is hardly going to help as majority of work is done outside the
>     face-to-face meetings, in fact, consistent need for more than one
>     session maybe considered as an indication that the WG has more
>     than enough on its charter.

Seems to conclude that the problem cannot be solved within the existing PPVPN WG.  Let's get the WG chairs' proposals on how to fix the problem within the WG, and discuss their proposals.  Let's reach a WG consensus as to which solution best solves the problem.

Jerry

---

From: "Hamid Ould-Brahim" <[email-masked]>
Date: Mon, 12 May 2003 16:20:26 -0400

Alex,

These clarifications of your first email are
certainly welcome although they are coming *one* day 
before May 11 deadline set in your previous email. 

See some comments inline...

>    2. Focus the charters to ensure progress on items already in
>       the pipe; expand the charters and add more work items as
>       things progress
> 

I am not sure we exhausted all the options. In addition to what George,
Bryan and others suggested on alternatives, other options can be 
considered as well.

If we assume a wg split is necessary (which I am no sure it is
at this point in time), then why not address VPLS 
separately from other l2vpn work. A potential option is Yakov's suggestion 
to split l2vpn in two wgs. Another option is to:

a) Keep ppvpn wg as it is covering l3vpn and l2vpn
   (other than VPLS), still covering the generic documents, 
   the common documents/mechanisms, the "Provider-Provisioned" 
   aspects, inter-as, etc.

and, 

b) Move VPLS specific related work (including provider-bridges liaison,
   etc) in a "Temporary" focused wg (we have temporary area why not
   have "temporary WGs" in INT area as well). 

   While the ppvpn, vpls are progressing we can decide to join them 
   at a given time. 

At least this option keeps ppvpn as it is in terms of structure,
avoids the questions on what to do with common l2+l3
work, does minimum disruption to ppvpn wg activities in l3, l3+l2 
space, takes into account that l3vpn work is in its final stage.

Other options as well is to look at a re-org from a wider
angle that affects both PWE3 and PPVPN. For example, merge some
PWE3 work with l2vpn VPW work, etc (I never understood why 
some l2vpn signaling is done in another wg).  

It looks to me an "easy-step" approach is more appropriate than
drastic change where the vpn problem is simplified into 
l3 and l2 work. 

I definitely favor (as Jerry already noted) a 'let's wait a bit longer'
approach and progress the current work and if needed discuss in Vienna 
options and solutions as was suggested by others (and 
involving all the parties). 

Hamid.

---

From: "Paul Unbehagen" <[email-masked]>
Date: Tue, 13 May 2003 13:29:27 -0400

I agree as well, Marco has done a great job for the working group.

Regards,

Paul Unbehagen

-----Original Message-----
From: Rajiv Papneja [mailto:[email-masked]] 
Sent: Tuesday, May 13, 2003 10:18 AM
To: Jamoussi, Bilel [BL60:1A00:EXCH]; 'Ash, Gerald R (Jerry), ALABS'; 'Alex
Zinin'; [email-masked]
Subject: Re: WG split: why and how?

Same here. I offer my full support for Marco and his great contribution to
the WG. 

  -Rajiv

----- Original Message ----- 

From: Bilel <mailto:[email-masked]>  Jamoussi 

To: 'Ash, Gerald R (Jerry), ALABS' <mailto:[email-masked]>  ; 'Alex Zinin'
<mailto:[email-masked]>  ; [email-masked]'
<mailto:[email-masked]'>  

Sent: Monday, May 12, 2003 10:52 PM

Subject: RE: WG split: why and how?

BNJ> Folks, 

BNJ> I also believe Marco has done a very good job managing the PPVPN WG. 
BNJ> If you share this "vote of confidence" please voice it to the list. 

BNJ> Bilel. 

-----Original Message----- 
From: Ash, Gerald R (Jerry), ALABS [mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Monday, May 12, 2003 3:33 PM 
To: Alex Zinin; [email-masked] <mailto:[email-masked]>  
Cc: Ash, Gerald R (Jerry), ALABS 
Subject: RE: WG split: why and how? 

<clip> 

Granted that there is a large number of tasks and documents to manage, which
is one reason why work has not been completed.  However, this problem has
only recently been identified for discussion on the list, and apparently has
not been discussed to any great extent with the WG chairs (Marco's input).  

The PPVPN chairs have ably managed the large workload, e.g., see Marco's
very thorough update on 'PPVPN WG Status' at IETF-56  <clip>

Jerry

---

From: "Shashi Kiran" <[email-masked]>
Date: Tue, 13 May 2003 10:41:42 -0700

Agree on the excellent work being done by the current WG. Should be allowed
to continue and progress.
 
Rgds 
Shashi Kiran 

----- Original Message ----- 
From: Bilel Jamoussi <mailto:[email-masked]>  
To: 'Ash, Gerald R (Jerry), ALABS' <mailto:[email-masked]>  ; 'Alex Zinin'

BNJ> Folks, 

BNJ> Bilel. 

-----Original Message----- 

<clip> 

Jerry

---

From: "Ash, Gerald R (Jerry), ALABS" <[email-masked]>
Date: Tue, 13 May 2003 14:55:40 -0500

Jerry> Seems to conclude that the problem cannot be solved within the
Jerry> existing PPVPN WG. Let's get the WG chairs' proposals on how to fix
Jerry> the problem within the WG, and discuss their proposals.

Alex> The ADs will consider the discussion on the list and conversations
Alex> with the WG chairs and will make the decision.

Your proposal to split the WG is the only 'solution' being considered.

I suggested to compare your solution to the WG chairs' solution for how to progress the work of PPVPN faster within the current WG.  Surely the WG chairs have been asked for their proposals on this in (private) discussions with you and the other ADs.  Can we consider what they propose?  And if not, why not?

Jerry