Subject: RE: vpls scaling question

From: "Wright, Steven" <[email-masked]>
Date: Mon, 12 May 2003 12:21:18 -0500

Loa,

1) I'm not trying to create requirements here, just to understand what the
group consensus is. i.e. is this  vpls thing intended to emulate current
switch capabilities/constraints or do something more ?

2) Perhaps my terminology was confusing. I was referring to the case of a
service provider with 10,000,000  customers, each with their own service
instance. This indeed would be a blessing ! (assuming they all pay their
bills). Each customer may only want a relatively few VLANs...

3) Is this a realistic target application ?? well that's always debatable!
But consider the case of 1 AS per LATA -  and what's the max number of
households / LATA ? Well there are metro's with 1-10,000,000 households...

4) Specific deployments depend on a lot more than design constraints (e.g.
$).....
  so ...see 1) above...

regards
Steven Wright 

> -----Original Message-----
> From: Loa Andersson [mailto:[email-masked]]
> Sent: Sunday, May 11, 2003 6:17 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: vpls scaling question
> 
> 
> Steve,
> 
> just to make sure we are on the same field. For me a vpls is 
> a service I
> as an oprator offer a customer, could you please give me a scenario
> where that customer would need 10,000,000 VLANs.
> If you are talikng about number of vpls's in the operator network,
> 10,000,000 "service instances" is not a problem, in fact it would be a
> blessing :)
> 
> /Loa
> 
> Steven.Wright wrote:
> > to clarify the INTRA- AS vpls case
> > I would like to better understand the expected capabilities 
> of  INTRA-AS 
> > vpls vs a network of Ethernet switches.
> >  
> > What is the scaling objective for vpls ?
> > Current generation Ethernet switches have evolved from the 4096 
> > VLAN/network to 4096 VLAN/port. Scale limits on  SP 
> Ethernet networks 
> > are typically driven by other factors e.g. MAC address table size, 
> > issues with multicast etc.
> >  
> > Is vpls intended to tackle any of those scale constraints ? 
> or to put it 
> > another way...
> > Current Ethernet switch networks can support on the order 
> of 10,000 VLAN 
> > service instances.  Will vpls enable scaling to the 
> 10,000,000 or so 
> > service instances/AS necessary to enable Ethernet as a 
> residential service ?
> >  
> >  
> >  
> >  
> > 
> >     -----Original Message-----
> >     *From:* Steven.Wright [mailto:[email-masked]]
> >     *Sent:* Wednesday, April 23, 2003 5:04 PM
> >     *To:* *Subject:* vpls scaling question
> > 
> >     vpls is proposed as a mechanism to enable large-scale 
> Ethernet networks.
> >     Can anyone quantify for me at what stage flat Ethernet networks
> >     break and vpls is required ?
> >     i.e what should the decision criteria be to convert an Ethernet
> >     network to a vpls network ?
> >     Steven Wright
> >     BellSouth
> > 
> 
> 
> -- 
> /Loa
> 
> mobile + 46 739 81 21 64
> email: [email-masked]
> 

*****
"The information transmitted is intended only for the person or entity to
which it is addressed and may contain confidential, proprietary, and/or
privileged material.  Any review, retransmission, dissemination or other use
of, or taking of any action in reliance upon, this information by persons or
entities other than the intended recipient is prohibited.  If you received
this in error, please contact the sender and delete the material from all
computers."

---

From: Eric Rosen <[email-masked]>
Date: Mon, 12 May 2003 13:54:23 -0400

Steven> I was  referring to the case  of a service  provider with 10,000,000
Steven> customers, each  with their own service instance.  Each customer may
Steven> only want a relatively few VLANs... 

Steven> there are metro's with 1-10,000,000 households... 

Of these  10 million households,  how many want  VLANs?  How many  have even
heard of VLANs? 

How many  households contain  more than  one site, and  want those  sites to
appear to be on a common LAN? 

Surely for residential households, you want to treat each one as a single IP
subnet, and  connect them to  a router.  I  don't see where VPLS  even comes
into it.  Am I missing something?

---

From: "Steven.Wright" <[email-masked]>
Date: Tue, 20 May 2003 10:22:08 -0400

> appear to be on a common LAN?

consider:
one VLAN for internet access (consumer service)
one VLAN for telecommuting (business service)

> into it.  Am I missing something?
the VLAN ID may be used to identify traffic of a customer within a
particular service provider's network.
the IP service(s) may be provided by a different service provider(s)

---

From: Ping Pan <[email-masked]>
Date: Tue, 20 May 2003 08:42:53 -0700

> the IP service(s) may be provided by a different service provider(s)

But there are only 4000 VLAN values altogether. There is no high-speed 
MAC chip available that supports stacked-VLAN last time I look into it.

Am I missing something here?

- Ping