Subject: RE: Draft charter for L2VPN - IPLS & ARP Mediation

From: "Hamid Ould-Brahim" <[email-masked]>
Date: Tue, 13 May 2003 18:03:05 -0400

> 
> I'd like to see the work in this area - IPLS & ARP Mediation 
> -progressed and
> documented in a published RFC. They are not the most widely 
> deployed cases,
> but they do exist and  have real network applications.
> 
> I do not care which group does the work. Given the current emphasis on
> polishing charters, it should appear within the scope of one of them.
> 

I agree. In fact I would like the l2vpn interworking topic
to be considered.

Hamid.

---

From: "Himanshu Shah" <[email-masked]>
Date: Wed, 14 May 2003 17:29:20 -0400

That is like asking for every draft that
Cisco employee has contributed whether Cisco 
is planning to implement it?

IETF operates on individual contributions
and opinions.

/himanshu

> -----Original Message-----
> From: Ali Sajassi [mailto:[email-masked]]
> Sent: Wednesday, May 14, 2003 4:56 PM
> To: [email-masked]; [email-masked]
> Subject: RE: Draft charter for L2VPN - IPLS & ARP Mediation
> 
> 
> 
> Steven,
> Does Bell South plan to offer VPLS ? If it plans to offer it, 
> then there 
> should be no need for IPLS because VPLS can be considered as 
> a super-set 
> since it covers both switches and routers as CEs and it 
> supports both IP 
> and non-IP traffic. Also inter-operability between IPLS and 
> VPLS is another 
> thing to consider if you plan to offer both !! However, if 
> Bell South plans 
> to offer IPLS in lieu of VPLS and assumes that all the 
> end-points for a 
> transparent LAN service are IPs, then that's a different story.
> 
> -Ali
> 
> 
> 
> 
>

---

From: "Himanshu Shah" <[email-masked]>
Date: Thu, 15 May 2003 08:54:38 -0400

Its a dubious question. 

It appears to indicate that if South Bell
is planning to offer VPLS, he should not
support the IPLS draft. It is particularly
disturbing to have it asked in response
to his individual technical opinion.

/himanshu

> Sent: Wednesday, May 14, 2003 8:26 PM
> To: Himanshu Shah; Ali Sajassi; [email-masked];
> [email-masked]
> Why am I not surprised to hear from you first :-)
> My questions was directed to the providers and I'd like to know which 
> providers are considering to offer IPLS and get some feedback 
> from them:
> 
> How many are considering to offer IPLS in lieu of VPLS ? and
> How many are considering to offer both IPLS and VPLS ?
> 
> -Ali
> 
> At 05:29 PM 5/14/2003 -0400, Himanshu Shah wrote:

---

From: Ali Sajassi <[email-masked]>
Date: Thu, 15 May 2003 11:05:11 -0700

The question was stated very clearly and was intended to get feedback from 
the operators and to ensure that we are all working under the same assumption.

IPLS has been designed and optimized for VPLS-challenged PE routers. In 
other words, PE routers that perform IPLS are not expected to perform VPLS 
functionality.

All I want to do is to make sure that operators are O.K. with it. In other 
words, to have one PE for IPLS functionality and another for VPLS 
functionality. In cases that the operator doesn't need to offer VPLS 
functionality, then all they need is an IPLS-capable PE. I just want to 
confirm if that's what the operators expect.

-Ali

---

From: Ali Sajassi <[email-masked]>
Date: Thu, 15 May 2003 17:02:06 -0700

At 04:49 PM 5/15/2003 -0400, Hamid Ould-Brahim wrote:

>Ali,
>Not sure I understand your conclusion. IPLS looks designed for
>IP-based CEs. I am not sure why a PE that provides IPLS service
>cannot provide as well VPLS service to other CEs
>(for example LAN switches) - if that PE can handle both -.
>The operator has the choice anyway given the situation and
>what functionality is supported on that PE.

With respect to IP-based CEs, both IPLS and VPLS services look the same and 
they can't tell the difference. However, if end-points are IP, then certain 
optimization wrt to PE internal operation can be achieved.

>If an operator plans to provide IPLS or VPLS
>wouldn't she/he engineer the PE to meet the vpls/ipls requirements?

With VPLS you can offer TLS service to both IP and non-IP end points and 
with IPLS you can offer TLS service to IP end-points only.

-Ali

> >In cases that the operator doesn't need to offer VPLS
>You may be asking fair question, I just don't see why an
>operator needs two distinct PEs if it needs to
>offer both IPLS and VPLS?
>
>Looking at the IPLS draft, I may agree with you that there
>is too much emphasis that an IPLS-capable-PE is a PE
>that cannot provide VPLS service while in fact - in my
>opinion - it should state that if an operator knows apriori
>that the CEs are all IP host/routers, then an IPLS like
>service may be offered (to what extent it simplifies/optimize
>the PE compared to VPLS service needs to be known)...and IPLS
>(as Steven pointed out) is considered just additional tool in
>an operator toolbox (unless in your question you wanted
>to refer/point to something else).
>
>Hamid.
>
>
>
>
>
>
>