Subject: RE: IMPORTANT: Strategy for VPN work in IETF

From: "Nagarajan, Ananth [CC]" <[email-masked]>
Date: Mon, 5 May 2003 10:05:22 -0500

Any effort to speed up the work in the WG is welcome.  The idea seems logical, but should have been done as soon as the ppvpn WG started accepting L2VPN within the charter.  Right now, I am afraid it would create another administrative delay  in the work - because the L3 work is more or less done.  (I am anticipating that in the next few months, the WG will concentrate fully on L2 work).
 
If, in fact, the WG does split, then we also need to think about what to do with a few documents such as the generic reqts draft, that will be ready for IESG last call this week, that really is an umbrella document for both L2 and L3 VPNs.  Similarly, I think we have the terminology draft too that we need to determine what to do with.
 
Thanks,
Ananth

	-----Original Message----- 
	From: Alex Zinin [mailto:[email-masked]] 
	Sent: Sun 5/4/2003 2:11 AM 
	To: [email-masked] 
	Cc: [email-masked]; Wijnen, Bert (Bert); Thomas Narten; Peterson, Jon; Allison Mankin 
	Subject: IMPORTANT: Strategy for VPN work in IETF

	Folks,
	
	Since San Francisco IETF meeting the IESG has been considering the
	situation in the SUB-IP area and in the PPVPN Working Group in particular.
	
	Such close attention to this WG was triggered by numerous concerns that
	the IESG members received from the WG participants about limited and
	slow progress within the WG despite the efforts of the WG chairs and its
	members. The IESG also used this opportunity to consider the IETF area
	that the PPVPN work would fit best.
	
	After much deliberation, the involved ADs (Bert, Thomas, and I) are
	considering the following organizational changes in order to improve WG
	focus and productivity and ensure faster progress of the VPN-related work:
	
	 1. Split of Layer-2 and Layer-3 VPN work in separate Working Groups.
	
	    The L2 and L3 VPN work spaces are each big enough to warrant a separate
	    WG. While concentration of all VPN-related work in a single forum was
	    the right thing to do to ensure coordination of efforts when the PPVPN
	    WG was created and L2 VPN work came in, such concentration is causing
	    scaling problems within the WG at this moment.
	
	    Migration of work into two separate WGs for L2 and L3 VPN technologies
	    with more specific WG charters will help to focus discussions, prevent
	    staff and meeting time overloading, and will aid faster progress of
	    corresponding technologies.
	
	 2. Migration of the VPN-related work to the Internet area.
	
	    As previously discussed, VPN-related work could be argued to belong
	    to more than one area. Tunneling mechanisms are the property that
	    gravitates this work to the Internet area, which is where we believe
	    the VPN work should go.
	
	    As part of this move, we are also considering moving PWE3 into INT,
	    so that L2TPEXT, PWE3, and thew new VPN WGs are operating in the same
	    area.
	
	Based on the above considerations, we are considering the following steps:
	
	 1. Two new WGs--L2VPN and L3VPN--will be created in the Internet area.
	    The mailing lists will be established and the discussion of the proposed
	    charters of the new WGs will be initiated shortly.
	
	 2. Once the charters of the new WGs are agreed upon and approved by the IESG,
	    creation of the L2VPN and L3VPN WGs and shutdown of the PPVPN WG will be
	    performed simultaneously. PPVPN WG documents will be migrated to the
	    corresponding new WGs.
	
	It is our intention to complete this process by the Vienna IETF meeting.
	Also, these changes are being made for management reasons and are not intended
	to be a "reset" on WG activities or to halt or interrupt progress on current
	ongoing WG activities.
	
	We'd like to hear from the WG members if they see any fatal flaws with
	the proposed approach. Please send us your feedback by May 11th.
	
	Regards,
	
	--
	Alex Zinin
	IETF SUB-IP Area Co-Director

---

From: "Hamid Ould-Brahim" <[email-masked]>
Date: Mon, 5 May 2003 13:24:29 -0400

Alex,

> members. 

[clipped...]

Wouldn't be more appropriate to first discuss what these 
concerns are and if they are indeed justified concerns, and
solicit feedback from the wg to discuss options or
improvements on how to move the wg forward and get consensus 
on that. If I recall, similar open approach has been taken for 
sup-ip area in Atlanta meeting.

Kind of hard to be *confident* that the proposed reorganization 
will actually address the raised concerns without actually
knowing what these concerns are in the first place! 

After all, the amount of work after the split is exactly 
the same as before the split if not bigger (given that
l3vpns work is almost done and the split will
introduce additional administrative overhead).

Hamid.

---

From: "Hamid Ould-Brahim" <[email-masked]>
Date: Mon, 5 May 2003 14:44:52 -0400

Eric,

> 
> 
> Alex> these  changes are  being  made  for management  
> reasons  and are  not
> Alex> intended to  be a  "reset" on  WG activities or  to 
> halt  or interrupt
> Alex> progress on current ongoing WG activities. 
> 
<snip>
> 
> 1. Before being comfortable with a  reorganization, I'd like 
> to see what the new charters  will be.  I'd particularly  
> like to be sure  
> that the L3VPN   charter is  not constructed so as to  cause a reset.
Same 
>  with the PWE3
>    charter; we don't want to have to refight old wars.
> 
>

Valid concern! and if the split implies rechartering,
debate around the charters, approval, etc, etc, one cannot 
claim that this proposed organizational change is purely 
an administrative operation.

Hamid.

---

From: "Hamid Ould-Brahim" <[email-masked]>
Date: Tue, 6 May 2003 17:01:31 -0400

Ananth,

>If, in fact, the WG does split, then we also need to think about 
>what to do with a few documents such as the generic reqts draft, 
>that will be ready for IESG last call this week, that really is 
>an umbrella document for both L2 and L3 VPNs.  Similarly, I think 
>we have the terminology draft too that we need to determine what to do
with. 

The bgp auto-discovery draft covers as well
both layer-3 and layer-2 vpns. 

But besides the "what to do with these common drafts 
question?", we need to ask ourselves why these drafts
were created in the first place. For example isn't
the generic requirement document covers common 
requirements for layer-2 and layer3 vpns. The simple 
existence of these drafts indicate that there is
a belief within the wg that layer-2 and layer-3 vpns
share something in common such as service attributes, topology, 
security, etc (documented in this draft).

On that topic, if later on there are proposals that
apply to both layer-2 and layer-3 vpns, where these
proposals need to be captured, on what charter...
One way or the other, the 'link', whatever that might be
(protocols, service characteristics, etc), between layer-2 
and layer-3 work needs to be taken into account and splitting
the wg will somehow eliminate the need to explore
this side of the vpn problem.

Hamid.

---

From: [email-masked]
Date: Wed, 7 May 2003 22:13:36 +0100

Hamid Ould-Brahim wrote 07 May 2003 19:09

Thomas, Eric, 
> 
> Thomas> The above could be read as indicating that the 
> discussion/urgency of 
> Thomas> the L2 work is pushing out or drowning out discussion 
> on L3 topics. 
> 
> Yes, I do think so. 
To be more precise, the discussions were mostly on vpls service, 
and since l2vpn includes services other than vpls, this could 
be read as well that vpls discussion/urgency is pushing out or 
drowning out discussions on other l2vpn services. In that 
respect, creating a new l2vpn wg will not make the situation any 
better. 
Hamid. 

NH=> Excellent observation Hamid.  It would seem to me that a L2 VPN service
should be nothing more than some form of co pkt-sw managed BW service.  This
could then be the common *default* VPN solution on which additional *client*
layer VPN services (be they IP (rfc2547) or ethernet (VPLS)) can be
considered (see my recent posting to Alex which suggested such a view).
However, even though I can see logic in grouping together the common server
layer aspects and then adding specific client layer aspects as needed, maybe
this is not so attractive to some?

regards, Neil

---

From: "Serbest, Yetik" <[email-masked]>
Date: Mon, 12 May 2003 09:42:23 -0500

I agree with Loa as well. I believe that there is a lot to be done in L2
space (working with 802.1ad etc...). I don't think forming DTs or focus
groups would help that much.

thanks,
yetik

> From: Muneyoshi Suzuki [mailto:[email-masked]]
> Sent: Sunday, May 11, 2003 9:00 PM
> Cc: [email-masked]
> Subject: Re: IMPORTANT: Strategy for VPN work in IETF
> 
> 
> 
> I second Loa.
> 
> Thanks,
> 
> 
> Muneyoshi Suzuki
> Nippon Telegraph and Telephone Corp.
> 
> 
>  > many of the points brought up by Thomas, Jeremy, Ananth and Luyuan
>  > valid.
>  > 
>  > I would agree that if there is like 13 docs that needs to 
> go into IESG
>  > review shortly for the L3VPNs only, this in itself is proof of that
>  > there is an abundance of work to be undertaken in the L3VPN area.
>  > Haven't checked but if there are MIB modules among those docs, one
>  > shouldn't underestimate the amont of work that needs to go into
>  > preparing those docs for IESG review.
>  > 
>  > The amount of work is even larger for the L2VPNs.
>  > 
>  > There seems to a, "if only thinking" around the split. "If 
> only we'd
>  > done this along time ago!" or "It would have been better 
> if we only had
>  > done this from start!".
>  > While I can agree on the sentiment, it is focusing on the 
> wrong problem.
>  > 
>  > We have a situation where we need to speed up the output 
> in this ppvpn
>  > area, I don't think there is an agreement on this?
>  > 
>  > My experience from the mpls wg is that I as a wg chair very often
>  > becomes a bottleneck, solely on reeading and crosschecking 
> capacity. Now
>  > if Alex is proposing to throw more manpower on those tasks 
> in an area
>  > that is understood to be work intensive, he nees support in this!
>  > 
>  > I really think there are separate issues here, but where 
> splitting the
>  > wg could contribute solve more than one, simple by adding 
> fresh blood.
> 
>