Subject: RE: Plug-and-play components (was FW: Single vs many solution(s))

From: [email-masked]
Date: Tue, 6 May 2003 23:58:08 +0100

Hi Mark,
> Neil,
> 
> [clipped]
> 
> >> As an operator I have a requirement to be able to
> choose addressing, routing, signalling (for the 2 co
> modes), OAM, etc functional components *independently*
> (using best-of-breed selection criteria) both per
> mode and within each mode.<<
> 
> Not sure how this can be achieved in practice (under
> current industry structure/system architectures).
NH=> Easy....just find a vendor who recognises it!  We did for L1
control-plane signalling and are now happily using PNNI (as we wanted).  It
a great signalling protocol...better than rsvp-te in our view.  I know
another large operator who has done exactly the same as we have (even bought
from the same vendor) though is still trotting out the GMPLS stuff on the
lists....quite bizarre.  As I noted in an earlier mail....its not at all
clear to me that those vocal on the IETF lists represent an operator's true
internal position. 

> I
> doubt it can be achieved by many startups 
NH=> vendors?  operators?  The issue here is running with the herd and being
too afraid to to say what you really think.  I have lots count of the
private mails I have had agreeing with the stuff I have posted in the past
and yet not feeling able to say so publically.  I think there are some
massive opportunties (playing to the trad operator markets) for vendors who
can spot the key stuff and act on it.  And the feedback I get from vendors I
deal with is that we are some way ahead in our thinking as to what the real
networking issues are and how best to tackle them.  MPLS (esp) is a major
opportunity waiting to happen.

>- actually
> any; unless I misunderstand your meaning. Perhaps you
> could give some thoughts on how this could be achieved
> in practice, but ultimately maybe this group can not
> really tackle this issue and the IESG should take it
> up in some way. Perhaps this is yet another reason for
> an "architecture" function/WG/BOF in the IETF.
NH=> I am not so pessimistic about the future.  I think there is a great
future *iff* we all can shake off our technology religions/prejudices and
just accept there is a role for cnls, co pkt-sw and co cct-sw mode to live
in harmony.  The 'bad' stuff arises from those who don't have such open
minds, and assume that stuff like the GMPLS peer-model makes any sense and
that MPLS is the same as IP.  This is just technology dogma at work.  All 3
modes have a required future.
> Mark

---

From: Mark Seery <[email-masked]>
Date: Tue, 6 May 2003 16:14:26 -0700 (PDT)

Hi Neil,

Didn't mean to bring in to question your logic, just
trying to suggest that not every vendor can support
every possible combination, and that it may not be
possible to create optimized solutions if a vendor
indeed tried to. At some point the vendor has to know
the specific solution an operator wants, build it,
test it, deploy it, and fix it ;-)

It could be argued an open systems approach to your
desire could help you, where for example you could by
the PNNI stack yourself and install it on the system,
but no such model exists today, and CW is that such an
approach is not practical.

Mark

---

From: "Mark Seery" <[email-masked]>
Date: Thu, 8 May 2003 23:07:46 -0700

Ok, so now I get it.

Its all about the architectural ability to use different components -I
didn't get that originally.

More offline.

Mark

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, May 06, 2003 3:58 PM
To: [email-masked]
Cc: [email-masked]
Subject: RE: Plug-and-play components (was FW: Single vs many
solution(s))

Hi Mark,