Subject: A new draft,IS-IS as PE/CE routing protocol in BGP/MPLS/VPN

From: lidefeng <[email-masked]>
Date: Tue, 13 May 2003 12:49:46 +0800

Hi,all,

In deploying BGP/MPLS VPN,there are sites that CE run IS-IS protocol with
PE,and the corresponding customer is reluctant to change the routing
protocol they used in the sites,to accomodate this situation, it is better
to run isis protocol between PE and CE,however,ther isn't any draft to
specify the scenario in the BGP MPLS VPN. This draft addresses this
scenario,the abstract is as following:

 IS-IS protocol, which is specified in [1], can be used as IGP between
   the Customer Edge (CE) router and the Provider Edge (PE) router in
   BGP/MPLS VPNs as per [1]. This document provides a detailed solution
   for IS-IS working as PE/CE Protocol in VPN services specified in [1].

---

From: Manav Bhatia <[email-masked]>
Date: Thu, 15 May 2003 17:14:15 +0530

Lidefeng,
Just a general observation:

- Whenever a PE router receives a MP-BGP UPDATE, it must execute the BGP
Decision Process to decide the best path to the prefix contained in the
UPDATE. When this decision process completes, the *best* route is passed
onto the IS-IS selection process for import into any relevant VRFs. Because
multiple UPDATEs for the same prefix might be received, and because IS-IS
has its own selection process for differing metric types, the BGP Decision
Process IMHO should be modified to prefer routes with internal metrics over
the routes with external metrics. The Decision process will be based on the
ISIS metric type that will be conveyed within the IS-IS Route Type Extended
Community Attribute that accompanies the ISIS VPN-IPv4 route.

There seems to be no mention of this in the draft.

- Is there a reason why you're not sending any metrics (wide/narrow) info
in the extended community?

Regards,
Manav

----- Original Message ----- 
From: "lidefeng" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Tuesday, May 13, 2003 10:19 AM
Subject: [Isis-wg] A new draft,IS-IS as PE/CE routing protocol in
BGP/MPLS/VPN

---

From: stefano previdi <[email-masked]>
Date: Thu, 15 May 2003 23:45:59 +0200

> Community Attribute that accompanies the ISIS VPN-IPv4 route.

If I understand correctly the concept of the sham-link, the 
PE will receive a mp-bgp route containing the other end of 
the sham-link and the extComm describing it. This route need 
to be the best among other (possible) mp-bgp routes (with 
same RD) for the same prefix. If such route is best, then you 
won't really import it into the vrf but rather you will "use 
it" in order to add a (fake) adjacency into the isis lsp the 
PE will originate. Then you run spf as part of the isis 
instance running in the vrf and compute your routes. After 
spf computation you'll find that the prefixes of the remote 
site are reachable through the sham link (according to the 
metric of your links of course). So I don't believe you 
really need to change the bgp selection process.

Btw, I don't see any reference to TLVs 22 and 135 in the 
draft...

s.

> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/isis-wg
>

---

From: Manav Bhatia <[email-masked]>
Date: Fri, 16 May 2003 12:15:14 +0530

Stefano,

AFAIK a sham link is only required when two VPN sites that belong to the
same area share a direct backdoor link. If no backdoor link exists between
the sites then no sham link is required.

So what happens if i dont have that direct (backdoor) link between two
different VPN sites or if there is no IS-IS adjacency over that backdoor
link?

Regards,
Manav

----- Original Message ----- 
From: "stefano previdi" <[email-masked]>
To: "Manav Bhatia" <[email-masked]>; "lidefeng" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Friday, May 16, 2003 3:15 AM
Subject: Re: [Isis-wg] Re: IS-IS as PE/CE routing protocol in BGP/MPLS/VPN

s.

---

From: stefano previdi <[email-masked]>
Date: Fri, 16 May 2003 10:23:00 +0200

> different VPN sites or if there is no IS-IS adjacency over that backdoor

Then you do the usual propagation from/to isis/mp-bgp 
and I believe BGP has already all you need to make your 
own selection decision (localPref, MED).

Anyway, if you advertise the same prefix from different 
sites, I suppose is because these sites have some sort 
of common connectivity to that prefix... and what is 
the operational scenario where the same prefix is 
advertised with different metric-type ? If it is just a 
matter of preference you can just play with the metric 
value (with wide metric you have all you need)

s.