Subject: RE: IMPORTANT: Strategy for VPN work in IETF

From: "Nagarajan, Ananth [NTWK SVCS]" <[email-masked]>
Date: Fri, 9 May 2003 10:51:56 -0500

I think I agree with Jeremy here.  After thinking about the proposed split for some time, I realized that (as I said earlier) it would have made more sense if this was done as soon as L2VPN/PWE3-related stuff was brought into the WG.  I also feel that there are several "generic" documents, in addition to the ones I brought up on this thread some time ago, and it will become increasingly complex to decide where those kind of documents would fit.

My preference is to schedule two sessions at Vienna, and spend some time discussing this, before any decision is made.  

PS: Another potential problem that would happen is having to subscribe to both the l2 and l3 vpn mailing lists and getting duplicate emails everytime a generic issue is discussed.

Ananth

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, May 09, 2003 9:54 AM
> To: Thomas Narten
> Cc: Alex Zinin; [email-masked]
> Subject: Re: IMPORTANT: Strategy for VPN work in IETF
> 
> 
> Hi Thomas, all,
> 
> > The chairs themselves seem to agree that there are some 13 documents
> > on L3 that are not through the system yet. I'm a bit 
> concerned to hear
> > that there has been minimal discussion on L3 topics over the last
> > year, given the number of L3 work items that apparently need to get
> > completed.
> > 
> > The above could be read as indicating that the discussion/urgency of
> > the L2 work is pushing out or drowning out discussion on L3 
> topics. If
> > that is the case, a separate WG, mailing list, etc., may well help.
> > I'm assuming the L3 work is important and should get completed.
> 
> I believe that it can also be read as indicating that many feel that
> most of the (current) L3VPN work is stable and agreed upon, 
> and doesn't
> need more discussion within the WG. As was already hinted previously,
> the progress of the L3VPN work has been delayed (for a long time)
> because the framework and requirements documents needed to be accepted
> first.
> 
> I do believe however that several proposed new working items (QoS,
> security, management, multicast, etc.) have received little attention
> from the WG because of the current L2VPN (VPLS) 
> discussions/urgency. But
> as many of these are aimed at both L2 and L3VPNs, and as I don't find
> reference to these items in the proposed charters, I 
> understand that the
> goal of the proposed split is not to accomodate these.
> 
> On one hand, I believe that the idea of two separate WGs is a 
> good one,
> but on the other hand, I'm not sure how much it will help 
> now, so far in
> the process.
> 
> I also personally believe that the PPVPN WG has produced valuable
> results, and is making progress on complex topics every day 
> (look at the
> current IEEE vs VPLS discussions on this list). And this despite the
> fact that the 'market' is not waiting and despite the fact that the
> number of interested individuals (from different backgrounds: SPs,
> vendors, academic and other standard bodies) is very large.
> 
> Jeremy.
> 
> 
>

---

From: Alex Zinin <[email-masked]>
Date: Fri, 9 May 2003 16:05:48 -0700

Ananth,

Friday, May 9, 2003, 8:51:56 AM, Nagarajan, Ananth [NTWK SVCS] wrote:
> I think I agree with Jeremy here. After thinking about the proposed
> split for some time, I realized that (as I said earlier) it would
> have made more sense if this was done as soon as L2VPN/PWE3-related
> stuff was brought into the WG.

Isn't later better than never?

> I also feel that there are several "generic" documents, in addition
> to the ones I brought up on this thread some time ago, and it will
> become increasingly complex to decide where those kind of documents
> would fit.

Please list those documents.

> My preference is to schedule two sessions at Vienna, and spend some
> time discussing this, before any decision is made.

I'll address this in my answer to Fabio.

> PS: Another potential problem that would happen is having to
> subscribe to both the l2 and l3 vpn mailing lists and getting
> duplicate emails everytime a generic issue is discussed.

I was under impression that modern e-mail clients had tools to
deal with this :)

Alex