Subject: RE: Single vs many solution(s)

From: "Himanshu Shah" <[email-masked]>
Date: Tue, 6 May 2003 11:23:38 -0400

Richard,
 
Like it or not - this entire debate is about which signaling protocol
to use. K.Kompella VPLS (decoupled feature) could also be supported
using LDP signaling. However, that is not the focus of the debate.
 
As for inter-AS case, I remember the discussion in one of the design
team meetings (in Boston) where Yakov himself suggested that inter-AS can be
handled by one AS handing off the traffic on the Ethernet and other
AS picking that up as customer facing inter-carrier traffic. May be
I misunderstood him.
 
I am (personally) skeptical about the BGP vs LDP support
numbers. There is danger in delaying this decision, it impedes
the L2VPN standardization effort, which in turn causes reluctance 
and spurious in offering such service.
 
/himanshu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, May 06, 2003 10:27 AM
To: Himanshu Shah; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: Single vs many solution(s)

Himanshu, 

I believe that there can exist multiple solutions for different sets
of problems. However, one must not confuse the solution with
signaling. We oughta not have two signaling mechanisms for 
two solutions to the same problem.

[RS: I agree that there should only be one 'functional specification'. However, I don't think we can rule out the possibility of having to use more than one protocol for each function until the functional specifications have been developed.] 
 
A while back, it was determined that PW setup signaling is not
the charter of PPVPN but of PWE3. Lately, we have been 
discussing again whether BGP based signaling is better than LDP
based signaling. We have got to get past this issue once and for
all. My personal experience (having implemented BGP based 
signaling for L2VPN) is that my previous company could not find any customer 
demand for BGP-based solution (we did not look into Italy though :-) 
However, there was greater interest in LDP based solution and
public forums to test interoperability with.

[RS: Carrying out a quick count of the individuals that have expressed support on this mailing list for the two opposing drafts (K.Kompella vs. V.Kompella/Lasserre), based on whether they work for an SP or a vendor the results are (roughly):
 
Draft     Vendor Support    SP Support
BGP              4                      19
LDP               7                       3
 
These results would suggest that customers (i.e. SPs) prefer the BGP approach. I am not saying that I agree, far from it, but I don't think that we should rule out protocols at this stage, especially in the inter-AS case. Instead we should be focussing on getting the functional specifications correct.]
 
I think we have learned enough lessons from CR-LDP vs RSVP-TE
debacle. Lets not repeat it for L2VPN.
 
...Richard 

 
 -----Original Message-----
From: Vasile Radoaca [mailto:[email-masked]]
Sent: Monday, May 05, 2003 11:21 PM
To: 'Alex Zinin'; [email-masked]
Cc: Yakov Rekhter
Subject: RE: Single vs many solution(s)

Alex, 

  I think the ideal goal is to have only one solution, but such ideal usual can be achieved if we are working in a pure theoretical environment, without market considerations. In reality the market is driving in most of the cases, and some assumptions made two years ago are not any more valid - there are categories of SPs that pretty much have disappeared from the map.

  You stated very clear that a problem space needs to have a single solution. I fully agree with you as a goal, but ut the issue that we face right now is that the problem space is not well concluded and well understood just purely from technical considerations. 

 The L2 VPLS is a complex space with multiple dimensions, and the vendors - in the last two years -  have worked from different angles, optimizing one or more dimension(s) of the problem space (probable the downturn in the market it self, was part of the problem). Without to contradict each other, most of the solutions are closed in a specific dimension, based on some objective/subjective parameters or experience and some criteria of optimization. Moving in only one dimension doesn't scale it self.

 The fact we do have more than one solution, I think is a good thing, and doesn't contradict that we can't move toward one solution, if we are driving diligently, and willing to make compromises. Taken such research value in consideration, would be a positive sign that IETF is looking to create a solution that would be valid for a while. Reading the mailing list, I observed the same wise advise from most of the SPs, and this reflect not a "problem" but a reality.

Cheers 
   Vasile 
  
-----Original Message----- 
From: Alex Zinin [ mailto:[email-masked]] 
Sent: Monday, May 05, 2003 5:27 PM 
To: [email-masked] 
Cc: Yakov Rekhter 
Subject: Single vs many solution(s) 

Yakov, 

[I took the liberty to change the subject line] 

>> I believe the goal for the WG should be to work out 
>> a single solution. 

> That is certainly not in the charter. In fact the goal 
> you stated above directly contradicts what is in the charter: 

>    Multiple approaches are being developed as each approach 
>    has particular characteristics and differing scope of 
> applicability. 

Thanks for pointing out a possible contradiction. I don't think it exists. 

My opinion (and I think it would be safe for me to say it is consistent with that of the IESG) is that as long as different solutions are solving different problems (or, as the text of the charter says, have different scopes of applicability), it is fine to have more than one solution. However, for a single problem, we only need a single STD'ized solution.

> And if you believe that for VPLS the goal should be a single solution, 
> then why wouldn't you insist to have the same goal for L3 VPNs ? 

you forgot to add "and if you wouldn't insist on a single solution for L3 VPNs, then why do you insist on this for L2 VPNs" ;-)

The reason is I don't want to restart the L3 VPN work in the IETF and/or revisit the decisions that have been made in the past, while I still see a reasonable opportunity to steer the L2 VPN work.

> Also, if you insist on a single solution, wouldn't that 
> imply a single auto-discovery mechanism for VPLS ? 

This would definitely be my preference. 

Alex

---

From: Yakov Rekhter <[email-masked]>
Date: Mon, 12 May 2003 11:45:34 -0700

Himanshu,

> team meetings (in Boston) where Yakov himself suggested that inter-AS =
> can be handled by one AS handing off the traffic on the Ethernet and other

May be you did.

> and spurious in offering such service.

Your assertion about relation between delaying standardizaiong
effort and offering VPLS service is questionable. Perhaps you may
consider that 2547bis is widely deployed, even if it is not an IETF
standard. Ditto for draft-martini.

Yakov.