Subject: RE: Comments on the L2 VPN framework and solutions documents

From: "Himanshu Shah" <[email-masked]>
Date: Mon, 12 May 2003 17:42:33 -0400

Ali, 

You seem to have different opinion than others
in IEEE group.

ali> I don't think there is a disconnect. When you talk about 
ali> P-STP, you need to consider both intra-island and 
ali> inter-island. P-STP is NOT used for inter-island - 
ali> for that we use full-mesh with split horizon. 
ali> Also keep in mind that P-STP is suggested for 
ali> Ethernet access domain and not MPLS access domain.

However, Mick seems to suggest something different

mick> If the VPLS drafts have not changed significantly in 
mick> their intent (I don't think they have) there is not a disconnect here. 
mick> There is a difference between running spanning tree to cut PWs 
mick> and reduce their topology to that of a spanning tree 
mick> (which is what the VPLS folks were correctly rejecting) 
mick> and conveying spanning tree BPDUs across the emulated LAN 
mick> formed by PWs so that bridge ports attaching to that emulate LAN 
mick> service can have the right state, including the 'LAN' or not in the 
mick> active topology/topologies for VLANs. Again it is neccessary to get 
mick> the layering straight, focusing on which wire a BPDU goes down before
mick> the layering is straight really doesn't help.

Can you clarify what you mean?

/himanshu

---

From: "Mick Seaman" <[email-masked]>
Date: Mon, 12 May 2003 15:23:55 -0700

Himanshu,

I don't see the disconnect between what Ali is saying below and what I said.
They may be different statements but I don't see that that means they
disagree. Unfortunately I don't see how to resolve your difficulties. Mick

-----Original Message-----
From: Himanshu Shah [mailto:[email-masked]]
Sent: Monday, May 12, 2003 2:43 PM
To: Ali Sajassi; [email-masked]; Norman Finn; Muneyoshi Suzuki;
Tony Jeffree; Les Bell; Paul Congdon; Neil Jarvis
Cc: [email-masked]; [email-masked]
Subject: RE: Comments on the L2 VPN framework and solutions documents

Ali, 

/himanshu

---

From: [email-masked]
Date: Mon, 12 May 2003 19:53:52 -0400 (EDT)

Hello Himanshu,

Nice to hear from you again.

My understanding of the below discussion is that Ali and Mick are agreed
on the following:

- Spanning Tree will not run on service providers networks natively
- Islands of Spanning Tree may exist on service provider networks
- Spanning Tree BPDUs may be encapsulated across PW connections

I see the layer model in the following way:

Higher layer (usually IP)
VLAN (optional)
Spanning Tree
Encapsulated Ethernet (only on the P-P or P-PE connections)
MPLS (only on the P-P and P-PE connections)
Ethernet or core network equivalent

Does everyone agree that this is the correct order of the layer model?
ST resides below VLANs because BPDUs are never tagged (even in the case of
802.1s).

Maybe this should be clarified in the proper drafts so that everyone is
clear.

Thanks,
-Ben