Subject: multi-link CE-PE connections

From: "Shanthi Pendyala" <[email-masked]>
Date: Thu, 29 May 2003 18:01:11 -0700

hi,

what is recommended way to support/detect the following VPLS (mis)configuration. For simplicity assume Ethernet attachment circuits.

	-------------------------
	|  PE		|
	|		|
	------------------------
	 P1/	\ P2
	   /	 \
	------------------
	| HUB        |
	-----------------
	     |
	     |
	----------------
	|  CE	|
	--------------

1: it is a misconfiguration. don't do it
2: vendors are running proprietary link-level protocols to break the local loop (P1<->P2) at the PE. one of the ports (P1 or P2) is blocked at any one time..
3: what if it is not a misconfiguration but customers want to do this intentionally to provide redundant PE-CE links ?

Thank you

shanthi kiran
Luminous Networks
Cupertino CA

---

From: "Javier Antich" <[email-masked]>
Date: Fri, 30 May 2003 00:22:12 -0700

I would make the hub to be a switch and run STP, and make the PE(s) tunnel its BPDUs, so that the switch receives on one link its own BPDUs, that would make the switch block one of the ports. 
Now, what if the customer switch does not configure properly STP, or just forgets to do it, you will have a funny (and dangerous) loop unless the PE is able to handle that situation.

regards.
Javier.

__________________________________________________
Javier Antich Romaguera
Systems Engineer
Riverstone Networks EMEA
e-mail: [email-masked]
mobile: +34 639 218 428
__________________________________________________

-----Original Message-----
From: Shanthi Pendyala [mailto:[email-masked]]
Sent: viernes, 30 de mayo de 2003 3:01
To: [email-masked]
Subject: multi-link CE-PE connections

hi,

Thank you

shanthi kiran
Luminous Networks
Cupertino CA