Subject: RE: Single vs many solution(s) (LONG reply)

From: "Busschbach, Peter B (Peter)" <[email-masked]>
Date: Tue, 13 May 2003 20:31:14 -0400

> From: Ross Callon [mailto:[email-masked]]
> Sent: Tuesday, May 13, 2003 1:30 PM
> Subject: RE: Single vs many solution(s) (LONG reply)

> >I don't think the IETF is making business decisions. Vendors 
> are free to develop proprietary solutions and service 
> providers are free to deploy them. However, a standards body 
> should develop one solution as THE standard.
> >
> >...
> >Peter
> 
> This is ignoring 17 years of IETF experience, and more than 
> 20 years of 
> standards experience. The reality is that neither the IETF 
> nor any other 
> standards body is good at choosing between major approaches. When 
> we have tried to do this (or when any other standards group has tried
> this) we have failed more often than succeeded. Where we have let more
> than one major approach be progressed, we have succeeded most of the
> time (although usually most of the approaches eventually go away). 
> 

Ross,

I think there is a difference between new, unproven technologies - like IP routing protocols in the eigthies and the various wireless protocols more recently - and more mature technologies.  

SONET, ATM, GR-303 etc. were based on experiences with earlier technologies and for all intents and purposes, they have led to a clear set of standards that have been adopted widely. I don't know why you suggest that in general standards groups fail to advance single solutions.

I maintain that having multiple solutions for the same problem comes at great cost to the industry. Developing multiple routing protocols may have been unavoidable, but the fact that every router now has to support both IS-IS and OSPF is inefficient from multiple perspectives.

I think that the issues that are being discussed in the PPVPN WG (e.g. discovery and signaling)are not new. There are several existing protocols that can do the trick and the question is which ones are best suited to be used in L2 VPNs. In this particular case, I think that advancing multiple solutions will have more negative than positive consequences.

In summary, I stick with my original point (but with different capitalization): a standards body SHOULD develop one solution as the standard.

Peter

< snipped >

> Making decisions like this is just something that a standards 
> body is not capable of doing well. 
> 
> Ross 
>

---

From: Ross Callon <[email-masked]>
Date: Wed, 14 May 2003 10:47:07 -0400

>I think there is a difference between new, unproven technologies - like IP routing protocols in the eigthies and the various wireless protocols more recently - and more mature technologies.  

IP routing protocols in the mid 80's were in fact pretty well 
understood. The problem was that a large political group 
which was primarily composed of people who had a less than 
thorough understanding of routing was making the decision. 

>In summary, I stick with my original point (but with different capitalization): a standards body SHOULD develop one solution as the standard.

At this point I think that we know that both of the VPLS proposals would
work, with some level of administrative effort. I don't think that we have a
complete understanding of the relative administrative effort required.

I could certainly live with a solution in which both proposals are progressed
as Experimental, with the understanding that in two or three years we
will look and see how widely deployed each proposal is, and what the 
operational experience is. In a few years we could then progress each 
proposal if it has positive operational experience and also lets say at least 
about 30% of the overall market (meaning that if both proposals work well
and are widely deployed we might progress both to Standard status, but if 
one gets the overwhelming % of the overall market then only it would be 
progressed as a full standard). 

Ross