Subject: RE: WG last call on LSR and LDP MIB modules - setting dates

From: "Natale, Robert C (Bob)" <[email-masked]>
Date: Thu, 19 Jun 2003 10:30:04 -0400

Hi,

Apologies for keeping the long cc: list....

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, June 19, 2003 8:37 AM
> 
> ...
> My read of the draft is that the authors are indeed requesting 
> changes to the LDP protocol.  One example is the
> discussion on sessions being enabled/disabled.  As Tom points out, 
> this is not in the MIB because it is not in the protocol.

Yes, and we all understand (I hope) the futility of that.

However, these exchanges do raise several very good points:  E.g.,

   - Isn't it a good idea to have a fuller understanding of
     how a technology should be managed *before and/or during*
     protocol development?

   - If so, perhaps:

      - Each protocol development WG should have a Mgmt & Ops advisor?

        (The "MIB Doctors" service is valuable but seems to tend to
        focus on SMI compliance (and similar issues) to the exclusion
        of MIB sufficiency relative to the management requirements of
        using the technology at hand.)

      - The Mgmt & Ops Area should publish a set of critical generic
        management requirements for all protocol development WGs to
        refer to as they do their core work.

        (Yes, everyone knows how important management and operations
        are :-], but everyone also knows how much that is just given
        "lip service" in the segments of the real world that don't
        include real users.)

> ...
> A question was made privately to one of the authors at the 
> Atlanta IETF that perhaps a MIB which stores LDP counter information
> in a history table (such as is done in SONET) could be useful to them?

This is a good example of the kind of generic feature and "re-use"
that I am talking about above.

Cheers,

BobN

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 19 Jun 2003 11:03:56 -0400

> From: Natale, Robert C (Bob) [mailto:[email-masked]] 
> Sent: Thursday, June 19, 2003 10:30 AM
> To: [email-masked]
> Cc: 'MPLS WG'; [email-masked]; 'Ash, Gerald R (Jerry), 
> ALABS'; Wijnen, Bert (Bert); 'Loa Andersson'; 'Lai, Wai S 
> (Waisum), ALABS'; 'Chung, Li-Jin W, ALABS'; 
> [email-masked]; 'Van der Linde, Harmen, ALABS'
> Subject: RE: WG last call on LSR and LDP MIB modules - setting dates
> 
> 
> Hi,
> 

	Yes. 
 
>         using the technology at hand.)

	Yes, I agree. 
 
>         refer to as they do their core work.

	BUT, those requirements should be used hand-in-hand
with those produced by the WG. Also, the WG may have a good
reason to not use some of those requirements and should be
free to do so if there is consensus to do so.
 
	--Tom

> This is a good example of the kind of generic feature and 
> "re-use" that I am talking about above.
> 
> Cheers,
> 
> BobN
>