Subject: RE: decisions on L2 solutions documents

From: "Hamid Ould-Brahim" <[email-masked]>
Date: Mon, 2 Jun 2003 11:05:39 -0400

Eric,

> 
> Vach: <VPNid, PE1, PE2, Vcid>
> 
> Eric: <VPNid, PE1, PE2, VCid at PE1, VCid at PE2>
> 

Yes. I think Vach wanted to keep exactly
the same model for PW provisioning as
in Martini without configuring SAII, TAII to
reflect VCID. But I agree from
signaling point of view it is the same.

> That is, the only difference is whether to have a VCid which 
> is unique for a
> given pair of PEs, and have  that VCid provisioned at both 
> ends, vs. whether
> to allow each end to use a different VCid. 
> 

Yes. I think that is the difference, and I say ability
to support an auto-discovery mechanism is an important
aspect of a VPLS solution. If both ends of pw are configured 
then there is no point of using an auto-discovery
mechanism. Not sure that is acceptable.

[clipped]...

> 
> We could  compromise by  allowing a one-name  format and a  
> two-name format,
> keeping  the one-name  format for  VPLS and  HVPLS, and  
> using  the two-name
> format only where  is it really required.  However,  I think 
> that compromise
> would result in something which is more complicated than it 
> needs to be. 
> 

I'd rather prefer one format. Let's not redo the same thing
as in pw control draft. Two exclusive formats may imply the
need to support compatibility procedures, etc (and I don't see 
how interoperability can be achieved with two formats).

Hamid.

---

From: Peter Willis <[email-masked]>
Date: Mon, 02 Jun 2003 18:21:24 +0100

Wouldn't it be kind of cool if we could use the same addressing format for 
what ever MPLS LSP/pseudo wire/tunnel? Is it too simple to say we always 
identify the end-point of an LSP/PW/tunnel with a unique address (I mean 
unique for the LSP/PW/tunnel so no 2 PWs share the same address)?

Now I know the problem is IPv4 space isn't big enough to do this so why not 
use IPv6 addresses? Since you've got to implement IPv6 at the RFC specification 
level anyway wouldn't it be good to use IPv6 to address LSPs/PWs/tunnels 
consistently? That way we'll have another incentive to move to IPv6 - it'll 
ease the management & implementation of LSPs/PWs/tunnels.

Well I'll let you pragmatic types get back to work ;-)

Regards,
Peter.