Subject: RE: VPLS naming issues

From: "Hamid Ould-Brahim" <[email-masked]>
Date: Mon, 23 Jun 2003 15:13:23 -0400

Eric,

>
> My  thinking is  that the  Generalized FEC  Id is  a naming 
> mechanism which
> provides everything that  is needed for VPLS, but which  also
> can cover more
> applications.  So I don't really see the downside.
>
 
I haven't seen this subject line before (I guess I didn't realize
that Vach's email on timeslot request included items to be 
discussed).
 
I agree that VPN-ID TLV doesn't address the scope of
deployment scenarios that a VPLS system needs to consider
and particularly distributed VPLS case.
 
I am not sure I understand why Vach is insisting on VPN-ID
TLV since clearly it requires extra work that has already been done 
within PWE3 wg and l2vpn drafts proposals (which pretty much address 
Vach's main requirements and other l2vpn requirements). Besides that any 
VPN-ID proposal will need to be standardized...why go through all of 
that while we do have an approach that is already available and 
documented. 
 
I thought initially the motivation behind VCID is to line up
with Martini's initial signaling model (PWid FEC), but with
the introduction of a VPN-ID TLV that goal disappears anyway.
 
Are there clearly new requirements or technical benefits
that justify defining a new VPN-ID TLV besides just
using the Generalized ID FEC?
 
Hamid.

---

From: "Vach Kompella" <[email-masked]>
Date: Mon, 23 Jun 2003 12:34:25 -0700

>> Vach's main requirements and other l2vpn requirements).

I don't believe I'm insisting on a VPN ID TLV.  Hamid, you should probably go
and read my email.

I think I know both Hamid's and Eric's opinions.  I'm sure there are any number
of ways of encoding a VPN ID.  I am trying to gauge consensus before I go and
make a significant unilateral change in a document that is a WG document.  I
hope people are not as apathetic in Vienna.

>> that Vach's email on timeslot request included items to be

Loa asked for us to post the points we wanted to raise in our timeslots so that
we could get email activity before the meeting (and hopefully have brief
timeslots).

-Vach