Subject: RE: decisions on L2 solutions documents

From: "Hamid Ould-Brahim" <[email-masked]>
Date: Mon, 2 Jun 2003 13:34:35 -0400

Peter,

> 
> 
> Wouldn't it be kind of cool if we could use the same 
> addressing format for 
> what ever MPLS LSP/pseudo wire/tunnel? Is it too simple to 
> say we always 
> identify the end-point of an LSP/PW/tunnel with a unique 
> address (I mean 
> unique for the LSP/PW/tunnel so no 2 PWs share the same address)?
>

But it that case how about pw created for l2vpns. Would these
addresses be required to be always unique or can be
overlapping?  

In addition to that if these addresses are taken from the
provider space or are unique across VPNs, wouldn't that limit
the flexibility of the client to use private addresses 
particularly for services like svc-vpns.

Hamid.

---

From: Peter Willis <[email-masked]>
Date: Tue, 03 Jun 2003 09:44:12 +0100

> addresses be required to be always unique or can be

Yes if you created L2VPNs from PWs then the PWs would still be uniquely 
addressed. However if one wanted to connect a set of uniquely addressed access 
points together without PWs in an any to any/full mesh/mp-mp fashion then
 an IP network  already does this very neatly ;-)

> particularly for services like svc-vpns.

The addresses would come from the provider space as the LSPs/PWs/tunnels are 
connected to the edges of the provider's network. The client can use any 
addressing scheme they like. But you point out a good issue with signalling if 
the VPNs set-up where to be signalled by the client then what addresses/names 
would be used? These names would (should?) not have to be the same as the 
addresses the provider uses to set-up the VPN.

Peter.