Subject: [precis] do subclasses need names?

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 11 Apr 2012 13:54:00 -0600

While writing documents that subclass the base PRECIS classes, I've
found myself naming the subclasses (e.g., rfc6122bis talks about the
localpart subclass of the NameClass and the resourcepart subclass of
the FreeClass). Is this something we want to encourage? If so, does it
make sense to gather those names when people register new uses of
PRECIS as requested in the framework document?

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/

---

From: Joe Hildebrand <[email-masked]>
Date: Wed, 11 Apr 2012 14:33:28 -0600

That seems like a reasonable idea.  Is there a suggested naming pattern that
denotes the superclass?  E.g. ResourceFreeClass, LocalpartNameClass

On 4/11/12 1:54 PM, "Peter Saint-Andre" <[email-masked]> wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.8 (Darwin)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
> 
> iEYEARECAAYFAk+F4VcACgkQNL8k5A2w/vxRvACgoX1+IvQU/W6ZWKF5aCHcoYmV
> Py4AoIYMBBxvtmCSkM1Vsy+46USwzumQ
> =pg4b
> -----END PGP SIGNATURE-----
> _______________________________________________
> precis mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/precis

-- 
Joe Hildebrand

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 11 Apr 2012 15:50:40 -0600

We could go all Perly and do FreeClass::resourcepart

;-)

On 4/11/12 2:33 PM, Joe Hildebrand wrote:
> That seems like a reasonable idea.  Is there a suggested naming
> pattern that denotes the superclass?  E.g. ResourceFreeClass,
> LocalpartNameClass
> 
> 
> While writing documents that subclass the base PRECIS classes,
> I've found myself naming the subclasses (e.g., rfc6122bis talks
> about the localpart subclass of the NameClass and the resourcepart
> subclass of the FreeClass). Is this something we want to encourage?
> If so, does it make sense to gather those names when people
> register new uses of PRECIS as requested in the framework
> document?
> 
> Peter
>

---

From: Dave Thaler <[email-masked]>
Date: Wed, 11 Apr 2012 21:59:45 +0000

I like Joe's suggestion.

-Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Joe Hildebrand
Sent: Wednesday, April 11, 2012 1:33 PM
To: Peter Saint-Andre; [email-masked]
Subject: Re: [precis] do subclasses need names?

That seems like a reasonable idea.  Is there a suggested naming pattern that denotes the superclass?  E.g. ResourceFreeClass, LocalpartNameClass

--
Joe Hildebrand

---

From: Tony Hansen <[email-masked]>
Date: Thu, 12 Apr 2012 14:33:19 -0400

Using namespace scoping seems reasonable. Just about any separator would 
suffice, as in "::" from C++ & Perl, "." from a variety of languages, 
":" from xml, etc.

     Tony Hansen

PS. I would have called it C++ namespacing.

On 4/11/2012 5:50 PM, Peter Saint-Andre wrote:
>> On 4/11/12 1:54 PM, "Peter Saint-Andre"<[email-masked]>
>> wrote:
>>