Subject: [PSAMP] configuration of hash function in PSAMP

From: "DUFFIELD, NICHOLAS G (NICK)" <[email-masked]>
Date: Thu, 20 Nov 2008 20:56:18 -0500

Benoit and I started a discussion on how hash function parameters are to be specified in the IPFIX/PSAMP configuration draft, which Juergen suggested we move to the mailing list.

-------

Benoit,

Thanks.

More generally, I think the mapping between SELECTOR_PARAMETERS items in PSAMP-tech, and the corresponding elements in the configuration model, should be unambiguously recorded in the standard.

Possible options: (i) uniformize the names across both drafts, or (ii) have comments in the configuration document that make it clear which item from psamp-tech is referred to.

Nick

> -----Original Message-----
> From: Benoit Claise [mailto:[email-masked]]
> Sent: Thursday, November 20, 2008 5:23 PM
> To: DUFFIELD, NICHOLAS G (NICK)
> Cc: 'Juergen Quittek'; Zseby, Tanja; Gerhard Muenz; Benoit Claise
> Subject: Re: configuration of hash function in PSAMP
>
> Nick,
>
> > Actually this may well be is OK as is: the initvalues for hash functions
> are specified in PSAMP-tech (32bit number when used), and the config draft
> appears include all the items needed to specify
> >
> > mask for hash input
> > (headerBits, payloadBytes, payloadBits)
> >
> > initvalues
> > Benoit: is this inputBits? Please confirm.
> >
> These inputBits come from "Input bits" in PSAMP-TECH.
> Please post this to the mailing list so that everybody is aware.
>
> Regards, Benoit.
> >
> > draft-ietf-ipfix-configuration-model-01.txt:
> > container filterHash {
> >           description "In PSAMP-MIB, function and funcParam are OIDs.";
> >           leaf addrType { type inet:ip-version; }
> >           leaf headerBits { type string; }
> >           leaf payloadBytes { type uint32; }
> >           leaf payloadBits { type string; }
> >           leaf function { type string; }
> >           leaf funcParam { type string; }
> >           leaf inputBits { type uint32; }
> >           leaf outputBits { type uint32; }
> >           leaf outputMask { type string; }
> >           leaf selection { type string; }
> >         }
> >
> > draft-ietf-psamp-sample-tech-11.txt:
> > Case Hashing:
> >        - Hash Domain (Input bits from packet)
> >             - <Header type = IPv4>
> >             - <Input bit specification, header part>
> >             - <Header type =  IPv6>
> >             - <Input bit specification, header part>
> >             - <payload byte number N>
> >             - <Input bit specification, payload part>
> >        - Hash Function
> >             - Hash function name
> >             - Length of input key (eliminate 0x bytes)
> >             - Output value (length M and bitmask)
> >             - Hash Selection Range, as a list of non overlapping
> >               intervals [start value, end value] where value is in
> >               [0,2^M-1]
> >             - Additional parameters dependent on specific Hash
> >               Function (e.g. hash input bits (seed))
> >
> >
> >

_______________________________________________
PSAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/psamp

---

From: Gerhard Muenz <[email-masked]>
Date: Fri, 21 Nov 2008 12:02:43 +0100

Hi,

Just to make this clear: The PSAMP parameters of the configuration model
are adopted from the PSAMP MIB document. The only difference is the
match filter, where the configuration model uses other parameter names
(ieId instead of fieldId) and allows ieName and enterpriseNumber as
well. Of course, ieName does not make sense the MIB. enterpriseNumber
could be added to the MIB as well.

So, I suggest that you discuss an update of PSAMP MIB. After that, the
changes can be adopted to the configuration draft accordingly.

Regards,
Gerhard

-- 
Dipl.-Ing. Gerhard Münz
Chair for Network Architectures and Services (I8)
Department of Informatics
Technische Universität München
Boltzmannstr. 3, 85748 Garching bei München, Germany
Phone:  +49 89 289-18008       Fax: +49 89 289-18033
E-mail: [email-masked]    WWW: http://www.net.in.tum.de/~muenz