Subject: Source ID -> Observation Domain Id?

From: Benoit Claise <[email-masked]>
Date: Thu, 23 Mar 2006 18:27:52 -0600

Dear all,

During his review, Bert was confused by the sourceId being the unique Id 
for the observation domain

    - [IPFIX-ARCH] sect 5.4 last line
      s/Source ID/Domain ID/ ??
      Or should the section title be somthing about "Source" ??
      I am getting a bit confused about DOmain and Source ID I guess?
      Protocol doc does indeed speak about SOurce ID.

I agree that this confusing, and should be changed. However, this must 
be changed in ALL IPFIX and PSAMP documents.
Information model: sourceId -> observationDomainId
Protocol: Source ID -> Observation Domain ID

Any objections before starting to change the documents?

Regards, Benoit.

---

From: Paul Aitken <[email-masked]>
Date: Fri, 24 Mar 2006 01:03:27 +0000

Benoit,

> Any objections before starting to change the documents?

No objection. I agree, because the definition is:

     sourceId                An identifier of an Observation Domain

So obviously it's "Observation Domain ID".

Unfortunately it requires a small change in several places.
-- 
Paul Aitken
Cisco Systems Ltd, Edinburgh, Scotland.

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/psamp/>

---

From: Brian Trammell <[email-masked]>
Date: Fri, 24 Mar 2006 01:46:40 -0600

Benoit,

Also agreed on this point - all other objects with identifiers have  
identifier names of the form <object-name>Id; it's worth changing  
this for consistency. Note this will also require a change to the  
name of the sourceId IE in the information model.

Regards,

Brian

---

From: Thomas Dietz <[email-masked]>
Date: Fri, 24 Mar 2006 09:39:12 +0100

Benoit,

I also agree. It makes things even clearer.

Regards, Thomas

Am Freitag, 24. März 2006 01:27 schrieb Benoit Claise:
> I agree that this confusing, and should be changed. However, this must be
> changed in ALL IPFIX and PSAMP documents. Information model: sourceId ->
> observationDomainId

---

From: Benoit Claise <[email-masked]>
Date: Thu, 30 Mar 2006 22:50:30 +0200

[re-posting to include the new psamp mailing list]

Regards, Benoit.
> Dear all,
>
> Considering also that we proposed to change the "Source ID" to "Observation Domain ID", we have to change the two definitions (Observation Domain and Source ID) in all the IPFIX and PSAMP drafts.
>
> Here is the old "Observation Domain" definition
>
>    An Observation Domain is the largest set of Observation Points for 
>    which Flow information can be aggregated by a Metering Process.  
>    Each Observation Domain presents itself using a unique ID to the 
>    Collecting Process to identify the IPFIX Messages it generates.  For 
>    example, a router line card may be an observation domain if it is 
>    composed of several interfaces, each of which is an Observation 
>    Point.  Every Observation Point is associated with an Observation 
>    Domain. 
> Here is the new "Observation Domain" proposal.
>
>       An Observation Domain is the largest set of Observation Points for
>       which Flow information can be aggregated by a Metering Process.
>       For example, a router line card may be an Observation Domain if it
>       is composed of several interfaces, each of which is an Observation
>       Point. In the IPFIX Message it generates, the Observation Domain
>       includes its Observation Domain ID, which is a unique per 
> Exporting Process.
>       That way, the Collecting Process can identify the specific 
> Observation
>       Domain from the Exporter that sends the IPFIX Messages. Every
>       Observation Point is associated with an Observation Domain.
>
> Here is the old "Source ID" definition
>    Source ID 
>            A 32-bit identifier of the Observation Domain that is 
>            locally unique to the Exporting Process.  The Exporting 
>            Process uses the Source ID to uniquely identify to the 
>            Collecting Process the Observation Domain that metered the 
>            Flows.  Collecting Processes SHOULD use the combination the 
>            combination of the Exporter (exporterIPv4Address, 
>            exporterIPv6Address, or exportingProcessId) and the Source 
>            ID field to separate different export streams originating 
>            from the same Exporting Process.  The Source ID SHOULD be 0 
>            when no specific Source ID is relevant for the entire IPFIX 
>            Message.  For example, when exporting the Exporting Process 
>            Statistics, or in case of hierarchy of Collector when 
>            aggregated data records are exported.  The Source ID MUST be 
>            zero when the IPFIX Message contains data records with 
>            different Source ID values defined as scopes. 
> Here is the new "Observation Domain ID" definition
>            A 32-bit identifier of the Observation Domain that is 
>            locally unique to the Exporting Process.  The Exporting 
>            Process uses the Observation Domain ID to uniquely identify to the 
>            Collecting Process the Observation Domain that metered the 
>            Flows.  Collecting Processes SHOULD use the combination the 
>            combination of the Exporter (exporterIPv4Address, 
>            exporterIPv6Address, or exportingProcessId) and the Observation
>            Domain ID field to separate different export streams originating 
>            from the same Exporting Process.  The Observation Domain ID SHOULD be 0 
>            when no specific Observation Domain ID is relevant for the entire IPFIX 
>            Message.  For example, when exporting the Exporting Process 
>            Statistics, or in case of hierarchy of Collector when 
>            aggregated data records are exported.  
>
> The last sentence of the definition, on which Bert had also a comment, has been removed from the definition:
>   
>
>     - sect 3.1 under SOurce ID
>     I do not understand the last sentence. WHat does it mean?
>     pls clarify in text.
>
> It's now part of the section "3.4.2.1 Scope". I agree that having this sentence was not too clear, as the readers don't know the notion of scope at this stage of the draft.
>  
>            The Source ID MUST be 
>            zero when the IPFIX Message contains data records with 
>            different Source ID values defined as scopes. 
>
> Feedback?
> Note: I will post the next version of the protocol draft by tomorrow, as agreed.
>
> Regards, Benoit.
>> Benoit,
>>

_______________________________________________
PSAMP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/psamp

---

From: Thomas Dietz <[email-masked]>
Date: Fri, 31 Mar 2006 09:43:36 +0200

Dear Benoit,

the text is fine. I just pointed at some wording issues inside.

Regards,

Thomas

Am Donnerstag, 30. März 2006 16:56 schrieb Benoit Claise:
> Dear all,
>
> Considering also that we proposed to change the "Source ID" to "Observation
> Domain ID", we have to change the two definitions (Observation Domain and
> Source ID) in all the IPFIX and PSAMP drafts.
>
                                                    ^^^ is unique per

>            Process uses the Observation Domain ID to uniquely identify to
> the Collecting Process the Observation Domain that metered the Flows. 
> Collecting Processes SHOULD use the combination the combination of the
                                  ^^^^^^^^^^^^^^^^ delete once   

> Exporter (exporterIPv4Address,
>            from the same Exporting Process.  The Observation Domain ID
> SHOULD be 0 when no specific Observation Domain ID is relevant for the
> entire IPFIX Message.  For example, when exporting the Exporting Process
> It's now part of the section "3.4.2.1 Scope". I agree that having this
> sentence was not too clear, as the readers don't know the notion of scope
> at this stage of the draft.
>
>            The Source ID MUST be

I guess you already changed "Source ID" to "Observation Domain ID" here...

> >> be changed in ALL IPFIX and PSAMP documents. Information model: sourceId
> >> -> observationDomainId

-- 
Thomas Dietz
Network Laboratories, NEC Europe Ltd., 69115 Heidelberg, Germany

---

From: Benoit Claise <[email-masked]>
Date: Fri, 31 Mar 2006 09:48:34 +0200

Thanks Thomas,

Corrected.

Regards, Benoit.