Subject: PROTO-19: The timestamp should be reported to microsecond resolution

From: Benoit Claise <[email-masked]>
Date: Fri, 03 Mar 2006 00:14:28 +0100

Dear all,

PROTO-19 "the timestamp of observation of the packet at the Observation
Point. The timestamp should be reported to microsecond resolution."
Nothing is mentioned in this draft regarding this issue.

The idea, to fulfill this requirement, is to add a microsecond precision 
timestamp in the "Basic Packet Report".
However, neither in [PSAMP-INFO] nor in [IPFIX-INFO] we do have absolute 
timestamps except ... that [IPFIX-INFO] specifies the following time 
stamps: flowStartSeconds, flowEndSeconds, flowStartMilliSeconds, 
flowEndMilliSeconds, flowStartMicroSeconds, flowEndMicroSeconds, 
flowStartNanoSeconds, flowEndNanoSeconds.

Considering that a PSAMP Packet Report is a flow composed of a single 
packet, can we reuse the flowStartMicroSeconds Information Element?
Or (if you are a purist), the "flow" prefix is confusing in a PSAMP 
implementation?
Please provide your feedback.

If the latter, then we must define a new Information Element for the 
microsecond precision. And, while doing that, we should define the other 
precision at the same time: second, millisecond, and nanosecond.

timeSeconds

  Description: The absolute time.
  Abstract Data Type: dateTimeSeconds
  ElementId: 
  Status: current
  Units: seconds

timeMilliSeconds

  Description: The absolute time.
  Abstract Data Type: dateTimeMilliSeconds
  ElementId: 
  Status: current
  Units: milliseconds

timeMicroSeconds

  Description: The absolute time.
  Abstract Data Type: dateTimeMicroSeconds
  ElementId: 
  Status: current
  Units: microseconds

timeNanoSeconds
  Description: The absolute time.
  Abstract Data Type: dateTimeNanoSeconds
  ElementId: 
  Status: current
  Units: nanoseconds

Regards, Benoit.

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/psamp/>

---

From: Paul Aitken <[email-masked]>
Date: Thu, 02 Mar 2006 23:22:11 +0000

Benoit,

> can we reuse the flowStartMicroSeconds Information Element?

 From the purist perspective, I would prefer to create the new timestamp 
elements you list. They're more appropriate than flowStart... and may be 
of use in other ways in future.

> microsecond precision. And, while doing that, we should define the 
> other precision at the same time: second, millisecond, and nanosecond.

Agreed.

-- 
Paul Aitken
Cisco Systems Ltd, Edinburgh, Scotland.

---

From: Juergen Quittek <[email-masked]>
Date: Fri, 03 Mar 2006 01:55:48 +0100

Paul and Benoit,

I see no problem with creating "flow-independent" time stamps.

However, I would also be fine with the other alternative
of using the flow start elements.

Thanks,

    Juergen

--On 3/2/06 11:22 PM +0000 Paul Aitken wrote:

>  From the purist perspective, I would prefer to create the new timestamp elements you list. They're more appropriate than flowStart... and may be of use in other ways in future.
>

---

From: Benoit Claise <[email-masked]>
Date: Fri, 03 Mar 2006 02:11:58 +0100

Juergen,
> I see no problem with creating "flow-independent" time stamps.
Done in [PSAMP-INFO] and used in [PSAMP-PROTO]

Regards, Benoit.
>>  From the purist perspective, I would prefer to create the new 
>> timestamp elements you list. They're more appropriate than 
>> flowStart... and may be of use in other ways in future.
>>