Subject: PROTO-108 statement that PSAMP-PROTO meets the PSAMP-FMWK requirements

From: Benoit Claise <[email-masked]>
Date: Fri, 03 Mar 2006 01:20:01 +0100

Dear all,

   PROTO-108 Have a statement that this protocol specification  
   meets all requirements for the PSAMP protocol stated in the framework  
   except ... An then have a list of bullets, where at minimum there is 
   stated "not yet covered" or a longer explanation why it is not 
   covered. This would be replacement for the long list of requirements 
   in section 6.1 

The section 6.1 was created as an intermediate step while producing the 
full PSAMP specifications.
Therefore, there is no point anymore to explain, next to each 
[PSAMP-FMWK] requirements, how IPFIX/PSAMP fulfills it... as all is 
specified in details in the other sections of the draft.

The section 6.1 should be removed and the following text proposal should 
be added at the end of section 6

    The PSAMP protocol specifications meets all the protocol
    requirements stated in the PSAMP framework document [PSAMP-FMWK]:
        * Extensibility
        * Parallel measurement processes
        * Encrypted packets 
        * Indication of information loss
        * Accuracy
        * Privacy
        * Timeliness
        * Congestion avoidance
        * Secure export:
        * Export rate limit
        * Microsecond timestamp resolution

    With the choice of IPFIX as PSAMP export protocol, the compression
    option mentioned in the framework document [PSAMP-FMWK] is not
    addressed.

If you object, please let me know.

Regards, Benoit.

---

From: Juergen Quittek <[email-masked]>
Date: Fri, 03 Mar 2006 04:59:33 +0100

--On 3/3/06 1:20 AM +0100 Benoit Claise wrote:

> The section 6.1 was created as an intermediate step while
> producing the full PSAMP specifications.
> Therefore, there is no point anymore to explain, next to
> each [PSAMP-FMWK] requirements, how IPFIX/PSAMP fulfills
> it... as all is specified in details in the other sections
> of the draft.
>
> The section 6.1 should be removed and the following text
 proposal should be added at the end of section 6
> With the choice of IPFIX as PSAMP export protocol, the
> compression option mentioned in the framework document
> [PSAMP-FMWK] is not addressed.

This is much better than the current text.
However, it sounds a bit strange to say "meets all"
in the first line and "not addressed".  What about
replacing in the first line "all" with "almost all"
and mentioning the exception in the last paragraph:

  "The only requirements that is not met is export packet
  compression. With the choice of IPFIX as PSAMP export protocol,
  the export packet compression option mentioned in the section
  8.5 of the framework document [PSAMP-FMWK] is not addressed."

> If you object, please let me know.

Thanks,

    Juergen

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/psamp/>

---

From: Benoit Claise <[email-masked]>
Date: Fri, 03 Mar 2006 10:18:12 +0100

Hi Juergen,

Good catch. Corrected.

Thanks and regards, Benoit.