Subject: [quicwg/base-drafts] Connection Migration section should talk about client and server, not endpoint and peer (#4125)

From: Marten Seemann <[email-masked]>
Date: Tue, 22 Sep 2020 01:38:46 -0700

We decided to only specify client-initiated connection migration in QUIC v1. The section about Connection Migration mostly talks about endpoint and peer though, which makes it really hard to parse. I haven't implement migration yet in quic-go, and reading this section confused me at multiple places.

I believe that specifying the role of the endpoint would make things a lot clearer, and could offer to come up with a PR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4125

---

From: Martin Thomson <[email-masked]>
Date: Tue, 22 Sep 2020 15:23:36 -0700

I don't think this is worth doing, but would look at a PR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4125#issuecomment-697013832

---

From: ianswett <[email-masked]>
Date: Tue, 22 Sep 2020 15:24:27 -0700

To clarify, this would only apply to connection migration, not the path validation section that immediately precedes it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4125#issuecomment-697014116

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 23 Sep 2020 18:45:48 -0700

@marten-seemann: The idea was to keep the migration mechanisms generic, since they _can_ be applied to either endpoint. However, this isn't adequate if we support migration at both ends, since you'd have to deal with other situations, such as simultaneous migration. v1 simply limits the scope of where these mechanisms ought to be applied.

There's value in that, but I understand your reservations. Like @martinthomson, I'm not keen to follow the premise of this issue, but I'd be open to a PR. I'd also be open to clarifying the parts you found confusing.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4125#issuecomment-698062563

---

From: ianswett <[email-masked]>
Date: Thu, 24 Sep 2020 15:26:59 -0700

Looking at that section again, I don't believe I want to do anything about this issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4125#issuecomment-698620368

---

From: Martin Thomson <[email-masked]>
Date: Thu, 24 Sep 2020 15:44:11 -0700

This choice was deliberate.  Maybe it's nicer, but now is not really a good time.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4125#issuecomment-698625802

---

From: Martin Thomson <[email-masked]>
Date: Thu, 24 Sep 2020 15:44:12 -0700

Closed #4125.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4125#event-3805345176