Subject: [quicwg/base-drafts] Access loss recovery state in congestion control pseudocode (#4174)

From: Martin Thomson <[email-masked]>
Date: Wed, 30 Sep 2020 03:33:46 -0700

Otherwise, the RTT estimate will be askew.

Closes #4172.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4174

-- Commit Summary --

  * Access loss recovery state in congestion control pseudocode

-- File Changes --

    M draft-ietf-quic-recovery.md (19)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4174.patch
https://github.com/quicwg/base-drafts/pull/4174.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4174

---

From: ianswett <[email-masked]>
Date: Wed, 30 Sep 2020 12:34:12 -0700

@ianswett approved this pull request.

One suggestion, but LG

> @@ -1269,6 +1269,9 @@ sent_packets\[kPacketNumberSpace]:
 : An association of packet numbers in a packet number space to information
   about them.  Described in detail above in {{tracking-sent-packets}}.
 
+first_rtt_sample:

I'd suggest putting this below min_rtt in the list of variables.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4174#pullrequestreview-499640023

---

From: Martin Thomson <[email-masked]>
Date: Wed, 30 Sep 2020 17:01:39 -0700

@martinthomson pushed 1 commit.

530f5fac4c5782d85398451bdebba5fd0a9fe7d7  Reorder variable descriptions

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4174/files/054991156e82aeea5ef6b72a0ef4937c03cc4ed0..530f5fac4c5782d85398451bdebba5fd0a9fe7d7

---

From: ianswett <[email-masked]>
Date: Wed, 30 Sep 2020 17:22:03 -0700

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4174#pullrequestreview-499937888

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 30 Sep 2020 22:59:44 -0700

@janaiyengar approved this pull request.

Thanks for catching this -- this is shared state in all implementations, and it makes sense to write the pseudo code this way.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4174#pullrequestreview-500027814

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 30 Sep 2020 23:00:07 -0700

Merged #4174 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4174#event-3827643177