Subject: [quicwg/base-drafts] it might not be possible to set the DF bit on all systems (#4130)

From: Marten Seemann <[email-masked]>
Date: Tue, 22 Sep 2020 02:00:59 -0700

> The QUIC packet size includes the QUIC header and protected payload, but not the UDP or IP headers

For example, OSX doesn't have an API to set this bit (allegedly this will change with Big Sur).
Furthermore, not all implementations might have access to an API that allows them to set bits in the IP header. If I remember correctly, this is one of the reasons we made ECN optional.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4130

---

From: Lars Eggert <[email-masked]>
Date: Tue, 22 Sep 2020 03:42:15 -0700

I think you wanted to quote this part
> UDP datagrams MUST NOT be fragmented at the IP layer.  In IPv4
({{!IPv4=RFC0791}}), the DF bit MUST be set to prevent fragmentation on the
path.

Would a proposal be to make the MUST a SHOULD and say "unless this is not supported by the underlying OS"?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4130#issuecomment-696642638

---

From: Marten Seemann <[email-masked]>
Date: Tue, 22 Sep 2020 06:54:40 -0700

Yes, that was a weird copy-paste error.
If we say "unless this is not supported by the underlying OS or the programming language" we can probably even keep the MUST.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4130#issuecomment-696737485

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 23 Sep 2020 20:02:22 +0000 (UTC)

This is an editorial issue, since the intent of the MUST cannot be to require something that isn't possible.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4130#issuecomment-697941838

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 23 Sep 2020 16:53:26 -0700

Closed #4130 via #4140.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4130#event-3800800647