Subject: [quicwg/base-drafts] add an introduction for testing of ECN support (#4141)

From: Marten Seemann <[email-masked]>
Date: Wed, 23 Sep 2020 01:09:16 -0700

Fixes #4109.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4141

-- Commit Summary --

  * add an introduction for testing of ECN support

-- File Changes --

    M draft-ietf-quic-transport.md (7)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4141.patch
https://github.com/quicwg/base-drafts/pull/4141.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4141

---

From: Martin Thomson <[email-masked]>
Date: Wed, 23 Sep 2020 02:43:33 -0700

@martinthomson commented on this pull request.

WFM

> @@ -1463,9 +1463,10 @@ properties:
 * authenticated negotiation of an application protocol (TLS uses ALPN
   {{?ALPN}} for this purpose)
 
-An endpoint verifies support for Explicit Congestion Notification (ECN) by
-observing whether the ACK frames acknowledging the first packets it sends carry
-ECN counts, as described in {{ecn-validation}}.
+Endpoints can use packets sent during the handshake to test for Explicit
+Congestion Notification (ECN) ({{ecn}}) support. An endpoint verifies support

```suggestion
Congestion Notification (ECN) support; see {{ecn}}. An endpoint verifies support
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4141#pullrequestreview-494482621

---

From: Marten Seemann <[email-masked]>
Date: Wed, 23 Sep 2020 02:51:50 -0700

@marten-seemann pushed 1 commit.

5e30c61d7382e875c4160dc20bb4d6599cc65ce4  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4141/files/a51fa1013fa560e0451edb135686dbfafcad68de..5e30c61d7382e875c4160dc20bb4d6599cc65ce4

---

From: ianswett <[email-masked]>
Date: Wed, 23 Sep 2020 06:49:08 -0700

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4141#pullrequestreview-494679972

---

From: ianswett <[email-masked]>
Date: Wed, 23 Sep 2020 06:49:33 -0700

Yeah, this is better.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4141#issuecomment-697382996

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 23 Sep 2020 13:20:37 -0700

@janaiyengar approved this pull request.

This is good, thanks!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4141#pullrequestreview-495017405

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 23 Sep 2020 13:20:50 -0700

Merged #4141 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4141#event-3800001019