Subject: [quicwg/base-drafts] A few of gorry's nits (#4085)

From: ianswett <[email-masked]>
Date: Wed, 09 Sep 2020 18:24:39 -0700

Fixes #3992
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4085

-- Commit Summary --

  * A few of gorry&#39;s nits

-- File Changes --

    M draft-ietf-quic-recovery.md (22)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4085.patch
https://github.com/quicwg/base-drafts/pull/4085.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4085

---

From: Martin Thomson <[email-masked]>
Date: Wed, 09 Sep 2020 19:14:07 -0700

@martinthomson approved this pull request.

Some suggestions only.

> +The time length of a connection that is experiencing consecutive PTOs is
+limited by the endpoint's idle timeout.

```suggestion
The total length of time over which consecutive probes are sent is limited by the idle timeout.
```
?

> @@ -480,11 +480,11 @@ implementations SHOULD NOT use a packet threshold less than 3; see {{?RFC5681}}.
 
 Some networks may exhibit higher degrees of packet reordering, causing a sender
 to detect spurious losses. Additionally, packet reordering could be more common
-with QUIC than TCP, because network elements that could observe and fix the
-order of reordered TCP packets cannot do that for QUIC. Algorithms that increase
-the reordering threshold after spuriously detecting losses, such as RACK
-{{?RACK}}, have proven to be useful in TCP and are expected to at least as
-useful in QUIC.
+with QUIC than TCP, because network elements that could observe and reorder
+out-of-order TCP packets cannot do that for QUIC, because packet numbers

```suggestion
TCP packets cannot do that for QUIC, because packet numbers
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4085#pullrequestreview-485518176

---

From: ianswett <[email-masked]>
Date: Thu, 10 Sep 2020 09:27:59 -0700

@ianswett pushed 1 commit.

0cbd1c09aaec823eaa7c4c7d65d2e698e78f54f7  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4085/files/fecde82497dd504b6868e0fd4ee45c14d841bac1..0cbd1c09aaec823eaa7c4c7d65d2e698e78f54f7

---

From: ianswett <[email-masked]>
Date: Thu, 10 Sep 2020 09:29:02 -0700

@ianswett commented on this pull request.

Sure, works for me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4085#discussion_r486477256

---

From: ianswett <[email-masked]>
Date: Thu, 10 Sep 2020 09:29:06 -0700

0b3c4ec4268c5fa750aa1e126e6a06b35b29ee07  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4085/files/0cbd1c09aaec823eaa7c4c7d65d2e698e78f54f7..0b3c4ec4268c5fa750aa1e126e6a06b35b29ee07

---

From: ianswett <[email-masked]>
Date: Thu, 10 Sep 2020 16:30:00 +0000 (UTC)

5ca2491cdd2b7ee2e365f24513c210ad4b908a87  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4085/files/0b3c4ec4268c5fa750aa1e126e6a06b35b29ee07..5ca2491cdd2b7ee2e365f24513c210ad4b908a87

---

From: ianswett <[email-masked]>
Date: Thu, 10 Sep 2020 09:30:51 -0700

I'm honestly not sure we need this sentence, but I suspect it was added because someone asked for it?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4085#discussion_r486478349

---

From: ianswett <[email-masked]>
Date: Thu, 10 Sep 2020 09:36:37 -0700

65f1ae510fd51f346aa4e0033294ca4c56f14a96  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4085/files/5ca2491cdd2b7ee2e365f24513c210ad4b908a87..65f1ae510fd51f346aa4e0033294ca4c56f14a96

---

From: ianswett <[email-masked]>
Date: Thu, 10 Sep 2020 09:37:09 -0700

f0a0ea28fe700df0fc6058a28e1e2df2ab9d6fbb  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4085/files/65f1ae510fd51f346aa4e0033294ca4c56f14a96..f0a0ea28fe700df0fc6058a28e1e2df2ab9d6fbb

---

From: ianswett <[email-masked]>
Date: Thu, 10 Sep 2020 09:38:15 -0700

3f64dfa6db3f7f3b9d885245cdea18c26db8b782  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4085/files/f0a0ea28fe700df0fc6058a28e1e2df2ab9d6fbb..3f64dfa6db3f7f3b9d885245cdea18c26db8b782

---

From: ianswett <[email-masked]>
Date: Thu, 10 Sep 2020 09:41:31 -0700

554e89277cbd83f9e8991e94a87b236b02ae75e6  Reference coalesced packets in transport

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4085/files/3f64dfa6db3f7f3b9d885245cdea18c26db8b782..554e89277cbd83f9e8991e94a87b236b02ae75e6

---

From: ianswett <[email-masked]>
Date: Thu, 10 Sep 2020 11:20:38 -0700

cf7563aa6bf66f06989c2c7fc50d1530f51649e8  Merge branch 'master' into ianswett-gorry

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4085/files/554e89277cbd83f9e8991e94a87b236b02ae75e6..cf7563aa6bf66f06989c2c7fc50d1530f51649e8

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 10 Sep 2020 12:34:32 -0700

@janaiyengar approved this pull request.

One nit, but LGTM.

> @@ -601,8 +601,8 @@ occurs across all spaces to prevent excess load on the network.  For example,
 a timeout in the Initial packet number space doubles the length of the timeout
 in the Handshake packet number space.
 
-The time length of a connection that is experiencing consecutive PTOs is
-limited by the endpoint's idle timeout.
+The total length of time over which consecutive PTOs expire are limited by the

```suggestion
The total length of time over which consecutive PTOs expire is limited by the
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4085#pullrequestreview-486249569

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 10 Sep 2020 12:34:50 -0700

@janaiyengar pushed 1 commit.

a0fc574f860668648c9cf9216a71d82fb9097852  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4085/files/cf7563aa6bf66f06989c2c7fc50d1530f51649e8..a0fc574f860668648c9cf9216a71d82fb9097852

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 10 Sep 2020 12:42:25 -0700

Merged #4085 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4085#event-3752831986