Subject: [quicwg/base-drafts] Where is padding explained? (#4145)

From: Gorry Fairhurst <[email-masked]>
Date: Wed, 23 Sep 2020 08:38:32 -0700

* I have a long comment on a scattered observation that could be very simple to fix: In section 6, it wasn’t clear what were the ways that "padding" could be performed. There could be various ways - simply leave UDP payload unused, fill it with coalesced QUIC packets, add padding and other frames, etc and when the text says this I think it’s unclear to me what is expected - any or all of these, but it doesn't seem to be said.
e.g.:
/Clients that support multiple QUIC versions SHOULD pad the first UDP datagram they send to the largest of the minimum datagram sizes from all versions they support. /
- Is the assumption here, more like:
/Clients that support multiple QUIC versions SHOULD coalesce QUIC packets or add PADDING frames to pad the first UDP datagram they send to the largest of the minimum datagram sizes from all versions they
support. /
… rather than some other technique to pad-out the datagram payload?
See also:
/Clients MUST ensure that UDP datagrams containing Initial packets have UDP payloads of at least 1200 bytes, adding padding to packets in the datagram as necessary.  A client that sends padded datagrams allows the server to send more data prior to completing address validation./
and later:
/In particular, an endpoint can pad a packet carrying a PATH_CHALLENGE for Path Maximum Transfer Unit (PMTU) discovery /
- So, I think the topic of padding needs a tiny bit more clarification - it’s almost there, but maybe a sentence that explicitly explains the permitted options in section 14 would be good, which could be cited rather than this scattered mention of “pad-out”

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4145

---

From: David Schinazi <[email-masked]>
Date: Wed, 23 Sep 2020 08:46:47 -0700

Perhaps these mentions of the word "padding" just need to reference section 19.1. "PADDING Frames" ?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4145#issuecomment-697573357

---

From: Gorry Fairhurst <[email-masked]>
Date: Wed, 23 Sep 2020 09:03:24 -0700

If that is all that is intended, we should say so.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4145#issuecomment-697601545

---

From: ianswett <[email-masked]>
Date: Wed, 23 Sep 2020 16:08:10 +0000 (UTC)

Agreed, I think the right phrasing is PADDING Frames, though I don't think we need to reference 19.1 in every spot we talk about PADDING frames.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4145#issuecomment-697609718

---

From: Gorry Fairhurst <[email-masked]>
Date: Wed, 23 Sep 2020 09:13:16 -0700

So could we grep for Padding and ensure we say /PADDING Frame/? - I guess the REF first time used would be good - if not already there?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4145#issuecomment-697618451

---

From: Gorry Fairhurst <[email-masked]>
Date: Wed, 23 Sep 2020 09:26:50 -0700

How about something like: PR #4148 ?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4145#issuecomment-697642043

---

From: Martin Thomson <[email-masked]>
Date: Wed, 23 Sep 2020 22:13:33 -0700

Closing now that we have #4148.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4145#issuecomment-698116535

---

From: Martin Thomson <[email-masked]>
Date: Wed, 23 Sep 2020 22:13:34 -0700

Closed #4145.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4145#event-3801398064