Subject: Re: [quicwg/base-drafts] Move/duplicate no server migration text (#4063)

From: ekr <[email-masked]>
Date: Tue, 01 Sep 2020 11:25:55 -0700

It's not awesome because it basically contradicts the generic text in 9.3.
But maybe we're past the point of diminishing returns

On Mon, Aug 31, 2020 at 10:45 PM Martin Thomson <[email-masked]>
wrote:

> Is this enough?
>
> This document limits migration of connections to new client addresses,
> except as described in Section 9.6.
>
> This appears in the top of Section 9
> <https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#section-9-6>
> (that's paragraph 6, not sub-section 6 in case you look at the URL).
>
> —
> You are receiving this because you authored the thread.
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/4063#issuecomment-684361776>,
> or unsubscribe
> <https://github.com/notifications/unsubscribe-auth/AAIPLILPEYN5MKC3J7TADWDSDSC6RANCNFSM4QQWMEVA>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4063#issuecomment-685053005

---

From: Mike Bishop <[email-masked]>
Date: Wed, 02 Sep 2020 12:21:03 -0700

The intent was to keep the path validation mechanisms generic so that an extension could potentially introduce server migration later.  It's stated in 9.6 and the top of 9; before and after the generic part seems sufficient to me.  That said, I think the server migration extension would still require that the client be the one to actually make the change.  Only clients should ever spontaneously send from a new address.  (P2P scenarios notwithstanding....)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4063#issuecomment-685945667

---

From: Lars Eggert <[email-masked]>
Date: Mon, 21 Sep 2020 04:54:18 -0700

@ekr do I read your last comment as you being OK with closing this with no action?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4063#issuecomment-696065817

---

From: ekr <[email-masked]>
Date: Mon, 21 Sep 2020 05:48:27 -0700

To be honest, I still think this could use some work, but I'm willing to let it drop.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4063#issuecomment-696091374

---

From: Lars Eggert <[email-masked]>
Date: Mon, 21 Sep 2020 05:50:49 -0700

Thanks. Let's see if someone has energy/interest to do a PR during the next few days.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4063#issuecomment-696092610

---

From: Martin Thomson <[email-masked]>
Date: Thu, 24 Sep 2020 01:02:52 +0000 (UTC)

Closed #4063 via #4142.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4063#event-3800933936