Subject: [quicwg/base-drafts] multiple editorial nits in Section 5 (Connection ID) (#4110)

From: Marten Seemann <[email-masked]>
Date: Mon, 21 Sep 2020 07:25:27 -0700

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4110

-- Commit Summary --

  * improve wording on accepting and rejecting Early Data
  * avoid repition regarding stream number limits
  * clarify that changes before an error actually must be reverted
  * clarify that the server must use the same version as the client

-- File Changes --

    M draft-ietf-quic-transport.md (13)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4110.patch
https://github.com/quicwg/base-drafts/pull/4110.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4110

---

From: Martin Thomson <[email-masked]>
Date: Mon, 21 Sep 2020 18:50:35 -0700

@martinthomson approved this pull request.

One nit, but this is good.

> @@ -1238,8 +1237,8 @@ connection that are encrypted with a key it has not yet computed. The client MAY
 drop these packets, or MAY buffer them in anticipation of later packets that
 allow it to compute the key.
 
-If a client receives a packet that has an unsupported version, it MUST discard
-that packet.
+If a client receives a packet that uses a different version that it initially

```suggestion
If a client receives a packet that uses a different version than it initially
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4110#pullrequestreview-493084446

---

From: Marten Seemann <[email-masked]>
Date: Mon, 21 Sep 2020 19:37:10 -0700

@marten-seemann pushed 1 commit.

612073d33b93a1f01f3f9c6bd349037934aaeecf  fix typo

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4110/files/5e1228002ed4ec4246b9d32ce2033648f3d28271..612073d33b93a1f01f3f9c6bd349037934aaeecf

---

From: Martin Thomson <[email-masked]>
Date: Tue, 22 Sep 2020 15:06:09 -0700

Merged #4110 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4110#event-3795367232