Subject: [quicwg/base-drafts] "With Literal Name" instead of "Without Name Reference" (#4163)

From: Martin Thomson <[email-masked]>
Date: Thu, 24 Sep 2020 00:17:22 -0700

This saves bytes (that&#39;s the most important reason).

This uses something positive rather than something negative to define
the instruction.

Yes, it means that there are two &quot;Literal&quot;s in the name of an
instruction.  But now it says what is inside rather than what isn&#39;t.

Closes #4137.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4163

-- Commit Summary --

  * &quot;With Literal Name&quot; instead of &quot;Without Name Reference&quot;

-- File Changes --

    M draft-ietf-quic-qpack.md (8)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4163.patch
https://github.com/quicwg/base-drafts/pull/4163.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4163

---

From: Mike Bishop <[email-masked]>
Date: Thu, 24 Sep 2020 07:42:02 -0700

@MikeBishop approved this pull request.

Also consider changing on line 1640.

> @@ -1122,7 +1122,7 @@ Only the field name is taken from the dynamic table entry; the field value is
 encoded as an 8-bit prefix string literal; see {{string-literals}}.

-### Literal Field Line Without Name Reference
+### Literal Field Line With Literal Name
 
 The literal field line without name reference representation encodes a

```suggestion
The literal field line with literal name representation encodes a
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4163#pullrequestreview-495646377

---

From: ianswett <[email-masked]>
Date: Thu, 24 Sep 2020 09:09:54 -0700

@ianswett approved this pull request.

Seems like a sensible change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4163#pullrequestreview-495732641

---

From: Bence Béky <[email-masked]>
Date: Thu, 24 Sep 2020 10:05:16 -0700

@bencebeky approved this pull request.

I think this is an improvement.

It has always bothered me that "literal field line" is used in sitations when only part of the field line is literal, and this change does not address that.  An alternative would be:
insert with literal name => insert literal field line (or literal entry)
literal field line with name reference => field line with name reference and literal value
literal field line with literal name => literal field line

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4163#pullrequestreview-495777594

---

From: Martin Thomson <[email-masked]>
Date: Thu, 24 Sep 2020 14:31:51 -0700

@martinthomson pushed 1 commit.

9f3be4132db5b3a0cc14ea03825dfe04a19e8bcd  missed one

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4163/files/58fdbce7406b57f93cb7e1e1ed4bd9232ad1bf35..9f3be4132db5b3a0cc14ea03825dfe04a19e8bcd

---

From: Martin Thomson <[email-masked]>
Date: Thu, 24 Sep 2020 14:33:13 -0700

@bencebeky I can't solve all the problems :)  I think that in HPACK "literal" was reserved for the value more than the name.  Maybe this only highlights that...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4163#issuecomment-698599798

---

From: afrind <[email-masked]>
Date: Thu, 24 Sep 2020 14:58:00 -0700

@afrind pushed 1 commit.

7df623d0d559897541cbb274d761a7a890c1a03b  Update draft-ietf-quic-qpack.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4163/files/9f3be4132db5b3a0cc14ea03825dfe04a19e8bcd..7df623d0d559897541cbb274d761a7a890c1a03b

---

From: afrind <[email-masked]>
Date: Thu, 24 Sep 2020 15:07:21 -0700

Merged #4163 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4163#event-3805260451

---

From: Bence Béky <[email-masked]>
Date: Fri, 25 Sep 2020 10:41:00 -0700

> @bencebeky I can't solve all the problems :) I think that in HPACK "literal" was reserved for the value more than the name. Maybe this only highlights that...

I understand.  This commit at least solves some of them, thank you for the improvement!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4163#issuecomment-699061700

---

From: Dmitri Tikhonov <[email-masked]>
Date: Fri, 25 Sep 2020 20:18:14 -0700

Beauty is in the eye of the beholder.  What am I to do with all the "wonr" variable names?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4163#issuecomment-699289400