Subject: [quicwg/base-drafts] Is NOT appropriate (#4120)

From: Lars Eggert <[email-masked]>
Date: Tue, 22 Sep 2020 00:36:32 -0700

Issue raised by @gorryfair via [email](https://mailarchive.ietf.org/arch/msg/quic/nUyowuoahrCG1JgVt_APRgaw8ug):

> (iii) I see the desire to emphasise the “NOT”, but I query if this is correct usage of a RFC2119 keyword in Appendix A?:
/The following statements are NOT guaranteed to be true for every QUIC
   version:/

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4120

---

From: Martin Thomson <[email-masked]>
Date: Tue, 22 Sep 2020 00:42:56 -0700

It's NOT a 2119 keyword, just emphasis.  To be pedantic, 2119 doesn't reserve the use of all uppercase phrases.

I believe the emphasis to be especially important given that many of these statements are in fact true for QUIC v1.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4120#issuecomment-696561398

---

From: Gorry Fairhurst <[email-masked]>
Date: Tue, 22 Sep 2020 02:03:52 -0700

That said - I'll let RFC-Ed agree/disagree on best style - this text a really important note, and simply writing NOT in capital letters maybe isn't the best way to call out this? 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4120#issuecomment-696598236

---

From: Lars Eggert <[email-masked]>
Date: Tue, 22 Sep 2020 02:45:11 -0700

Maybe SHOUT it? "ANY OF THE FOLLOWING STATEMENTS CAN CHANGE FROM VERSION TO VERSION:"

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4120#issuecomment-696617477

---

From: Lars Eggert <[email-masked]>
Date: Wed, 23 Sep 2020 00:57:22 -0700

I added a PR that tries to address this by rephrasing and highlighting stylistically. Not sure if this is better. I would actually suggest to just close with no action.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4120#issuecomment-697200109

---

From: Gorry Fairhurst <[email-masked]>
Date: Wed, 23 Sep 2020 01:08:54 -0700

This is just editorial. Please consider my comment, and then just decide what is best.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4120#issuecomment-697205806

---

From: Martin Thomson <[email-masked]>
Date: Wed, 23 Sep 2020 02:39:20 -0700

Closed #4120 via #4139.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4120#event-3797194601