Subject: [quicwg/base-drafts] Add draft shepherd writeup for base-drafts (#4107)

From: Lars Eggert <[email-masked]>
Date: Mon, 21 Sep 2020 04:17:00 -0700

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4107

-- Commit Summary --

  * Add draft shepherd writeup for base-drafts

-- File Changes --

    A writeups/base-drafts.md (312)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4107.patch
https://github.com/quicwg/base-drafts/pull/4107.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4107

---

From: Lars Eggert <[email-masked]>
Date: Mon, 21 Sep 2020 09:41:49 -0700

@larseggert pushed 1 commit.

9dfc7c33ff3f771da26519b810a361f73f0edf86  Language & other fixes

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4107/files/94ab76cab9915e78c04f705bbddd10b128dd57ba..9dfc7c33ff3f771da26519b810a361f73f0edf86

---

From: Martin Thomson <[email-masked]>
Date: Mon, 21 Sep 2020 19:09:42 -0700

@martinthomson approved this pull request.

SHIP IT!

I trust that the other shepherds will review this before it is sent.  Merge it before then as you like.

Do you want to tweak CODEOWNERS?

> +-->
+
+All references within this document set have been identified as either normative
+or informative.
+
+
+## 14. Normative References
+<!--
+(14) Are there normative references to documents that are not ready for
+advancement or are otherwise in an unclear state? If such normative references
+exist, what is the plan for their completion?
+-->
+
+The document set contains the following normative references to I-Ds:
+
+* draft-ietf-tsvwg-datagram-plpmtud

This was published as RFC 8899.  We should fix the reference.

> +-->
+
+The document set defines several IANA registries that offer “Provisional
+Registrations” and require Expert review. The IESG should select subject matter
+experts for these registration types; candidates include the document editors
+and the individuals named as contributors in the acknowledgment sections.
+
+
+## 19. Validation of Formal Language Parts
+<!--
+(19) Describe reviews and automated checks performed by the Document Shepherd to
+validate sections of the document written in a formal language, such as XML
+code, BNF rules, MIB definitions, YANG modules, etc.
+-->
+
+No formal code exists in the document set. draft-ietf-quic-recovery contains

transport and qpack both include pseudocode in appendices.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4107#pullrequestreview-493088322

---

From: Lars Eggert <[email-masked]>
Date: Mon, 21 Sep 2020 23:19:22 -0700

9495bb8b45b50d16232859d406f582eb11d79e2a  Address @martinthomson's suggestions

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4107/files/9dfc7c33ff3f771da26519b810a361f73f0edf86..9495bb8b45b50d16232859d406f582eb11d79e2a

---

From: Lars Eggert <[email-masked]>
Date: Mon, 21 Sep 2020 23:19:54 -0700

@martinthomson what should I tweak in CODEOWNERS?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4107#issuecomment-696530476

---

From: Martin Thomson <[email-masked]>
Date: Mon, 21 Sep 2020 23:36:10 -0700

Oh, I see that you already list chairs as owning everything...  No action required (I would not have included that).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4107#issuecomment-696536449

---

From: Lars Eggert <[email-masked]>
Date: Mon, 21 Sep 2020 23:48:34 -0700

d53345c00cfd817865086a1405cc06764ab339e3  Assign docs to shepherds

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4107/files/9495bb8b45b50d16232859d406f582eb11d79e2a..d53345c00cfd817865086a1405cc06764ab339e3

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 22 Sep 2020 18:58:39 +0000 (UTC)

@LPardue commented on this pull request.

```suggestion
The document set defines several IANA registries that offer “Provisional
Registrations” and "Permanent Registration, which both require Expert review.
The IESG should select subject matter experts for these registration types;
candidates include the document editors and the individuals named as
contributors in the acknowledgment sections.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4107#pullrequestreview-493758776

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 22 Sep 2020 11:58:53 -0700

@LPardue approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4107#pullrequestreview-493759006

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 22 Sep 2020 14:51:12 -0700

@janaiyengar approved this pull request.

W00t!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4107#pullrequestreview-493872159

---

From: Mike Bishop <[email-masked]>
Date: Tue, 22 Sep 2020 15:30:57 -0700

@MikeBishop commented on this pull request.

```suggestion
The document set defines several IANA registries that offer "Provisional
Registrations" and require Expert review. The IESG should select subject matter
```
I question the use of smart quotes.  Same in @LPardue's suggestion.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4107#pullrequestreview-493890663

---

From: Lars Eggert <[email-masked]>
Date: Wed, 23 Sep 2020 00:45:14 -0700

44e4a62bc29e2161dd2d58519baf7624589ba147  More IANA

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4107/files/d53345c00cfd817865086a1405cc06764ab339e3..44e4a62bc29e2161dd2d58519baf7624589ba147

---

From: Lars Eggert <[email-masked]>
Date: Wed, 23 Sep 2020 00:45:36 -0700

@larseggert commented on this pull request.

Will fix.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4107#discussion_r493267381

---

From: Lars Eggert <[email-masked]>
Date: Wed, 23 Sep 2020 00:47:05 -0700

f4acf6c55692c019ceea71f379767fcb65c8225d  Fix quotes (and nits)

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4107/files/44e4a62bc29e2161dd2d58519baf7624589ba147..f4acf6c55692c019ceea71f379767fcb65c8225d

---

From: Lars Eggert <[email-masked]>
Date: Wed, 23 Sep 2020 01:47:27 -0700

Merged #4107 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4107#event-3796973659

---

From: Lars Eggert <[email-masked]>
Date: Wed, 23 Sep 2020 01:47:56 -0700

I'm merging this now. We can continue to word-smith on the merged version, if needed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4107#issuecomment-697225774