Subject: [quicwg/base-drafts] TLS: improve check for unconsumed data on encryption level changes (#4155)

From: Marten Seemann <[email-masked]>
Date: Wed, 23 Sep 2020 22:43:44 -0700

This check really is triggered by TLS providing new keys, not QUIC delivering data on a higher encryption level.

Otherwise, in the case where no session ticket is sent, this condition would go undetected for unconsumed data at the Handshake encryption level.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4155

-- Commit Summary --

  * improve check for unconsumed data on encryption level changes

-- File Changes --

    M draft-ietf-quic-tls.md (7)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4155.patch
https://github.com/quicwg/base-drafts/pull/4155.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4155

---

From: Marten Seemann <[email-masked]>
Date: Wed, 23 Sep 2020 22:49:41 -0700

@marten-seemann pushed 1 commit.

f2c78136a255ade805f564b81d634f98e10682e9  improve check for unconsumed data on encryption level changes

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4155/files/f9c67e6241a9cc87d20d417c79fcbd84ef04bdd9..f2c78136a255ade805f564b81d634f98e10682e9

---

From: Martin Thomson <[email-masked]>
Date: Wed, 23 Sep 2020 23:11:12 -0700

Merged #4155 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4155#event-3801534980