Subject: [quicwg/base-drafts] Why do we talk about ECN validation in the chapter "Cryptographic and Transport Handshake"? (#4109)

From: Marten Seemann <[email-masked]>
Date: Mon, 21 Sep 2020 07:18:12 -0700

The sentence
> An endpoint verifies support for Explicit Congestion Notification (ECN) by
observing whether the ACK frames acknowledging the first packets it sends carry
ECN counts, as described in {{ecn-validation}}.

seems to not belong into that section.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4109

---

From: ianswett <[email-masked]>
Date: Tue, 22 Sep 2020 15:50:06 -0700

Assuming one enables ECN on Initial and Handshake packets in order to perform ECN validation, then I think it's the right place?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4109#issuecomment-697022969

---

From: Lars Eggert <[email-masked]>
Date: Wed, 23 Sep 2020 00:43:24 -0700

@marten-seemann are you OK with @ianswett's explanation, i.e., can we close with no action?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4109#issuecomment-697193477

---

From: Marten Seemann <[email-masked]>
Date: Wed, 23 Sep 2020 00:57:13 -0700

Not really happy with it, tbh. The sentence feels completely out of place as it stands now. I think we should either move it to the ECN section (I think that would make the most sense), or at least add an introductory sentence, along these lines:
> Endpoints can use packets sent during the handshake to test for ECN ({{ref:ecn}}) support.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4109#issuecomment-697200016

---

From: Lars Eggert <[email-masked]>
Date: Wed, 23 Sep 2020 01:03:22 -0700

I like the introductory sentence.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4109#issuecomment-697203137

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 23 Sep 2020 13:20:50 -0700

Closed #4109 via #4141.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4109#event-3800001036