Subject: [quicwg/base-drafts] Hexadecimal capitalization (#4070)

From: Mike Bishop <[email-masked]>
Date: Wed, 02 Sep 2020 06:29:40 -0700

#3949 found a few places where HTTP was inconsistent about using upper-case versus lower-case letters for hex numbers.  Turns out there were lots more, primarily in HTTP but also a few in transport and TLS.

This normalizes all of them to lower-case.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4070

-- Commit Summary --

  * HTTP hex to lower-case
  * TLS hex to lower-case
  * Transport hex to lower-case

-- File Changes --

    M draft-ietf-quic-http.md (36)
    M draft-ietf-quic-tls.md (4)
    M draft-ietf-quic-transport.md (4)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4070.patch
https://github.com/quicwg/base-drafts/pull/4070.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4070

---

From: Lars Eggert <[email-masked]>
Date: Wed, 02 Sep 2020 06:31:12 -0700

@larseggert approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4070#pullrequestreview-480820945

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 02 Sep 2020 06:34:25 -0700

@LPardue approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4070#pullrequestreview-480824019

---

From: Martin Thomson <[email-masked]>
Date: Fri, 04 Sep 2020 04:48:30 -0700

@martinthomson approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4070#pullrequestreview-482585472

---

From: Mike Bishop <[email-masked]>
Date: Fri, 04 Sep 2020 08:47:46 -0700

@MikeBishop commented on this pull request.

> @@ -2124,18 +2124,18 @@ The entries in {{iana-error-table}} are registered by this document.
 | H3_EXCESSIVE_LOAD                 | 0x0107     | Peer generating excessive load           | {{http-error-codes}}   |
 | H3_ID_ERROR                       | 0x0108     | An identifier was used incorrectly       | {{http-error-codes}}   |
 | H3_SETTINGS_ERROR                 | 0x0109     | SETTINGS frame contained invalid values  | {{http-error-codes}}   |
-| H3_MISSING_SETTINGS               | 0x010A     | No SETTINGS frame received               | {{http-error-codes}}   |
-| H3_REQUEST_REJECTED               | 0x010B     | Request not processed                    | {{http-error-codes}}   |
-| H3_REQUEST_CANCELLED              | 0x010C     | Data no longer needed                    | {{http-error-codes}}   |
-| H3_REQUEST_INCOMPLETE             | 0x010D     | Stream terminated early                  | {{http-error-codes}}   |
-| H3_CONNECT_ERROR                  | 0x010F     | TCP reset or error on CONNECT request    | {{http-error-codes}}   |
+| H3_MISSING_SETTINGS               | 0x010a     | No SETTINGS frame received               | {{http-error-codes}}   |
+| H3_REQUEST_REJECTED               | 0x010b     | Request not processed                    | {{http-error-codes}}   |
+| H3_REQUEST_CANCELLED              | 0x010c     | Data no longer needed                    | {{http-error-codes}}   |
+| H3_REQUEST_INCOMPLETE             | 0x010e     | Stream terminated early                  | {{http-error-codes}}   |

```suggestion
| H3_REQUEST_INCOMPLETE             | 0x010d     | Stream terminated early                  | {{http-error-codes}}   |
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4070#pullrequestreview-482765600

---

From: Mike Bishop <[email-masked]>
Date: Fri, 04 Sep 2020 08:47:54 -0700

@MikeBishop pushed 1 commit.

711b21cfdeed168c53b9d763efd31207b8718c5d  Update draft-ietf-quic-http.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4070/files/48440b40467c0ad81c7d70f6ea117a79b34b7ee7..711b21cfdeed168c53b9d763efd31207b8718c5d

---

From: Mike Bishop <[email-masked]>
Date: Fri, 04 Sep 2020 08:49:08 -0700

Merged #4070 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4070#event-3730427107

---

From: Dmitri Tikhonov <[email-masked]>
Date: Fri, 04 Sep 2020 08:59:32 -0700

Uppercase hex numbers are hexier!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4070#issuecomment-687238223