Subject: [quicwg/base-drafts] advice on how to disable ECN is problematic when multiplexing multiple connections (#4122)

From: Marten Seemann <[email-masked]>
Date: Tue, 22 Sep 2020 01:18:45 -0700

The spec says:
> If validation fails, then the endpoint MUST disable ECN. It stops setting the ECT codepoint in IP packets that it sends, assuming that either the network path or the peer does not support ECN.

This is fine advice when a single QUIC connection uses a socket. When multiplexing multiple connections on the same socket, it won't be possible to disable ECN on a per-packet basis, unless you want to call `setsockopt` before every datagram that is sent.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4122

---

From: Lars Eggert <[email-masked]>
Date: Tue, 22 Sep 2020 01:23:07 -0700

Not true. You can use ancillary data with `sendmsg` to specify ECN codepoints for each packet to be transmitted.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4122#issuecomment-696579022

---

From: Marten Seemann <[email-masked]>
Date: Tue, 22 Sep 2020 01:30:34 -0700

Interesting, I didn't know that. I guess we can close this issue with no action then?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4122#issuecomment-696582509

---

From: Lars Eggert <[email-masked]>
Date: Tue, 22 Sep 2020 01:31:54 -0700

I would think so.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4122#issuecomment-696583178

---

From: Lars Eggert <[email-masked]>
Date: Tue, 22 Sep 2020 03:39:56 -0700

Closed #4122.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4122#event-3792589506