Subject: Re: [quicwg/base-drafts] Persistent congestion pseudocode to match text (#4010)

From: Kazu Yamamoto <[email-masked]>
Date: Tue, 01 Sep 2020 18:51:32 -0700

> I'd actually suggest we remove pseudocode for InPersistentCongestion() and leave it up to implementers.

I agree with @ianswett.

Now the explanation of persistent congestion in recovery draft is very clear. I think we can leave it up to implementaters.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4010#issuecomment-685233840

---

From: Jana Iyengar <[email-masked]>
Date: Fri, 04 Sep 2020 17:42:07 -0700

I think there's value in having the part that shows how to disregard packets prior to the first RTT sample. The code clarifies the text here. The PR does leave the tricky part -- finding the largest loss period -- to implementers since that is very implementation specific.

@ianswett : other than that bit, are there other parts that you think are becoming implementation specific?

Note that in terms of actual code, this PR isn't much larger than the current code. There are large comments, which are useful I think.

I'm not wedded to this PR and I'm ok with @ianswett's suggestion; I don't think this PR is all that complex though.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4010#issuecomment-687494844

---

From: ianswett <[email-masked]>
Date: Sat, 05 Sep 2020 05:24:10 -0700

@janaiyengar the new pc_lost variable seems one step too implementation specific to me, particularly for implementations that use a single PN space.  The addition of first_rtt_sample seems potentially helpful to me, though I'd also be fine with saying it in a pseudocode comment.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4010#issuecomment-687603486

---

From: Kazu Yamamoto <[email-masked]>
Date: Sat, 05 Sep 2020 19:16:28 -0700

@janaiyengar A issue of this PR is that `pc_lost` is cleared only when a persistent congestion happens. If it does not happen, all packets are recorded until the connection is finished. I don't think that such behavior is a good implementation example.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4010#issuecomment-687688274

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 08 Sep 2020 15:56:09 -0700

Closed #4010 via #4080.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4010#event-3743117731