Subject: Re: [quicwg/base-drafts] Tweak the split between quic-transport and quic-tls drafts (#3717)

From: Christian Huitema <[email-masked]>
Date: Mon, 14 Sep 2020 11:28:14 -0700

It would be nice i the PR also addressed the issue #4097 -- section 4 including a long description of which frames belongs in what type of packet, which is better addressed by a reference to the transport draft.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3717#issuecomment-692232576

---

From: Lars Eggert <[email-masked]>
Date: Wed, 16 Sep 2020 09:01:03 -0700

@DavidSchinazi my take is that we're stable enough at this time, if you still have energy to prep a PR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3717#issuecomment-693503187

---

From: David Schinazi <[email-masked]>
Date: Wed, 16 Sep 2020 14:43:38 -0700

Thanks @larseggert ! I'll need a few weeks before I get started on this but I still have the energy.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3717#issuecomment-693681542

---

From: Lars Eggert <[email-masked]>
Date: Thu, 17 Sep 2020 00:18:25 -0700

In that case, maybe someone else can get to it sooner - I still have this unfounded optimism that we can be in IETF LC soon...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3717#issuecomment-694023654

---

From: David Schinazi <[email-masked]>
Date: Thu, 17 Sep 2020 17:12:24 +0000 (UTC)

If there's a time pressure I can increase the priority of this over other work. Do we have a deadline here?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3717#issuecomment-694373911

---

From: Martin Thomson <[email-masked]>
Date: Thu, 17 Sep 2020 17:10:05 -0700

As you say, WGLC happened.  I know that Jana wants to get some editorial work in after that (small language fixups, maybe a tiny bit of shuffling of content).  So this really comes down to one question: When do you want QUIC to be published?

Any time we allow for editorial cleanup adds directly to the time it takes to publish.  If WGLC passes this time around with no major issues, then we could immediately publish a -31 draft and make a publication request.

Second is the risk that we invalidate the WGLC when we do *any* significant amount of editorial work.  If we plan another round of calls, then this costs little.  If we don't (see above), then this carries some risk of restarting the clock.

I guess you could interpret this as "finish this before September 24 or avoid risky changes".  I don't know how realistic either one is.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3717#issuecomment-694567068

---

From: Mike Bishop <[email-masked]>
Date: Fri, 18 Sep 2020 07:26:57 -0700

Looking at what would be entailed, my first instinct was to try slotting it into new subsections of Section 12.1.  However, that makes the TOC deeper than is ideal and would probably require more editorial fine-tuning to get right.  If you want to pursue this, I think the fastest path to coherency is to make a new top-level section at the end of the document on Packet Protection and just adjust the cross-references to be forward-references there.

Then:
- New text on the values supplied by TLS (packet protection keys, header protection keys, ability to generate new keys on demand) in a subsection of TRANS-7
- Move TLS-5.0 into TRANS-(new).0
- Retain TLS-5.1 and TLS-5.2 in TLS
- Split TLS-5.3, moving the "how to apply selected AEAD and key" into TRANS-(new).1
- Move most of TLS-5.4 through TLS-5.6 into subsections of TRANS-(new), leaving only the key derivation in TLS
- TLS-5.7 should mostly move to a subsection of TRANS-13.1, but some TLS specifics would need to be abstracted out
- TLS-5.8 should move under TRANS-(new)
- TLS-7 should move under TRANS-(new), possibly removing specific references to TLS and discussing tampering with the cryptographic handshake generically.

TLS-6 is trickier.  The mechanics of how to perform a key update on the wire need to move, probably to the final subsection of TRANS-(new); the mechanics of how to obtain the new key need to remain in TLS.  These aren't currently clearly separated, and might require some additional text to abstract them.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3717#issuecomment-694900675

---

From: Christian Huitema <[email-masked]>
Date: Fri, 18 Sep 2020 17:48:41 -0700

The better is the enemy of the good. I wish we did these changes, because I wish there was no redundancy between the TLS and the transport draft. But then, with the current documents, we did manage to get a large number of implementations that all interoperate. There is a case for leave it as it and ship it now!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3717#issuecomment-695140217

---

From: Lars Eggert <[email-masked]>
Date: Sat, 19 Sep 2020 09:51:32 -0700

Maybe we need a "hold for revision" status for PRs.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3717#issuecomment-695331118

---

From: Lars Eggert <[email-masked]>
Date: Sat, 19 Sep 2020 09:55:17 -0700

I'm any case, I'd like to second @martinthomson's suggestion to get this done by Sep 24. I know that's just a few days away, but this seems to be the last issue that requires significant text changes, and so I hope this is doable.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3717#issuecomment-695331524

---

From: David Schinazi <[email-masked]>
Date: Tue, 22 Sep 2020 16:39:51 -0700

OK I'm starting work on this now. I'll have a first draft of a PR soon

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3717#issuecomment-697037961

---

From: Christian Huitema <[email-masked]>
Date: Tue, 22 Sep 2020 17:35:47 -0700

@DavidSchinazi I just pushed PR 4136 (https://github.com/quicwg/base-drafts/pull/4136) that solves issue 4097, so you don't have to do that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3717#issuecomment-697053481

---

From: David Schinazi <[email-masked]>
Date: Tue, 22 Sep 2020 17:54:15 -0700

@huitema I already have that in my PR, so happy to land whichever is ready first and rebase the other.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3717#issuecomment-697058232

---

From: David Schinazi <[email-masked]>
Date: Tue, 22 Sep 2020 18:44:15 -0700

OK I have a first draft at #4138. Reviews welcome!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3717#issuecomment-697072042

---

From: Martin Thomson <[email-masked]>
Date: Thu, 24 Sep 2020 16:03:18 -0700

Thanks for doing the work David.  I think that there is a path toward taking that PR, but it's a long one and the editors feel like it is more important to publish.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3717#issuecomment-698631380

---

From: Martin Thomson <[email-masked]>
Date: Thu, 24 Sep 2020 16:03:19 -0700

Closed #3717.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3717#event-3805386211