Subject: [quicwg/base-drafts] Make the DF requirement a "MUST, unless". (#4140)

From: Lars Eggert <[email-masked]>
Date: Wed, 23 Sep 2020 01:01:53 -0700

Fixes #4130.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4140

-- Commit Summary --

  * Make the DF requirement a &quot;MUST, unless&quot;. Fixes #4130.

-- File Changes --

    M draft-ietf-quic-transport.md (2)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4140.patch
https://github.com/quicwg/base-drafts/pull/4140.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4140

---

From: Marten Seemann <[email-masked]>
Date: Wed, 23 Sep 2020 01:03:17 -0700

@marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4140#pullrequestreview-494400032

---

From: Martin Thomson <[email-masked]>
Date: Wed, 23 Sep 2020 02:42:31 -0700

@martinthomson commented on this pull request.

This seems fine.  What do you think of the short version?

> @@ -4028,7 +4028,7 @@ smallest allowed maximum packet size of 1200 bytes.
 
 UDP datagrams MUST NOT be fragmented at the IP layer.  In IPv4
 ({{!IPv4=RFC0791}}), the DF bit MUST be set to prevent fragmentation on the
-path.
+path, unless the underlying network stack does not offer an API for doing so.

```suggestion
path, if possible.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4140#pullrequestreview-494481584

---

From: Lars Eggert <[email-masked]>
Date: Wed, 23 Sep 2020 02:50:45 -0700

@larseggert commented on this pull request.

Fine by me. @marten-seemann?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4140#discussion_r493387683

---

From: Marten Seemann <[email-masked]>
Date: Wed, 23 Sep 2020 02:51:28 -0700

@marten-seemann commented on this pull request.

wfm

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4140#discussion_r493388382

---

From: Lars Eggert <[email-masked]>
Date: Wed, 23 Sep 2020 03:54:08 -0700

@larseggert pushed 1 commit.

31f8d8caf1b99c593c24274df005a9a2570da9aa  Use "if possible"

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4140/files/01b7c557658dda5f4c30931d57b556049dc50af7..31f8d8caf1b99c593c24274df005a9a2570da9aa

---

From: ianswett <[email-masked]>
Date: Wed, 23 Sep 2020 06:25:10 -0700

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4140#pullrequestreview-494655530

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 23 Sep 2020 13:00:58 -0700

@janaiyengar commented on this pull request.

>  ({{!IPv4=RFC0791}}), the DF bit MUST be set to prevent fragmentation on the
-path.
+path, if possible.

gh doesn't let me suggest a change on unmodified lines: "... the DF bit MUST be set if possible, to prevent fragmentation on the path."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4140#pullrequestreview-495003899

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 23 Sep 2020 16:48:42 -0700

@janaiyengar pushed 1 commit.

8f00e0de5434b8a40e3c9f3564004b52e28bcd7f  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4140/files/31f8d8caf1b99c593c24274df005a9a2570da9aa..8f00e0de5434b8a40e3c9f3564004b52e28bcd7f

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 23 Sep 2020 16:51:28 -0700

dea1604889d670409c337c5233484e9e996c3a07  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4140/files/8f00e0de5434b8a40e3c9f3564004b52e28bcd7f..dea1604889d670409c337c5233484e9e996c3a07

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 23 Sep 2020 16:53:26 -0700

Merged #4140 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4140#event-3800800638