Subject: [quicwg/base-drafts] Migration can be unpermitted (#4142)

From: Mike Bishop <[email-masked]>
Date: Wed, 23 Sep 2020 14:46:34 +0000 (UTC)

Reading over the text in the sections @ekr commented on, it feels like the heart of the conflict is this:

- Some sections say that servers don&#39;t migrate in this version of QUIC.
- This section speaks generically about what an implementation MUST do if the peer migrates, suggesting clients have to obey them if the server does migrate.

Additionally, we&#39;ve discussed mitigations to other issues (e.g. #3765) in which a server might consider certain probes/migrations unacceptable and simply not respond to them.  That possibility isn&#39;t currently discussed in the text.

The solution to both appears to be the same:  Condition the MUST on acceptance of the migration.  If the migration is somehow unacceptable (the remote address violates some deployment-specific rule, or the migration is prohibited by this version of QUIC) these requirements simply don&#39;t attach.  The recipient *doesn&#39;t* change where they&#39;re sending packets or validate the new address.  That might mean the connection fails rather than migrating, but that&#39;s the price you pay.

I think this is editorial, because it acknowledges a carve-out in the MUST that we&#39;ve always implicitly used to accommodate other text in the doc.

Fixes #4063.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4142

-- Commit Summary --

  * Migration can be unpermitted

-- File Changes --

    M draft-ietf-quic-transport.md (10)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4142.patch
https://github.com/quicwg/base-drafts/pull/4142.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4142

---

From: Mike Bishop <[email-masked]>
Date: Wed, 23 Sep 2020 07:48:17 -0700

@MikeBishop pushed 1 commit.

a0488e2d98c9a2f351b32f8ec56be36b8dc50f80  to which

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4142/files/0cc279a7a0b6c3fe149c230712a0d811d72d4e30..a0488e2d98c9a2f351b32f8ec56be36b8dc50f80

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 23 Sep 2020 17:42:37 -0700

@janaiyengar approved this pull request.

LGTM, but one nit. I'd like @martinthomson to review this too.

> @@ -2329,15 +2329,16 @@ verifies ECN capability as described in {{ecn}}.
 Receiving a packet from a new peer address containing a non-probing frame
 indicates that the peer has migrated to that address.
 
-An endpoint only changes the address that it sends packets to in response to the
-highest-numbered non-probing packet. This ensures that an endpoint does not send
-packets to an old peer address in the case that it receives reordered packets.
-
-In response to such a packet, an endpoint MUST send subsequent packets to the
-new peer address and MUST initiate path validation ({{migrate-validate}}) to
-verify the peer's ownership of the address if validation is not already
+If the recipient permits the migration, an endpoint MUST send subsequent packets

```suggestion
If the recipient permits the migration, it MUST send subsequent packets
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4142#pullrequestreview-495146391

---

From: Martin Thomson <[email-masked]>
Date: Wed, 23 Sep 2020 18:02:08 -0700

@martinthomson pushed 1 commit.

6bcc9a884a787cb8e0b5ad061f615cf5ab798937  the recipient, not an (or any) endpoint

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4142/files/a0488e2d98c9a2f351b32f8ec56be36b8dc50f80..6bcc9a884a787cb8e0b5ad061f615cf5ab798937

---

From: Martin Thomson <[email-masked]>
Date: Wed, 23 Sep 2020 18:02:51 -0700

Merged #4142 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4142#event-3800933926