Subject: [quicwg/base-drafts] Pseudo-Retry packet not contain the source connection id (#4066)

From: sharmafb <[email-masked]>
Date: Tue, 01 Sep 2020 14:57:30 -0700

As per drafts 28 and 29 of QUIC-TLS, the pseudo-retry packet contains the following fields:

Retry Pseudo-Packet {
     ODCID Length (8),
     Original Destination Connection ID (0..160),
     Header Form (1) = 1,
     Fixed Bit (1) = 1,
     Long Packet Type (2) = 3,
     Type-Specific Bits (4),
     Version (32),
     DCID Len (8),
     Destination Connection ID (0..160),
     SCID Len (8),
     Retry Token (..),
}

As per this definition, the Source Connection ID is not included in the pseudo-retry packet. This change seems to have been introduced in draft 28, but the implementations I've looked at still include it in the retry pseudo packet. Was this omission intentional? I can't seem to find any discussion around this change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4066

---

From: Martin Thomson <[email-masked]>
Date: Tue, 01 Sep 2020 15:11:03 -0700

Thanks, but this has already been fixed in the editor's copy.  The fix will be in the next revision.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4066#issuecomment-685160430

---

From: Martin Thomson <[email-masked]>
Date: Tue, 01 Sep 2020 15:11:07 -0700

Closed #4066.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4066#event-3717031982