Subject: [quicwg/base-drafts] Should invalid TP result in FRAME_ENCODING_ERROR? (#4099)

From: Dmitri Tikhonov <[email-masked]>
Date: Tue, 15 Sep 2020 06:26:58 -0700

I noticed this in the Transport Draft (ID-30):

```
   If a max_streams transport parameter or MAX_STREAMS frame is received
   with a value greater than 2^60, this would allow a maximum stream ID
   that cannot be expressed as a variable-length integer; see
   Section 16.  If either is received, the connection MUST be closed
   immediately with a connection error of type FRAME_ENCODING_ERROR; see
   Section 10.2.
```

Is this intentional?  Should an invalid transport parameter result in a frame encoding error?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4099

---

From: ianswett <[email-masked]>
Date: Tue, 15 Sep 2020 06:36:37 -0700

I believe this aligns with our principles that a framing error which can be detected with no connection context is a FRAME_ENCODING_ERROR.

Is there another error you'd suggest?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4099#issuecomment-692719261

---

From: Dmitri Tikhonov <[email-masked]>
Date: Tue, 15 Sep 2020 06:39:30 -0700

My concern is that transport parameter values have nothing to do with framing and using _FRAME_ENCODING_ERROR_ is therefore misleading.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4099#issuecomment-692720960

---

From: Marten Seemann <[email-masked]>
Date: Tue, 15 Sep 2020 06:41:26 -0700

> I believe this aligns with our principles that a framing error which can be detected with no connection context is a FRAME_ENCODING_ERROR.

We only ever applied this principle to frames though, so I'm not sure we can use it as a precedent here. The name is indeed confusing, as it's FRAME_ENCODING_ERROR and not FRAMING_ERROR or ENCODING_ERROR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4099#issuecomment-692722162

---

From: Lars Eggert <[email-masked]>
Date: Tue, 15 Sep 2020 06:43:45 -0700

I always rationalized this as "the encoded content of the CRYPTO frame is erroneous".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4099#issuecomment-692723616

---

From: Dmitri Tikhonov <[email-masked]>
Date: Tue, 15 Sep 2020 06:50:24 -0700

Well, if we've been through this before, I won't insist -- it's just something that jumped out at me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4099#issuecomment-692727733

---

From: Marten Seemann <[email-masked]>
Date: Tue, 15 Sep 2020 07:01:45 -0700

> I always rationalized this as "the encoded content of the CRYPTO frame is erroneous".

That's even more confusing. The CRYPTO frame itself is totally fine. I'd be in favor of changing it to a TRANSPORT_PARAMETER_ERROR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4099#issuecomment-692734905

---

From: Martin Thomson <[email-masked]>
Date: Thu, 24 Sep 2020 02:10:41 -0700

Closed #4099 via #4100.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4099#event-3802197983