Subject: [quicwg/base-drafts] Add warning about request forgery and client-side migration (#4086)

From: ekr <[email-masked]>
Date: Wed, 09 Sep 2020 20:40:32 -0700

I find Martin's argument that QUIC servers are able to control their topology well enough to prevent request forgery attacks somewhat persuasive. However:

1. I think the document should be clearer that if you can't do this you can't deploy QUIC as a server.
2. We should add text indicating that a candidate extension to allow migration by the client would need to deal with this (likely by adding one of the countermeasures we decided not to ass). This is a very long specification and otherwise the institutional knowledge about this issue is likely to be lost.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4086

---

From: ekr <[email-masked]>
Date: Wed, 09 Sep 2020 20:40:54 -0700

If people agree, I can provide PRs for these.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4086#issuecomment-689958412

---

From: Martin Thomson <[email-masked]>
Date: Wed, 09 Sep 2020 21:14:37 -0700

These sound like good additions that I would welcome.  (I would write the PR, but I don't trust myself, I'd appreciate you providing text.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4086#issuecomment-689968307

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 10 Sep 2020 04:07:26 -0700

Sounds like a good path forward.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4086#issuecomment-690159993

---

From: Mike Bishop <[email-masked]>
Date: Fri, 11 Sep 2020 07:56:16 -0700

> 2. We should add text indicating that a candidate extension to allow migration by the client would need to deal with this (likely by adding one of the countermeasures we decided not to ass). This i…

Do you mean migration by the server?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4086#issuecomment-691144464

---

From: ekr <[email-masked]>
Date: Fri, 11 Sep 2020 08:12:20 -0700

I'm not clear on the grammar, but I mean "the server address changing"

On Fri, Sep 11, 2020 at 7:56 AM Mike Bishop <[email-masked]>
wrote:

>
>    1. We should add text indicating that a candidate extension to allow
>    migration by the client would need to deal with this (likely by adding one
>    of the countermeasures we decided not to ass). This is a very long
>    specification and otherwise the institutional knowledge about this issue is
>    likely to be lost.
>
> —
> You are receiving this because you authored the thread.
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/4086#issuecomment-691144464>,
> or unsubscribe
> <https://github.com/notifications/unsubscribe-auth/AAIPLIP2O65HJHDOBLREVWLSFI3ANANCNFSM4REBBT4A>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4086#issuecomment-691153453

---

From: Mike Bishop <[email-masked]>
Date: Fri, 11 Sep 2020 08:21:14 -0700

FWIW, when we've talked about a server migration extension before, it was usually in the form of a frame that mimics the preferred_address TP, prompting the client to probe the new address and actually make the change.  That approach seems like it limits the attacks to those already possible with SPA, though it broadens the window / number of attempts.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4086#issuecomment-691158462

---

From: Lars Eggert <[email-masked]>
Date: Mon, 21 Sep 2020 04:53:33 -0700

Could people take a look at the PR? Would like to move this along.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4086#issuecomment-696065443

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 22 Sep 2020 15:26:53 -0700

Closed #4086 via #4104.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4086#event-3795419695