Subject: Re: [quicwg/base-drafts] Can PATH_RESPONSE be sent on a different path than PATH_CHALLENGE? (#4064)

From: Martin Thomson <[email-masked]>
Date: Tue, 01 Sep 2020 18:20:33 -0700

So I thought we were really crisp about this, but we were not.

PATH_RESPONSE does not need to follow the path on which PATH_CHALLENGE was received.  We're clear about this when it comes to preferred address handling, but there is some vestigial text that contradicts this.  That should be fixed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4064#issuecomment-685223891

---

From: David Schinazi <[email-masked]>
Date: Tue, 01 Sep 2020 19:00:12 -0700

For the record, I personally believe that #4068 adequately resolves this issue while remaining purely editorial.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4064#issuecomment-685236813

---

From: Martin Thomson <[email-masked]>
Date: Tue, 01 Sep 2020 19:01:39 -0700

Thanks for being so prompt David.  I will leave this for a bit to allow others a chance to spot errors, but I plan to merge this before we publish -30 (real soon now, I hope).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4064#issuecomment-685237463

---

From: Mike Bishop <[email-masked]>
Date: Wed, 02 Sep 2020 13:48:17 -0700

Yes, the requirement was removed but the inverse statement was never explicitly added.  #4068 corrects that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4064#issuecomment-685989228

---

From: Martin Thomson <[email-masked]>
Date: Fri, 04 Sep 2020 04:50:00 -0700

Closed #4064 via #4068.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4064#event-3729375316