Subject: [quicwg/base-drafts] Add a text for alternative approach for congestion avoidance cwnd growth (#4082)

From: Junho Choi <[email-masked]>
Date: Tue, 08 Sep 2020 15:53:50 -0700

Instead of updating pseudocode of cwnd growth in congestion avoidance,
add a text on alternative approach described in RFC3465.

Close #3917.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4082

-- Commit Summary --

  * Add a text for alternative approach for congestion avoidance cwnd growth

-- File Changes --

    M draft-ietf-quic-recovery.md (4)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4082.patch
https://github.com/quicwg/base-drafts/pull/4082.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4082

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 08 Sep 2020 15:54:45 -0700

@LPardue approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4082#pullrequestreview-484548012

---

From: ianswett <[email-masked]>
Date: Tue, 08 Sep 2020 15:55:13 -0700

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4082#pullrequestreview-484548190

---

From: Martin Thomson <[email-masked]>
Date: Tue, 08 Sep 2020 15:56:13 -0700

@martinthomson approved this pull request.

"the division operation" or just "division", I think.

> @@ -1664,6 +1664,10 @@ OnPacketSentCC(bytes_sent):
 Invoked from loss detection's OnAckReceived and is supplied with the
 newly acked_packets from sent_packets.
 
+In congestion avoidance, implementers that use an integer representation
+for congestion_window should be careful with the division, and can use

```suggestion
for congestion_window should be careful with division, and can use
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4082#pullrequestreview-484548478

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 08 Sep 2020 15:57:05 -0700

@janaiyengar pushed 1 commit.

e5b556f0603c328138148fb1290d6518fed6f691  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4082/files/4bfdbfdb33f26681818e9d4b87b1f2503e95113f..e5b556f0603c328138148fb1290d6518fed6f691

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 08 Sep 2020 15:57:11 -0700

@janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4082#pullrequestreview-484548901

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 08 Sep 2020 15:59:27 -0700

Merged #4082 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4082#event-3743130968