Subject: [quicwg/base-drafts] Replace frame mapping text by ref. to tp draft. (#4136)

From: Christian Huitema <[email-masked]>
Date: Tue, 22 Sep 2020 17:27:24 -0700

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4136

-- Commit Summary --

  * Replace frame mapping text by ref. to tp draft.

-- File Changes --

    M draft-ietf-quic-tls.md (28)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4136.patch
https://github.com/quicwg/base-drafts/pull/4136.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4136

---

From: Martin Thomson <[email-masked]>
Date: Tue, 22 Sep 2020 18:01:00 -0700

@martinthomson requested changes on this pull request.

This isn't quite enough as the transport draft contains reference to this section of the document.  I would prefer that this text be moved under a new Section 12.5 and the text "Section 4 of [QUIC-TLS] provides more detail about these restrictions." in [Section 12.4](https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#section-12.4-10) adjusted to point to that.  There might be other citations for Section 4 of [QUIC-TLS] as well that would need adjustment.

> -  application errors (type 0x1d) MUST only appear in the application data packet
-  number space.
-
-- ACK frames MAY appear in any packet number space, but can only acknowledge
-  packets that appeared in that packet number space.  However, as noted below,
-  0-RTT packets cannot contain ACK frames.
-
-- All other frame types MUST only be sent in the application data packet number
-  space.
-
-Note that it is not possible to send the following frames in 0-RTT packets for
-various reasons: ACK, CRYPTO, HANDSHAKE_DONE, NEW_TOKEN, PATH_RESPONSE, and
-RETIRE_CONNECTION_ID.  A server MAY treat receipt of these frames in 0-RTT
-packets as a connection error of type PROTOCOL_VIOLATION.
+into the same packet. Some frames are prohibited in different packet number
+spaces, as specified in section 12.4 of {{QUIC-TRANSPORT}}.

```suggestion
spaces, as specified in Section 12.4 of {{QUIC-TRANSPORT}}.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4136#pullrequestreview-493940673

---

From: Christian Huitema <[email-masked]>
Date: Tue, 22 Sep 2020 18:20:49 -0700

@huitema pushed 1 commit.

cdf738bc72f778c3287392e7958bb00338304db1  Move prohibition to transport.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4136/files/c8fa3f68bf276762c0251c5ed3c8ce75fcd006f9..cdf738bc72f778c3287392e7958bb00338304db1

---

From: Christian Huitema <[email-masked]>
Date: Tue, 22 Sep 2020 18:21:33 -0700

@huitema commented on this pull request.

-  number space.
-

Just pushed a commit to do that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4136#discussion_r493120144

---

From: Martin Thomson <[email-masked]>
Date: Tue, 22 Sep 2020 18:24:24 -0700

@martinthomson commented on this pull request.

Thanks for moving it.  It's easier that way.

There is another reference to Section 4 of the TLS spec in Section 19.19 as well. (That's the bottom of CONNECTION_CLOSE.)

> @@ -3487,6 +3487,33 @@ This rule applies to all current and future QUIC frame types.  An endpoint
 MAY treat the receipt of a frame type that uses a longer encoding than
 necessary as a connection error of type PROTOCOL_VIOLATION.
 
+## Frames and Number Spaces {#frames_and_spaces}

We use hyphens mostly.

```suggestion
## Frames and Number Spaces {#frames-and-spaces}
```

And up on line 3443 (where I can't comment) replace: "Section 4 of {{QUIC-TLS}}" with "{{frames-and-spaces}}".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4136#pullrequestreview-493966760

---

From: Christian Huitema <[email-masked]>
Date: Tue, 22 Sep 2020 19:17:27 -0700

Give me couple hours, I will fix that after dinner.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4136#discussion_r493155522

---

From: Christian Huitema <[email-masked]>
Date: Tue, 22 Sep 2020 20:32:59 -0700

5b2b78c79219e7e266937bb0942fc6adb9a6cb4b  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4136/files/cdf738bc72f778c3287392e7958bb00338304db1..5b2b78c79219e7e266937bb0942fc6adb9a6cb4b

---

From: Christian Huitema <[email-masked]>
Date: Tue, 22 Sep 2020 20:42:01 -0700

2ed2dd6f39efb6e47e4046dae949cb4b787b8015  Fix refs to Section 4 of TLS.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4136/files/5b2b78c79219e7e266937bb0942fc6adb9a6cb4b..2ed2dd6f39efb6e47e4046dae949cb4b787b8015

---

From: Christian Huitema <[email-masked]>
Date: Tue, 22 Sep 2020 20:43:03 -0700

There were two references, I fixed them both.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4136#issuecomment-697116027

---

From: Martin Thomson <[email-masked]>
Date: Tue, 22 Sep 2020 20:51:43 -0700

@martinthomson approved this pull request.

Thanks Christian, this looks good.  I'll give @janaiyengar a chance to review also, but I think it's worth taking this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4136#pullrequestreview-494010188

---

From: ianswett <[email-masked]>
Date: Wed, 23 Sep 2020 06:42:54 -0700

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4136#pullrequestreview-494673541

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 23 Sep 2020 13:16:32 -0700

@janaiyengar approved this pull request.

Makes sense, thanks for writing this up, @huitema.

-  number space.
-
+spaces, as specified in section 12.5 of {{QUIC-TRANSPORT}}.

```suggestion
spaces; see section 12.5 of {{QUIC-TRANSPORT}}.
```

+## Frames and Number Spaces {#frames-and-spaces}

```suggestion
## Frames and Packet Number Spaces {#frames-and-spaces}
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4136#pullrequestreview-495006288

---

From: Christian Huitema <[email-masked]>
Date: Wed, 23 Sep 2020 13:27:23 -0700

d20c348c3e09910c1e7b46ba99fe3145c16941f0  Update draft-ietf-quic-tls.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4136/files/2ed2dd6f39efb6e47e4046dae949cb4b787b8015..d20c348c3e09910c1e7b46ba99fe3145c16941f0

---

From: Christian Huitema <[email-masked]>
Date: Wed, 23 Sep 2020 13:27:38 -0700

Done.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4136#discussion_r493874527

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 23 Sep 2020 15:28:42 -0700

Merged #4136 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4136#event-3800607329