Subject: [quicwg/base-drafts] All H3 frames are flow controlled (#4074)

From: Lucas Pardue <[email-masked]>
Date: Sat, 05 Sep 2020 11:07:33 -0700

Closes #4057 
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4074

-- Commit Summary --

  * All H3 frames are flow controlled

-- File Changes --

    M draft-ietf-quic-http.md (7)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4074.patch
https://github.com/quicwg/base-drafts/pull/4074.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4074

---

From: ianswett <[email-masked]>
Date: Sat, 05 Sep 2020 12:51:21 -0700

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4074#pullrequestreview-483075499

---

From: Dmitri Tikhonov <[email-masked]>
Date: Sat, 05 Sep 2020 18:54:30 -0700

Should it state explicitly that HTTP/3 frame *headers* are flow-controlled as well?  In other words, flow control is now the job of the transport.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4074#issuecomment-687686702

---

From: Lucas Pardue <[email-masked]>
Date: Sat, 05 Sep 2020 18:57:07 -0700

Good observation, I'll add a clarification.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4074#issuecomment-687686879

---

From: Martin Thomson <[email-masked]>
Date: Sun, 06 Sep 2020 02:33:10 -0700

@martinthomson commented on this pull request.

> @@ -2264,6 +2264,13 @@ given time without modifying it.
 
 [QPACK] provides additional details.
 
+### Flow Control Differences
+
+HTTP/2 specifies a stream flow control mechanism. Although all HTTP/2 frames are
+delivered on streams, only the DATA frame type is subject to flow control. QUIC
+subsumes flow control and all HTTP/3 frame types defined in this document are

```suggestion
provides flow control for stream data and all HTTP/3 frame types defined in this document are
```

"subsumes" isn't the word I think you want here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4074#pullrequestreview-483127358

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 07 Sep 2020 04:24:06 -0700

@LPardue pushed 1 commit.

ed2f96f9bf592a8784035dde9a4fcc79a39bc345  MT's suggestion

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4074/files/ce44aedf6249e50eda1587167676318be1b6375c..ed2f96f9bf592a8784035dde9a4fcc79a39bc345

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 07 Sep 2020 04:30:44 -0700

34b5c0db4ae18164f85f9064bbbea3913cc320f1  Clarify frame header and payload flow control

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4074/files/ed2f96f9bf592a8784035dde9a4fcc79a39bc345..34b5c0db4ae18164f85f9064bbbea3913cc320f1

---

From: Mike Bishop <[email-masked]>
Date: Tue, 08 Sep 2020 11:27:21 -0700

@MikeBishop approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4074#pullrequestreview-484391501

---

From: Mike Bishop <[email-masked]>
Date: Tue, 08 Sep 2020 15:21:13 -0700

Merged #4074 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4074#event-3743030496