Subject: [quicwg/base-drafts] ECN verification 3RTT period (#4132)

From: Tatsuhiro Tsujikawa <[email-masked]>
Date: Tue, 22 Sep 2020 06:47:29 -0700

https://tools.ietf.org/html/draft-ietf-quic-transport-30#section-13.4.2.1 and https://tools.ietf.org/html/draft-ietf-quic-transport-30#appendix-B describe ECN validation and they say :

> To reduce the chances of misinterpreting congestive loss as packets
   dropped by a faulty network element, an endpoint could set the ECT(0)
   codepoint for only the first ten outgoing packets on a path, or for a
   period of three RTTs, whichever occurs first.

Initial PTO timeout is also 3RTT.  If client does not get ACK for its first flight Initial, after 3RTT later, it resends Initial without ECT set because client is now in "UNKNOWN" state.
If the first client Initial is really lost, ECN validation fails.

It seems to me that it would be better to lengthen timeout or ensure enough packets are sent not limited by the timeout?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4132

---

From: Marten Seemann <[email-masked]>
Date: Tue, 22 Sep 2020 22:39:26 -0700

It seems like this particular problem was introduced by reducing the initial RTT from 500ms to 333ms (in #3823).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4132#issuecomment-697145348

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 24 Sep 2020 14:37:56 -0700

Closed #4132 via #4160.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4132#event-3805181288