Subject: [quicwg/base-drafts] Ben Kaduk's TLS Comment 15 (#4491)

From: Lucas Pardue <[email-masked]>
Date: Tue, 05 Jan 2021 18:55:32 -0800

@kaduk said:

> Section 5.3
> 
>    QUIC can use any of the cipher suites defined in [TLS13] with the
>    exception of TLS_AES_128_CCM_8_SHA256.  [...]
> 
> It's a little interesting to use the RFC as the authority on
> ciphersuites rather than the registry, but I guess the header protection
> scheme requirement makes it more reasonable.  Also, for what it's worth,
> there are MAC-only TLS 1.3 ciphersuites in the IANA registry.  I don't
> know whether you want to say anything (to forbid?) such things from
> being used as QUIC AEADs.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4491

---

From: Martin Thomson <[email-masked]>
Date: Tue, 05 Jan 2021 21:54:05 -0800

Yes, we can't say anything about TLS 1.3 ciphers in the registry.  This is really just informative language as we list the suites fully.  It's important to call out the exception for the short-tag suite, and this is the best way I could see to do that.

I don't think that we are obliged to acknowledge the MAC-only - and non-recommended - suites here.  Technically speaking, those could be used with QUIC if someone wanted to define header protection (the identity transform perhaps?) for them, but I think that it's better to say nothing at all.  I'm sure that we can expend many email bytes on the topic if it comes up, but I'm happy to defer that discussion.

My proposal for this issue is no action.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4491#issuecomment-755097566

---

From: kaduk <[email-masked]>
Date: Sat, 09 Jan 2021 19:33:05 -0800

Part of why I had commented here is that "can use any of [implicit list of 4 ciphers]" might be misread as saying that no other ciphers will ever be allowed.  I *think* that "is the AEAD that is negotiated for use with the TLS connection" implies that other ciphers can be used, provided the header protection requirement is met, so I am okay with closing with no change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4491#issuecomment-757408010

---

From: Lucas Pardue <[email-masked]>
Date: Sun, 10 Jan 2021 13:14:49 -0800

Since the Comment Maker is happy to close with no action, that is what I'm doing.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4491#issuecomment-757545081

---

From: Lucas Pardue <[email-masked]>
Date: Sun, 10 Jan 2021 13:14:49 -0800

Closed #4491.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4491#event-4188440363