Subject: [quicwg/base-drafts] Ben Kaduk's TLS Comment 25 (#4501)

From: Lucas Pardue <[email-masked]>
Date: Tue, 05 Jan 2021 19:01:19 -0800

@kaduk said:

> Section 9
> 
> In various places (e.g., §4.1.4) we recommend to buffer (or "retain")
> data that cannot be processed yet.  Perhaps it goes without saying, but
> such buffering needs limits in place in order to avoid DoS.
> 
> It may be too banal to mention again here that the Initial secret/keys
> are not particularly secure, but I'll mention it just in case we want
> to.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4501

---

From: Martin Thomson <[email-masked]>
Date: Tue, 05 Jan 2021 23:01:29 -0800

Two separate comments in this issue:

1. We address buffering and retention in [Section 7.5 of the transport doc](https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#name-cryptographic-message-buffe) and referenced in [Section 4.1.3](https://quicwg.org/base-drafts/draft-ietf-quic-tls.html#section-4.1.3-12).  I think that suffices.
2. Given that we dedicate [Section 7](https://quicwg.org/base-drafts/draft-ietf-quic-tls.html#name-security-of-initial-message) to the issue of "security" for Initial packets, it probably isn't necessary to repeat things here.  (We might consider moving Section 7 to this section, I guess.  I just don't like the grab-bag that is security considerations.)

I don't think we should do anything in response to this, though I might be convinced to move Section 7.  I will say that it's really annoying to move sections, so I'd need a push.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4501#issuecomment-755123912

---

From: Sean Turner <[email-masked]>
Date: Fri, 08 Jan 2021 08:02:58 -0800

I do not see any reason to move it. This entire document is all about security considerations.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4501#issuecomment-756836136

---

From: kaduk <[email-masked]>
Date: Sat, 09 Jan 2021 19:54:06 -0800

> 1. We address buffering and retention in [Section 7.5 of the transport doc](https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#name-cryptographic-message-buffe) and referenced in [Sectio…

Yes, that looks like it should suffice.  (I read -tls before -transport and didn't think to check if -transport said anything on this topic.)

> 2. Given that we dedicate [Section 7](https://quicwg.org/base-drafts/draft-ietf-quic-tls.html#name-security-of-initial-message) to the issue of "security" for Initial packets, it probably isn't nec…

I only mentioned it because sometimes people skip to the named security considerations section and pretend they can ignore the rest of the document.  That's ill-advised, of course, and we need not go out of our way to support it -- we do already say that there are many security-relevant details in the rest of the document.  So this one is looking like close with no change, and thanks for the pointer to the transport section.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4501#issuecomment-757409930

---

From: Martin Thomson <[email-masked]>
Date: Mon, 11 Jan 2021 20:58:54 -0800

Closed #4501.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4501#event-4193991711