Subject: [quicwg/base-drafts] Robert Wilton's Comment 3 (#4670)

From: Lucas Pardue <[email-masked]>
Date: Wed, 06 Jan 2021 18:41:20 -0800

Rob Wilton said:

> >    1.2.  Terms and Definitions
> >
> >    Frame: A unit of structured protocol information. There are multiple frame
> >    types, each of which carries different information. Frames are contained in
> >    QUIC packets.
>
> Perhaps indicate that a quic packet can contain multiple frames?  The
> terminology states that a datagram contains multiple quick packets, but it
> wasn't obvious to me that a quick packet can contain multple frames.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4670

---

From: Martin Thomson <[email-masked]>
Date: Thu, 07 Jan 2021 17:02:33 -0800

> Perhaps indicate that a quic packet can contain multiple frames? 

Only some QUIC packets can contain frames, so doing that is hard.  As a definition, I believe that what is there is enough, and the [complete description](https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#name-frames-and-frame-types) can be used to get the extra information needed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4670#issuecomment-756480903

---

From: Lars Eggert <[email-masked]>
Date: Tue, 12 Jan 2021 01:51:23 -0800

Closed #4670.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4670#event-4194965630