Subject: [quicwg/base-drafts] Éric Vyncke's Invariants Comment 1 (#4546)

From: Lucas Pardue <[email-masked]>
Date: Tue, 05 Jan 2021 20:04:35 -0800

Éric Vyncke said:

> Should the use of UDP transport be also an invariant ?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4546

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 14:48:47 -0800

How is this not enough?

> QUIC endpoints exchange UDP datagrams that contain one or more QUIC packets. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4546#issuecomment-755763925

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 07 Jan 2021 00:42:34 -0800

Also, I don't think UDP is invariant. QUIC is designed with the facilities of UDP in mind, however one can define how to run QUIC over other datagram providing lower layers. One simply have to discuss how to identify each datagram carrying a QUIC packet, identify paths and path changes as well as any support for service demultiplexing if needed. QUICs strong integrity protection makes the whole checksum mostly irrelevant.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4546#issuecomment-755972478

---

From: Martin Thomson <[email-masked]>
Date: Thu, 07 Jan 2021 08:55:49 -0800

On this, I disagree.  QUIC defines UDP as an invariant.  Porting QUIC to run on another protocol (e.g., MASQUE) makes it not-QUIC or like-QUIC.  Maybe this should have been more clearly stated then, as this is my understanding of the consensus of the working group.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4546#issuecomment-756240132

---

From: ianswett <[email-masked]>
Date: Thu, 07 Jan 2021 09:38:52 -0800

There was a lengthy discussion about whether QUIC could run over something besides UDP on the mailing list a while back, and it was pretty clear it was out of scope for v1.

I believe people will want to run QUIC over things besides UDP, but I don't think that will happen immediately and I believe that will require new drafts with the appropriate updates.  I'm happy to do that in the future when we understand the non-UDP use cases for QUIC better.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4546#issuecomment-756267581

---

From: mirjak <[email-masked]>
Date: Fri, 08 Jan 2021 07:51:12 -0800

My understanding is that QUICv1 is defined as a protocol on top of UDP and as such e.g. the spec can assume that there are UDP ports, however, I wouldn't see that an invariant for all future version of QUIC.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4546#issuecomment-756828990

---

From: Mike Bishop <[email-masked]>
Date: Fri, 08 Jan 2021 12:22:29 -0800

If we make that decision in the future, we can update the invariants to be broader.  Or a draft could specify that it's defining a protocol in which QUIC packets that could have been sent in UDP are sent in something else.  Regardless, we decided that a non-UDP-based protocol was out-of-scope even for the invariants and the document reflects this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4546#issuecomment-756980490

---

From: Lars Eggert <[email-masked]>
Date: Tue, 12 Jan 2021 00:13:23 -0800

I'm reading this discussion as "close with no action". Or does someone want to propose a PR that makes the UDP invariant clearer?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4546#issuecomment-758485584

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 12 Jan 2021 00:18:50 -0800

Close with no action. If the question of "should UDP be invariant", I think it is, but I also don't think we need to resolve this now.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4546#issuecomment-758488320

---

From: Lars Eggert <[email-masked]>
Date: Tue, 12 Jan 2021 01:42:55 -0800

Closed #4546.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4546#event-4194926889