Subject: [quicwg/base-drafts] Brian Kaduk's nits on HTTP/3 (#4810)

From: Mike Bishop <[email-masked]>
Date: Fri, 22 Jan 2021 12:34:37 -0800

Collection of editorial changes from @kaduk&#39;s review.

Fixes #4760.
Fixes #4776.
Fixes #4777.
Fixes #4780.
Fixes #4781.
Fixes #4782.
Fixes #4783 if no one objects.
Fixes #4785.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4810

-- Commit Summary --

  * Expert Reviewers gonna do...
  * Insert reliance in intro
  * Control streams need flow control credit
  * Note flow control difference in HTTP/2 appendix
  * CONNECT precautions
  * 8470 applied to QUIC
  * Reserve 0x0
  * ALTSVC informative
  * Setting values in Appendix
  * Abort reading, not discard

-- File Changes --

    M draft-ietf-quic-http.md (97)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4810.patch
https://github.com/quicwg/base-drafts/pull/4810.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4810

---

From: Mike Bishop <[email-masked]>
Date: Fri, 22 Jan 2021 12:41:04 -0800

@MikeBishop pushed 1 commit.

f439aaec3bf195e7940a6ffbade378c7efd714b3  Merge remote-tracking branch 'origin/master' into http/bk_nits

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4810/files/cc0bec66bed34e7097a92e6d52457bf571870f80..f439aaec3bf195e7940a6ffbade378c7efd714b3

---

From: kaduk <[email-masked]>
Date: Fri, 22 Jan 2021 16:29:57 -0800

@kaduk approved this pull request.

Thanks; these look good to me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4810#pullrequestreview-574709127

---

From: Martin Thomson <[email-masked]>
Date: Sun, 24 Jan 2021 22:48:32 -0800

@martinthomson commented on this pull request.

One change here looks a little off.

> @@ -1908,13 +1920,13 @@ A client can discard responses that it cannot process.
 
 ### CONNECT Issues
 
-The CONNECT method can be used to create disproportionate load on a proxy,
-since stream creation is relatively inexpensive when compared to the creation
-and maintenance of a TCP connection.  A proxy might also maintain some resources
-for a TCP connection beyond the closing of the stream that carries the CONNECT
+The CONNECT method can be used to create disproportionate load on a proxy, since

```suggestion
The CONNECT method can be used to create disproportionate load on a proxy, as
```

> +Therefore, a proxy might delay increasing the QUIC stream limits to account for
+the resources consumed by CONNECT requests.

The original text existed to note that accounting for streams as requests is insufficient in the case that a CONNECT request is used.  Delay does no good.  What we might instead say is that any proxy that supports CONNECT might choose to limit the number of concurrent CONNECT streams it accepts (and account for the higher cost of those streams when considering overall resource allocation).

> @@ -2267,6 +2286,10 @@ of time.  HTTP/3 servers might choose to permit a larger number of concurrent
 client-initiated bidirectional streams to achieve equivalent concurrency to
 HTTP/2, depending on the expected usage patterns.
 
+In HTTP/2, only request and response bodies (DATA frames) are subject to flow

```suggestion
In HTTP/2, only request and response bodies (the frame payload of DATA frames) are subject to flow
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4810#pullrequestreview-575100683

---

From: kaduk <[email-masked]>
Date: Mon, 25 Jan 2021 22:13:37 -0800

@kaduk commented on this pull request.

It looks like the original text did two things: note that CONNECT streams are more expensive than request streams (as you note here), but also that resources used for CONNECT streams might linger even after the HTTP stream is closed (the point I remarked upon where the properties of HTTP/3 and HTTP/2 diverge qualitatively).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4810#discussion_r564258184

---

From: Mike Bishop <[email-masked]>
Date: Tue, 26 Jan 2021 07:28:30 -0800

@MikeBishop commented on this pull request.

Hm, that's a different reading that I'd initially taken.  I'll try to rework the text a bit more.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4810#discussion_r564600519

---

From: Mike Bishop <[email-masked]>
Date: Tue, 26 Jan 2021 07:28:49 -0800

d2cc6824b14d227bd52caa18fc6299637f05ff1c  Apply suggestions from code review

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4810/files/f439aaec3bf195e7940a6ffbade378c7efd714b3..d2cc6824b14d227bd52caa18fc6299637f05ff1c

---

From: Mike Bishop <[email-masked]>
Date: Tue, 26 Jan 2021 07:34:01 -0800

3c60c7ef174f7a903c06d15c3654c8130a0b8485  More conservative about resources

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4810/files/d2cc6824b14d227bd52caa18fc6299637f05ff1c..3c60c7ef174f7a903c06d15c3654c8130a0b8485

---

From: Mike Bishop <[email-masked]>
Date: Tue, 26 Jan 2021 15:11:58 -0800

c04b41398c88f676190b6ecb63285dbb694336b6  Split CONNECT paragraph

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4810/files/3c60c7ef174f7a903c06d15c3654c8130a0b8485..c04b41398c88f676190b6ecb63285dbb694336b6

---

From: Mike Bishop <[email-masked]>
Date: Tue, 26 Jan 2021 15:12:58 -0800

Merged #4810 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4810#event-4253160744