Subject: [quicwg/base-drafts] Ben Kaduk's Transport Comment 5 (#4612)

From: Lucas Pardue <[email-masked]>
Date: Wed, 06 Jan 2021 17:02:21 -0800

@kaduk said

> Section 4.1
>
> > QUIC employs a limit-based flow-control scheme where a receiver
> > advertises the limit of total bytes it is prepared to receive on a
> > given stream or for the entire connection.  [...]
>
> Should I be reading some distinction into "limit-based" (here) vs
> "credit-based" (earlier) flow control?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4612

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 17:23:15 -0800

No.

This is a question and I don't think that it needs any change in response.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4612#issuecomment-755823030

---

From: kaduk <[email-masked]>
Date: Wed, 06 Jan 2021 17:25:36 -0800

While it doesn't require a change, I would have thought that consistent use of terminology would be preferred.
Would it help if I made a pull request?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4612#issuecomment-755823799

---

From: Mike Bishop <[email-masked]>
Date: Fri, 08 Jan 2021 13:21:39 -0800

If we are to align, I suspect limit-based is more correct.  Credit-based makes me think of HTTP/2-style sending of deltas, whereas QUIC always sends the new absolute value of the limit.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4612#issuecomment-757003965

---

From: Martin Thomson <[email-masked]>
Date: Sun, 10 Jan 2021 17:45:03 -0800

"credit-based scheme is used to limit stream creation" is the only instance of "credit-based", but there are lots of uses of the word "credit", often in the context of discussing flow control or stream limits.  I suspect that fixing this would be too disruptive.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4612#issuecomment-757585577

---

From: Martin Thomson <[email-masked]>
Date: Mon, 11 Jan 2021 20:46:15 -0800

Closed #4612.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4612#event-4193966037