Subject: [quicwg/base-drafts] Ben Kaduk's TLS Comment 28 (#4504)

From: Lucas Pardue <[email-masked]>
Date: Tue, 05 Jan 2021 19:02:40 -0800

@kaduk said:

> Appendix A.2
> 
>    The client sends an Initial packet.  The unprotected payload of this
>    packet contains the following CRYPTO frame, plus enough PADDING
>    frames to make a 1162 byte payload:
>    [...]
>    The unprotected header includes the connection ID and a 4-byte packet
>    number encoding for a packet number of 2:
> 
>    c300000001088394c8f03e5157080000449e00000002
> 
> If I'm reading this correctly, the variable-length integer encoding of
> the packet Length is 0x449e which would indicate a 1182-byte payload
> (including packet number), not 1162.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4504

---

From: Martin Thomson <[email-masked]>
Date: Tue, 05 Jan 2021 23:14:26 -0800

I should have put money on @kaduk validating the examples...

The use of "payload" refers to the frames contained in the packet, which are 1182 - 4 (packet number length) - 16 (aead expansion).  Would "The frames carried by this packet includes the following CRYPTO frame, plus enough PADDING frames to reach 1162 bytes." be better?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4504#issuecomment-755129646

---

From: kaduk <[email-masked]>
Date: Sat, 09 Jan 2021 20:24:40 -0800

Ah, of course, the authentication tag.  (I only remembered that the packet number length was included as an afterthought, but 4 != 20 and I didn't pause to think what might be adding 16 other bytes.)
Thanks for the PR, @MikeBishop !

I am not sure who would take the other end of that bet, though ... I seem to have a track record of putting DISCUSSes on for examples that don't match the protocol spec.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4504#issuecomment-757412792

---

From: Jana Iyengar <[email-masked]>
Date: Sun, 10 Jan 2021 18:48:52 -0800

I will say that examples are important, so thank you for going through them, @kaduk!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4504#issuecomment-757598340

---

From: Martin Thomson <[email-masked]>
Date: Sun, 10 Jan 2021 18:54:55 -0800

Closed #4504 via #4694.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4504#event-4188766667