Subject: [quicwg/base-drafts] Ben Kaduk's Transport Comment 17 (#4624)

From: Lucas Pardue <[email-masked]>
Date: Wed, 06 Jan 2021 17:10:25 -0800

@kaduk said:

> Section 8.2
>
> > Path validation is used by both peers during connection migration
> > (see Section 9) to verify reachability after a change of address.  In
> > path validation, endpoints test reachability between a specific local
> > address and a specific peer address, where an address is the two-
> > tuple of IP address and port.
>
> In light of the toplevel definition of "address" in this document, the
> last clause seems unnecessary.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4624

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 19:34:59 -0800

This text critically depends on that definition, so it is my opinion that the repetition is helpful here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4624#issuecomment-755861167

---

From: kaduk <[email-masked]>
Date: Wed, 06 Jan 2021 19:38:35 -0800

I'm fine with closing with no-change here.  Though I do note that the local definition does not mention IP version and the document-scope definition does.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4624#issuecomment-755862303

---

From: Lars Eggert <[email-masked]>
Date: Tue, 12 Jan 2021 01:53:47 -0800

Closed #4624.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4624#event-4194976592