Subject: [quicwg/base-drafts] Éric Vyncke's HTTP/3 Comment 4 (#4754)

From: Lucas Pardue <[email-masked]>
Date: Tue, 19 Jan 2021 09:48:00 -0800

@evyncke said

> -- Section 4.4 --
> Should the client behavior be specified when server does not respect "A server
> SHOULD use Push IDs sequentially, beginning from zero. " ?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4754

---

From: Martin Thomson <[email-masked]>
Date: Tue, 19 Jan 2021 12:53:31 -0800

Using out of order isn't easily detectable.

The main reason to do so is to ensure that you get the most out of credit the client extends with MAX_PUSH_ID. If you leave gaps, those might delay increases. Not sure if that really needs to be said though.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4754#issuecomment-763132952

---

From: Mike Bishop <[email-masked]>
Date: Tue, 19 Jan 2021 13:44:15 -0800

No, because QUIC does not give guarantees about delivery order.  Apparent misordering could be due to servers using IDs out-of-order or simply reordering on the wire.  A server that actually uses the IDs out-of-order is only hurting itself.

Proposed no action.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4754#issuecomment-763160633

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 19 Jan 2021 13:52:53 -0800

(As an individual) yep, a server that starts above 0 at N is probably always operating at a deficit because the client can't know that lower than N would ever be used. Also, practically speaking, any client action we might offer is likely to be terminal for a connection, which is pretty unfortunate for a server that dares even use Server Push in the first place. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4754#issuecomment-763165256

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 26 Jan 2021 15:21:41 -0800

Closing with no action.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4754#issuecomment-767894523

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 26 Jan 2021 15:21:41 -0800

Closed #4754.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4754#event-4253185129