Subject: [quicwg/base-drafts] Éric Vyncke's QPACK Comment 1 (#4774)

From: Lucas Pardue <[email-masked]>
Date: Wed, 20 Jan 2021 09:06:46 -0800

@evyncke said

> I have only one generic comment, did the WG look into the Static Context Header
> Compression out of the LPWAN WG ? As there are similarities.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4774

---

From: Dmitri Tikhonov <[email-masked]>
Date: Wed, 20 Jan 2021 11:34:25 -0800

I do not believe we did.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4774#issuecomment-763882635

---

From: Mike Bishop <[email-masked]>
Date: Wed, 20 Jan 2021 12:04:57 -0800

No, we didn't.  It's possible there would be some concepts we could have borrowed, but from a cursory examination, SCHC appears to be a framework for building a compression scheme rather than a concrete compression scheme.  Given the focus on reducing individual bits and bytes out, I'm not sure whether we would have adopted that framework.

Regardless, I don't believe this requests a change to the document.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4774#issuecomment-763899207

---

From: Eric Vyncke <[email-masked]>
Date: Wed, 20 Jan 2021 12:16:23 -0800

No changes are required indeed as it is way too late.

It is symptomatic though that WG are isolated one from the other. Sigh... Nothing specific to QUIC though

-éric

________________________________
De : Mike Bishop <[email-masked]>
Envoyé : mercredi 20 janvier 2021 21:04
À : quicwg/base-drafts <[email-masked]>
Cc : Eric Vyncke <[email-masked]>; Mention <[email-masked]>
Objet : Re: [quicwg/base-drafts] Éric Vyncke's QPACK Comment 1 (#4774)

—
You are receiving this because you were mentioned.
Reply to this email directly, view it on GitHub<https://github.com/quicwg/base-drafts/issues/4774#issuecomment-763899207>, or unsubscribe<https://github.com/notifications/unsubscribe-auth/ABC32H2TOMV3X5CSNS65SF3S24ZOJANCNFSM4WK7O67A>.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4774#issuecomment-763905519

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 20 Jan 2021 13:26:08 -0800

Given that QPACK's precursor, HPACK, was published in 2015 https://tools.ietf.org/html/rfc7541 I'm surprised to see that SCHC has no mention of it ;-)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4774#issuecomment-763958495

---

From: Mike Bishop <[email-masked]>
Date: Wed, 20 Jan 2021 13:28:28 -0800

I agree, and it's one of the things that concerns me about certain WGs forgoing meeting during IETF week and having interims instead; there's even less awareness of what other WGs are working on and where they can overlap.  I do wish there'd been contact in either direction sooner, in case either group had ideas the other could have used.  But here we are.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4774#issuecomment-763959807

---

From: Dmitri Tikhonov <[email-masked]>
Date: Wed, 20 Jan 2021 13:34:20 -0800

On the bright side, I don't think SCHC would be applicable to HTTP/3 (or at least not be an improvement over HPACK).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4774#issuecomment-763963142

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 25 Jan 2021 10:35:23 -0800

Since we agree no action is required, closing the issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4774#issuecomment-767025225

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 25 Jan 2021 10:35:24 -0800

Closed #4774.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4774#event-4247120809