Subject: [quicwg/base-drafts] Ben Kaduk's TLS Comment 20 (#4496)

From: Lucas Pardue <[email-masked]>
Date: Tue, 05 Jan 2021 18:58:30 -0800

@kaduk said:

> Section 5.8
> 
>    The secret key and the nonce are values derived by calling HKDF-
>    Expand-Label using
>    0xd9c9943e6101fd200021506bcc02814c73030f25c79d71ce876eca876e6fca8e as
>    the secret, with labels being "quic key" and "quic iv" (Section 5.1).
> 
> HKDF-Expand-Label also takes a "Context" argument; what value is used
> for that?  (Presumably the ouput Length argument is set to the lengths
> of the stated fields.)
> 
>    Retry Pseudo-Packet {
>      ODCID Length (8),
>      Original Destination Connection ID (0..160),
>      Header Form (1) = 1,
>      Fixed Bit (1) = 1,
>      Long Packet Type (2) = 3,
>      Type-Specific Bits (4),
>      Version (32),
>      DCID Len (8),
>      Destination Connection ID (0..160),
>      SCID Len (8),
>      Source Connection ID (0..160),
>      Retry Token (..),
>    }
> 
> Should we say that the four bits before Version are Unused (not
> Type-Specific Bits), as they are in the Retry packet itself?  (I assume
> that the the arbitrary value in those bits does need to be preserved,
> though.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4496

---

From: Martin Thomson <[email-masked]>
Date: Tue, 05 Jan 2021 22:17:11 -0800

The Context thing should be addressed by #4571.  The 4 bits should be "Unused" to match the transport spec.  I'll fix that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4496#issuecomment-755106417

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 21:44:39 -0800

Closed #4496 via #4575.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4496#event-4178282093