Subject: [quicwg/base-drafts] Roman Danyliw's Transport Comment 3 (#4566)

From: Lucas Pardue <[email-masked]>
Date: Tue, 05 Jan 2021 20:29:03 -0800

Roman Danyliw said:

> ** Section 21.5.  Per “QUIC servers SHOULD NOT be deployed in networks that
> also have inadequately secured UDP endpoints”, I was wondering if this caution
> is a realistic.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4566

---

From: Mike Bishop <[email-masked]>
Date: Fri, 08 Jan 2021 12:41:20 -0800

It might not be entirely realistic, in that the person deploying a server might not be aware of unsecure endpoints around them, but it's better to have the caution present than say nothing.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4566#issuecomment-756988182

---

From: Martin Thomson <[email-masked]>
Date: Sun, 10 Jan 2021 17:13:23 -0800

I think that it is moderately realistic for most deployments.  There aren't so many UDP-based protocols out there in common usage.  Besides, conducting an audit, if you did not already know, would be healthy.

>From another angle, a reason to include this is that if you have a firewall, deploy a QUIC server behind that firewall, and don't know what else is behind that firewall, then us writing this text makes it clear where fault lies if something bad happens.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4566#issuecomment-757579865

---

From: Martin Thomson <[email-masked]>
Date: Mon, 11 Jan 2021 20:45:10 -0800

This is not an editorial issue.  I think that it is an excellent question, and definitely the sort of question I would expect the IESG to press on.  FWIW, I think that this response would be totally unreasonable if this were TCP instead of UDP, which implies that there is a degree of subjectivity involved in the decision.

The working group position suggests no action, but I want to confirm that @rdanyliw is satisfied with that response.  As this was only a comment, not DISCUSS, I'm going to assume that this is OK unless I'm told otherwise.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4566#issuecomment-758395700

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 11 Jan 2021 21:08:52 -0800

Would it help to more tightly scope the definition of "networks"? One absurd reading is that QUIC should not be deployed on Internet facing networks because there is not a 0% chance of some unsecured UDP listening host somewhere.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4566#issuecomment-758404860

---

From: Martin Thomson <[email-masked]>
Date: Mon, 11 Jan 2021 21:13:03 -0800

I think we might be able to say "networks without ingress filtering [BCP38]".  Servers are only vulnerable to these attacks if they (or their network) permits source address spoofing.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4566#issuecomment-758406326

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 11 Jan 2021 21:26:52 -0800

WfMq

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4566#issuecomment-758411649

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 11 Jan 2021 23:32:55 -0800

I think the addition of BCP 38 makes it much more pointed and realistic. Overall, this is an important cautionary note. We decided that instead of trying to fix this in the protocol, it made sense to force those deploying QUIC to consider the implications of the environment in which they are doing it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4566#issuecomment-758466046

---

From: Lars Eggert <[email-masked]>
Date: Tue, 12 Jan 2021 00:25:10 -0800

@rdanyliw could you comment on the proposed resolution?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4566#issuecomment-758491766

---

From: Roman Danyliw <[email-masked]>
Date: Tue, 12 Jan 2021 06:53:36 -0800

Thanks for the refined text.  The reference to ingress filtering makes it clearer.  Consider this COMMENT resolved.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4566#issuecomment-758708520

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 12 Jan 2021 15:13:56 -0800

Closed #4566 via #4733.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4566#event-4198480095