Subject: [quicwg/base-drafts] Murray Kucherawy's QPACK Comment 2 (#4798)

From: Lucas Pardue <[email-masked]>
Date: Thu, 21 Jan 2021 06:26:40 -0800

@mskucherawy said

> In Section 2.2.1:
>
> >   While blocked, encoded field section data SHOULD remain in the
> >   blocked stream's flow control window.
>
> Since SHOULD grants me a choice, why might I decide not to do what it says
> here?  Or should this be MUST?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4798

---

From: Dmitri Tikhonov <[email-masked]>
Date: Thu, 21 Jan 2021 06:34:59 -0800

One could imagine an implementation using a small buffer to read the beginning of the stream.  If the whole field section happens to fit into it, so be it.  A _MUST_ would probably mean that a conforming implementation had to unread the field section.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4798#issuecomment-764685135

---

From: Martin Thomson <[email-masked]>
Date: Thu, 21 Jan 2021 13:45:59 -0800

We can probably just use "can" here.  From an interoperability standpoint, there is no value to recommending any particular value.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4798#issuecomment-764961359

---

From: afrind <[email-masked]>
Date: Tue, 26 Jan 2021 09:29:35 -0800

Does SHOULD -> can mean this is a design change?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4798#issuecomment-767701786

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 26 Jan 2021 09:56:06 -0800

Yes, so if you're advocating doing that then I'll mark this as design.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4798#issuecomment-767718839

---

From: Dmitri Tikhonov <[email-masked]>
Date: Tue, 26 Jan 2021 13:05:23 -0800

The _SHOULD_ is there to guard against memory exhaustion attacks.  Streams "parking" is a QPACK design feature.  The _SHOULD_ should stay.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4798#issuecomment-767826963

---

From: afrind <[email-masked]>
Date: Tue, 26 Jan 2021 15:32:51 -0800

The plan is to leave the SHOULD, but add more editorial text in 2.2.1 explaining why it's a good idea.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4798#issuecomment-767899076

---

From: afrind <[email-masked]>
Date: Wed, 27 Jan 2021 10:11:41 -0800

Closed #4798 via #4818.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4798#event-4257280026