Subject: [quicwg/base-drafts] Érik Vyncke's Transport Comment 16 (#4539)

From: Lucas Pardue <[email-masked]>
Date: Tue, 05 Jan 2021 19:51:52 -0800

Érik Vyncke said:

> -- Section 1 --
> In "QUIC authenticates all packets and encrypts as much as is practical." it is
> a little unclear to me whether the 'as much' applies only to 'encrypts' or also
> on 'authenticates'. Or is it clear for an English-native speaker (that I am
> not).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4539

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 14:33:54 -0800

This is deliberate.  Everything is authenticated (absent some unused fields in Retry packets and Version Negotiation, which has a big TBD on it).  As much as possible is encrypted.

I'm going to propose no action here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4539#issuecomment-755758395

---

From: Mike Bishop <[email-masked]>
Date: Thu, 07 Jan 2021 06:48:54 -0800

Well, it's not deliberate that he has trouble parsing it, so I don't think that's the right way to justify a no-action.  This is an editorial comment.  Something like "QUIC authenticates all packets; as much of each packet as practical is also encrypted." would make the same statement with less possibility of misunderstanding.

As a native speaker, I don't find the current text confusing, but I also realize that our audience includes those from different backgrounds; I'm not opposed to making an editorial change here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4539#issuecomment-756161519

---

From: Jana Iyengar <[email-masked]>
Date: Sun, 10 Jan 2021 17:39:31 -0800

Closed #4539 via #4717.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4539#event-4188673228