Subject: [quicwg/base-drafts] Éric Vyncke's HTTP/3 Comment 7 (#4757)

From: Lucas Pardue <[email-masked]>
Date: Tue, 19 Jan 2021 09:49:45 -0800

@evyncke said

> -- Section 11.2.1 and others --
> I must admit that the purpose of the special "0x1f * N + 0x21" values are
> unknown to me (or is it only for application padding as described in the
> security section?) but shouldn't they be reserved in the IANA registry?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4757

---

From: Mike Bishop <[email-masked]>
Date: Tue, 19 Jan 2021 13:59:50 -0800

We believe the note, updated based on IANA feedback during Last Call, is sufficient.  Reserving 148 quadrillion values in the registry would cause the registry to be impossible to download in the lifetime of humanity; see #4428.

The purpose is described in [Section 7.2.8](https://quicwg.org/base-drafts/draft-ietf-quic-http.html#section-7.2.8), to exercise the requirement to ignore unknown frame types (a.k.a. GREASE).

Proposal is to make no change; this was already covered during IANA review.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4757#issuecomment-763168640

---

From: Eric Vyncke <[email-masked]>
Date: Wed, 20 Jan 2021 03:49:53 -0800

If IANA has agreed, then I am fine with it.

BTW, I was not asking to make those zillions of reservations but leaving a note in the registry ;-)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4757#issuecomment-763550730

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 26 Jan 2021 15:22:57 -0800

It's a fair question but the WG and the responsible AD are satisfied with our IANA considerations at this stage, closing with no action.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4757#issuecomment-767895026

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 26 Jan 2021 15:22:57 -0800

Closed #4757.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4757#event-4253188509