Subject: [quicwg/base-drafts] Reference more TCP RFCs (#4598)

From: ianswett <[email-masked]>
Date: Wed, 06 Jan 2021 13:29:27 -0800

Fixes #4554
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4598

-- Commit Summary --

  * Reference more TCP RFCs

-- File Changes --

    M draft-ietf-quic-recovery.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4598.patch
https://github.com/quicwg/base-drafts/pull/4598.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4598

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 15:21:20 -0800

@martinthomson approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4598#pullrequestreview-563102452

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 15:21:42 -0800

@martinthomson commented on this pull request.

> @@ -209,9 +209,9 @@ multiple round trips.
 
 ## No Reneging
 
-QUIC ACKs contain information that is similar to TCP SACK, but QUIC does not
-allow any acknowledged packet to be reneged, greatly simplifying implementations
-on both sides and reducing memory pressure on the sender.
+QUIC ACKs contain information that is similar to TCP SACK ({{?RFC6675}}), but

Should SACK be expanded on first use?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4598#pullrequestreview-563102531

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 06 Jan 2021 19:08:06 -0800

@janaiyengar commented on this pull request.

> +QUIC ACKs contain information that is similar to TCP SACK ({{?RFC6675}}), but
+QUIC does not allow any acknowledged packet to be reneged, greatly simplifying
+implementations on both sides and reducing memory pressure on the sender.

```suggestion
QUIC ACK frames contain information similar to that in TCP Selective
Acknowledgements (SACKs, {{?RFC2018}}). However, QUIC does not allow a packet
acknowledgement to be reneged, greatly simplifying implementations on both sides
and reducing memory pressure on the sender.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4598#pullrequestreview-563182485

---

From: ianswett <[email-masked]>
Date: Thu, 07 Jan 2021 11:46:17 -0800

@ianswett pushed 1 commit.

d5dacc8297df4d940590be9f4ea760e87d2b73a5  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4598/files/c98b9df251e78e2f5ad2692e8bd5c8ca7ba5080f..d5dacc8297df4d940590be9f4ea760e87d2b73a5

---

From: ianswett <[email-masked]>
Date: Thu, 07 Jan 2021 11:46:36 -0800

@ianswett commented on this pull request.

 ## No Reneging

Good point, Jana did that for me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4598#discussion_r553550424

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 07 Jan 2021 16:51:27 -0800

Merged #4598 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4598#event-4182355813