Subject: [quicwg/base-drafts] Érik Vyncke's Transport Comment 2 (#4525)

From: Lucas Pardue <[email-masked]>
Date: Tue, 05 Jan 2021 19:45:49 -0800

Érik Vyncke said:

> -- Section 2.2 --
>   "an endpoint MAY treat receipt of different data at
>    the same offset within a stream as a connection error of type
>    PROTOCOL_VIOLATION."
> 
> Should it be a SHOULD or even a MUST rather than a MAY ? Even if streams are
> protected, isn't it a security issue to allow overwrite of a stream ? Esp when
> the endpoints could deliver out-of-order to the application ?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4525

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 02:04:21 -0800

It can't be a MUST.  Our established principles for errors handling requires that it be reasonable to ask every implementation to run the check for violations.  Checking this is not cheap.  I don't think that anyone was willing to commit to checking in this case.  Many stacks don't touch bytes if that can be avoided.

For similar reasons, this can't be SHOULD, to recommend this, we'd need most implementations being willing to check.  So we arrive at MAY.

This is a pattern we have used for a number of other cases where checking protocol conformance might be expensive.

It's not necessarily a security issue.  That only really happens if you have an two things looking at the bytes in different ways.  As we expect receivers to only read bytes once, it is unlikely that there is any opportunity for a bait-and-switch.  Finally, we don't explicitly allow for a third party in the protocol, which is one case I'm aware of where this could happen.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4525#issuecomment-755206371

---

From: MikkelFJ <[email-masked]>
Date: Thu, 07 Jan 2021 09:37:09 -0800

Agreed, but it may be worth a note in security considerations relating to how API's are designed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4525#issuecomment-756266532

---

From: Martin Thomson <[email-masked]>
Date: Thu, 07 Jan 2021 14:42:56 -0800

I think that would be too fine a point to be making.  It would also require a lot more text than my brief note here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4525#issuecomment-756432045

---

From: Martin Thomson <[email-masked]>
Date: Mon, 11 Jan 2021 20:36:14 -0800

This is not an editorial comment, so I can't close it, but I propose that we do so.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4525#issuecomment-758392438

---

From: Lars Eggert <[email-masked]>
Date: Tue, 12 Jan 2021 00:17:10 -0800

Labelling this as design, but am noting your suggestion to close with no action.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4525#issuecomment-758487461

---

From: David Schinazi <[email-masked]>
Date: Wed, 13 Jan 2021 08:59:52 -0800

I support closing with no action.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4525#issuecomment-759584050