Subject: [quicwg/base-drafts] Closure alerts are errors too (#4570)

From: Martin Thomson <[email-masked]>
Date: Tue, 05 Jan 2021 21:05:22 -0800

This changes the shape of the requirement from one that proscribes the
behaviour of a TLS stack to the reaction of QUIC to a warning level
alert.  This recommends treating them as fatal as QUIC never
deliberately closes TLS.

This is a normative change that should have no practical effect on
implementations.

Closes #4485.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4570

-- Commit Summary --

  * Closure alerts are errors too

-- File Changes --

    M draft-ietf-quic-tls.md (7)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4570.patch
https://github.com/quicwg/base-drafts/pull/4570.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4570

---

From: Marten Seemann <[email-masked]>
Date: Tue, 05 Jan 2021 21:07:27 -0800

@marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4570#pullrequestreview-562327985

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 05 Jan 2021 21:50:33 -0800

@janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4570#pullrequestreview-562340636

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 05 Jan 2021 22:41:18 -0800

@kazuho approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4570#pullrequestreview-562357315

---

From: David Schinazi <[email-masked]>
Date: Wed, 06 Jan 2021 04:19:09 -0800

@DavidSchinazi approved this pull request.

I agree that this is a good improvement, especially for folks who can't modify their TLS stack.

> @@ -803,8 +803,11 @@ added to 0x100 to produce a QUIC error code from the range reserved for
 CRYPTO_ERROR. The resulting value is sent in a QUIC CONNECTION_CLOSE frame of
 type 0x1c.
 
-The alert level of all TLS alerts is "fatal"; a TLS stack MUST NOT generate
-alerts at the "warning" level.
+QUIC is only able to convey an alert level of "fatal". The only existing uses

```suggestion
QUIC is only able to convey an alert level of "fatal". In TLS 1.3, the only existing uses
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4570#pullrequestreview-562667204

---

From: ianswett <[email-masked]>
Date: Wed, 06 Jan 2021 08:28:00 -0800

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4570#pullrequestreview-562853451

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 16:27:37 -0800

@martinthomson pushed 1 commit.

a7806d569497c228dd4d339545db301c67dd148f  qualify

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4570/files/4cad27d2cd1183446aa245d9353c8c7816eeb28f..a7806d569497c228dd4d339545db301c67dd148f

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 16:28:08 -0800

0625b35a2def96b9d17a9137e622ca1121417ac4  Wrap

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4570/files/a7806d569497c228dd4d339545db301c67dd148f..0625b35a2def96b9d17a9137e622ca1121417ac4

---

From: Sean Turner <[email-masked]>
Date: Fri, 08 Jan 2021 04:06:36 -0800

@seanturner approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4570#pullrequestreview-564211551

---

From: kaduk <[email-masked]>
Date: Wed, 13 Jan 2021 15:10:16 -0800

@kaduk approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4570#pullrequestreview-567733110

---

From: Martin Thomson <[email-masked]>
Date: Thu, 14 Jan 2021 14:58:35 -0800

Merged #4570 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4570#event-4208575155