Subject: [quicwg/base-drafts] Robert Wilton's Comment 2 (#4669)

From: Lucas Pardue <[email-masked]>
Date: Wed, 06 Jan 2021 18:40:40 -0800

Rob Wilton said:

> This may not be discuss worthy, but some of the spin bit behaviour is
> inconsistently defined between the quic transport and quic manageability
> drafts.  Specifically:
>   - The transport draft states that at least 1 in 16 connections "MUST" disable
>   spinning, whereas the manageability draft states this as "recommended". - In
>   the case that the spin bit is disabled, the transport draft uses
>   "RECOMMENDED" to use a random value for each packet, or chosen independently
>   for each connection.  Whereas the manageability draft uses "can" and lists
>   the two options in the opposite order.
>
>   For this review, since it is in IESG review, I've presumed that the transport
>   draft has the definitive definitions and the manageability draft is lagging.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4669

---

From: mirjak <[email-masked]>
Date: Thu, 07 Jan 2021 04:37:31 -0800

These statements are not meant as normative clauses in the manageability document but rather to explain what to expect from QUIC. I recreated a PR to simply remove the "recommended" phrasing (see https://github.com/quicwg/ops-drafts/pull/169). I believe the "can" is still okay in this context but we can also use another phrasing here and change the listed order if that makes it more clear...?

Thanks for noting this!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4669#issuecomment-756091345

---

From: Martin Thomson <[email-masked]>
Date: Thu, 07 Jan 2021 17:00:38 -0800

Closing as it is not relevant.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4669#issuecomment-756480168

---

From: Martin Thomson <[email-masked]>
Date: Thu, 07 Jan 2021 17:00:38 -0800

Closed #4669.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4669#event-4182384150