Subject: [quicwg/base-drafts] Barry Leiba's Transport Comment 3 (#4560)

From: Lucas Pardue <[email-masked]>
Date: Tue, 05 Jan 2021 20:23:18 -0800

Barry Leiba said:

> — Section 4 —
> 
>    It is necessary to limit the amount of data that a receiver could
>    buffer, to prevent a fast sender from overwhelming a slow receiver,
>    or to prevent a malicious sender from consuming a large amount of
>    memory at a receiver.
> 
> You’re not talking about limiting the ability of the receiver (“could buffer”),
> but limiting the potential buffering requirement on the client (“has to
> buffer”), yes?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4560

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 16:11:00 -0800

receiver/client is an invalid comparison here, so this is a bit of a confusing question.  The point is to ensure that a receiver *can* limit what space it commits for buffering.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4560#issuecomment-755789576

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 11 Jan 2021 18:13:45 -0800

Closed #4560 via #4719.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4560#event-4193655794