Subject: [quicwg/base-drafts] Not unauthenticated, but those that cannot be processed (#4736)

From: Jana Iyengar <[email-masked]>
Date: Tue, 12 Jan 2021 07:14:43 +0000 (UTC)

Closes #4711.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4736

-- Commit Summary --

  * sync
  * Not unauthenticated, but packets it cannot process

-- File Changes --

    M draft-ietf-quic-recovery.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4736.patch
https://github.com/quicwg/base-drafts/pull/4736.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4736

---

From: Martin Thomson <[email-masked]>
Date: Mon, 11 Jan 2021 23:15:12 -0800

@martinthomson approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4736#pullrequestreview-565989718

---

From: ianswett <[email-masked]>
Date: Tue, 12 Jan 2021 14:54:22 -0800

@ianswett commented on this pull request.

> +An endpoint that always retransmits packets in response to receiving packets
+that it cannot process risks creating an infinite exchange of packets.

```suggestion
An endpoint that always retransmits packets in response to receiving
unprocessable packets risks creating an infinite exchange of packets.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4736#pullrequestreview-566768882

---

From: ianswett <[email-masked]>
Date: Tue, 12 Jan 2021 14:54:38 -0800

@ianswett approved this pull request.

LG, one suggestion

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4736#pullrequestreview-566769044

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 12 Jan 2021 15:12:06 -0800

@janaiyengar pushed 1 commit.

c92b4b3d560969c94dbfcacc81e7b7d230691610  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4736/files/b411aee9dbb0c90c27ffe32aa586f6f5079720d6..c92b4b3d560969c94dbfcacc81e7b7d230691610

---

From: Martin Thomson <[email-masked]>
Date: Tue, 12 Jan 2021 16:12:41 -0800

@martinthomson commented on this pull request.

I don't like this change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4736#discussion_r556179218

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 12 Jan 2021 16:26:51 -0800

@janaiyengar commented on this pull request.

Yeah, I think that this changes what an endpoint cannot do right now to a property of the packets. I'm reverting this change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4736#discussion_r556183769

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 12 Jan 2021 16:28:13 -0800

33b5a53b167a687d8dc3a69195bee981b928069e  revert unprocessable packets

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4736/files/c92b4b3d560969c94dbfcacc81e7b7d230691610..33b5a53b167a687d8dc3a69195bee981b928069e

---

From: Martin Thomson <[email-masked]>
Date: Tue, 12 Jan 2021 16:28:38 -0800

Merged #4736 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4736#event-4198778909