Subject: [quicwg/base-drafts] Ben Kaduk's Transport Comment 18 (#4625)

From: Lucas Pardue <[email-masked]>
Date: Wed, 06 Jan 2021 17:10:55 -0800

@kaduk said:

> Section 9
>
> > The design of QUIC relies on endpoints retaining a stable address for
> > the duration of the handshake.  [...]
>
> Why do we allow PATH_CHALLENGE (and the impossible PATH_RESPONSE) to be
> sent in 0-RTT frames, then?  (This might dupe a comment later...)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4625

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 19:37:03 -0800

We don't have prohibitions on any frame type in 0-RTT as opposed to 1-RTT.  Those things that can't appear in 0-RTT can't because they are only sent in response to other activity.

Just a question.  No action proposed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4625#issuecomment-755861876

---

From: kaduk <[email-masked]>
Date: Wed, 06 Jan 2021 19:40:47 -0800

Well, we should handle things consistently in Table 3 whichever way we want to call it.  Right now the table says "no-0-RTT" for ACK and nothing else, and I don't see how the situation for ACK is fundamentally different than for at least PATH_RESPONSE if not others.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4625#issuecomment-755862977

---

From: Mike Bishop <[email-masked]>
Date: Fri, 08 Jan 2021 13:40:47 -0800

Incidentally, the table also says that CRYPTO and NEW_TOKEN are impossible in 0-RTT but possible in 1-RTT.

ACK can't be sent in 0-RTT, because you can't (legally) have processed any packets in the 0/1-RTT packet number space while you're still sending 0-RTT packets.  At the point in which you're allowed to start processing incoming 1-RTT packets from the server, you have 1-RTT send keys and are prohibited from continuing to send in 0-RTT.

By the same logic, it's impossible to send a PATH_RESPONSE in 0-RTT.  That should probably be fixed in the table.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4625#issuecomment-757010949

---

From: Jana Iyengar <[email-masked]>
Date: Sun, 10 Jan 2021 17:16:15 -0800

This point seems reasonable and the so is @MikeBishop's fix in #4720.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4625#issuecomment-757580443

---

From: Martin Thomson <[email-masked]>
Date: Sun, 10 Jan 2021 18:09:31 -0800

Closed #4625 via #4720.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4625#event-4188705781