Subject: [quicwg/base-drafts] Remove SHOULD regarding QUIC bit on VN (#4471)

From: Martin Thomson <[email-masked]>
Date: Mon, 04 Jan 2021 15:39:13 -0800

Closes #4468.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4471

-- Commit Summary --

  * Remove SHOULD regarding QUIC bit on VN

-- File Changes --

    M draft-ietf-quic-transport.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4471.patch
https://github.com/quicwg/base-drafts/pull/4471.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4471

---

From: ianswett <[email-masked]>
Date: Tue, 05 Jan 2021 08:25:55 -0800

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4471#pullrequestreview-561936119

---

From: mirjak <[email-masked]>
Date: Thu, 07 Jan 2021 04:21:17 -0800

@mirjak commented on this pull request.

> @@ -4636,10 +4636,8 @@ Version Negotiation Packet {
 ~~~
 {: #version-negotiation-format title="Version Negotiation Packet"}
 
-The value in the Unused field is selected randomly by the server.  Clients MUST
-ignore the value of this field.  Servers SHOULD set the most significant bit of
-this field (0x40) to 1 so that Version Negotiation packets appear to have the
-Fixed Bit field.
+The value in the Unused field is set to an arbitrary value by the server.

I guess it would make sense to note that this bit can not be assumptned to be 1 for VN packets also earlier in the document as the section on long header packets says: 

```
The next bit (0x40) of byte 0 is set to 1. Packets containing a zero value for this bit are not valid packets in this version and MUST be discarded.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4471#pullrequestreview-563442697

---

From: Martin Thomson <[email-masked]>
Date: Mon, 11 Jan 2021 20:02:37 -0800

@martinthomson pushed 1 commit.

414eb367e0dc2d09af7481557e4691be7f1b40f1  Note VN exception

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4471/files/0f6190fa336fa787dd473f6cfbb29cc08ba2d5b5..414eb367e0dc2d09af7481557e4691be7f1b40f1

---

From: David Schinazi <[email-masked]>
Date: Wed, 13 Jan 2021 09:01:42 -0800

@DavidSchinazi approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4471#pullrequestreview-567433600

---

From: Martin Thomson <[email-masked]>
Date: Thu, 14 Jan 2021 14:44:52 -0800

Closing in line with discussions.  Will pursue an explanation instead.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4471#issuecomment-760524016

---

From: Martin Thomson <[email-masked]>
Date: Thu, 14 Jan 2021 14:44:52 -0800

Closed #4471.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4471#event-4208537553