Subject: [quicwg/base-drafts] Coalescing for padding clarification (#4738)

From: Lars Eggert <[email-masked]>
Date: Tue, 12 Jan 2021 05:44:35 -0800

This text in `#initial-size` seems to cause confusion for implementors:
> by adding PADDING frames to the Initial packet or by coalescing the Initial packet; see {{packet-coalesce}}

since it leaves it unclear *what* the Initial packet can be coalesced with to pad it. Specifically, some implementations use zeros or other (random) data, which seems to surprise some implementors.

(`#packet-coalesce`, which is referred to, also doesn't seem to clarify this.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4738

---

From: Tatsuhiro Tsujikawa <[email-masked]>
Date: Tue, 12 Jan 2021 07:52:35 -0800

My understanding is that transport draft does not say anything about padding outside QUIC packet.  Because a receiver is required to ignore invalid long packets, zero padding outside QUIC packet just works.  So this is "OK because it is not explicitly disallowed" category.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4738#issuecomment-758750668

---

From: Lars Eggert <[email-masked]>
Date: Tue, 12 Jan 2021 07:57:39 -0800

I agree, but it has tripped up implementers (again). I wonder if a wording can be found that doesn't do that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4738#issuecomment-758753928

---

From: ianswett <[email-masked]>
Date: Tue, 12 Jan 2021 07:59:03 -0800

I'd be happy to see a bit more explicit text to clarify this, since as you said, it's come up a few times as non-obvious.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4738#issuecomment-758754887

---

From: Lars Eggert <[email-masked]>
Date: Tue, 12 Jan 2021 08:02:06 -0800

Maybe something like: "An Initial that is padded by coalescing could be coalesced with valid or even invalid QUIC packets; the latter MUST be ignored as described in Section XYZ."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4738#issuecomment-758756911

---

From: Martin Thomson <[email-masked]>
Date: Tue, 12 Jan 2021 16:42:03 -0800

Closed #4738 via 2000306a1d49c91f7fdcf38e7912a19610b1762c.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4738#event-4198830657