Subject: [quicwg/base-drafts] Ben Kaduk's Transport Comment 3 (#4610)

From: Lucas Pardue <[email-masked]>
Date: Wed, 06 Jan 2021 16:54:35 -0800

@kaduk said:

> Section 2.4
> 
> > *  write data, understanding when stream flow control credit
> >    (Section 4.1) has successfully been reserved to send the written
> >    data;
> 
> (side note) I note that "flow control credit has been reserved" is
> different than "has been ACKd by the peer".  I guess the expectation is
> that if such information is needed, an application-layer ACK should be
> used, since QUIC ACKs can be sent before the peer application has
> consumed the received data?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4610

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 17:15:46 -0800

Yes.  QUIC stacks could provide an API that indicates that data was received by a peer, but it is not a very useful signal, because it says nothing about whether it was read by the other side, only that it was buffered.  As the original E2E paper says: any number of things can go wrong from that point that would mean failure to the application, rendering the intermediate-level signal less useful as anything other than an optimization.

This is a question and needs no change in response.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4610#issuecomment-755820859

---

From: Martin Thomson <[email-masked]>
Date: Mon, 11 Jan 2021 20:45:58 -0800

Closed #4610.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4610#event-4193965516