Subject: [quicwg/base-drafts] TLS doesn't have to pad (#4821)

From: Martin Thomson <[email-masked]>
Date: Thu, 28 Jan 2021 16:35:22 -0800

Cleanup the language here a little.

Closes #4745.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4821

-- Commit Summary --

  * TLS doesn&#39;t have to pad

-- File Changes --

    M draft-ietf-quic-tls.md (7)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4821.patch
https://github.com/quicwg/base-drafts/pull/4821.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4821

---

From: David Schinazi <[email-masked]>
Date: Thu, 28 Jan 2021 18:06:13 -0800

@DavidSchinazi approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4821#pullrequestreview-578888710

---

From: Marten Seemann <[email-masked]>
Date: Thu, 28 Jan 2021 18:42:01 -0800

@marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4821#pullrequestreview-578901126

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 28 Jan 2021 19:15:49 -0800

@janaiyengar commented on this pull request.

> +enough that the Initial packet fills a datagram of the minimum size required for
+carring Initial packets. QUIC implementations use PADDING frames or packet
+coalescing to ensure that datagrams are large enough; see {{Section 14.1 of
+QUIC-TRANSPORT}}.

```suggestion
enough to meet QUIC's requirements for Initial packets; see {{Section 14.1 of
QUIC-TRANSPORT}}. QUIC implementations use PADDING frames or packet coalescing
to ensure that datagrams are large enough.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4821#pullrequestreview-578911879

---

From: Martin Thomson <[email-masked]>
Date: Thu, 28 Jan 2021 20:13:22 -0800

@martinthomson commented on this pull request.

That is where I started, but we don't have requirements for packets, we have requirements for datagrams.  Maybe "...for datagrams that carry Initial packets..."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4821#discussion_r566568237

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 28 Jan 2021 20:16:12 -0800

Ah, yes, makes sense. "datagrams that carry Initial packets" works.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4821#discussion_r566568953

---

From: Martin Thomson <[email-masked]>
Date: Thu, 28 Jan 2021 20:47:09 -0800

@martinthomson pushed 1 commit.

6e45d1adc9d32b6ee3973a9a98461decd5026ab3  Tweak

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4821/files/f32daed82b0d4ddad645958d4c217cd9ce5464db..6e45d1adc9d32b6ee3973a9a98461decd5026ab3

---

From: Sean Turner <[email-masked]>
Date: Fri, 29 Jan 2021 07:44:57 -0800

@seanturner approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4821#pullrequestreview-579377039