Subject: [quicwg/base-drafts] Ben Kaduk's TLS Comment 30 (#4506)

From: Lucas Pardue <[email-masked]>
Date: Tue, 05 Jan 2021 19:03:56 -0800

@kaduk said:

> Appendix B.1.1, B.1.2
> 
> I don't think that Theorem 4.3 of [GCM-MU] is the right reference for
> both formulae.  (I actually had trouble matching up any of the formulae
> in the paper with the ones here due to different variable names, and ran
> out of time to dig further.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4506

---

From: Martin Thomson <[email-masked]>
Date: Tue, 05 Jan 2021 23:25:07 -0800

It is 4.3, though the intermediate working is not entirely obvious.  That is, the full form is:

![image](https://user-images.githubusercontent.com/67641/103740541-850e2c80-504b-11eb-8741-4fcdb9c92481.png)

The formulae shown in the draft discard irrelevant factors and just concentrate on those that include q or v (these map to I think \sigma and q in the paper, and our q also contributes to B as that theorem is a MU result).  I don't have this all paged in right now, but I'm happy to walk through the derivation some time.  I was able to validate the results Felix provided here, as were Chris Wood and Ekr, I would expect you to be able to as well.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4506#issuecomment-755133566

---

From: kaduk <[email-masked]>
Date: Sat, 09 Jan 2021 19:59:51 -0800

Okay.  Mostly I just wanted to check that it wasn't theorem 4.2 for one formula and 4.3 for the other.  Sorry for not having persevered at it (I was past my time budget for -tls at this point).
To be clear, that's "close with no change".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4506#issuecomment-757410549

---

From: Lucas Pardue <[email-masked]>
Date: Sun, 10 Jan 2021 13:15:33 -0800

Since the Comment Maker is happy to close with no action, that is what I'm doing.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4506#issuecomment-757545174

---

From: Lucas Pardue <[email-masked]>
Date: Sun, 10 Jan 2021 13:15:34 -0800

Closed #4506.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4506#event-4188441009