Subject: [quicwg/base-drafts] Ben Kaduk's TLS Comment 16 (#4492)

From: Lucas Pardue <[email-masked]>
Date: Tue, 05 Jan 2021 18:55:57 -0800

@kaduk said:

> Section 5.4.x
> 
> Are we really sure that we want to use normative pseudocode?  I thought
> (but cannot currently substantiate) that we typically preferred
> normative prose and example pseudocode, since pseudocode somewhat
> intrinsically has not-fully-specified semantics.  As some specific (but
> not comprehensive!) examples, which bytes of the mask are used when the
> packet number is encoded in fewer than 4 bytes, and the key/plaintext
> inputs to AES-ECB seem to only be specified in the pseudocode.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4492

---

From: Martin Thomson <[email-masked]>
Date: Tue, 05 Jan 2021 21:59:13 -0800

That's just an oops.  There is a paragraph that *almost* defines this in prose.  It just needs a little push and we don't need to rely exclusively on pseudocode.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4492#issuecomment-755099537

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 21:44:48 -0800

Closed #4492 via #4572.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4492#event-4178282451