Subject: [quicwg/base-drafts] Explain TLS/QUIC key update differences (#4576)

From: Martin Thomson <[email-masked]>
Date: Tue, 05 Jan 2021 22:27:03 -0800

Closes #4497.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4576

-- Commit Summary --

  * Explain TLS/QUIC key update differences

-- File Changes --

    M draft-ietf-quic-tls.md (3)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4576.patch
https://github.com/quicwg/base-drafts/pull/4576.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4576

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 05 Jan 2021 22:36:23 -0800

@kazuho approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4576#pullrequestreview-562355543

---

From: Marten Seemann <[email-masked]>
Date: Tue, 05 Jan 2021 22:57:04 -0800

@marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4576#pullrequestreview-562362934

---

From: ianswett <[email-masked]>
Date: Wed, 06 Jan 2021 08:28:56 -0800

@ianswett approved this pull request.

> @@ -1452,6 +1452,9 @@ without needing to receive the first packet that triggered the change.  An
 endpoint that notices a changed Key Phase bit updates keys and decrypts the
 packet that contains the changed value.
 
+Initiating a key updates results in both endpoints updating keys.  This differs

```suggestion
Initiating a key update results in both endpoints updating keys.  This differs
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4576#pullrequestreview-562854164

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 16:32:41 -0800

@martinthomson pushed 1 commit.

9d42f066e9739beeb2c78c9231522f6c97054361  plural/not

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4576/files/8c56d8db7e977f72aa312bf6ecdc56c75ef44cf7..9d42f066e9739beeb2c78c9231522f6c97054361

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 06 Jan 2021 22:47:17 -0800

@janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4576#pullrequestreview-563245174

---

From: Sean Turner <[email-masked]>
Date: Fri, 08 Jan 2021 04:17:21 -0800

@seanturner approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4576#pullrequestreview-564217178

---

From: kaduk <[email-masked]>
Date: Sat, 09 Jan 2021 19:36:03 -0800

@kaduk approved this pull request.

Thank you!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4576#pullrequestreview-564825974

---

From: Martin Thomson <[email-masked]>
Date: Sun, 10 Jan 2021 18:25:21 -0800

Merged #4576 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4576#event-4188724052