Subject: [quicwg/base-drafts] Ben Kaduk's Transport Comment 12 (#4619)

From: Lucas Pardue <[email-masked]>
Date: Wed, 06 Jan 2021 17:07:32 -0800

@kaduk said:

> Section 7.4
>
> >                 Application protocols can recommend values for
> > transport parameters, such as the initial flow control limits.
> > However, application protocols that set constraints on values for
> > transport parameters could make it impossible for a client to offer
> > multiple application protocols if these constraints conflict.
>
> Should we go a step further and forbid application protocols from making
> such requirements?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4619

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 17:43:59 -0800

No.  I think that making protocols aware of the risk to potential cohabitation is sufficient.  There are cases where it might be deemed acceptable not to potentially share a handshake between protocols.  We just wanted to ensure that this wasn't done accidentally.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4619#issuecomment-755829718

---

From: Martin Thomson <[email-masked]>
Date: Mon, 11 Jan 2021 20:55:27 -0800

Closed #4619.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4619#event-4193984410