Subject: [quicwg/base-drafts] Robert Wilton's Comment 11 (#4678)

From: Lucas Pardue <[email-masked]>
Date: Wed, 06 Jan 2021 18:45:35 -0800

Rob Wilton said:

> >   16. Variable-Length Integer Encoding
> >
> >    No requirement to send integers in smallest encoding possible?  E.g. okay
> >    to send the value 3 in an 8 byte field?
>
> This section doesn't indicate whether a sender is allowed to send integers not
> using the smallest possible encoding, and doesn't indicate whether a receive is
> expected to process non optimal encodings.  It might be helpful to be explicit.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4678

---

From: Martin Thomson <[email-masked]>
Date: Thu, 07 Jan 2021 17:19:51 -0800

The one case where non-optimal encodings are forbidden is https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#section-12.4-18

Otherwise, there is no restriction.  Yes, 3 can be encoded in 8 bytes.  But it is worth noting.  (I thought that we had.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4678#issuecomment-756486044

---

From: Jana Iyengar <[email-masked]>
Date: Sun, 10 Jan 2021 18:10:29 -0800

Closed #4678 via #4704.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4678#event-4188706759