Subject: [quicwg/base-drafts] Ben Kaduk's Invariants Comment 5 (#4512)

From: Lucas Pardue <[email-masked]>
Date: Tue, 05 Jan 2021 19:27:47 -0800

@kaduk said:

> Appendix A
> 
>    *  The Version field in a QUIC long header is the same in both
>       directions
> 
> (I note that this implicitly assumes there are only two directions.  We do
> explicitly assume there are only two parties involved, so perhaps this
> is acceptable.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4512

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 00:59:48 -0800

Yes.  You might have said that "both directions" just represents another bad assumption about this being a two-party protocol, but we explicitly say that it is.

There were comments about multi-party communications, that's a problem that I would like to leave the problems of defining that to an update of this document.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4512#issuecomment-755173862

---

From: kaduk <[email-masked]>
Date: Thu, 07 Jan 2021 15:54:21 -0800

Thanks; let's close with no change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4512#issuecomment-756457596

---

From: Martin Thomson <[email-masked]>
Date: Thu, 07 Jan 2021 17:36:44 -0800

Closed #4512.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4512#event-4182459685