Subject: [quicwg/base-drafts] Ben Kaduk's QPACK Comment 5 (#4795)

From: Lucas Pardue <[email-masked]>
Date: Thu, 21 Jan 2021 06:21:00 -0800

@kaduk said

> Appendix B
>
> I worked through the examples.  The presentation format is quite nice, and
> I appreciate all the detailed breakdowns!
>
> However, we show the dynamic table as being 1-indexed, but I'm pretty
> sure the prose says it should be 0-indexed.  We do it consistently, at
> least, and toss some extra '1's into the math to make the numbers work
> out, but since the static table is by definition 0-indexed, it's a bit
> weird to show the dynamic table as 1-indexed.
>
> Additionally, I think that B.5 is an exception to the "we do it
> consistently" -- while the 81... dynamic insert with relative index 1
> does refer to the indicated custom-key field, that would be absolute
> index 3 in the 1-indexed presentation we give (though it would be
> absolute index 2 if 0-indexed, if I'm getting this right).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4795

---

From: afrind <[email-masked]>
Date: Mon, 25 Jan 2021 16:01:36 -0800

Thank you for working through the examples in such detail -- I'm glad you like them and the format!

These are both excellent catches.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4795#issuecomment-767190410

---

From: afrind <[email-masked]>
Date: Wed, 27 Jan 2021 09:21:36 -0800

Closed #4795 via #4816.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4795#event-4257053059