Subject: [quicwg/base-drafts] Ben Kaduk's Transport Comment 31 (#4643)

From: Lucas Pardue <[email-masked]>
Date: Wed, 06 Jan 2021 18:00:21 -0800

@kaduk said:

> Section 17.2.5.1
>
> > A server MAY send Retry packets in response to Initial and 0-RTT
> > packets.  A server can either discard or buffer 0-RTT packets that it
> > receives.  A server can send multiple Retry packets as it receives
> > Initial or 0-RTT packets.  A server MUST NOT send more than one Retry
> > packet in response to a single UDP datagram.
>
> When the server sends multiple Retry packets in such a scenario, do the
> Source Connection ID fields need to be different (or the same) across
> all of them?  (Or does it not matter?)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4643

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 22:08:22 -0800

Yes, a server might send many Retry packets.  We don't require that the connection ID be the same though.  Our defense there is  that the client will only process one Retry.

This is a question and doesn't require any action.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4643#issuecomment-755907548

---

From: Martin Thomson <[email-masked]>
Date: Mon, 11 Jan 2021 20:07:55 -0800

Closed #4643.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4643#event-4193893126