Subject: [quicwg/base-drafts] The transport parameter removes EOED (#4689)

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 23:08:23 -0800

As agreed via mail.

Closes #4475.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4689

-- Commit Summary --

  * The transport parameter removes EOED

-- File Changes --

    M draft-ietf-quic-tls.md (3)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4689.patch
https://github.com/quicwg/base-drafts/pull/4689.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4689

---

From: Marten Seemann <[email-masked]>
Date: Wed, 06 Jan 2021 23:09:28 -0800

@marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4689#pullrequestreview-563253322

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 07 Jan 2021 07:43:52 +0000 (UTC)

@janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4689#pullrequestreview-563267882

---

From: Nick Banks <[email-masked]>
Date: Thu, 07 Jan 2021 07:56:11 -0800

@nibanks approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4689#pullrequestreview-563603646

---

From: Sean Turner <[email-masked]>
Date: Fri, 08 Jan 2021 04:33:15 -0800

@seanturner approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4689#pullrequestreview-564225882

---

From: David Schinazi <[email-masked]>
Date: Wed, 13 Jan 2021 08:58:21 -0800

@DavidSchinazi approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4689#pullrequestreview-567430375

---

From: ianswett <[email-masked]>
Date: Wed, 13 Jan 2021 14:53:46 -0800

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4689#pullrequestreview-567724508

---

From: kaduk <[email-masked]>
Date: Wed, 13 Jan 2021 15:13:25 -0800

@kaduk approved this pull request.

This gets the job done, with or without the suggested rewording.

> @@ -1821,6 +1821,9 @@ QUIC (such as the use of TLS with TCP defined in {{!TLS13}}).  A fatal
 unsupported_extension alert MUST be sent by an implementation that supports this
 extension if the extension is received when the transport is not QUIC.
 
+Negotiating the quic_transport_parameters extension causes the EndOfEarlyData to

```suggestion
Negotiating the quic_transport_parameters extension causes the requirement to send EndOfEarlyData to
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4689#pullrequestreview-567734571

---

From: Martin Thomson <[email-masked]>
Date: Wed, 13 Jan 2021 15:28:18 -0800

@martinthomson commented on this pull request.

I think that the shorter phrasing is better.  It's not about not having a requirement to send EOED, but a requirement to not send EOED.  And, as this refers to the very next section, the fewer words expended here the better.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4689#discussion_r556944643

---

From: Sean Turner <[email-masked]>
Date: Thu, 14 Jan 2021 08:10:13 -0800

@seanturner commented on this pull request.

For the question is whether an implementer (bot being on mind you) would be confused by the lack of "requirement to send" phrase, I tend to think that without it's still clear that you don't send EOED.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4689#discussion_r557511169

---

From: Martin Thomson <[email-masked]>
Date: Thu, 14 Jan 2021 14:58:09 -0800

Merged #4689 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4689#event-4208573995