Subject: [quicwg/base-drafts] Robert Wilton's HTTP/3 Comment 1 (#4804)

From: Lucas Pardue <[email-masked]>
Date: Thu, 21 Jan 2021 06:32:32 -0800

@rgwilton said

> 4.1.1.  Field Formatting and Compression
>
> >   As in previous versions of HTTP, field names are strings containing a
> >   subset of ASCII characters that are compared in a case-insensitive
> >   fashion.  Properties of HTTP field names and values are discussed in
> >   more detail in Section 5.1 of [SEMANTICS].  As in HTTP/2, characters
> >   in field names MUST be converted to lowercase prior to their
> >   encoding.  A request or response containing uppercase characters in
> >   field names MUST be treated as malformed (Section 4.1.3).
>
> Why make the comparison case-insensitive given that the request MUST only use
> lowercase characters?  Presumably implementations will just do a regular case
> sensitive comparison?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4804

---

From: Martin Thomson <[email-masked]>
Date: Thu, 21 Jan 2021 13:59:20 -0800

I have to say, this is a little odd.  HTTP requires case insensitive comparison, but by calling it out here, the juxtaposition is weird.  As we force lowercase, we could just strike: "that are compared in a case-insensitive fashion"

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4804#issuecomment-764968167

---

From: Mike Bishop <[email-masked]>
Date: Fri, 22 Jan 2021 12:53:47 -0800

The first is a statement of fact about what SEMANTICS requires.  However, I agree that we reduce confusion and lose nothing by making the statement less explicit.  Interested parties can read SEMANTICS.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4804#issuecomment-765678238

---

From: Mike Bishop <[email-masked]>
Date: Mon, 25 Jan 2021 12:54:48 -0800

Closed #4804 via #4813.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4804#event-4247669408