Subject: [quicwg/base-drafts] Ben Kaduk's Transport Comment 27 (#4639)

From: Lucas Pardue <[email-masked]>
Date: Wed, 06 Jan 2021 17:58:35 -0800

@kaduk said:

> Section 13.2.3
>
> > ACK frames SHOULD always acknowledge the most recently received
> > packets, and the more out-of-order the packets are, the more
> > important it is to send an updated ACK frame quickly, [...]
>
> Do we have a strict definition of "out of order" that we adhere to?  I
> didn't see one in [QUIC-RECOVERY] on a quick search, but haven't read it
> in depth yet.
> (TCP RACK used roughly "X is out of order when X has lower sequence
> number than Y and X is received after Y is received", which is what I'll
> use as a mental model until I read otherwise.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4639

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 21:52:17 -0800

Recovery defines this concept.  Out of order is "not the next expected packet".  But this is not something that needs to be precise, as it is made in support of a general statement, not one with normative force.

Propose no action.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4639#issuecomment-755901577

---

From: Lars Eggert <[email-masked]>
Date: Tue, 12 Jan 2021 01:46:32 -0800

Closed #4639.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4639#event-4194942820