Subject: [quicwg/base-drafts] First in a range is confusing (#4706)

From: Martin Thomson <[email-masked]>
Date: Thu, 07 Jan 2021 17:49:14 -0800

Amanda from IANA says:

> I'm not sure I understand the first two paragraphs of Section 22.1.2 
> correctly, where the assignment of the "first available codepoint in a 
> range" is described. I'm not sure what the term "range" means.

I believe that the original idea was that we privilege the first unassigned value in each range of values that has a different length encoding for varints.  But as we are also using these rules for non-varint encodings, that sort of rulemaking is likely confusing.

I'm proposing that this be made simply "first unassigned codepoint".  PR to follow.

(This will affect more than just -transport, but the text change only occurs there, so I think we're OK.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4706

---

From: Martin Thomson <[email-masked]>
Date: Tue, 12 Jan 2021 16:45:01 -0800

Closed #4706 via #4707.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4706#event-4198841855