Subject: [quicwg/base-drafts] Ben Kaduk's HTTP/3 Comment 3 (#4778)

From: Lucas Pardue <[email-masked]>
Date: Wed, 20 Jan 2021 11:41:54 -0800

@kaduk said

> Section 4.1.1
>
> >  Such intermediaries
> >   SHOULD also remove other connection-specific fields, such as Keep-
> >   Alive, Proxy-Connection, Transfer-Encoding, and Upgrade, even if they
> >   are not nominated by the Connection field.
>
> I don't understand why Transfer-Encoding is intrinsically
> connection-scoped.  [HTTP11] seems to discuss it acting on a "message"
> and being tied to a specific request or response.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4778

---

From: Mike Bishop <[email-masked]>
Date: Fri, 22 Jan 2021 09:19:13 -0800

This isn't an HTTP/3 question, but a SEMANTICS question.  Transfer-Encoding is hop-by-hop, used to encode (generally, compress) a request or response body in transit.  Content-Encoding is an end-to-end encoding that intermediaries can pass without understanding.

No action for HTTP/3 here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4778#issuecomment-765564877

---

From: kaduk <[email-masked]>
Date: Mon, 25 Jan 2021 22:32:19 -0800

Agreed.
(I see now that I was assuming "connection-specific" as "applies to the entire connection" rather than "is restricted in scope to the single connection as opposed to end-to-end".)
I can't actually push the "close" button for you, though :smile: 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4778#issuecomment-767329819

---

From: Lars Eggert <[email-masked]>
Date: Tue, 26 Jan 2021 03:18:53 -0800

Closed #4778.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4778#event-4250181124