Subject: [quicwg/base-drafts] Cleanup packet padding language in TLS (#4745)

From: Martin Thomson <[email-masked]>
Date: Thu, 14 Jan 2021 22:10:25 -0800

This text could be better:

> The TLS implementation does not need to ensure that the ClientHello is large enough to meet the requirements for QUIC packets. QUIC PADDING frames are added to increase the size of the packet as necessary; see Section 14.1 of [QUIC-TRANSPORT].

Maybe instead:

> The TLS implementation does not need to ensure that the ClientHello is large enough to meet the minimum datagram size for carrying QUIC Initial packets. QUIC implementations use PADDING frames or packet coalescing to ensure that datagrams are large enough; see Section 14.1 of [QUIC-TRANSPORT].

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4745

---

From: Lars Eggert <[email-masked]>
Date: Tue, 26 Jan 2021 03:25:09 -0800

Does anyone want to prepare a PR? Otherwise, this will get dropped I guess.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4745#issuecomment-767480192

---

From: Martin Thomson <[email-masked]>
Date: Tue, 26 Jan 2021 21:10:24 -0800

I didn't want to clutter our list of stuff with post-IESG PRs.  I'll copy the above text once HTTP is done (real soon now).

We're going to have to be careful that these little tweaks don't pile up.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4745#issuecomment-768034942

---

From: Lars Eggert <[email-masked]>
Date: Thu, 28 Jan 2021 04:09:52 -0800

I think this should be good to go now?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4745#issuecomment-769011045