Subject: [quicwg/base-drafts] QPACK: explain blocked stream flow control (#4818)

From: afrind <[email-masked]>
Date: Tue, 26 Jan 2021 16:00:27 -0800

Fixes: #4798
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4818

-- Commit Summary --

  * QPACK: explain blocked stream flow control

-- File Changes --

    M draft-ietf-quic-qpack.md (5)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4818.patch
https://github.com/quicwg/base-drafts/pull/4818.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4818

---

From: Martin Thomson <[email-masked]>
Date: Tue, 26 Jan 2021 21:18:30 -0800

@martinthomson commented on this pull request.

> +To bound the memory requirements of the decoder for blocked streams, encoded
+field section data SHOULD remain in the stream's flow control window while the
+stream is blocked.  A stream becomes unblocked when the Insert Count becomes

This seems to lack the "why" still.  Instructions that are read from the stream will be unusable while blocked but they need to be retained in memory AND the protocol does not provide any way to limit allocations for that memory.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4818#pullrequestreview-576991345

---

From: Mike Bishop <[email-masked]>
Date: Wed, 27 Jan 2021 08:13:04 -0800

@MikeBishop commented on this pull request.

I agree with Martin's comment; if we're going to explain, we should cover why the reverse is bad.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4818#pullrequestreview-577508007

---

From: afrind <[email-masked]>
Date: Wed, 27 Jan 2021 09:05:16 -0800

@afrind pushed 1 commit.

3264b1e153806a58cdedb19e67d539841f5ea1ea  Explain why not

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4818/files/6cd4224f36f5eb8bbc13f299aca200599993c815..3264b1e153806a58cdedb19e67d539841f5ea1ea

---

From: Mike Bishop <[email-masked]>
Date: Wed, 27 Jan 2021 10:02:15 -0800

@MikeBishop approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4818#pullrequestreview-577614636

---

From: afrind <[email-masked]>
Date: Wed, 27 Jan 2021 10:11:41 -0800

Merged #4818 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4818#event-4257280007