Subject: [quicwg/base-drafts] Éric Vyncke's Recovery Comment 4 (#4591)

From: Lucas Pardue <[email-masked]>
Date: Wed, 06 Jan 2021 07:00:03 -0800

Éric Vyncke said:

> -- Section 7.2 --
>   "Endpoints SHOULD use an initial congestion
>    window of 10 times the maximum datagram size (max_datagram_size),
>    limited to the larger of 14720 bytes or twice the maximum datagram
>    size. "
> 
> The above text looks ambiguous to me especially with the ',' before 'limited'.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4591

---

From: Mike Bishop <[email-masked]>
Date: Fri, 08 Jan 2021 12:52:55 -0800

I think the ambiguity is whether the "limited to" is saying:

- the maximum datagram size is no more than twice the maximum datagram size (which is nonsensical)
- the initial congestion window is min(10\*max_datagram_size, max(14720 bytes, 2\*max_datagram_size))

Given that one of the possible interpretations is logically inconsistent, the other one must be correct.  I'm not sure how to make this sentence clearer except through pseudo-code.  Looking at the pseudo-code, there isn't any -- kInitialWindow is declared to be a constant, value defined by this text, but the definition of this constant is given in terms of a variable (max_datagram_size).

Maybe kInitialWindow should become a variable itself, and then have pseudo-code with the max/min relationship added to B.3?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4591#issuecomment-756992706

---

From: ianswett <[email-masked]>
Date: Tue, 12 Jan 2021 17:12:13 -0800

Closed #4591 via #4740.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4591#event-4198930760