Subject: [quicwg/base-drafts] Ben Kaduk's Transport Comment 48 (#4660)

From: Lucas Pardue <[email-masked]>
Date: Wed, 06 Jan 2021 18:08:52 -0800

@kaduk said:

> Section 21.13
>
> >                     Ideally, routing decisions are made independently
> > of client-selected values; a Source Connection ID can be selected to
> > route later packets to the same server.
>
> Is the client's address considered to be "client-selected"?  It's not
> clear to me that ignoring IP address locality and routing efficiency is
> going to be the ideal behavior.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4660

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 23:03:14 -0800

Yes, the client address is under client control (especially if you consider spoofing).

This is talking about ideals.  Reality won't be, probably.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4660#issuecomment-755928807

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 06 Jan 2021 23:23:42 -0800

I'll add that this doesn't ignore those points. As @martinthomson says, it notes what the ideal is... we don't have any control over how folks deploy their load balancers, and we don't have good recommendations in place here besides noting the pitfalls.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4660#issuecomment-755937100

---

From: Lars Eggert <[email-masked]>
Date: Tue, 12 Jan 2021 01:53:05 -0800

Closed #4660.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4660#event-4194973399