Subject: [quicwg/base-drafts] Erik Kline's Transport Comment 2 (#4514)

From: Lucas Pardue <[email-masked]>
Date: Tue, 05 Jan 2021 19:34:34 -0800

Erik Kline said:

> [ section 9.6.3 ]
> 
> * Entirely optional, but I wonder if it's worth noting that in certain
>   situations, for example an IPv6-only client and IPv4-only server, the
>   client might be required to evaluate use of an alternate address family
>   address if, for example, some transition mechanism (a la NAT64) was in
>   use.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4514

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 01:09:32 -0800

My personal preference is to avoid the transition technology quagmire.  However, that is partly because I'm not very well versed in it.  I would also prefer if servers offer v6 for v6-only clients.

If someone were able to offer text I might be OK with that.  As we do send IP literals in the protocol, it isn't crazy to acknowledge the need to deal with that.

As it is, I think that we're OK without reference to transition technologies.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4514#issuecomment-755178444

---

From: ianswett <[email-masked]>
Date: Wed, 06 Jan 2021 08:08:14 -0800

I think I'd prefer to not add any text on this one.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4514#issuecomment-755391630

---

From: Erik Kline <[email-masked]>
Date: Thu, 07 Jan 2021 07:12:04 -0800

Fair enough!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4514#issuecomment-756175603

---

From: Mike Bishop <[email-masked]>
Date: Thu, 07 Jan 2021 13:59:42 -0800

Yeah, presumably a v6-only client using a transition technology has some mechanism to deal with v4 addresses anyway, whether that's a way to map them to a v6 address or simply failing to transition.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4514#issuecomment-756412928

---

From: Martin Thomson <[email-masked]>
Date: Thu, 07 Jan 2021 17:36:50 -0800

Closed #4514.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4514#event-4182459929

---

From: Erik Kline <[email-masked]>
Date: Sat, 09 Jan 2021 22:41:49 -0800

Well, sometimes client implementations might be aware of the transition mechanism.  This can happen when, for example, DNS64 is used and the IPv6 address received is a NAT64 address that makes things "just work" for the IPv6-only client contacting an IPv4-only server.

If you wanted some sample text, I might suggest something along these lines:

> Note that if the only non-zero address available is from a different address family than the endpoint implementation
> can make reasonable use of (e.g., and IPv6-only client receives only an IPv4 address), the implementation may
> need to coordinate with any address family transition technologies in use.  The precise mechanisms by which this
> can be done vary by transition technology and are out of scope of this document.

This shouldn't cause any unnecessary Informative references to be added.

Again: only if you want to note it so that implementors can bear it in mind.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4514#issuecomment-757426482