Subject: [quicwg/base-drafts] 0-RTT is possible without prior communication (#4549)

From: Martin Thomson <[email-masked]>
Date: Tue, 05 Jan 2021 20:05:27 -0800

Though I guess provisioning of a PSK depends on prior communication of a
sort, there is no need to be so absolute here.

Closes #4478.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4549

-- Commit Summary --

  * 0-RTT is possible without prior communication

-- File Changes --

    M draft-ietf-quic-tls.md (2)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4549.patch
https://github.com/quicwg/base-drafts/pull/4549.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4549

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 05 Jan 2021 21:27:42 -0800

@janaiyengar commented on this pull request.

> @@ -235,7 +235,7 @@ Data is protected using a number of encryption levels:
 Application Data may appear only in the Early Data and Application Data
 levels. Handshake and Alert messages may appear in any level.
 
-The 0-RTT handshake is only possible if the client and server have previously
+The 0-RTT handshake can be enabled if the client and server have previously

```suggestion
The 0-RTT handshake can be used if the client and server have previously
```
?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4549#pullrequestreview-562333725

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 05 Jan 2021 22:46:26 -0800

@kazuho approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4549#pullrequestreview-562359168

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 15:13:04 -0800

@martinthomson pushed 1 commit.

443bcc38bc1bcca8d863b58c9dc57531a87c8f07  used is good

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4549/files/55c81451956cc42f758d63b1722e50ce3529ec07..443bcc38bc1bcca8d863b58c9dc57531a87c8f07

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 06 Jan 2021 18:51:56 -0800

@janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4549#pullrequestreview-563177987

---

From: Marten Seemann <[email-masked]>
Date: Wed, 06 Jan 2021 19:23:30 -0800

@marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4549#pullrequestreview-563186710

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 22:49:30 -0800

Merged #4549 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4549#event-4178448596