Subject: [quicwg/base-drafts] Robert Wilton's QPACK Comment 4 (#4803)

From: Lucas Pardue <[email-masked]>
Date: Thu, 21 Jan 2021 06:30:24 -0800

@rgwilton said

> I note that the algorithm uses a static table.  Is there any consideration to
> be able to update or evolve that static table over time?  E.g., perhaps in 10
> years time, the traffic will have changed sufficiently enough that a new
> version of the static table should be generated.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4803

---

From: Martin Thomson <[email-masked]>
Date: Thu, 21 Jan 2021 13:57:56 -0800

Funny, RFC 7541 received the same comment.  The response then still applies I believe: if we need a new compression scheme, we'll need a new protocol.

The nature of the protocol is such that negotiation of a compression scheme could add significant (and undesirable) latency if it were done orthogonal to the protocol negotiation.

That sounds terrible in some ways, but what we've learned is that the needs change only gradually, and that timescale matches with the general evolution cadence of the protocols.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4803#issuecomment-764967487

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 21 Jan 2021 14:08:24 -0800

Its a fair observation. There's been some ideas floating around. But as Martin says, there's tradeoff. The scheme, via the dynamic table, is flexible enough to support evolving HTTP trends without standards coordination effort. The static table has been optimised for a client first flight request,  and I dare say that many of those characteristics won't vary so much for the primary HTTP use case of browsing. Evolving or alternate tables might help, but the latency cost to negotiate them makes the net result similar to dynamic compression. I'm happy that our extension or evolving mechanisms are sufficient for the current understood needs.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4803#issuecomment-764972417

---

From: afrind <[email-masked]>
Date: Mon, 25 Jan 2021 16:45:30 -0800

Propose to close with no action.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4803#issuecomment-767205879