Subject: [quicwg/base-drafts] Ben Kaduk's Transport Comment 21 (#4632)

From: Lucas Pardue <[email-masked]>
Date: Wed, 06 Jan 2021 17:54:15 -0800

@kaduk said:

> Section 10.3
>
> Just to check my understanding: it is "safe" for a server to decide that
> it will never use stateless reset and send random values in the
> stateless_reset_token fields that it immediately forgets?  (It would
> then not be able to ever send stateless reset, of course, but AFAICT
> that is the only consequence.  The client still has to track the
> relevant state, and the server has to track
> per-connection-ID-sequence-number state.)  I don't know if that's worth
> mentioning, since the field is otherwise essentially mandatory when
> server connection IDs are in use.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4632

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 21:17:00 -0800

Yes, it is safe.  This is what our stack does right now.  We don't use stateless reset.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4632#issuecomment-755889826

---

From: kaduk <[email-masked]>
Date: Sun, 10 Jan 2021 23:32:55 -0800

Thanks for confirming.  (This was just a question, and is now answered, so "close with no change", right?)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4632#issuecomment-757675655

---

From: Lars Eggert <[email-masked]>
Date: Tue, 12 Jan 2021 01:45:16 -0800

Closed #4632.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4632#event-4194937546