Subject: Re: [quicwg/base-drafts] Clarify definition of off-path (#4462)

From: Martin Thomson <[email-masked]>
Date: Sun, 03 Jan 2021 14:54:50 -0800

@martinthomson pushed 1 commit.

be3b4e852050338bea18bd61efe825f6b192d259  Fewer words

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4462/files/4b8f06ecbbdcfefea4b6441c71e984cd8f210c6b..be3b4e852050338bea18bd61efe825f6b192d259

---

From: Martin Thomson <[email-masked]>
Date: Sun, 03 Jan 2021 15:15:26 -0800

b7b06086078b65ee99c456ad97643bb87146d9c1  Add invariants to the list

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4462/files/be3b4e852050338bea18bd61efe825f6b192d259..b7b06086078b65ee99c456ad97643bb87146d9c1

---

From: martinduke <[email-masked]>
Date: Mon, 04 Jan 2021 07:37:30 -0800

@martinduke approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4462#pullrequestreview-561124991

---

From: Sean Turner <[email-masked]>
Date: Mon, 04 Jan 2021 19:05:38 -0800

@seanturner commented on this pull request.

> @@ -4258,8 +4258,9 @@ Path Maximum Transmission Unit Discovery (PMTUD; {{!RFC1191}}, {{!RFC8201}})
 relies on reception of ICMP messages (e.g., IPv6 Packet Too Big messages) that
 indicate when an IP packet is dropped because it is larger than the local router
 MTU. DPLPMTUD can also optionally use these messages.  This use of ICMP messages
-is potentially vulnerable to off-path attacks that successfully guess the
-addresses used on the path and reduce the PMTU to a bandwidth-inefficient value.
+is potentially vulnerable to attacks by elements that cannot observe packets

elements or entities or does it matter? "path elements" is used only once elsewhere in the I-D.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4462#pullrequestreview-561486417

---

From: Martin Thomson <[email-masked]>
Date: Mon, 04 Jan 2021 19:24:10 -0800

6d5f25cf8498c2318b3ef62971cac2cf56505ef0  entities

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4462/files/b7b06086078b65ee99c456ad97643bb87146d9c1..6d5f25cf8498c2318b3ef62971cac2cf56505ef0

---

From: Eric Kinnear <[email-masked]>
Date: Tue, 05 Jan 2021 14:16:45 -0800

@ekinnear approved this pull request.

> @@ -6706,19 +6709,19 @@ An off-path attacker can:
 
 An off-path attacker cannot:
 
-- Modify any part of a packet
+- Modify packets sent by endpoints

Ah, good call

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4462#pullrequestreview-562176594

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 05 Jan 2021 21:07:38 -0800

@janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4462#pullrequestreview-562328051

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 06 Jan 2021 18:33:50 -0800

Merged #4462 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4462#event-4177904425