Subject: [quicwg/base-drafts] Ben Kaduk's TLS Comment 23 (#4499)

From: Lucas Pardue <[email-masked]>
Date: Tue, 05 Jan 2021 19:00:03 -0800

@kaduk said:

> Section 6.5
> 
>    An endpoint MAY allow a period of approximately the Probe Timeout
>    (PTO; see [QUIC-RECOVERY]) after receiving a packet that uses the new
>    key generation before it creates the next set of packet protection
>    keys.  [...]
> 
> (editorial) Similarly to the previous section, I think the action being
> described here might be more properly described as "promoting the 'next'
> keys to be the 'current' keys (and thus starting the precomputation for
> the subsequent 'next' keys)".  Surly this is not advocating waiting a
> PTO before generating the keys you need to process a packet you just
> received ... right?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4499

---

From: Martin Thomson <[email-masked]>
Date: Tue, 05 Jan 2021 22:45:48 -0800

I'll roll this into the change for #4498 as it relates to the same basic text.  I like the "promoting" idea, though I'm not going to go back and rewrite everything to use it.  Here, the important thing is to have words for current, next, and "subsequent next" to avoid making this more confusing than necessary.  I think that I got it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4499#issuecomment-755117544

---

From: Martin Thomson <[email-masked]>
Date: Sun, 10 Jan 2021 18:25:37 -0800

Closed #4499 via #4577.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4499#event-4188724375