Subject: [quicwg/base-drafts] Ben Kaduk's QPACK Comment 6 (#4796)

From: Lucas Pardue <[email-masked]>
Date: Thu, 21 Jan 2021 06:21:22 -0800

@kaduk said

> Appendix C
>
> It might be worth a brief mention of the API contracts for (e.g.) the
> encode*() functions.  The second argument of encodeInteger() as "the
> byte value used to fill in the bits of the first byte that are not
> consumed by the trailing N-prefix integer" is particularly hard to infer
> (if it's even the correct inference).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4796

---

From: Lars Eggert <[email-masked]>
Date: Tue, 26 Jan 2021 03:39:31 -0800

Could we please start the discussion on this one?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4796#issuecomment-767487077

---

From: afrind <[email-masked]>
Date: Tue, 26 Jan 2021 09:28:20 -0800

I agree that this would make the code more readable and usable and I'm drafting a PR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4796#issuecomment-767700896