Subject: [quicwg/base-drafts] Robert Wilton's Comment 12 (#4679)

From: Lucas Pardue <[email-masked]>
Date: Wed, 06 Jan 2021 18:46:01 -0800

Rob Wilton said:

>    17.  Packet Formats
>
>     Version: The QUIC Version is a 32-bit field that follows the first byte.
>     This field indicates the version of QUIC that is in use and determines how
>     the rest of the protocol fields are interpreted.
>
> By "rest of the protocol fields", I had incorrectly interpreted this as meaning
> all subsequent fields described after the version field are determined
> Perhaps worth clarifying - although I recall that it does become clear
> elsewhere.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4679

---

From: Martin Thomson <[email-masked]>
Date: Thu, 07 Jan 2021 17:26:18 -0800

It means "all of the other fields", so "rest of" is fine.  As the entire point of the document is to define what the semantics of those other fields are, this seems like it is OK without further adjustment.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4679#issuecomment-756488069

---

From: Lars Eggert <[email-masked]>
Date: Tue, 12 Jan 2021 01:53:34 -0800

Closed #4679.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4679#event-4194975521