Subject: [quicwg/base-drafts] Relationship of payload and length (#4694)

From: Mike Bishop <[email-masked]>
Date: Thu, 07 Jan 2021 13:43:01 -0800

Fixes #4504.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4694

-- Commit Summary --

  * Relationship of payload and length

-- File Changes --

    M draft-ietf-quic-tls.md (5)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4694.patch
https://github.com/quicwg/base-drafts/pull/4694.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4694

---

From: Martin Thomson <[email-masked]>
Date: Thu, 07 Jan 2021 17:32:37 -0800

@martinthomson approved this pull request.

Fine, sure.

> @@ -2143,8 +2143,9 @@ baf4559fedba753de171fa71f50f1ce1 5d43e994ec74d748002b000302030400
 75300901100f088394c8f03e51570806 048000ffff
 ~~~
 
-The unprotected header includes the connection ID and a 4-byte packet number
-encoding for a packet number of 2:
+The unprotected header indicates a length of 1182 bytes: the 4-byte packet
+number, the 1162-byte payload, and the 16-byte authentication tag.  The header

```suggestion
number, 1162 bytes of frames, and the 16-byte authentication tag.  The header
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4694#pullrequestreview-563945991

---

From: Martin Thomson <[email-masked]>
Date: Thu, 07 Jan 2021 17:33:56 -0800

@martinthomson commented on this pull request.

Also, now this has a merge conflict thanks to #4695.  Use `git merge -s ours`.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4694#discussion_r553690377

---

From: Sean Turner <[email-masked]>
Date: Fri, 08 Jan 2021 04:36:58 -0800

@seanturner approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4694#pullrequestreview-564227852

---

From: Jana Iyengar <[email-masked]>
Date: Sun, 10 Jan 2021 18:50:07 -0800

@janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4694#pullrequestreview-564974060

---

From: Martin Thomson <[email-masked]>
Date: Sun, 10 Jan 2021 18:54:24 -0800

@martinthomson pushed 1 commit.

cb09a2794f5611d3fdc0deb6fc49b8b81a191e35  woo

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4694/files/7a0fb8fcf7ae9ad84a120072e2ade0810a1a6d19..cb09a2794f5611d3fdc0deb6fc49b8b81a191e35

---

From: Martin Thomson <[email-masked]>
Date: Sun, 10 Jan 2021 18:54:55 -0800

Merged #4694 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4694#event-4188766665