Subject: [quicwg/base-drafts] Ben Kaduk's QPACK Comment 1 (#4791)

From: Lucas Pardue <[email-masked]>
Date: Thu, 21 Jan 2021 06:18:29 -0800

@kaduk said

> Section 2.1.1.1
>
> Figure 1 might benefit from an explicit indication of which direction is
> higher (or lower) absolute index.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4791

---

From: afrind <[email-masked]>
Date: Mon, 25 Jan 2021 16:55:23 -0800

This table appears before the general discussion of indexing.  One thought is to add something along the top of the table, like this: 

```
             <-- Newer Entries          Older Entries -->
   +--------+---------------------------------+----------+
   | Unused |          Referenceable          | Draining |
   | Space  |             Entries             | Entries  |
   +--------+---------------------------------+----------+
            ^                                 ^          ^
            |                                 |          |
      Insertion Point                 Draining Index  Dropping
                                                       Point
```

?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4791#issuecomment-767209304

---

From: kaduk <[email-masked]>
Date: Mon, 25 Jan 2021 22:19:00 -0800

Your proposal does improve the clarity of the figure, but I am hoping for more.
While it is true that the dedicated sections that discuss indexing appear later in the document, the introductory text alongside the figure uses language such as "smallest absolute index", increases the draining index", and "with an absolute index lower than the draining index" that imply a numerical ordering and directionality of the indices.  Interpreting the figure would be easier with the direction of that ordering stated explicitly, as might be done via "Newer Entries (larger index)"/etc..

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4791#issuecomment-767322621

---

From: Lars Eggert <[email-masked]>
Date: Tue, 26 Jan 2021 03:37:51 -0800

We need to come to a decision on this. Since this is from an IESG COMMENT (and not a DISCUSS), the editors can IMO go ahead with their preferred resolution.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4791#issuecomment-767486335

---

From: afrind <[email-masked]>
Date: Tue, 26 Jan 2021 15:38:05 -0800

Closed #4791 via #4815.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4791#event-4253227663