Subject: [quicwg/base-drafts] PTO is restarted on handshake confirmation (#4734)

From: Jana Iyengar <[email-masked]>
Date: Mon, 11 Jan 2021 23:05:55 -0800

Closes #4710.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4734

-- Commit Summary --

  * PTO is restarted on handshake confirmation

-- File Changes --

    M draft-ietf-quic-recovery.md (1)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4734.patch
https://github.com/quicwg/base-drafts/pull/4734.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4734

---

From: Martin Thomson <[email-masked]>
Date: Mon, 11 Jan 2021 23:13:36 -0800

@martinthomson approved this pull request.

Perfect.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4734#pullrequestreview-565989013

---

From: ianswett <[email-masked]>
Date: Tue, 12 Jan 2021 15:26:04 -0800

@ianswett requested changes on this pull request.

I don't think this is correct, since when Initial or Handshake keys are discarded, if the PTO was set based on one of those PN spaces, clearly the PTO would need to be reset.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4734#pullrequestreview-566783849

---

From: Martin Thomson <[email-masked]>
Date: Tue, 12 Jan 2021 16:20:05 -0800

Ian is right, we would lose the Initial discard condition.  Drop the Handshake key drop condition.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4734#issuecomment-759119999

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 12 Jan 2021 16:21:09 -0800

@janaiyengar pushed 1 commit.

fdfcc4827e35f8902a738a0d7f28693963c43583  initial keys are a different moment

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4734/files/58efd319c877ec601f13c80364432982cb25cc9b..fdfcc4827e35f8902a738a0d7f28693963c43583

---

From: Martin Thomson <[email-masked]>
Date: Tue, 12 Jan 2021 16:21:38 -0800

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4734#pullrequestreview-566805257

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 12 Jan 2021 16:22:37 -0800

@ianswett -- you're right, but I think that only applies to Initial here, since hs confirmed is the same as hs keys getting dropped. Take a look at the new text.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4734#issuecomment-759120810

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 12 Jan 2021 16:33:57 -0800

161d0599c97dd336873e4ef93d94f95074da887f  parallel is better

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4734/files/fdfcc4827e35f8902a738a0d7f28693963c43583..161d0599c97dd336873e4ef93d94f95074da887f

---

From: Martin Thomson <[email-masked]>
Date: Tue, 12 Jan 2021 16:34:26 -0800

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4734#pullrequestreview-566809712

---

From: ianswett <[email-masked]>
Date: Tue, 12 Jan 2021 16:34:38 -0800

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4734#pullrequestreview-566809794

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 12 Jan 2021 16:40:02 -0800

Merged #4734 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4734#event-4198822483