Subject: [quicwg/base-drafts] Robert Wilton's Comment 9 (#4676)

From: Lucas Pardue <[email-masked]>
Date: Wed, 06 Jan 2021 18:44:33 -0800

Rob Wilton said:

>    4.6.  Controlling Concurrency
>
>     An endpoint that is unable to open a new stream due to the peer's limits
>     SHOULD send a STREAMS_BLOCKED frame (Section 19.14). This signal is
>     considered useful for debugging. An endpoint MUST NOT wait to receive this
>     signal before advertising additional credit, since Iyengar & Thomson
>     Expires 16 June 2021 [Page 29] Internet-Draft QUIC Transport Protocol
>     December 2020 doing so will mean that the peer will be blocked for at least
>     an entire round trip, and potentially indefinitely if the peer chooses not
>     to send STREAMS_BLOCKED frames.
>
> By additional credit, does it sending MAX_STREAMS?  If so, it might be helpful
> to clarify that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4676

---

From: Martin Thomson <[email-masked]>
Date: Thu, 07 Jan 2021 17:16:07 -0800

I think that this is OK without change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4676#issuecomment-756484939

---

From: Lars Eggert <[email-masked]>
Date: Tue, 12 Jan 2021 01:51:01 -0800

Closed #4676.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4676#event-4194963890