Subject: [quicwg/base-drafts] Ben Kaduk's TLS Comment 26 (#4502)

From: Lucas Pardue <[email-masked]>
Date: Tue, 05 Jan 2021 19:01:39 -0800

@kaduk said:

> Section 9.6
> 
>    The initial secrets use a key that is specific to the negotiated QUIC
>    version.  New QUIC versions SHOULD define a new salt value used in
>    calculating initial secrets.
> 
> Also for the Retry Integrity Tag key/nonce secret?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4502

---

From: Martin Thomson <[email-masked]>
Date: Tue, 05 Jan 2021 23:04:18 -0800

That does not have the same impetus, so I think that it is reasonable to omit it.  Updating the keys would be OK and I would expect it to happen, but it is not necessary to the extent that it needs to be called out.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4502#issuecomment-755125285

---

From: Martin Thomson <[email-masked]>
Date: Mon, 11 Jan 2021 20:58:42 -0800

Closed #4502.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4502#event-4193991326