Subject: [quicwg/base-drafts] Erik Kline's Transport Comment 1 (#4513)

From: Lucas Pardue <[email-masked]>
Date: Tue, 05 Jan 2021 19:34:02 -0800

Erik Kline said:

> [ section 8.2.3 ]
> 
> * I found this wording a tad odd:
> 
>     If the PATH_CHALLENGE frame that resulted in successful path
>     validation was sent in a datagram that was not expanded to at least
>     1200 bytes, the endpoint can regard the address as valid.
> 
>   It seems like whether the frame was padded to 1200 or not, if the response
>   data matches the challenge data the address can be considered validated.
> 
>   I think the point at the end of the sentence is to say that *only* the
>   address, but not the MTU, can be taken as validated.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4513

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 01:04:24 -0800

Yep, when it's called out, it's distinctly odd.  Hopefully it's an easy fix, but writing is hardd.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4513#issuecomment-755176059

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 21:58:47 -0800

Closed #4513 via #4580.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4513#event-4178317131