Subject: [quicwg/base-drafts] Ben Kaduk's TLS Comment 11 (#4487)

From: Lucas Pardue <[email-masked]>
Date: Tue, 05 Jan 2021 18:53:24 -0800

@kaduk said:

> Section 4.9.3
> 
>    0-RTT keys to allow decrypting reordered packets without requiring
>    their contents to be retransmitted with 1-RTT keys.  After receiving
>    a 1-RTT packet, servers MUST discard 0-RTT keys within a short time;
>    the RECOMMENDED time period is three times the Probe Timeout (PTO,
>    see [QUIC-RECOVERY]).  A server MAY discard 0-RTT keys earlier if it
> 
> Just to check my understanding, the two endpoints will not necessarily
> agree on the value of PTO at any given point in time, so this is a
> heuristic and not some form of synchronized behavior where the server
> replicates the client's loss-detection algorithm precisely?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4487

---

From: Martin Thomson <[email-masked]>
Date: Tue, 05 Jan 2021 21:16:55 -0800

That is correct.  The idea is to ensure that you leave enough time for badly reordered or delayed packets to get through so that you can process them rather than be forced to throw them away.  

We've used this same value throughout because even if there is some difference in what different endpoints think, it's more than generous enough to catch any stragglers.

In practice, this could be much less.  Packets are declared lost by their sender after 9/8 of an RTT, and this only needs to capture variances in the one-way delay, so you might reasonably drop much sooner (9/16ths of an RTT, say).  But nor is there any real harm in keeping the keys, so we use the generous value and stick with the same timer value for all of this sort of thing.

Proposal here is no change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4487#issuecomment-755084114

---

From: Martin Thomson <[email-masked]>
Date: Mon, 11 Jan 2021 21:01:07 -0800

Closed #4487.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4487#event-4193996337