Subject: [quicwg/base-drafts] Ben Kaduk's Recovery Comment 2 (#4709)

From: Lucas Pardue <[email-masked]>
Date: Thu, 07 Jan 2021 18:19:38 -0800

@kaduk said:

> Section 5.3
> 
> > After the handshake is confirmed, any acknowledgement delays reported
> > by the peer that are greater than the peer's max_ack_delay are
> > attributed to unintentional but potentially repeating delays, such as
> > scheduler latency at the peer or loss of previous acknowledgements.
> 
> I don't think I understand how loss of previous acknowledgements could
> induce a peer to delay sending an ack longer than its max_ack_delay
> after an ack-eliciting packet.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4709

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 11 Jan 2021 18:37:50 -0800

`ack_delay` in an ACK frame is recorded as the time since the `largest_acknowledged` packet was received. If the `largest_acknowledged` does not change as subsequent ACK frames are sent by the receiver, `ack_delay` only increases in subsequent ACK frames. Now, if there's no acknowledgement loss, the receiver of acknowledgements would read the first `ack_delay` in the first such ACK frame. If there is loss however, the receiver of acknowledgements would read only subsequent ACK frames, which might have `ack_delay` that is larger than `max_ack_delay`.

Does that help?

I propose closing with no action.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4709#issuecomment-758355186

---

From: Lars Eggert <[email-masked]>
Date: Tue, 12 Jan 2021 01:49:39 -0800

@kaduk does this explanation and proposed resolution work for you?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4709#issuecomment-758538832

---

From: kaduk <[email-masked]>
Date: Tue, 12 Jan 2021 20:35:59 -0800

That helps, yes, and thank you.  I think I was confused about which direction of ACKs were getting lost.
"loss of previous acknowledgments of the same packet" or "loss of previous attempts to acknowledge the packet in question" would have averted my confusion, though I concede that neither flows terribly well.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4709#issuecomment-759199339

---

From: Lars Eggert <[email-masked]>
Date: Tue, 26 Jan 2021 03:24:29 -0800

OK, closing with no action as agreed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4709#issuecomment-767479849

---

From: Lars Eggert <[email-masked]>
Date: Tue, 26 Jan 2021 03:24:30 -0800

Closed #4709.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4709#event-4250201848