Subject: [quicwg/base-drafts] Ben Kaduk's Transport Comment 25 (#4637)

From: Lucas Pardue <[email-masked]>
Date: Wed, 06 Jan 2021 17:57:29 -0800

@kaduk said:

> Section 10.3.2

> > This design relies on the peer always sending a connection ID in its
> > packets so that the endpoint can use the connection ID from a packet
> > to reset the connection.  An endpoint that uses this design MUST
> > either use the same connection ID length for all connections or
> > encode the length of the connection ID such that it can be recovered
> > without state.  In addition, it cannot provide a zero-length
> > connection ID.
>
> (There is a corollary that the length of the connection ID has to be
> enough so that multiple connection IDs can be issued to all potential
> peers cumulatively over the lifetime of the static key, though perhaps
> it's sufficiently obvious so as to go without saying.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4637

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 21:44:19 -0800

Yes, I think that it is obvious enough.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4637#issuecomment-755898622

---

From: kaduk <[email-masked]>
Date: Sun, 10 Jan 2021 23:35:07 -0800

Sounds good.  (I am probably hyper-sensitized to this given how much time we spent on it for DTLS in the context of the injectivity of the MAC construction.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4637#issuecomment-757676565

---

From: Lars Eggert <[email-masked]>
Date: Tue, 12 Jan 2021 00:00:42 -0800

I read this as "close with no action".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4637#issuecomment-758479298

---

From: Lars Eggert <[email-masked]>
Date: Tue, 12 Jan 2021 01:46:43 -0800

Closed #4637.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4637#event-4194943829