Subject: [quicwg/base-drafts] Ben Kaduk's Transport Comment 32 (#4644)

From: Lucas Pardue <[email-masked]>
Date: Wed, 06 Jan 2021 18:00:44 -0800

@kaduk said:

> Section 17.2.5.2
>
> > Token field to the token provided in the Retry.  The client MUST NOT
> > change the Source Connection ID because the server could include the
> > connection ID as part of its token validation logic; see
> > Section 8.1.4.
>
> It looks like Section 8.1.4 doesn't actually talk specifically about
> connection IDs being bound to the token, just "additional information
> about clients".  Perhaps it should?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4644

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 22:13:37 -0800

It isn't necessary that the value be stable for any property we rely on, but keeping it stable allows some implementation shortcuts for servers (and avoids problems that might arise from the Initial growing by more than the server expects, for instance).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4644#issuecomment-755909602

---

From: Mike Bishop <[email-masked]>
Date: Fri, 08 Jan 2021 13:51:19 -0800

For concreteness, the proposal is no action.  The client MUST NOT change, because it doesn't know whether the server might have bound it into the token state; the server is not under any obligation to do so.  Both are correct.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4644#issuecomment-757014547

---

From: Martin Thomson <[email-masked]>
Date: Mon, 11 Jan 2021 20:08:19 -0800

Closed #4644.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4644#event-4193893815