Subject: [quicwg/base-drafts] Ben Kaduk's TLS Comment 32 (#4593)

From: Lucas Pardue <[email-masked]>
Date: Wed, 06 Jan 2021 08:33:45 -0800

@kaduk said:

> I think we would benefit from some clarity about the client's response
> to a Retry.  Specifically, is the client expected to use the same
> ClientHello from the first Initial, in the Initial generated in response
> to the Retry?  I did not see any notes about, e.g., transport parameter
> values sent by the client changing in response to Retry, and since the
> Connection IDs change it seems that we might fall under the Random (and
> key share) reuse considerations for TLS.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4593

---

From: kaduk <[email-masked]>
Date: Wed, 06 Jan 2021 08:39:10 -0800

I see now that §17.2.5.3 of -transport says it should be the "same cryptographic handshake message", but
reiterating that in this document seems like it would be useful.  (The transport parameters should suffice to link the two attempts for transcript purposes, though perhaps we also should give some stronger guidance about the server checking that there is no change.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4593#issuecomment-755414309

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 14:26:42 -0800

Where would that mention sit?  Happy to add a reference, but I believe that the transport text is sufficient, this would just be informative.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4593#issuecomment-755755231

---

From: Mike Bishop <[email-masked]>
Date: Fri, 08 Jan 2021 13:13:28 -0800

4.3 starts to wave in that direction, talking about the added overhead on the second Initial if the server sends an Initial, and suggesting that might require fragmenting the ClientHello.  It wouldn't be out of place there, necessarily, but I also don't think anyone would look here for it.

I think you're fine without, personally.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4593#issuecomment-757000584

---

From: kaduk <[email-masked]>
Date: Fri, 08 Jan 2021 15:58:13 -0800

Having looked again with the benefit of fully reading -transport, I think we will be okay with no change.
It was slightly tempting to contrast Retry with HelloRetryRequest in Section 4.7, but this information would be out of place there.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4593#issuecomment-757053921

---

From: Martin Thomson <[email-masked]>
Date: Mon, 11 Jan 2021 20:57:29 -0800

Closed #4593.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4593#event-4193988773