Subject: [quicwg/base-drafts] Erik Kline's Transport Comment 4 (#4516)

From: Lucas Pardue <[email-masked]>
Date: Tue, 05 Jan 2021 19:35:37 -0800

Erik Kline said:

> [ section 14.1 ]
> 
> * I think it might be important to note that this strategy places some
>   restrictions on the use of things like IPv6 extension headers that can be
>   used in these packets.
> 
>   For example, on an IPv6-only link with a 1280 MTU, enforcing a 1200 byte
>   UDP payload in these packets leaves only 32 bytes of space for any
>   extension headers.
> 
>   I think this is likely fine for these initial packets (vis. section 8.1 and
>   so on ), but as a general requirement for all packets this could
>   artificially constrain use of new extension headers.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4516

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 01:27:17 -0800

Seems reasonable to mention.  Obviously many paths support a larger MTU and so will support more extensions (or options), but it's worth noting that there isn't a ton of space available.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4516#issuecomment-755186883

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 06 Jan 2021 18:45:20 -0800

Closed #4516 via #4582.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4516#event-4177925795