Subject: [quicwg/base-drafts] Update discussion of Version Negotiation (#4697)

From: kaduk <[email-masked]>
Date: Thu, 07 Jan 2021 15:16:47 -0800

Remove a sentence (apparently) about handling version negotiation packets from the section that&#39;s supposed to be about sending them.

Clarify that the handling of version negotiation packets is meant to be specified only by standards-track documents (since it is in some sense a cross-version invariant rather than version-specific behavior).  In particular, those documents will not necessarily be specifications for a future version of QUIC.

New versions of QUIC specified prior to the existence of a version negotiation mechanism are to respond to Version Negotiation packets in the same manner as v1.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4697

-- Commit Summary --

  * Tidy up &quot;sending version negotiation packets&quot;
  * Future-proof how we cover Version Negotiation

-- File Changes --

    M draft-ietf-quic-transport.md (22)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4697.patch
https://github.com/quicwg/base-drafts/pull/4697.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4697

---

From: Martin Thomson <[email-masked]>
Date: Thu, 07 Jan 2021 16:51:07 -0800

@martinthomson commented on this pull request.

This seems largely OK.  I do have a couple of reservations though.

> +{{version-downgrade}}.  New versions of QUIC (including
+non-standards-track versions) might be specified prior to the
+availability of a version negotiation mechanism.  Until a version
+negotiation mechanism is available, new versions of QUIC MUST respond to
+Version Negotiation packets as specified above.

I don't think that we need to include these last two sentences.  While we've definitely strayed into making forward-looking statements (read: predictions) about what we might do, this goes too far in my opinion.

> -As a result, the client discards all state for the connection and does not send
-any more packets on the connection.

Why remove this?  It doesn't seem to be responsive to the concerns that the rest of the change addresses.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4697#pullrequestreview-563929847

---

From: kaduk <[email-masked]>
Date: Thu, 07 Jan 2021 17:58:09 -0800

@kaduk commented on this pull request.

I concede it was a bit speculative to say that this reflects existing consensus.  That said, there is perhaps a spectrum of options, from removing it entirely to "are expected to", "SHOULD", etc.  It sounds like you prefer just removing it entirely, to confirm?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4697#discussion_r553697252

---

From: kaduk <[email-masked]>
Date: Thu, 07 Jan 2021 17:59:12 -0800

It's unrelated and could easily be elided.
I read through the whole top-level section while working on this PR, and I thought this looked out of place (it's the "Remove a sentence (apparently) about handling version negotiation packets from the section that's supposed to be about sending them.").  I could be mistaken about that, though, and we can split it out if that's preferred.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4697#discussion_r553697549

---

From: Martin Thomson <[email-masked]>
Date: Thu, 07 Jan 2021 18:00:21 -0800

Please try to focus on targeted fixes.  That makes this process a lot easier to manage.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4697#discussion_r553697870

---

From: Martin Thomson <[email-masked]>
Date: Thu, 07 Jan 2021 18:01:20 -0800

Yes.  I don't think that we get much value from saying anything like this, regardless of strength, simply because it is making a prediction about work that might happen in the future.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4697#discussion_r553698098

---

From: kaduk <[email-masked]>
Date: Thu, 07 Jan 2021 18:12:10 -0800

Before I commit another faux pas, is it preferred to force-push or push a revert commit (or something else)?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4697#discussion_r553700951

---

From: kaduk <[email-masked]>
Date: Thu, 07 Jan 2021 18:14:33 -0800

Fair enough.  I will wait a bit before pushing an update to effectuate that, in case others want to comment.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4697#discussion_r553701558

---

From: Martin Thomson <[email-masked]>
Date: Thu, 07 Jan 2021 19:07:12 -0800

I don't personally mind.  In this repo, we have let the commit history reflect the history of the issues.  So push as you like.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4697#discussion_r553716074

---

From: kaduk <[email-masked]>
Date: Fri, 08 Jan 2021 10:34:40 -0800

@kaduk pushed 2 commits.

1f5340d4eabc2a40ec10ed879a87ac3712e5c450  Revert "Tidy up "sending version negotiation packets""
5a501af1b3abe9d19aed0d7318a81b33d86139d7  Remove over-zealous forward-looking statement

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4697/files/a3039ffb8d483125c765449ef7d215131e258e2c..5a501af1b3abe9d19aed0d7318a81b33d86139d7

---

From: kaduk <[email-masked]>
Date: Fri, 08 Jan 2021 15:31:05 -0800

Pushed fixups for both points raised.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4697#issuecomment-757047485

---

From: Martin Thomson <[email-masked]>
Date: Sun, 10 Jan 2021 17:50:47 -0800

@martinthomson approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4697#pullrequestreview-564927048

---

From: Jana Iyengar <[email-masked]>
Date: Sun, 10 Jan 2021 18:40:37 -0800

@janaiyengar approved this pull request.

One suggestion, but this is good.

> @@ -1419,11 +1419,12 @@ expectation that it will eventually receive an Initial packet.
 
 ## Handling Version Negotiation Packets {#handle-vn}
 
-Version Negotiation packets are designed to allow future versions of QUIC to
-negotiate the version in use between endpoints.  Future versions of QUIC might
-change how implementations that support multiple versions of QUIC react to
-Version Negotiation packets when attempting to establish a connection using this
-version.
+Version Negotiation packets are designed to allow for functionality to be
+defined in the future that allows QUIC to negotiate the version of QUIC to use
+between endpoints.  Future standards-track specifications might change how

```suggestion
for a connection.  Future standards-track specifications might change how
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4697#pullrequestreview-564959586

---

From: Martin Thomson <[email-masked]>
Date: Sun, 10 Jan 2021 18:42:28 -0800

@martinthomson pushed 1 commit.

d2946d832fe5e1c641b72ab2965a8c7136ca37b3  VN is just for a connection

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4697/files/5a501af1b3abe9d19aed0d7318a81b33d86139d7..d2946d832fe5e1c641b72ab2965a8c7136ca37b3

---

From: Martin Thomson <[email-masked]>
Date: Sun, 10 Jan 2021 18:56:19 -0800

Merged #4697 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4697#event-4188768399