Subject: [quicwg/base-drafts] Ben Kaduk's TLS Comment 9 (#4485)

From: Lucas Pardue <[email-masked]>
Date: Tue, 05 Jan 2021 18:52:12 -0800

@kaduk said:

> Section 4.8
> 
>    The alert level of all TLS alerts is "fatal"; a TLS stack MUST NOT
>    generate alerts at the "warning" level.
> 
> This seems to be making a normative restriction on the operation of TLS,
> which is not in the QUIC WG charter.  Perhaps we should instead
> constrain the QUIC implementation to not accept such alerts (and what to
> do if they are received) and note that the only closure alerts in RFC
> 8446 are "close_notify" and "user_cancelled", which are replaced by
> equivalent QUIC-level functionality.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4485

---

From: Martin Thomson <[email-masked]>
Date: Tue, 05 Jan 2021 21:10:13 -0800

I'm going to request that we flag this one "design".

I think that we want to say:

1. the TLS connection is never closed using TLS mechanisms
2. QUIC can treat any TLS alert as fatal

PR created and email in the pipe.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4485#issuecomment-755082026

---

From: Lucas Pardue <[email-masked]>
Date: Fri, 08 Jan 2021 08:23:36 -0800

Marking this as design as requested.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4485#issuecomment-756850348

---

From: Martin Thomson <[email-masked]>
Date: Thu, 14 Jan 2021 14:58:34 -0800

Closed #4485 via #4570.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4485#event-4208575160

---

From: Martin Thomson <[email-masked]>
Date: Thu, 14 Jan 2021 22:58:40 +0000 (UTC)

Returning to an open state as the chairs directed in their plan.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4485#issuecomment-760529498

---

From: Martin Thomson <[email-masked]>
Date: Thu, 14 Jan 2021 22:58:40 +0000 (UTC)

Reopened #4485.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4485#event-4208575369