Subject: [quicwg/base-drafts] Transfer codings and normative references (#4746)

From: Mike Bishop <[email-masked]>
Date: Fri, 15 Jan 2021 13:56:15 -0800

@royfielding points out that, in addition to a couple easily-resolved normative references to the HTTP/1.1 draft (this content has moved to Semantics), there's a normative reference to "chunked" transfer encoding being prohibited.  But technically, this is still a MUST NOT for an informative reference.

One resolution would be to make it a statement of fact rather than a conformance requirement -- to say that the transfer codings defined by the HTTP/1.1 are HTTP/1.1-specific and not applicable to HTTP/3.  But that's a broader assertion than just "chunked."  Is there a reason we need to keep e.g. "Transfer-Encoding: gzip"?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4746

---

From: Kazuho Oku <[email-masked]>
Date: Mon, 18 Jan 2021 01:04:26 -0800

My +1 goes to talking about transfer-encodings in general rather than just chunked, but as stated in the review comment, IIUC we already use different language for endpoints and intermediaries and therefore am afraid we have to keep doing so.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4746#issuecomment-762099360

---

From: Mike Bishop <[email-masked]>
Date: Tue, 26 Jan 2021 15:58:54 -0800

Closed #4746 via #4747.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4746#event-4253277545