Subject: [quicwg/base-drafts] Reorder bidi clause for Recv (#4702)

From: Martin Thomson <[email-masked]>
Date: Thu, 07 Jan 2021 17:12:52 -0800

Closes #4674.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4702

-- Commit Summary --

  * Reorder bidi clause for Recv

-- File Changes --

    M draft-ietf-quic-transport.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4702.patch
https://github.com/quicwg/base-drafts/pull/4702.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4702

---

From: Marten Seemann <[email-masked]>
Date: Thu, 07 Jan 2021 18:34:45 -0800

@marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4702#pullrequestreview-563964573

---

From: ianswett <[email-masked]>
Date: Fri, 08 Jan 2021 11:55:03 -0800

@ianswett approved this pull request.

> @@ -654,9 +654,9 @@ initiated by a peer, receipt of a MAX_STREAM_DATA or STOP_SENDING frame for the
 sending part of the stream also creates the receiving part.  The initial state
 for the receiving part of a stream is "Recv".
 
-The receiving part of a stream enters the "Recv" state when the sending part of
-a bidirectional stream initiated by the endpoint (type 0 for a client, type 1
-for a server) enters the "Ready" state.
+For a bidirectional stream, the receiving part enters the "Recv" state when the
+sending part of the stream initiated by the endpoint (type 0 for a client, type

Given you start with "For a bidirectional stream," I think you can drop "of the stream" since this is a fairly long sentence.

```suggestion
sending part initiated by the endpoint (type 0 for a client, type
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4702#pullrequestreview-564539758

---

From: Martin Thomson <[email-masked]>
Date: Sat, 09 Jan 2021 05:24:28 -0800

@martinthomson pushed 1 commit.

f1f70d5ef2faaa6e7f169a8a81b88d35fd26c2b4  of the stream

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4702/files/14afca0f43f6f289eb5552dabc0c97dad6a7dfbc..f1f70d5ef2faaa6e7f169a8a81b88d35fd26c2b4

---

From: Jana Iyengar <[email-masked]>
Date: Sun, 10 Jan 2021 18:12:10 -0800

Merged #4702 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4702#event-4188708483