Subject: [quicwg/base-drafts] Spin bit: Not implemented == disabled (#4691)

From: Mike Bishop <[email-masked]>
Date: Thu, 07 Jan 2021 13:06:33 -0800

Fixes #4666.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4691

-- Commit Summary --

  * Not implemented == disabled

-- File Changes --

    M draft-ietf-quic-transport.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4691.patch
https://github.com/quicwg/base-drafts/pull/4691.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4691

---

From: ianswett <[email-masked]>
Date: Thu, 07 Jan 2021 13:09:49 -0800

@ianswett approved this pull request.

> @@ -5113,6 +5113,8 @@ discussed in {{?QUIC-MANAGEABILITY=I-D.ietf-quic-manageability}}.
 
 The spin bit is an OPTIONAL feature of this version of QUIC. A QUIC stack that
 chooses to support the spin bit MUST implement it as specified in this section.
+A QUIC stack that chooses not to support the spin bit MUST behave as if it were

Do we need to add this sentence?

> @@ -5126,7 +5128,9 @@ approximately one in eight network paths.
 When the spin bit is disabled, endpoints MAY set the spin bit to any value, and
 MUST ignore any incoming value. It is RECOMMENDED that endpoints set the spin
 bit to a random value either chosen independently for each packet or chosen
-independently for each connection ID.
+independently for each connection ID. One way to accomplish this is to adjust

This seems like a useful addition.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4691#pullrequestreview-563827295

---

From: Martin Thomson <[email-masked]>
Date: Thu, 07 Jan 2021 14:49:10 -0800

@martinthomson requested changes on this pull request.

I have a simpler change:

> The spin bit is an OPTIONAL feature of this version of QUIC.   An endpoint that does not support this feature MUST disable it, as defined below.

No. No. No.  This does not work.  We discussed this.  It breaks the AEAD.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4691#pullrequestreview-563885594

---

From: Jana Iyengar <[email-masked]>
Date: Sun, 10 Jan 2021 18:58:48 -0800

@janaiyengar commented on this pull request.

Use of "QUIC stack" is also odd. I like @martinthomson 's simpler suggestion.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4691#discussion_r554668300

---

From: Martin Thomson <[email-masked]>
Date: Sun, 10 Jan 2021 18:58:57 -0800

@martinthomson pushed 1 commit.

c49ab276fce93ef9e7c5898020f307ded7fdfb92  Disable if not supported

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4691/files/83c45e50e948f44fb5a74e8c59cf200e5d322cf7..c49ab276fce93ef9e7c5898020f307ded7fdfb92

---

From: Martin Thomson <[email-masked]>
Date: Sun, 10 Jan 2021 18:59:39 -0800

f39d6be45c40d96e69be07bd012033bc8fb94022  Remove bad recommendation

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4691/files/c49ab276fce93ef9e7c5898020f307ded7fdfb92..f39d6be45c40d96e69be07bd012033bc8fb94022

---

From: Jana Iyengar <[email-masked]>
Date: Sun, 10 Jan 2021 19:00:18 -0800

@janaiyengar approved this pull request.

@martinthomson -- this is good now. Thanks!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4691#pullrequestreview-564988255

---

From: Jana Iyengar <[email-masked]>
Date: Sun, 10 Jan 2021 19:01:45 -0800

Merged #4691 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4691#event-4188775611