Subject: [quicwg/base-drafts] Éric Vyncke's HTTP/3 Comment 5 (#4755)

From: Lucas Pardue <[email-masked]>
Date: Tue, 19 Jan 2021 09:48:36 -0800

@evyncke said

> -- Section 5.3 --
> Should the CONNECT method behavior be specified when the client does an
> immediate closure?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4755

---

From: Mike Bishop <[email-masked]>
Date: Tue, 19 Jan 2021 13:49:56 -0800

The text currently says:

> Correspondingly, if a proxy detects an error with the stream or the QUIC connection, it MUST close the TCP connection. If the underlying TCP implementation permits it, the proxy SHOULD send a TCP segment with the RST bit set.

Transport makes the following addition, in [19.19](https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#section-19.19-2):

> If there are open streams that have not been explicitly closed, they are implicitly closed when the connection is closed.

That might be worth reiterating in HTTP/3.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4755#issuecomment-763163707

---

From: Mike Bishop <[email-masked]>
Date: Fri, 22 Jan 2021 08:57:05 -0800

Closed #4755 via #4762.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4755#event-4239502333