Subject: [quicwg/base-drafts] Ben Kaduk's Transport Comment 19 (#4630)

From: Lucas Pardue <[email-masked]>
Date: Wed, 06 Jan 2021 17:51:31 -0800

@kaduk said:

> Section 9.5
>
> > Similarly, an endpoint MUST NOT reuse a connection ID when sending to
> > more than one destination address.  Due to network changes outside
> > the control of its peer, an endpoint might receive packets from a new
> > source address with the same destination connection ID, in which case
> > it MAY continue to use the current connection ID with the new remote
> > address while still sending from the same local address.
>
> The MAY seems like it may be in conflict with the MUST.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4630

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 19:42:07 -0800

It isn't so much in conflict, but an exception or qualification.

I don't want to make a change in response to this comment.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4630#issuecomment-755863312

---

From: kaduk <[email-masked]>
Date: Sun, 10 Jan 2021 23:31:38 -0800

I have seen other ADs ballot Discuss for situations like this (though admittedly not very often).
Please go ahead and close with no change, though.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4630#issuecomment-757675097

---

From: Lars Eggert <[email-masked]>
Date: Tue, 12 Jan 2021 01:45:06 -0800

Closed #4630.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4630#event-4194936665