Subject: Re: [quicwg/base-drafts] Martin Duke Transport Comment 1 (#4450)

From: MikkelFJ <[email-masked]>
Date: Sun, 03 Jan 2021 08:19:51 -0800

There could also be a size field of sorts that specify the size of a trailing integrity check without specifying it. Some QUIC versions may later be defined to understand such a field. And even later versions might choose a new check and reject older formats. All we need is to reserve the space for it now. It could be used in a smuggling attack of sorts, I suppose.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4450#issuecomment-753640774

---

From: Martin Thomson <[email-masked]>
Date: Mon, 11 Jan 2021 20:13:40 -0800

I'm not detecting any action here, just a reaffirmation of existing decisions with a repetition of the rationale.  And some new sky-castle building.

I think we're OK to close this one.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4450#issuecomment-758385297

---

From: Lars Eggert <[email-masked]>
Date: Tue, 12 Jan 2021 00:26:09 -0800

This is related to #4511 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4450#issuecomment-758492262

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 12 Jan 2021 00:37:33 -0800

They're different in that this one is about integrity protection, while #4511 is about authenticating a VN packet that leads to a new version being attempted. For this one, I think we're good to close.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4450#issuecomment-758498074

---

From: Lars Eggert <[email-masked]>
Date: Tue, 12 Jan 2021 01:41:39 -0800

Closed #4450.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4450#event-4194920859