Subject: [quicwg/base-drafts] PATH_RESPONSE can't occur in 0-RTT (#4720)

From: Mike Bishop <[email-masked]>
Date: Fri, 08 Jan 2021 13:46:20 -0800

You only send a PATH_RESPONSE when a PATH_CHALLENGE is received.  PATH_CHALLENGE can&#39;t have been sent in Initial or Handshake, so the client&#39;s first opportunity to process a PATH_CHALLENGE is when it begins consuming 1-RTT packets from the server.  At the point 1-RTT packets are being read, the client is no longer allowed to send 0-RTT packets, because:

&gt; A client MUST NOT send 0-RTT packets once it starts processing 1-RTT packets from the server. This means that 0-RTT packets cannot contain any response to frames from 1-RTT packets.

Therefore, PATH_RESPONSE is part of the class of frames which are simply not possible in 0-RTT.

Fixes #4625.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4720

-- Commit Summary --

  * PATH_RESPONSE can&#39;t occur in 0-RTT

-- File Changes --

    M draft-ietf-quic-transport.md (2)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4720.patch
https://github.com/quicwg/base-drafts/pull/4720.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4720

---

From: ianswett <[email-masked]>
Date: Fri, 08 Jan 2021 15:03:56 -0800

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4720#pullrequestreview-564638763

---

From: Marten Seemann <[email-masked]>
Date: Fri, 08 Jan 2021 19:32:21 -0800

@marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4720#pullrequestreview-564680422

---

From: Jana Iyengar <[email-masked]>
Date: Sun, 10 Jan 2021 17:15:34 -0800

@janaiyengar approved this pull request.

This is good, but I'd like @martinthomson to take a look. I'm super wary of changes like this, and the more eyes, the better.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4720#pullrequestreview-564922879

---

From: Martin Thomson <[email-masked]>
Date: Sun, 10 Jan 2021 18:09:26 -0800

This is correct.  There was a time where PATH_CHALLENGE could be sent in other types of packet, which would have made this possible but still likely inadvisable.  As it is, this is correct.

(I think we're going to conflict with other changes, but we'll just have to see.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4720#issuecomment-757589784

---

From: Martin Thomson <[email-masked]>
Date: Sun, 10 Jan 2021 18:09:31 -0800

Merged #4720 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4720#event-4188705780