Subject: [quicwg/base-drafts] Ben Kaduk's Transport Comment 8 (#4615)

From: Lucas Pardue <[email-masked]>
Date: Wed, 06 Jan 2021 17:05:03 -0800

@kaduk said:

> Section 5.2.2
>
> >                                 Servers SHOULD respond with a Version
> > Negotiation packet, provided that the datagram is sufficiently long.
>
> This SHOULD seems redundant with the first sentence of the section?
>
> > Packets with a supported version, or no version field, are matched to
> > a connection using the connection ID or - for packets with zero-
> > length connection IDs - the local address and port.  These packets
> > are processed using the selected connection; otherwise, the server
> > continues below.
>
> (side note) Packets with a short header do not indicate the connection
> ID length (or version).  I think we admit the possibility that a server
> could advertise a zero-length connection ID to some but not all clients;
> does that imply that a lookup by address/port in the local connection
> database would be needed to determine whether such a short-header packet
> would have a zero-length connection ID or not?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4615

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jan 2021 17:33:18 -0800

Regarding the first comment here, I'm OK with repetition.

The second doesn't result in action.

To the question there, yes, you could have a server with a mix of lookup techniques.  It's probably silly and convoluted, but it could be made to work.  You can do that in any number of ways.  A fixed length or self-delimiting connection ID can be looked up too; more so if the connection ID is also self-authenticating.  But we don't need to get into those details (we have other documents coming that do.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4615#issuecomment-755826531

---

From: Martin Thomson <[email-masked]>
Date: Mon, 11 Jan 2021 20:46:55 -0800

Closed #4615.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4615#event-4193967400