Subject: [quicwg/base-drafts] Update Contributing.md to reflect post-IESG world (#4824)

From: Lucas Pardue <[email-masked]>
Date: Wed, 03 Feb 2021 18:22:07 -0800

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4824

-- Commit Summary --

  * Update Contributing.md to reflect post-IESG world

-- File Changes --

    M CONTRIBUTING.md (91)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4824.patch
https://github.com/quicwg/base-drafts/pull/4824.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4824

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 03 Feb 2021 18:55:34 -0800

@janaiyengar commented on this pull request.

a few editorial comments

> +* Invariants
+* Transport
+* TLS
+* HTTP/3
+* QPACK
+* Recovery

Replace these with document names?

> @@ -21,12 +27,17 @@ new to this, you may also want to read the [Tao of the IETF](https://www.ietf.or
 
 <!-- END doctoc generated TOC please keep comment here to allow auto update -->
 
+# Engaging with the QUIC community
+
+The QUIC Working Group scope of work is described in our charter and it extends beyond the development of the documents held in this repository. Anyone is welcome to contribute to the QUIC community; you don't have to join the Working Group, because there is no "membership" -- anyone who participates in the work **is** a part of the QUIC Working Group.

```suggestion
The scope of work in the QUIC Working Group is described in our charter and extends beyond the development of the documents in this repository. Anyone is welcome to contribute to the QUIC Working Group; you don't have to join the Working Group, because there is no "membership" -- anyone who participates in the work **is** a part of the QUIC Working Group.
```

> @@ -21,12 +27,17 @@ new to this, you may also want to read the [Tao of the IETF](https://www.ietf.or
 
 <!-- END doctoc generated TOC please keep comment here to allow auto update -->
 
+# Engaging with the QUIC community
+
+The QUIC Working Group scope of work is described in our charter and it extends beyond the development of the documents held in this repository. Anyone is welcome to contribute to the QUIC community; you don't have to join the Working Group, because there is no "membership" -- anyone who participates in the work **is** a part of the QUIC Working Group.
+
+Before doing so, it's a good idea to familiarize yourself with our [charter](https://datatracker.ietf.org/wg/quic/about/). If you're new to IETF work, you may also want to read the [Tao of the IETF](https://www.ietf.org/tao.html).

```suggestion
Before doing so, please familiarize yourself with our [charter](https://datatracker.ietf.org/wg/quic/about/). If you are new to IETF work, you may also want to read the [Tao of the IETF](https://www.ietf.org/tao.html).
```

 ## Following Discussion
 
 The Working Group has a few venues for discussion:
 
-* We plan to meet at all [IETF meetings](https://www.ietf.org/meeting/) for the foreseeable future, and hold interim meetings between them. See our [meeting materials repository](https://github.com/quicwg/wg-materials) and the [official proceedings](https://datatracker.ietf.org/wg/quic/meetings/).
+* We plan to meet at all [IETF meetings](https://www.ietf.org/meeting/) for the foreseeable future, and possibly hold interim meetings between them if required. Agendas, minutes and presentations are available in our [meeting materials repository](https://github.com/quicwg/wg-materials) and the [official proceedings](https://datatracker.ietf.org/wg/quic/meetings/).

```suggestion
* We plan to meet at all [IETF meetings](https://www.ietf.org/meeting/) for the foreseeable future, and hold interim meetings between them as required. Agendas, minutes, and presentations are available in our [meeting materials repository](https://github.com/quicwg/wg-materials) and the [official proceedings](https://datatracker.ietf.org/wg/quic/meetings/).
```

-We use our [Github](https://github.com/quicwg/) issues lists to track items for discussion and
-their resolution.
+The Working Group has built consensus that is reflected in base-draft documents, which has been confirmed through the IETF Last Call and IESG review stages modulo any critical undiscovered issues. Design changes will no longer be considered unless there are severe security, deployment or implementation problems. modulo any open (or undiscovered) issues. The goal of the Post-IESG proces is to minimise changes that invalidate the accumulated consesus, which risks returning us to the pre Working Group Last Call stage of standardisation.

```suggestion
The consensus of the Working Group is reflected in the base-draft documents, which has been confirmed through the IETF Last Call and IESG review stages. The goal of the Post-IESG process is to minimize the risk of changes invalidating the established consensus in these documents. Consequently, design changes and substantial editorial changes will no longer be considered unless they relate to severe security, deployment, or implementation problems.
```

-Before filing a new issue, please consider a few things:
+In this process, all required parties will discuss each design or major editorial issue and proposed resolution (ideally based upon a Pull Request that specifies the exact changes to be made). Chairs will judge consensus, labelling the issue as `has-consensus`.

For clarity, can you list the "required parties"?

-* Issues should be just that; issues with our deliverables, **not proposals, questions or support requests**.
-* Please review the issues list to make sure that you aren't filing a duplicate.
-* If you're not sure how to phrase your issue, please ask on the [mailing list](https://www.ietf.org/mailman/listinfo/quic).
+### Raising Issues
+
+We will no longer consider Design changes or substantial Editorial changes unless they relate to severe security, interoperabily or deployment problems.

```suggestion
We will no longer consider design changes or substantial editorial changes unless they relate to severe security, deployment, or implementation problems.
```

> +We use our [Github](https://github.com/quicwg/) issues lists to track items for discussion and
+their resolution.

```suggestion
We will continue to use our [Github](https://github.com/quicwg/) issues lists to track items for discussion and their resolution.
```

 Issues will be labeled by the Chairs as either `editorial` or `design`:
 
-* **Design** issues require discussion and consensus in the Working Group. This discussion can happen both in the issue and on the [Working Group mailing list](https://www.ietf.org/mailman/listinfo/quic), as outlined below.
+* **Design** issues require discussion and consensus among the Working Group, Area Director and IESG. This discussion can happen both in the issue and on the [Working Group mailing list](https://www.ietf.org/mailman/listinfo/quic), and all other relavent mailing lists.

```suggestion
* **Design** issues require discussion and consensus among the Working Group, the Area Director, and the IESG. This discussion can happen in the issue, on the [Working Group mailing list](https://www.ietf.org/mailman/listinfo/quic), or other relevant mailing lists.
```

-* **Editorial** issues can be dealt with by the editor(s) without consensus or notification. Typically, any discussion will take place on the issue itself.
+* **Editorial** issues that or minor or unsubstantial can be dealt with by the editor(s) without consensus or notification. Larger editorial changes require discussion and and consensus among the Working Group, Area Director and IESG.

```suggestion
* **Editorial** issues that are minor can be dealt with by the editor(s) without consensus or notification. Larger editorial changes require discussion and and consensus among the Working Group, the Area Director, and the IESG.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4824#pullrequestreview-582991653

---

From: Martin Thomson <[email-masked]>
Date: Wed, 03 Feb 2021 18:56:45 -0800

@martinthomson commented on this pull request.

I think that you probably want to include more information on what someone might do if they have a non-critical problem or suggestion for improvement.

That is, we should be encouraging people to discuss their problems and ideas with the working group with the idea that they work toward new extensions to the protocol rather than changes to these documents.

Beyond that, there is a ton of stuff here that can be cut entirely.  Lots of this is process we invented during earlier stages of the work that no longer applies.

-Before doing so, it's a good idea to familiarize yourself with our current [issues list](https://github.com/quicwg/base-drafts/issues) and [charter](https://datatracker.ietf.org/wg/quic/about/). If you're
-new to this, you may also want to read the [Tao of the IETF](https://www.ietf.org/tao.html).
+* Invariants
+* Transport
+* TLS
+* HTTP/3
+* QPACK
+* Recovery
+
+**All of the documents have now passed IESG review stage. We will no longer consider Design changes or substantial Editorial changes unless they relate to severe security, interoperabily or deployment problems. See [Post-IESG Process](#post-iesg-process) below for further information** 

Maybe instead:

> All of the documents have been approved for publication as RFC. ...

That might be more accessible to people who aren't familiar with our processes.

I would drop the two "modulo..." bits.  Especially the second.

I think that you want to just say "Any change will be subject to careful review and discussion, which might involve the editors, chairs, working group, and our area director."  Leaving aside the question of how much discussion, which we might vary based on what the change is.

The `has-consensus` piece can go.

Oxford comma.

And again, I would say **Any issue** here.

 The open design issues in the issues list are those that we are currently discussing, or plan to discuss. They can be discussed on the mailing list or the issue itself.

We have none of these, so I think it would be best to avoid mention of it.

> -The late-stage process attempts to reflect the Working Group's current consensus in the drafts; the latest draft reflects that consensus, modulo any open (or undiscovered) issues. The goal for a late-stage draft is to reduce unnecessary design changes in the protocol, thereby aiding reviewers and assuring that the drafts accurately reflect consensus.
-
-In this process, the Working Group will discuss each design issue, and the Chairs will judge consensus, labelling the issue as `has-consensus` (ideally based upon a Pull Request that specifies the exact changes to be made).
-
-Only after that will the change be merged and the issue be closed.
-
-The drafts currently in the late stage are:
-
-* Invariants
-* Transport
-* TLS
-* HTTP/3
-* QPACK
-* Recovery
-
-![diagram of the late stage workflow](workflow.png "Late Stage Workflow")

You can delete this diagram here too.

I think that you might want to say outright that this repo is closed for business and that new issues should be first discussed by the working group.  Then set expectations: say that we will only consider the most serious issues that might jeopardize the successful deployment of QUIC, such as serious security flaws or bugs without workarounds.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4824#pullrequestreview-582992234

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 08 Feb 2021 14:19:00 -0800

@LPardue pushed 1 commit.

a408485205e662c3fd22da785674bf7d0df51199  simplify, simplify, simplify

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4824/files/59c65f7110da84300a4ee5406908f9342b2cedb1..a408485205e662c3fd22da785674bf7d0df51199

---

From: Martin Thomson <[email-masked]>
Date: Mon, 08 Feb 2021 16:19:18 -0800

This is good.  I think that staying silent on issues and pull requests might be best, given your note about how to engage.

> +* QUIC: A UDP-Based Multiplexed and Secure Transport
+* Version-Independent Properties of QUIC
+* Using TLS to Secure QUIC
+* QUIC Loss Detection and Congestion Control
+* Hypertext Transfer Protocol Version 3 (HTTP/3)
+* QPACK: Header Compression for HTTP/3

Links?

> -* If you're not sure how to phrase your issue, please ask on the [mailing list](https://www.ietf.org/mailman/listinfo/quic).
-
-Issues can also be raised on the [Working Group mailing
-list](https://www.ietf.org/mailman/listinfo/quic) by clearly marking them as such (e.g., "New
-Issue" in the `Subject:` line).
-
-Be aware that issues might be rephrased, changed in scope, or combined with others, so that the
-group can focus its efforts. If you feel that such a change loses an important part of your
-original issue, please bring it up, either in comments or on the list.
-
-Off-topic and duplicate issues will be closed without discussion. Note that comments on individual
-commits will only be responded to with best effort, and may not be seen.
-
-
-## Resolving Issues
+### Resolving Issues

I would keep cutting and just remove the issues and pull requests bit from here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4824#pullrequestreview-586038385

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 17 Feb 2021 07:04:03 -0800

fe7d938302b42b066f00e4cad644428d805b26d9  address more of MT' feedback

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4824/files/a408485205e662c3fd22da785674bf7d0df51199..fe7d938302b42b066f00e4cad644428d805b26d9

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 17 Feb 2021 07:07:45 -0800

7df204c7b682527fcab81d71d597f615b4e5925c  align readme with contributing

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4824/files/fe7d938302b42b066f00e4cad644428d805b26d9..7df204c7b682527fcab81d71d597f615b4e5925c

---

From: Lars Eggert <[email-masked]>
Date: Wed, 17 Feb 2021 07:17:10 -0800

@larseggert requested changes on this pull request.

-Anyone can contribute to QUIC; you don't have to join the Working Group, because there is no "membership" -- anyone who participates in the work, as outlined below, is part of the QUIC Working Group.
+The base-drafts repository is the historical home of the QUIC version 1
+specifications that were written by the QUIC Working Group.

```suggestion
specifications that were written by the IETF QUIC Working Group.
```

> +* [QUIC: A UDP-Based Multiplexed and Secure Transport](https://tools.ietf.org/html/draft-ietf-quic-transport)
+* [Version-Independent Properties of QUIC](https://tools.ietf.org/html/draft-ietf-quic-invariants)
+* [Using TLS to Secure QUIC](https://tools.ietf.org/html/draft-ietf-quic-tls)
+* [QUIC Loss Detection and Congestion Control](https://tools.ietf.org/html/draft-ietf-quic-recovery)
+* [Hypertext Transfer Protocol Version 3 (HTTP/3)](https://tools.ietf.org/html/draft-ietf-quic-http)
+* [QPACK: Header Compression for HTTP/3](https://tools.ietf.org/html/draft-ietf-quic-qpack)

The URLs should eventually be changed to the archival URLs at rfc-editor.org.

-<!-- START doctoc generated TOC please keep comment here to allow auto update -->
-<!-- DON'T EDIT THIS SECTION, INSTEAD RE-RUN doctoc TO UPDATE -->
+**All of the documents have been approved for publication as RFC. We will no

```suggestion
**All of the documents have been approved for publication as RFCs. We will no
```

> -commits will only be responded to with best effort, and may not be seen.
-
-
-## Resolving Issues
-
-Issues will be labeled by the Chairs as either `editorial` or `design`:
-
-* **Design** issues require discussion and consensus in the Working Group. This discussion can happen both in the issue and on the [Working Group mailing list](https://www.ietf.org/mailman/listinfo/quic), as outlined below.
-
-* **Editorial** issues can be dealt with by the editor(s) without consensus or notification. Typically, any discussion will take place on the issue itself.
-
-The open design issues in the issues list are those that we are currently discussing, or plan to discuss. They can be discussed on the mailing list or the issue itself.
-
-We're currently using two different processes for issue resolution, depending on draft maturity.
+Any change will be subject to careful review and discussion, which might involve
+the editors, chairs, Working Group, and our Area Director.

Maybe add:
```suggestion
After this review and discussion, errata may need to be filed for the published RFCs,
or the Working Group may otherwise address such valid issues.
```

> +  materials repository](https://github.com/quicwg/wg-materials) and the
+  [official proceedings](https://datatracker.ietf.org/wg/quic/meetings/).
+
+* Our [mailing list](https://www.ietf.org/mailman/listinfo/quic) is used for
+  most communication, including notifications of meetings, new drafts, consensus
+  calls and other business, as well as issue discussion.
+
+* We maintain several repositories in our GitHub organization
+  [Github](https://github.com/quicwg/). Specific issues are discussed on the
+  relevant issues list. If you don't want to use Github to follow these
+  discussions, you can subscribe to the [issue announce
+  list](https://www.ietf.org/mailman/listinfo/quic-issues).
+
+To be active in the Working Group, you can participate in any of these places.
+Most activity takes place on the mailing list, but if you just want to comment
+on and raise issues, that's fine too.

I'll note that we're not mentioning the Slack channel here - should we?

+**All of the documents have been approved for publication as RFC. We will no
+longer consider design changes or substantial editorial changes unless they
+relate to severe security, interoperability or deployment problems.**

You might want to point to `CONTRIBUTING.md` for more information.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4824#pullrequestreview-592295764

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 17 Feb 2021 07:25:57 -0800

4f7dfa76d1b45b2106efa4574d267c6d7c947434  Apply Lars' suggestions

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4824/files/7df204c7b682527fcab81d71d597f615b4e5925c..4f7dfa76d1b45b2106efa4574d267c6d7c947434

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 17 Feb 2021 07:36:08 -0800

@LPardue pushed 2 commits.

9380d4a6eba9d667b5037a5be527a2fa1512809f  Move contribution guidelines up to the top
da5b8222b9de6962f9727d7ea3958fdf6809155c  add Slack to Contributing

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4824/files/4f7dfa76d1b45b2106efa4574d267c6d7c947434..da5b8222b9de6962f9727d7ea3958fdf6809155c

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 17 Feb 2021 07:36:16 -0800

@LPardue commented on this pull request.

good idea, done.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4824#discussion_r577712710

---

From: Mike Bishop <[email-masked]>
Date: Wed, 17 Feb 2021 08:11:11 -0800

@MikeBishop approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4824#pullrequestreview-592366474

---

From: mjoras <[email-masked]>
Date: Wed, 17 Feb 2021 08:55:10 -0800

@mjoras approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4824#pullrequestreview-592413272

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 17 Feb 2021 08:58:00 -0800

Merged #4824 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4824#event-4342483627

---

From: Martin Thomson <[email-masked]>
Date: Wed, 17 Feb 2021 14:02:33 -0800

I think that we should create our own renderings of the final RFCs and point to those.  The official renderings are terrible.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4824#discussion_r577976027