Subject: [quicwg/base-drafts] Rejecting duplicated push streams requirement is unenforceable (#4828)

From: Guoye Zhang <[email-masked]>
Date: Tue, 16 Feb 2021 17:18:26 -0800

> Each Push ID MUST only be used once in a push stream header. If a push stream header includes a Push ID that was used in another push stream header, the client MUST treat this as a connection error of type H3_ID_ERROR

For clients that have sent CANCEL_PUSH, they don't know if server's push stream will still arrive or not. They have to remember Push IDs forever in order to differentiate between cancelled push and completed push.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4828

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 17 Feb 2021 06:41:25 -0800

I would appreciate some quick discussion if this issue is important to address before I approve or not. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4828#issuecomment-780601488

---

From: Mike Bishop <[email-masked]>
Date: Wed, 17 Feb 2021 06:51:12 -0800

We could make this a MAY.  The other formulation we've used is "MUST ... if the client detects", making the response mandatory if the condition is detected, but not specifying the required level of effort to detect it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4828#issuecomment-780607984

---

From: Mike Bishop <[email-masked]>
Date: Wed, 17 Feb 2021 06:53:24 -0800

I don't know that this issue is critical to address, but I agree that with certain (reasonable) implementation strategies this particular MUST becomes unenforceable / unachievable.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4828#issuecomment-780609596

---

From: ianswett <[email-masked]>
Date: Wed, 17 Feb 2021 07:33:06 -0800

+1 for "MUST if the client detects" if we're going to make a change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4828#issuecomment-780637162

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 17 Feb 2021 07:40:42 -0800

I think "MUST if detects" is suitable here - it points at the core problem. Simply s/MUST/MAY doesn't help people appreciate that might not be able to detect the condition. I'd also suggest that "MUST if detects" is an editorial change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4828#issuecomment-780645144

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 17 Feb 2021 11:15:28 -0800

@guoye-zhang can you confirm if #4829 addresses your issue? 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4828#issuecomment-780788133

---

From: Guoye Zhang <[email-masked]>
Date: Wed, 17 Feb 2021 11:27:51 -0800

Looks good!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4828#issuecomment-780795328

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 17 Feb 2021 11:31:59 -0800

Thanks. In that case I believe we have addressed this issue with an editorial change. @gloinul please confirm if we can merge the related PR and incorporate the change in during the RFC editor process.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4828#issuecomment-780797921

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 18 Feb 2021 07:31:53 -0800

Yes, the change looks good. I could actually include it as an RFC-edtior note in my approval message.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4828#issuecomment-781426194

---

From: Mike Bishop <[email-masked]>
Date: Thu, 18 Feb 2021 08:42:16 -0800

Closed #4828 via #4829.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4828#event-4347799697