Subject: [quicwg/base-drafts] What does GREASE mean for error codes? (#4857)

From: Victor Vasiliev <[email-masked]>
Date: Tue, 30 Mar 2021 08:38:17 -0700

We currently reserve a subset of the error code space for GREASE purposes, at least in HTTP/3.  However, we give no guidance on how to use this.  One possible interpretation is that peers should randomly replace their real error codes with a GREASE codepoint; however, some of the error codes we use do have special meaning (e.g. H3_REQUEST_REJECTED would normally result in the browser retrying the request) that would be lost, so that does not seem like an appropriate approach.

I think we should provide an explicit guidance to implementations or un-reserve those codepoints.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4857

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 30 Mar 2021 08:45:51 -0700

Endpoints should use the most appropriate error code, or a general purpose one. Grease error codes can be used to close grease streams, the spec states that somewhere.

I see your point but an implementation that chooses to ignore the specification guidance on the specific error code to use can to cause issues no matter what we statebin the spec.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4857#issuecomment-810371965

---

From: Victor Vasiliev <[email-masked]>
Date: Tue, 30 Mar 2021 08:54:44 -0700

Closed #4857.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4857#event-4528709028

---

From: Victor Vasiliev <[email-masked]>
Date: Tue, 30 Mar 2021 08:54:45 -0700

Okay, I think I did not read the spec carefully enough, it clearly says this only applies to `H3_NO_ERROR`.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4857#issuecomment-810378432