Subject: [quicwg/base-drafts] IANA: Leading zeros discrepancy (#4838)

From: Mike Bishop <[email-masked]>
Date: Tue, 16 Mar 2021 11:15:41 -0700

> In the document, the Stream Types registry presents numeric values 
> as two-digit sequences with a leading zero, while the first two 
> registries use one digit. Because 
> https://www.iana.org/assignments/quic uses two digits throughout, 
> we've used two here.

While the IANA copy of the registry uses two digits throughout, the QUIC draft is similarly inconsistent about whether literal hex values have any leading zeros.  Is it worth updating our hex literals to use full bytes (`0x00`, `0x0103`, etc.) or synchonizing on some other format?  We probably shouldn't synchronize on trimming, since IANA has already skewed the other way.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4838

---

From: Martin Thomson <[email-masked]>
Date: Tue, 23 Mar 2021 15:43:58 -0700

@MikeBishop, did #4844 fix this or do we need to inform IANA also?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4838#issuecomment-805316275

---

From: Mike Bishop <[email-masked]>
Date: Tue, 23 Mar 2021 15:48:13 -0700

We should probably shoot IANA an e-mail to update the registries with leading zeroes where they hadn't already assumed them.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4838#issuecomment-805318160

---

From: Martin Thomson <[email-masked]>
Date: Tue, 23 Mar 2021 16:37:34 -0700

I'll let you do that.  The only registries that are affected are in HTTP/3 and QPACK.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4838#issuecomment-805351090