Subject: [quicwg/base-drafts] Merge text on what not to send in response to ACKs (#4855)

From: ianswett <[email-masked]>
Date: Sun, 28 Mar 2021 13:56:51 -0700

Editorial improvement to fix #4833
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4855

-- Commit Summary --

  * Merge text on what not to send in response to ACKs

-- File Changes --

    M draft-ietf-quic-transport.md (12)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4855.patch
https://github.com/quicwg/base-drafts/pull/4855.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4855

---

From: ianswett <[email-masked]>
Date: Sun, 28 Mar 2021 14:18:34 -0700

@ianswett pushed 1 commit.

da100f58042e052a87a9d53cced714b87c650dbb  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4855/files/caea0a859bd2e5e572d0d8d45d9f6d0acb8c02d8..da100f58042e052a87a9d53cced714b87c650dbb

---

From: Martin Thomson <[email-masked]>
Date: Sun, 28 Mar 2021 16:10:29 -0700

@martinthomson approved this pull request.

Caution: this is starting to get to the point that tracking these in AUTH48 will be more difficult.  This is fine, but it is also unnecessary.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4855#pullrequestreview-622794480

---

From: Martin Thomson <[email-masked]>
Date: Tue, 30 Mar 2021 15:22:35 -0700

@martinthomson commented on this pull request.

> +an infinite feedback loop of acknowledgments, which could prevent the
+connection from ever becoming idle.  Non-ack-eliciting packets are eventually

```suggestion
an infinite feedback loop of acknowledgments.  Non-ack-eliciting packets are eventually
```

I think that the connection between infinite loop and never being idle is clear enough without saying it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4855#pullrequestreview-624751086

---

From: Martin Thomson <[email-masked]>
Date: Tue, 30 Mar 2021 15:25:51 -0700

Ok, that wasn't in the moved text, but it was in the original text at this location.  I can go either way.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4855#discussion_r604470959

---

From: Martin Thomson <[email-masked]>
Date: Tue, 30 Mar 2021 15:38:30 -0700

After having discussed this, I think that I'm opposed to this change.  @janaiyengar points out that the moved sentence more directly links to the paragraph preceding it.

There is a gap here.  We don't say here that you might deliberately include ack-eliciting frames in packets that are otherwise non-ack-eliciting so that you can get an acknowledgment.  The moved text here is about this case, saying that you can't do that every time.  It's missing that important context though.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4855#pullrequestreview-624758970

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 30 Mar 2021 15:53:19 -0700

I prefer #4859 -- let's do that one instead.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4855#issuecomment-810630471