Subject: [quicwg/base-drafts] There is not a singular application protocol error code space (#4856)

From: Lucas Pardue <[email-masked]>
Date: Mon, 29 Mar 2021 17:38:59 -0700

@martinthomson originally posted in https://github.com/quicwg/ops-drafts/pull/298#r600964526 a comment highlighting that although HTTP/3 uses a single error code space for connection and stream errors, there is no requirement for other application protocol mappings to do the same.

I found the text in https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#section-19.19 to give me the wrong assumptions. 

>  A CONNECTION_CLOSE frame of type 0x1d uses codes from the application protocol error code space

This is the only mention of an error code space in the text that will make it into RFC. So I suggest in the offending paragraph we delete the 2 occurrences of "space" and just state that the frame contains a value, either defined in transport [ref] or application [ref]

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4856

---

From: Mike Bishop <[email-masked]>
Date: Tue, 30 Mar 2021 13:02:19 -0700

"uses codes defined by the application protocol"?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4856#issuecomment-810540227