Subject: [quicwg/base-drafts] Pad hex literals to byte lengths (#4844)

From: Mike Bishop <[email-masked]>
Date: Thu, 18 Mar 2021 07:59:25 -0700

One possible resolution to #4838; all literals are zero-padded to full bytes.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4844

-- Commit Summary --

  * Pad hex literals to byte lengths

-- File Changes --

    M draft-ietf-quic-http.md (68)
    M draft-ietf-quic-qpack.md (20)
    M draft-ietf-quic-tls.md (16)
    M draft-ietf-quic-transport.md (2)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4844.patch
https://github.com/quicwg/base-drafts/pull/4844.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4844

---

From: Mike Bishop <[email-masked]>
Date: Thu, 18 Mar 2021 08:00:14 -0700

@MikeBishop pushed 1 commit.

6cbcc3cad959f38321b44804a86b39b7cc026eb0  Pad hex literals to byte lengths

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4844/files/f2292f2b14d90eaad69d41af5c96f57178f07d0b..6cbcc3cad959f38321b44804a86b39b7cc026eb0

---

From: Martin Thomson <[email-masked]>
Date: Thu, 18 Mar 2021 16:29:00 -0700

@martinthomson approved this pull request.

Yeah, this is easy to understand.  The tables must have been annoying.

> @@ -7688,7 +7688,7 @@ packets, or 0xe69e), 16 bits are required.
 
 In the same state, sending a packet with a number of 0xace8fe uses the 24-bit
 encoding, because at least 18 bits are required to represent twice the range
-(131,182 packets, or 0x2006e).
+(131,182 packets, or 0x02006e).

This is the only one I might skip here.  The others are distinctly and obviously references to codepoints, where consistency of presentation is worthwhile.  This is just a number in an example.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4844#pullrequestreview-615952883

---

From: Sean Turner <[email-masked]>
Date: Sun, 21 Mar 2021 08:36:57 -0700

@seanturner approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4844#pullrequestreview-617032812

---

From: Martin Thomson <[email-masked]>
Date: Tue, 23 Mar 2021 15:39:54 -0700

@martinthomson pushed 1 commit.

2af901998f5c5a4b2007de1a5df6e12bb2523a83  Merge branch 'master' into leading-zeros

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4844/files/6cbcc3cad959f38321b44804a86b39b7cc026eb0..2af901998f5c5a4b2007de1a5df6e12bb2523a83

---

From: Martin Thomson <[email-masked]>
Date: Tue, 23 Mar 2021 15:41:41 -0700

Merged #4844 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4844#event-4498875748