Subject: Re: [quicwg/base-drafts] Recovery: Corner case for when persistent congestion does not go into slow start (#4826)

From: Martine Lenders <[email-masked]>
Date: Thu, 22 Apr 2021 01:41:50 -0700

Ping?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4826#issuecomment-824656772

---

From: ianswett <[email-masked]>
Date: Thu, 22 Apr 2021 12:15:21 -0700

I discussed this with Jana when this was posted in late February, and the state machine becomes even more complex if one wants to handle every possible case, and this is not a typical one.  For example, slow start can also be exited due to the CWND exceeding the previous slow start threshold and one can re-enter recovery after receiving an acknowledgement of a packet, though possibly that's just a double-transition?  I believe there was another unlikely, but possible case we discussed that @janaiyengar might remember.

I'm not a big fan of the state machine personally, but it's very late to remove it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4826#issuecomment-825117407