Subject: [quicwg/base-drafts] Use zero-width spaces for the table (#4919)

From: Martin Thomson <[email-masked]>
Date: Tue, 18 May 2021 17:24:17 -0700

Until https://trac.tools.ietf.org/tools/xml2rfc/trac/ticket/548 is
fixed, this will generate horrible, horrible warnings, but this is what
we have agreed to have published.  It fixes an awkward layout arrangement.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4919

-- Commit Summary --

  * Use zero-width spaces for the table

-- File Changes --

    M rfc9000.md (2)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4919.patch
https://github.com/quicwg/base-drafts/pull/4919.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4919

---

From: Nick Banks <[email-masked]>
Date: Tue, 18 May 2021 17:26:39 -0700

@nibanks approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4919#pullrequestreview-662679450

---

From: Martin Thomson <[email-masked]>
Date: Tue, 18 May 2021 17:27:18 -0700

@martinthomson pushed 1 commit.

b63b4656ca3594546e3263e7b44f858902bbe475  Escape the single-quote to avoid smart quotes

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4919/files/7bdab26b2c2ca3e4ae2e66f04bd2a3f61656be3f..b63b4656ca3594546e3263e7b44f858902bbe475

---

From: Mike Bishop <[email-masked]>
Date: Wed, 19 May 2021 06:50:04 -0700

@MikeBishop commented on this pull request.

> @@ -7646,7 +7646,7 @@ The initial contents of this registry are shown in {{iana-error-table}}.
 | 0x0e  | KEY_UPDATE_ERROR          | Invalid packet protection update | {{error-codes}} |
 | 0x0f  | AEAD_LIMIT_REACHED        | Excessive use of packet protection keys | {{error-codes}} |
 | 0x10  | NO_VIABLE_PATH            | No viable network path exists | {{error-codes}} |
-| 0x0100 - 0x01ff | CRYPTO_ERROR     | TLS alert code                | {{error-codes}} |
+| 0x0100-​0x01ff | CRYPTO_ERROR      | TLS alert code                | {{error-codes}} |

Note that in 7753edbbe54c2c4f3acbbee7d878d5f14769c08a you added a space to avoid awkward table positioning in the txt output.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4919#pullrequestreview-663229074

---

From: Martin Thomson <[email-masked]>
Date: Wed, 19 May 2021 17:31:56 -0700

@martinthomson commented on this pull request.

Yes.  This is the result of an exchange with the RFC editor.  What you don't see here is that I added a space here also.  There is a zero-width space after the hyphen.  Of course, our tools erase this thanks to a bug in xml2rfc, but we've been promised a fix to that, so the table layout issue should eventually go away.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4919#discussion_r635667902

---

From: Martin Thomson <[email-masked]>
Date: Sun, 23 May 2021 17:28:41 -0700

@martinthomson pushed 2 commits.

8cdd7067fb84f38d04a46c0db12f90b18229d27c  Escape quote
31ea24cd127f514b8fa77b82b5629152c10e87dd  Use kramdown-rfc2629 pre-release

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4919/files/b63b4656ca3594546e3263e7b44f858902bbe475..31ea24cd127f514b8fa77b82b5629152c10e87dd

---

From: Jana Iyengar <[email-masked]>
Date: Sun, 23 May 2021 19:26:02 -0700

@janaiyengar approved this pull request.

Thanks for fixing these annoying issues. Merge if you think you're done with it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4919#pullrequestreview-666350169

---

From: Martin Thomson <[email-masked]>
Date: Sun, 23 May 2021 20:37:32 -0700

I'm going to wait for one of two things:

1. the latest kramdown release; until then, this won't build properly
2. RFC (in which case, to hell with this building correctly)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4919#issuecomment-846709009

---

From: Martin Thomson <[email-masked]>
Date: Sun, 23 May 2021 20:37:52 -0700

Merged #4919 into main.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4919#event-4784282465