Subject: Re: [quicwg/base-drafts] RPC text changes up to Section 10 (#4877)

From: Martin Thomson <[email-masked]>
Date: Sun, 02 May 2021 17:20:34 -0700

@martinthomson pushed 1 commit.

55c21aa1b1ed9eb8e00ed9954d0b6ffd35724bdd  Jana had some more text to add

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4877/files/9036660402a98810f9ea21839cc27f641a27a1b8..55c21aa1b1ed9eb8e00ed9954d0b6ffd35724bdd

---

From: Martin Thomson <[email-masked]>
Date: Sun, 02 May 2021 17:20:58 -0700

@martinthomson commented on this pull request.

Thanks Jana; I have taken most of these.  Comments on the rest follow.

>  servers.

-### Address Validation using Retry Packets {#validate-retry}
+### Address Validation Using Retry Packets {#validate-retry}

So was I.  I will ask directly and confirm that this was deliberate.

> @@ -833,7 +834,7 @@ consuming a large amount of memory.  To enable a receiver to limit memory
 commitments for a connection, streams are flow controlled both individually and
 across a connection as a whole.  A QUIC receiver controls the maximum amount of
 data the sender can send on a stream as well as across all streams at any time,
-as described in {{data-flow-control}} and {{fc-credit}}.
+as described in Sections {{<data-flow-control}} and {{<fc-credit}}.

New magic.  It is rendered as "4.3" instead of "Section 4.3".

>  An endpoint SHOULD limit the number of connection IDs it has retired locally and
 have not yet been acknowledged. An endpoint SHOULD allow for sending and

Yeah, this one makes me nervous.  I get that the original is a shade awkward, but I really don't want to touch this one.  More so when I see the mistake in your suggestion below.

> +tracking a number of RETIRE_CONNECTION_ID frames of at least twice the value of
+the active_connection_id_limit transport parameter. An endpoint MUST NOT forget

This isn't about giving the endpoint (the one that sends RETIRE_CONNECTION_ID) a limit.  Saying "is allowed to send and track" implies that the endpoint cannot send more than this.  The point is that it might need to apply its own limits to avoid having to track too many outstanding frames.

>  {{initiating-migration}} or when probing a new network path as described in
 {{probing}}.
 
 Similarly, an endpoint MUST NOT reuse a connection ID when sending to more than
 one destination address.  Due to network changes outside the control of its
 peer, an endpoint might receive packets from a new source address with the same
-destination connection ID, in which case it MAY continue to use the current
+Destination Connection ID, in which case it MAY continue to use the current

We've capitalized field names, so I think that this is right.  We don't use "destination" without referring to the field.

Do you want to say "field value" here to further clarify?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4877#pullrequestreview-650038007

---

From: Martin Thomson <[email-masked]>
Date: Sun, 02 May 2021 17:22:51 -0700

@martinthomson pushed 2 commits.

595a86866da65ec667a4a4313cb811b4dbf533eb  Wrap; my own tweaks
e4f20916ec6696c683a4db01c1223d14d556db5c  Merge branch 'master' into rpc-transport-1

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4877/files/55c21aa1b1ed9eb8e00ed9954d0b6ffd35724bdd..e4f20916ec6696c683a4db01c1223d14d556db5c

---

From: Martin Thomson <[email-masked]>
Date: Sun, 02 May 2021 22:18:42 -0700

3ff19a2e3fb7466a26f08a6626fc964f238e0f8e  Reword transport parameter remembering text

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4877/files/e4f20916ec6696c683a4db01c1223d14d556db5c..3ff19a2e3fb7466a26f08a6626fc964f238e0f8e

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 04 May 2021 11:57:14 -0700

@janaiyengar commented on this pull request.

Thanks, @martinthomson ! A few responses.

Yup, I understand the hesitation. I'd like to see if we can make it clearer, since at the moment, the sentence structure is going to require disambiguating (and we are going to receive requests from translators asking us to disambiguate later).

Reading it now makes this more reasonable ... I think I must have been reading it differently earlier. I don't mind dropping this one ... but I'd like to discuss the one above.

 {{probing}}.

Good point. We do use `Destination Connection ID` elsewhere too, so I think this is ok.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4877#pullrequestreview-651558671

---

From: Martin Thomson <[email-masked]>
Date: Tue, 04 May 2021 15:17:01 -0700

9b0c5db0bd3f3d297c1a1eac3aea7195ae8f5322  Missed one capital C on connection ID
e4efe870896842e2a15b0cf053cc613d39567ece  it's the frames that are not acknowledged

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4877/files/3ff19a2e3fb7466a26f08a6626fc964f238e0f8e..e4efe870896842e2a15b0cf053cc613d39567ece

---

From: Martin Thomson <[email-masked]>
Date: Tue, 04 May 2021 15:24:46 -0700

fb225bce1cd9a9854384d934f79c3538926306b9  ~~and~~

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4877/files/e4efe870896842e2a15b0cf053cc613d39567ece..fb225bce1cd9a9854384d934f79c3538926306b9

---

From: Martin Thomson <[email-masked]>
Date: Tue, 04 May 2021 15:27:58 -0700

Merged #4877 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4877#event-4685985574