Subject: [quicwg/base-drafts] Rpc recovery (#4895)

From: Martin Thomson <[email-masked]>
Date: Tue, 11 May 2021 15:11:21 -0700

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4895

-- Commit Summary --

  * Add some keywords
  * Missed a few
  * Take feedback, sort
  * Fixup
  * Up to S6 for recovery

-- File Changes --

    M rfc8999.md (11)
    M rfc9000.md (17)
    M rfc9001.md (8)
    M rfc9002.md (241)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4895.patch
https://github.com/quicwg/base-drafts/pull/4895.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4895

---

From: Martin Thomson <[email-masked]>
Date: Tue, 11 May 2021 15:15:00 -0700

@martinthomson pushed 1 commit.

90fa21970201dba6a71b5bfada19cde13fa6a51d  Up to S6 for recovery

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4895/files/172c013baf76118086aa75d4cd06d539551b10eb..90fa21970201dba6a71b5bfada19cde13fa6a51d

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 11 May 2021 15:28:06 -0700

@janaiyengar approved this pull request.

 ## Probe Timeout {#pto}
 
-A Probe Timeout (PTO) triggers sending one or two probe datagrams when
+A Probe Timeout (PTO) the triggers of sending one or two probe datagrams when

```suggestion
A Probe Timeout (PTO) triggers the sending of one or two probe datagrams when
```

 A connection MAY use the delay between sending a PATH_CHALLENGE and receiving a
 PATH_RESPONSE to set the initial RTT (see kInitialRtt in
 {{constants-of-interest}}) for a new path, but the delay SHOULD NOT be
 considered an RTT sample.
 
-When the Initial keys and Handshake keys are discarded ({{discarding-packets}}),
-any Initial packets and Handshake packets can no longer be acknowledged, so
-they are removed from bytes in flight. When Initial or Handshake keys are
-discarded, the PTO and loss detection timers MUST be reset, because discarding
-keys indicates forward progress and the loss detection timer might have been set
-for a now discarded packet number space.
+When the Initial keys and Handshake keys are discarded (see
+{{discarding-packets}}), any Initial packets and Handshake packets can
+no longer be acknowledged, so they are removed from bytes in
+flight. When Initial or Handshake keys are discarded, the PTO and loss
+detection timers MUST be reset, because discarding keys indicates
+forward progress and the loss detection timer might have been set for
+a now discarded packet number space.

```suggestion
a now-discarded packet number space.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4895#pullrequestreview-657278249

---

From: Martin Thomson <[email-masked]>
Date: Tue, 11 May 2021 15:28:28 -0700

126fedb8111ac6c056dcdc61a6ca03d8f43b9586  duuuuh

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4895/files/90fa21970201dba6a71b5bfada19cde13fa6a51d..126fedb8111ac6c056dcdc61a6ca03d8f43b9586

---

From: Martin Thomson <[email-masked]>
Date: Tue, 11 May 2021 15:28:36 -0700

e304d4650b36a7f843f04a98a888c499a70453c9  hyphen

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4895/files/126fedb8111ac6c056dcdc61a6ca03d8f43b9586..e304d4650b36a7f843f04a98a888c499a70453c9

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 11 May 2021 15:29:31 -0700

Merged #4895 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4895#event-4732115496