Subject: Re: [quicwg/base-drafts] Second batch of changes for transport (#4879)

From: Martin Thomson <[email-masked]>
Date: Sun, 02 May 2021 17:31:15 -0700

@martinthomson pushed 1 commit.

68e8fe8d91571d89f5679c6b51c02cc7ef72644a  ready for some line length warnings

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4879/files/6baec2cb66bf803dd971e832781c4e2ebfa3f1dc..68e8fe8d91571d89f5679c6b51c02cc7ef72644a

---

From: Martin Thomson <[email-masked]>
Date: Sun, 02 May 2021 17:38:17 -0700

@martinthomson pushed 3 commits.

4b680caf9971331ad480afa2d6af7dc951056603  Fixups
c55c989b1521f28f48ec89ff9a3377a410bdb570  Merge branch 'master' into rpc-transport-2
3e9b27d56c7473d0e6f1e52a0a41bc70a142d092  wrap

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4879/files/68e8fe8d91571d89f5679c6b51c02cc7ef72644a..3e9b27d56c7473d0e6f1e52a0a41bc70a142d092

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 04 May 2021 13:08:25 -0700

@janaiyengar approved this pull request.

One nit, but LGTM.

> @@ -5364,7 +5375,7 @@ Preferred Address {
   Stateless Reset Token (128),
 }
 ~~~
-{: #fig-preferred-address title="Preferred Address format"}
+{: #fig-preferred-address title="Preferred Address Format"}
 
 active_connection_id_limit (0x0e):

In the description below: s/"The active connection ID limit is"/"This is"

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4879#pullrequestreview-651620521

---

From: Martin Thomson <[email-masked]>
Date: Tue, 04 May 2021 15:00:51 -0700

@martinthomson pushed 4 commits.

aa92e26822745fbcab268b229250e6281c0f6f85  Missed a destination connection ID in lowercase
5ee395c54988717740ab8b4eb634c0346965eeec  Make largest acknowledged consistent
f7561f50361a250df6c77d76f37a1fc0d717f1ed  Make stream ID lowercase when it isn't a field
eeaec316c34a2e95b4b12f5d31ec1bb38747c9b0  Another 'this'

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4879/files/3e9b27d56c7473d0e6f1e52a0a41bc70a142d092..eeaec316c34a2e95b4b12f5d31ec1bb38747c9b0

---

From: Martin Thomson <[email-masked]>
Date: Tue, 04 May 2021 15:30:31 -0700

@martinthomson commented on this pull request.

 The following transport parameters are defined:
 
 original_destination_connection_id (0x00):
 
-: The value of the Destination Connection ID field from the first Initial packet
-  sent by the client; see {{cid-auth}}.  This transport parameter is only sent
-  by a server.
+: This parameter is the value of the Destination Connection ID field from the

No idea.  I'm not clear on what the rules are...  I just blindly added anything that wasn't concretely wrong :)

> @@ -5415,14 +5426,14 @@ active_connection_id_limit (0x0e):
 
 initial_source_connection_id (0x0f):
 
-: The value that the endpoint included in the Source Connection ID field of the
-  first Initial packet it sends for the connection; see {{cid-auth}}.
+: This is the value that the endpoint included in the Source Connection ID field

I think that these specific examples were not consistent in form with the other items in the list.  For instance, the above says "The active connection ID limit is an integer".

We could change "this" to something more descriptive, but as the definition here is more complex, I think that "this" works fine.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4879#discussion_r624832742

---

From: Martin Thomson <[email-masked]>
Date: Tue, 04 May 2021 15:30:34 -0700

Merged #4879 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4879#event-4685992697