Subject: [quicwg/base-drafts] All the missing pieces in RFC 9000 that I found (#4913)

From: Martin Thomson <[email-masked]>
Date: Tue, 11 May 2021 18:34:27 -0700

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4913

-- Commit Summary --

  * All the missing pieces in RFC 9000 that I found

-- File Changes --

    M rfc9000.md (150)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4913.patch
https://github.com/quicwg/base-drafts/pull/4913.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4913

---

From: Martin Thomson <[email-masked]>
Date: Tue, 11 May 2021 18:40:31 -0700

@martinthomson pushed 1 commit.

f520a5f9f40581adaf80689f888b6f50872a8218  Wrap

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4913/files/9b588fcdeddf32cc20ff7568e40f0ff83b688d0a..f520a5f9f40581adaf80689f888b6f50872a8218

---

From: Martin Thomson <[email-masked]>
Date: Tue, 11 May 2021 18:45:45 -0700

b7cb66305ad2dfad37252616aeee93fbe4efd978  All the stuff in RFC 9002 we missed in a screaming rush

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4913/files/f520a5f9f40581adaf80689f888b6f50872a8218..b7cb66305ad2dfad37252616aeee93fbe4efd978

---

From: Martin Thomson <[email-masked]>
Date: Tue, 11 May 2021 18:46:09 -0700

@martinthomson pushed 0 commits.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4913/files/b7cb66305ad2dfad37252616aeee93fbe4efd978..f520a5f9f40581adaf80689f888b6f50872a8218

---

From: Mike Bishop <[email-masked]>
Date: Wed, 12 May 2021 08:26:59 -0700

@MikeBishop approved this pull request.

> @@ -1382,7 +1382,7 @@ when a client's address changes.
 
 A server in a deployment that does not implement a solution to maintain
 connection continuity when the client address changes SHOULD indicate that
-migration is not supported by using the disable_active_migration transport

@janaiyengar explicitly added this "by" in 4601579.

> @@ -1829,7 +1829,7 @@ constraints conflict.
 
 Using 0-RTT depends on both client and server using protocol parameters that
 were negotiated from a previous connection.  To enable 0-RTT, endpoints store
-the values of the server transport parameters with any session tickets it
+the value of the server transport parameters with any session tickets it

This seems inconsistent with the remainder of the paragraph and following, where we talk about "values" for the individual parameters.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4913#pullrequestreview-658023392

---

From: Martin Thomson <[email-masked]>
Date: Wed, 12 May 2021 17:48:50 -0700

fedca1bf6846c4308c5cee9bf1e70cf8e876a5d9  Revert two deliberate changes

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4913/files/f520a5f9f40581adaf80689f888b6f50872a8218..fedca1bf6846c4308c5cee9bf1e70cf8e876a5d9

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 12 May 2021 17:51:04 -0700

@janaiyengar approved this pull request.

one comment but rest lgtm -- thanks!

Yup -- @MikeBishop added "that" on line 1384, which I think makes this "by" necessary.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4913#pullrequestreview-658495501

---

From: Martin Thomson <[email-masked]>
Date: Wed, 12 May 2021 17:51:42 -0700

Merged #4913 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4913#event-4739403620