Subject: [quicwg/base-drafts] Recommend careful behavior around push streams (#4931)

From: Mike Bishop <[email-masked]>
Date: Fri, 30 Jul 2021 11:39:13 -0700

Note that all of these recommendations are SHOULD NOT -- an implementation under memory pressure might choose to discard data aggressively, even at the risk of degrading the connection state.  Closes #4930.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4931

-- Commit Summary --

  * Recommend careful behavior

-- File Changes --

    M draft-ietf-quic-http.md (11)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4931.patch
https://github.com/quicwg/base-drafts/pull/4931.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4931

---

From: Lucas Pardue <[email-masked]>
Date: Fri, 30 Jul 2021 16:02:17 -0700

@LPardue commented on this pull request.

> @@ -1193,6 +1198,10 @@ Push Stream Header {
 ~~~~~~~~~~
 {: #fig-push-stream-header title="Push Stream Header"}
 
+A client SHOULD NOT abort reading on a push stream prior to reading the Push ID,

```suggestion
A client SHOULD NOT abort reading a push stream prior to reading the Push ID,
```

maybe?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4931#pullrequestreview-719508866

---

From: Lucas Pardue <[email-masked]>
Date: Fri, 30 Jul 2021 16:04:34 -0700

Thanks Mike. The change looks fine to me, I'll let others debate the finer details.

Assuming this is the preferred direction, I'd ask that we hold the PR and not merge it until all the process stuff is in hand.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4931#issuecomment-890241450

---

From: Kazuho Oku <[email-masked]>
Date: Fri, 30 Jul 2021 16:39:58 -0700

@kazuho approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4931#pullrequestreview-719518202

---

From: Martin Thomson <[email-masked]>
Date: Fri, 30 Jul 2021 19:01:12 -0700

@martinthomson commented on this pull request.

Thanks.  I think that the first change is the key change here; the latter changes are probably not a good idea.  Instead, I would note that if the client does abort reading (for either request streams or push streams) then this risks loss of any push ID that might have been sent, which might lead to timeouts.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4931#pullrequestreview-719535181