Subject: Re: [quicwg/base-drafts] negative base values (#4938)

From: Lucas Pardue <[email-masked]>
Date: Mon, 04 Oct 2021 05:36:08 -0700

Is there a concrete proposal here? Seeing a PR would let us understand the scope of change being proposed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4938#issuecomment-933440823

---

From: Bence Béky <[email-masked]>
Date: Tue, 05 Oct 2021 07:56:30 -0700

Kazuho, nice find!  I agree with your intuition.  In fact when I implemented QPACK decoding back in December 2018 I already assumed Base must not be negative and made our decoder close the connection (not just the stream) with QPACK_DECOMPRESSION_FAILED if it was negative, see https://github.com/google/quiche/blob/a6ef0a64fd597e53003c7846192790ed0e3642b5/quic/core/qpack/qpack_progressive_decoder.cc#L331.  This implementation has been used by Google's servers and by Chrome ever since we support HTTP/3, and I have not seen reports of interop problems, so I assume not many encoders out there generate negative Base values.

I support adding clarification to the specs.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4938#issuecomment-934487083