Subject: Re: [quicwg/base-drafts] Disagreement in handling of unknown unidirectional stream types (#4929)

From: Lucas Pardue <[email-masked]>
Date: Mon, 01 Nov 2021 06:48:51 -0700

> First and editorial, if the type is unknown/unsupported, the presence of frames can't be determined. This should refer to discarding any data, not frames specifically.

Agree. This change would meet the intent of the text and is editorial.

>  think the intent was MUST abort, but MAY pick an error code. Looking at the history of the commits in Section 6.2, it was first MUST abort, then SHOULD use a particular code, then became MAY use the specific code with the prohibition on blowing up the whole connection. The text should clarify the scope of the MAY.

So it the proposal here something like:

> If the stream header indicates a stream type that is not supported by the recipient, the remainder of the stream cannot be consumed as the semantics are unknown. Recipients of unknown stream types MAY abort reading of the stream and SHOULD use the H3_STREAM_CREATION_ERROR or a reserved error code (Section 8.1), but MUST NOT consider such streams to be a connection error of any kind.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4929#issuecomment-956249201

---

From: Mike Bishop <[email-masked]>
Date: Mon, 01 Nov 2021 09:19:21 -0700

I think I'd say "MUST either abort reading of the stream or discard incoming data without further processing.  If reading is aborted, the recipient SHOULD use...."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4929#issuecomment-956376387

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 01 Nov 2021 09:23:15 -0700

That would work for me too, care to make a PR?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4929#issuecomment-956379662