Subject: [quicwg/base-drafts] Auth48: Capitalization consistency (Issue #4950)

From: Mike Bishop <[email-masked]>
Date: Mon, 14 Feb 2022 10:11:42 -0800

Multiple related points (split slightly differently from how the RFC Ed did it):

> Throughout the text, the following terminology appears to be used 
> inconsistently. Please review these occurrences and let us know if any 
> updates are necessary.
> 
> - frame payload vs. Frame Payload
> - stream ID vs Stream ID

In general, the intent is to use "stream ID" or "frame payload" (lowercase) to refer to the identifier or payload itself, but "Stream ID" or "Frame Payload" (capitalized) to refer to the name of a field in a frame which carries an identifier or payload.  (Field names are intended to be capitalized in all cases.)  I will review instances of these terms to double-check whether that convention is used correctly throughout.

> Note that the authors of RFC 9000 indicated "stream ID" is correct.  This document introduces "Push ID" - should "stream ID" and "push ID" have the same capitalizaton? 

"Push ID" is deliberately capital, but by parallel with similar terms, it should probably be lowercase except when referring to the actual field.

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4950
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/issues/[email-masked]>

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 14 Feb 2022 10:34:44 -0800

Push ID -> push ID suggestion works for me

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4950#issuecomment-1039420402
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/issues/4950/[email-masked]>

---

From: Martin Thomson <[email-masked]>
Date: Mon, 14 Feb 2022 14:18:06 -0800

Yep, as Mike says:
Concept: push ID
Field: Push ID

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4950#issuecomment-1039627774
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/issues/4950/[email-masked]>