Subject: [quicwg/base-drafts] Rearrange and rename to align with updated HTTP/2 spec (PR #4959)

From: Mike Bishop <[email-masked]>
Date: Thu, 17 Feb 2022 13:43:19 -0800

The diff looks larger than it is; I moved some sections around to more closely resemble the TOC of the HTTP/2 spec, and changed a section title that seemed a bit odd a year later.  The relocated sections haven&#39;t changed.

Old TOC:
4.  HTTP Request Lifecycle
4.1.  HTTP Message Exchanges
4.1.1.  Field Formatting and Compression
4.1.2.  Request Cancellation and Rejection
4.1.3.  Malformed Requests and Responses
4.2.  The CONNECT Method
4.3.  HTTP Upgrade
4.4.  Server Push

New TOC:
4.  Expressing HTTP Semantics in HTTP/3
4.1.  HTTP Message Framing
4.1.1.  Request Cancellation and Rejection
4.1.2.  Malformed Requests and Responses
4.1.3.  HTTP Fields
4.2.  HTTP Control Data
4.2.1.  Request Pseudo-Header Fields
4.2.2.  Response Pseudo-Header Fields
4.3.  The CONNECT Method
4.4.  HTTP Upgrade
4.5.  Server Push

Comparison H2 TOC:
8.  Expressing HTTP Semantics in HTTP/2
8.1.  HTTP Message Framing
8.1.1.  Malformed Messages
8.2.  HTTP Fields
8.2.1.  Field Validity
8.2.2.  Connection-Specific Header Fields
8.2.3.  Compressing the Cookie Header Field
8.3.  HTTP Control Data
8.3.1.  Request Pseudo-Header Fields
8.3.2.  Response Pseudo-Header Fields
8.4.  Server Push
8.4.1.  Push Requests
8.4.2.  Push Responses
8.5.  The CONNECT Method
8.6.  The Upgrade Header Field

...and then some further sections as well.

Fixes #4953.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4959

-- Commit Summary --

  * Rearrange and rename to align with updated HTTP/2 spec

-- File Changes --

    M rfc9114.md (252)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4959.patch
https://github.com/quicwg/base-drafts/pull/4959.diff

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4959
You are receiving this because you are subscribed to this thread.

Message ID: &lt;quicwg/base-drafts/pull/[email-masked]&gt;

---

From: Mike Bishop <[email-masked]>
Date: Thu, 17 Feb 2022 13:45:58 -0800

@MikeBishop pushed 1 commit.

7f63bb03dd803c7ce9fcab6cbe2a8b5476a2a73c  Move Fields up a level

-- 
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4959/files/af0b0cbece91a8f5c9d1f10b6bf1547a20f1b0aa..7f63bb03dd803c7ce9fcab6cbe2a8b5476a2a73c
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4959/push/[email-masked]>

---

From: Mike Bishop <[email-masked]>
Date: Tue, 22 Feb 2022 12:17:03 -0800

acd3adf758c4dc8e8c3e040f619a7d8385d231f0  Minor tweaks

-- 
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4959/files/7f63bb03dd803c7ce9fcab6cbe2a8b5476a2a73c..acd3adf758c4dc8e8c3e040f619a7d8385d231f0
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4959/push/[email-masked]>

---

From: Mike Bishop <[email-masked]>
Date: Tue, 22 Feb 2022 12:21:10 -0800

eecbcb1e978b3e849312fc225b46db45f8d2f651  Fix section nesting

-- 
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4959/files/e76355e10eaf665990027e31467036275b91b325..eecbcb1e978b3e849312fc225b46db45f8d2f651
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4959/push/[email-masked]>

---

From: Mike Bishop <[email-masked]>
Date: Tue, 22 Feb 2022 12:21:57 -0800

Merged #4959 into h3qp_auth48.

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4959#event-6120733600
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4959/issue_event/[email-masked]>