Subject: [quicwg/base-drafts] Auth48: References to ASCII characters (Issue #4952)

From: Mike Bishop <[email-masked]>
Date: Mon, 14 Feb 2022 10:15:37 -0800

The RFC Editor asks:

> Please review the way characters and ASCII equivalents are displayed with regard to quotation and whether the ASCII value is listed etc. and let us know if/how to update.
> 
> - ':' character (ASCII 0x3a)
> - "?" character
> - the value '*' 
> - 0x3b, 0x20 (the ASCII string "; ")
> - carriage return (CR, ASCII 0xd)
> - line feed (LF, ASCII 0xa)
> - zero character (NUL, ASCII 0x0

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4952
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/issues/[email-masked]>

---

From: Mike Bishop <[email-masked]>
Date: Tue, 22 Feb 2022 12:31:39 -0800

Along the way, there are two equivalent statements that need to be deduplicated that this change touches:

>Contains the path and query parts of the target URI (the "path-absolute" production and optionally a '?' character followed by the "query" production; see Sections [3.3](https://rfc-editor.org/rfc/rfc3986#section-3.3) and [3.4](https://rfc-editor.org/rfc/rfc3986#section-3.4) of [[URI](https://github.com/quicwg/base-drafts/issues/4952#URI)]. **A request in asterisk form includes the value '*' for the ":path" pseudo-header field.**

>
>This pseudo-header field MUST NOT be empty for "http" or "https" URIs; "http" or "https" URIs that do not contain a path component MUST include a value of '/'. **The exception to this rule is an OPTIONS request for an "http" or "https" URI that does not include a path component; these MUST include a ":path" pseudo-header field with a value of '*'; see [Section 7.1](https://rfc-editor.org/rfc/rfc9110#section-7.1) of [[HTTP](https://github.com/quicwg/base-drafts/issues/4952#HTTP)].**

I would suggest collapsing these two into the first statement, but using OPTIONS as an example and keeping the reference into http-core.

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4952#issuecomment-1048186600
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/issues/4952/[email-masked]>

---

From: Mike Bishop <[email-masked]>
Date: Tue, 22 Feb 2022 12:55:09 -0800

Or perhaps that should be a question -- is there a difference between asterisk-form and OPTIONS-without-path?  

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4952#issuecomment-1048203101
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/issues/4952/[email-masked]>