Subject: [quicwg/base-drafts] Easy RFC Editor Questions (PR #4954)

From: Mike Bishop <[email-masked]>
Date: Mon, 14 Feb 2022 10:37:30 -0800

This PR covers questions asked during Auth48 which aren&#39;t pure copyediting, but seem to have a straightforward single-location fix.  Individual commits, so it&#39;s easy to pull one out if someone disagrees.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4954

-- Commit Summary --

  * Question 4; fixes #4947
  * Question 5
  * Question 6: parallel or reduce explanation?
  * Question 8: Break up anti-blocking guidance
  * Question 10: Fine to abbreviate
  * Question 11: What did original authors write?
  * Question 1: Title; fixes #4944

-- File Changes --

    M draft-ietf-quic-http.md (39)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4954.patch
https://github.com/quicwg/base-drafts/pull/4954.diff

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4954
You are receiving this because you are subscribed to this thread.

Message ID: &lt;quicwg/base-drafts/pull/[email-masked]&gt;

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 14 Feb 2022 10:41:25 -0800

@LPardue commented on this pull request.

lgtm

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4954#pullrequestreview-882045267
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4954/review/[email-masked]>

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 14 Feb 2022 10:41:32 -0800

@LPardue approved this pull request.

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4954#pullrequestreview-882045431
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4954/review/[email-masked]>

---

From: Mike Bishop <[email-masked]>
Date: Mon, 14 Feb 2022 10:45:47 -0800

@MikeBishop commented on this pull request.

Including the actual AUTH48 questions this addresses.

> @@ -1,6 +1,5 @@
 ---
-title: Hypertext Transfer Protocol Version 3 (HTTP/3)
-abbrev: HTTP/3
+title: HTTP/3

See #4944.

> @@ -606,7 +605,7 @@ The following pseudo-header fields are defined for requests:
     {{Section 7.1 of SEMANTICS}}.
 
 All HTTP/3 requests MUST include exactly one value for the ":method", ":scheme",
-and ":path" pseudo-header fields, unless it is a CONNECT request; see
+and ":path" pseudo-header fields, unless the request is a CONNECT request; see

RFC Editor asked:
>Because HTTP/3 requests is plural, may we update this as follows?
> 
> Original:
>>  All HTTP/3 requests MUST include exactly one value for the ":method",  
>> ":scheme", and ":path" pseudo-header fields, unless it is a CONNECT  
>> request; see Section 4.2.
> 
> Perhaps A:
>>  All HTTP/3 requests MUST include exactly one value for the ":method",  
>> ":scheme", and ":path" pseudo-header fields, except for CONNECT  
>> requests; see Section 4.2.
> 
> Perhaps B:
>>  All HTTP/3 requests MUST include exactly one value for the ":method",  
>> ":scheme", and ":path" pseudo-header fields, unless the request is a 
>> CONNECT  request; see Section 4.2.

> +Implementations SHOULD cancel requests by abruptly terminating any directions of
+a stream that are still open.  To do so, an implementation resets the sending
+parts of streams and aborts reading on the receiving parts of streams; see
+{{Section 2.4 of QUIC-TRANSPORT}}.

RFC Editor asked:
> This text is a bit tricky to read with all the -ing endings.  Is there a way to rephrase?

> +receiver, or bidirectional, carrying data in both directions.  Streams can be
+initiated by either the client or the server.  For more detail on QUIC streams,
+see {{Section 2 of QUIC-TRANSPORT}}.

RFC Editor asked:
> Should this sentence be made parallel by explaining both unidirectional and bidirectional?  Or may we remove the explanatory clause as unidirectional is used several times prior to this occurrence?

I opted to parallelize, since I don't see the initiator-to-receiver direction stated elsewhere, but I'm also happy to shorten the text if it's adequately covered elsewhere.

> +to use.
+
+Each endpoint needs to create at least one unidirectional stream for the HTTP
+control stream. QPACK requires two additional unidirectional streams, and other
+extensions might require further streams. Therefore, the transport parameters
+sent by both clients and servers MUST allow the peer to create at least three
+unidirectional streams. These transport parameters SHOULD also provide at least
+1,024 bytes of flow control credit to each unidirectional stream.

RFC Editor asked:

> Which of these interpretations is correct?  Also, note that this sentence is quite long and may benefit from further rephrasing to break it up.
> 
> Original:
>> To avoid blocking, the transport parameters sent by both clients and 
>> servers MUST allow the peer to create at least one unidirectional 
>> stream for the HTTP control stream plus the number of unidirectional 
>> streams required by mandatory extensions (three being the minimum 
>> number required for the base HTTP/3 protocol and QPACK), and SHOULD 
>> provide at least 1,024 bytes of flow control credit to each stream.
> 
> Perhaps A:
>> To avoid blocking, the transport parameters sent by both clients and 
>> servers 1) MUST allow the peer to create at least one unidirectional 
>> stream for the HTTP control stream plus the number of unidirectional 
>> streams required by mandatory extensions (three being the minimum 
>> number required for the base HTTP/3 protocol and
>> QPACK) and 2) SHOULD provide at least 1,024 bytes of flow-control 
>> credit to each stream.
> 
> Perhaps B:
>> To avoid blocking, the transport parameters sent by both clients and 
>> servers MUST allow the peer to create at least one unidirectional 
>> stream for the HTTP control stream plus the number of unidirectional 
>> streams required by mandatory extensions (three being the minimum 
>> number required for the base HTTP/3 protocol and QPACK), and the peer 
>> SHOULD provide at least 1,024 bytes of flow-control credit to each 
>> stream.

> +For fomatting reasons, setting names can be abbreviated by removing the
+'SETTING_' prefix.
+

RFC Editor asked:
> We note that RFC-to-be 9114 registers names in the HTTP/3 Settings registry that are preceded by "SETTINGS_".  They also include the following note in the IANA section: 
> 
>>  For fomatting reasons, the setting names here are abbreviated by 
>> removing the  'SETTING_' prefix.
> 
> Should "MAX_FIELD_SECTION_SIZE" be registered as "SETTINGS_MAX_FIELD_SECTION_SIZE"?  
> See https://www.iana.org/assignments/http3-parameters
> 
> Should a similar note be included in the IANA text as well? 

On re-reading, this may suggest the IANA page itself should be corrected to include SETTINGS_

> +Robbie Shade and Mike Warres were the authors of draft-shade-quic-http2-mapping,
+which was the basis for this document.

RFC Editor asked:
> We believe "original authors of this specification" refers to the authors of draft-shade-quic-http2-mapping; may we clarify that here?

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4954#pullrequestreview-882042640
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4954/review/[email-masked]>

---

From: Mike Bishop <[email-masked]>
Date: Mon, 14 Feb 2022 10:50:02 -0800

@MikeBishop pushed 7 commits.

3f5efd57c185a4237f760ee3811e7b85fac69125  Question 4; fixes #4947
4b53094dd12f8a803d71951ff8250fb1038185cc  Question 5
e6cb25f036d0d4a7d2ad144c2b1b2b22c1ebafae  Question 6: parallel or reduce explanation?
a201d859d114532cb0de65035378db7238021cfb  Question 8: Break up anti-blocking guidance
359a196da47455656d508930f13efb8915452699  Question 10: Fine to abbreviate
c6976678493f582b03b57ae6e3f9bfaf020a5d4b  Question 11: What did original authors write?
8b5c9c6517878647fba36045749d3dd34188dd27  Question 1: Title; fixes #4944

-- 
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4954/files/0174b4f5acb57008adbdc24a72c29de9cbac1ca3..8b5c9c6517878647fba36045749d3dd34188dd27
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4954/push/[email-masked]>

---

From: Martin Thomson <[email-masked]>
Date: Mon, 14 Feb 2022 14:21:21 -0800

@martinthomson approved this pull request.

Perhaps this can be less generous, as "basis" implies a lot more substance was provided by that document.

```suggestion
Robbie Shade and Mike Warres were the authors of draft-shade-quic-http2-mapping,
a precursor of this document.
```

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4954#pullrequestreview-882254764
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4954/review/[email-masked]>

---

From: Mike Bishop <[email-masked]>
Date: Wed, 16 Feb 2022 07:39:10 -0800

@MikeBishop pushed 1 commit.

aa63fb266b6bbc434d1e22678a08b6912579fb5f  Ungenerous souls of savage mould

-- 
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4954/files/8b5c9c6517878647fba36045749d3dd34188dd27..aa63fb266b6bbc434d1e22678a08b6912579fb5f
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4954/push/[email-masked]>

---

From: Mike Bishop <[email-masked]>
Date: Wed, 16 Feb 2022 08:43:40 -0800

cfb936700a8fa5908fde557f8389262d5347bbd6  Merge remote-tracking branch 'origin/h3qp_auth48' into http/easy_rfced_questions

-- 
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4954/files/aa63fb266b6bbc434d1e22678a08b6912579fb5f..cfb936700a8fa5908fde557f8389262d5347bbd6
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4954/push/[email-masked]>

---

From: Mike Bishop <[email-masked]>
Date: Wed, 16 Feb 2022 08:45:50 -0800

Merged #4954 into h3qp_auth48.

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4954#event-6084266694
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4954/issue_event/[email-masked]>