Subject: [quicwg/base-drafts] RFC Editor Copyedits (PR #4956)

From: Mike Bishop <[email-masked]>
Date: Tue, 15 Feb 2022 12:35:21 -0800

This PR contains (most?) of the changes to the HTTP/3 spec the RFC editor made directly.  There are a few I&#39;ve chosen not to incorporate here.  I will note them on the PR when they affect a particular line; general ones are:

- Combined references to sections; I don&#39;t see a way to do that in Markdown, but #4955 tracks this.
- The `&lt;sup&gt;` tag produces parentheses in the .txt version for me, but apparently not for the RFC Editor.  However, the XML still contains the correct output, so I&#39;m not currently planning to make changes.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4956

-- Commit Summary --

  * Most of the RFC Editor edits
  * Missed a few
  * HTTP/3 is RFC9114

-- File Changes --

    R rfc9114.md (346)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4956.patch
https://github.com/quicwg/base-drafts/pull/4956.diff

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4956
You are receiving this because you are subscribed to this thread.

Message ID: &lt;quicwg/base-drafts/pull/[email-masked]&gt;

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 15 Feb 2022 12:44:43 -0800

@LPardue commented on this pull request.

 HTTP/1.1 ({{?HTTP11=I-D.ietf-httpbis-messaging}}) uses whitespace-delimited text
-fields to convey HTTP messages.  While these exchanges are human-readable, using
+fields to convey HTTP messages.  While these exchanges are human readable, using

FYI https://github.com/NTAP/isb-ietf-config/issues/12

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4956#pullrequestreview-883627812
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4956/review/[email-masked]>

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 15 Feb 2022 12:49:07 -0800

> @@ -301,11 +302,11 @@ host identifier to an IP address, establishing a QUIC connection to that address
 on the indicated port (including validation of the server certificate as
 described above), and sending an HTTP/3 request message targeting the URI
 to the server over that secured connection.  Unless some other mechanism is used
-to select HTTP/3, the token "h3" is used in the Application-Layer Protocol
+to select HTTP/3, the token "h3" is used in the Application Layer Protocol

I disagree with this one, RFC 7301 only uses the hyphenated term of art "Application-Layer Protocol Negotiation Extension"

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4956#pullrequestreview-883631900
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4956/review/[email-masked]>

---

From: Mike Bishop <[email-masked]>
Date: Tue, 15 Feb 2022 12:49:14 -0800

I can't comment on a line I didn't change, but at line 116, the RFC editor suggested adding a colon to produce:

```
mechanisms, a lost or reordered packet causes all active transactions to
experience a stall: regardless of whether that transaction was directly impacted
by the lost packet.
```

The colon doesn't make sense to me, so I currently plan to ignore it, but noting it here for review.

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4956#issuecomment-1040778317
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4956/[email-masked]>

---

From: Mike Bishop <[email-masked]>
Date: Tue, 15 Feb 2022 12:51:29 -0800

@MikeBishop commented on this pull request.

>  implementation can decide to close a QUIC stream and communicate the type of
 error. Wire encodings of error codes are defined in {{http-error-codes}}.
-Stream errors are distinct from HTTP status codes which indicate error
+Stream errors are distinct from HTTP status codes that indicate error

The RFC editor proposed adding a comma, producing
```suggestion
Stream errors are distinct from HTTP status codes, which indicate error
```
However, that suggests that _all_ HTTP status codes indicate error conditions.  Instead, I've changed which->that indicating that here we're discussing only those HTTP status codes that indicate an error.

Along the way, I've had to learn the difference between the usage of "which" and "that", which still trips me up.

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4956#pullrequestreview-883634596
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4956/review/[email-masked]>

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 15 Feb 2022 12:52:49 -0800

## Registration of HTTP/3 Identification String {#iana-alpn}
 
 This document creates a new registration for the identification of
-HTTP/3 in the "Application-Layer Protocol Negotiation (ALPN)
+HTTP/3 in the "TLS Application-Layer Protocol Negotiation (ALPN)

and then it's not hyphenated here..

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4956#pullrequestreview-883635855
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4956/review/[email-masked]>

---

From: Mike Bishop <[email-masked]>
Date: Tue, 15 Feb 2022 12:57:41 -0800

```suggestion
to select HTTP/3, the token "h3" is used in the Application-Layer Protocol
```
Agreed; RFC 7301 wins.

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4956#discussion_r807308489
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4956/review/[email-masked]>

---

From: Mike Bishop <[email-masked]>
Date: Tue, 15 Feb 2022 12:58:44 -0800

I'm confused -- it _is_ hyphenated here.  Or do you mean they didn't remove the hyphen?  Regardless, the name of the registry is "TLS Application-Layer Protocol Negotiation (ALPN) Protocol IDs", so I agree that we should match.

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4956#discussion_r807309249
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4956/review/[email-masked]>

---

From: Mike Bishop <[email-masked]>
Date: Tue, 15 Feb 2022 12:59:05 -0800

@MikeBishop pushed 1 commit.

8309388a4d10b9c12d04ac12c772c9c7f5482cd1  Follow RFC 7301; revert change at line 305

-- 
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4956/files/65f2b27a4520f33c34f7d30d022e39481a484be3..8309388a4d10b9c12d04ac12c772c9c7f5482cd1
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4956/push/[email-masked]>

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 15 Feb 2022 13:01:09 -0800

I agree the `, which` variant breaks the intention of this sentence.

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4956#discussion_r807310971
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4956/review/[email-masked]>

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 15 Feb 2022 13:02:11 -0800

gah I can't type - Muphry's Law strikes. Making them both hyphenated is my suggestion.

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4956#discussion_r807311721
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4956/review/[email-masked]>

---

From: Martin Thomson <[email-masked]>
Date: Tue, 15 Feb 2022 14:39:33 -0800

@martinthomson commented on this pull request.

Yep, it's "Stream errors are distinct from (HTTP status codes that indicate...)"

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4956#discussion_r807377342
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4956/review/[email-masked]>

---

From: Martin Thomson <[email-masked]>
Date: Tue, 15 Feb 2022 14:41:37 -0800

@MikeBishop want to close NTAP/isb-ietf-config#11 now?

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4956#discussion_r807378554
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4956/review/[email-masked]>

---

From: Martin Thomson <[email-masked]>
Date: Tue, 15 Feb 2022 14:42:30 -0800

> @@ -2368,7 +2370,7 @@ QUIC simply by replacing Stream 0 in HTTP/2 with a control stream in HTTP/3.
 HTTP/3 extensions will not assume ordering, but would not be harmed by ordering,
 and are expected to be portable to HTTP/2.
 
-### Comparison Between HTTP/2 and HTTP/3 Frame Types
+### Comparison between HTTP/2 and HTTP/3 Frame Types

```suggestion
### Comparison of HTTP/2 and HTTP/3 Frame Types
```
?

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4956#pullrequestreview-883735960
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4956/review/[email-masked]>

---

From: Martin Thomson <[email-masked]>
Date: Tue, 15 Feb 2022 14:43:43 -0800

@martinthomson approved this pull request.

Skimmed, but this looks good.

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4956#pullrequestreview-883736887
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4956/review/[email-masked]>

---

From: Mike Bishop <[email-masked]>
Date: Wed, 16 Feb 2022 07:16:06 -0800

b7f83550aa17e03a860a54da95bcd7e85b8835a5  Between/between => of

-- 
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4956/files/8309388a4d10b9c12d04ac12c772c9c7f5482cd1..b7f83550aa17e03a860a54da95bcd7e85b8835a5
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4956/push/[email-masked]>

---

From: Mike Bishop <[email-masked]>
Date: Wed, 16 Feb 2022 07:23:10 -0800

4f43349ec886221e34255d5aeca16e351f2b618d  Combined internal references; fixes #4955

-- 
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4956/files/b7f83550aa17e03a860a54da95bcd7e85b8835a5..4f43349ec886221e34255d5aeca16e351f2b618d
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4956/push/[email-masked]>

---

From: Mike Bishop <[email-masked]>
Date: Wed, 16 Feb 2022 07:28:48 -0800

0efcdce593d792eaf4e4985af2f749a5a210adc8  Use << for section name references

-- 
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4956/files/4f43349ec886221e34255d5aeca16e351f2b618d..0efcdce593d792eaf4e4985af2f749a5a210adc8
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4956/push/[email-masked]>

---

From: Mike Bishop <[email-masked]>
Date: Wed, 16 Feb 2022 08:36:34 -0800

Merged #4956 into h3qp_auth48.

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4956#event-6084201991
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4956/issue_event/[email-masked]>