Subject: Re: [quicwg/base-drafts] Auth48: H3 is like H2 but uses QUIC, we get it (Issue #4946)

From: Mike Bishop <[email-masked]>
Date: Fri, 01 Apr 2022 11:05:01 -0700

Having looked at the references, they all seem reasonable with the possible exception of PUSH_PROMISE noting it behaves "as in HTTP/2."  Most references to HTTP/2 occur either in the first two sections of the document or in the Appendix which specifically discusses the relationship between HTTP/2 and HTTP/3.

#4978 removes that one extraneous reference.  Other than than, I plan to make no further changes to address this feedback unless someone wants to provide a more concrete list of places where the comparison is unnecessary.

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4946#issuecomment-1086190560
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/issues/4946/[email-masked]>

---

From: Lucas Pardue <[email-masked]>
Date: Fri, 01 Apr 2022 11:42:23 -0700

Marginal: Section 4.1.1 and 4.1.1.1 seems to have some egregious use of phrasing similar to "Like HTTP/2, ..." or "as in HTTP/2". 

You could possibly condense these to a sentence such as "Like HTTP/2, HTTP/3 has additional considerations related to use of characters in field names, the Connect header field, and pseudo-header fields". That could be inserted into to the second paragraph of 4.1.1 (thus breaking the para so the next one starts with "Characters in field names").

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4946#issuecomment-1086218892
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/issues/4946/[email-masked]>