Subject: [radext] 802.11u attributes for inclusion in draft-ietf-radext-ieee802ext

From: Bernard Aboba <[email-masked]>
Date: Mon, 2 Apr 2012 13:03:14 -0700

Find enclosed attributes that have been proposed for inclusion in the next
revision of draft-ietf-radext-ieee802ext. 

Comments?

---

From: <[email-masked]>
Date: Mon, 2 Apr 2012 22:14:03 +0200

+1 for addition of these attributes in the draft.

One minor question: even if straightforward, should we find a reference to the IEEE spec also for SSID, HESSID, Venue-Language, Venue-Name, in order to see the direct mapping between these attributes and the 802.11u parameters?

Lionel

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Bernard Aboba
Envoyé : lundi 2 avril 2012 22:03
À : [email-masked]
Objet : [radext] 802.11u attributes for inclusion indraft-ietf-radext-ieee802ext

Find enclosed attributes that have been proposed for inclusion in the next revision of draft-ietf-radext-ieee802ext. 

Comments?

---

From: <[email-masked]>
Date: Mon, 2 Apr 2012 22:14:03 +0200

Lionel

-----Message d'origine-----

Comments? 
_______________________________________________
radext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/radext

---

From: jouni korhonen <[email-masked]>
Date: Tue, 3 Apr 2012 09:36:50 +0300

<as an individual contributor>

I am in favor of adding these attributes into the draft-ietf-radext-ieee802ext.

- Jouni

On Apr 2, 2012, at 11:03 PM, Bernard Aboba wrote:

> <aaa-attributes-for-802-11u.txt>_______________________________________________
> radext mailing list
> [email-masked]

---

From: jouni korhonen <[email-masked]>
Date: Tue, 3 Apr 2012 09:36:50 +0300

- Jouni

---

From: Jouni Malinen <[email-masked]>
Date: Tue, 3 Apr 2012 11:45:25 +0300

> 3.  RADIUS attributes
> 
>    The RADIUS attributes associated with 802.11u WLAN access.

802.11u does not really exist anymore as an amendment since IEEE Std
802.11-2012 has now been published with that amendment included in the
main standard. All 802.11u references should be replaced with a
reference to IEEE Std 802.11-2012.

> 3.1.  WLAN-SSID
> 
>    Description
> 
>       The WLAN-SSID attribute contains the Service Set Identifier (SSID)
>       which identifies a specific 802.11 extended service set (ESS).
> 
>    0                   1                   2                   3
>    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>    |     Type      |  Length       |          String...
>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

>       The String field is between 1 and 32 octets in length.  The actual
>       format of the information is site or application specific, and a
>       robust implementation SHOULD support the field as undistinguished
>       octets.

It could be useful to be able to indicate the encoding of the SSID since
IEEE Std 802.11-2012 added a mechanism for indicating that the SSID is
encoded as UTF-8. This could be done, e.g., by adding a new integer
attribute for this with following values defined for now:

0 - Unspecified SSID encoding
1 - SSID encoded in UTF-8

> 8.  Normative References

>    [IEEE-802.11]
>               IEEE, "Information technology - Telecommunications and
>               information exchange between systems - Local and
>               metropolitan area networks - Specific Requirements Part
>               11:  Wireless LAN Medium Access Control (MAC) and Physical
>               Layer (PHY) Specifications, IEEE Std. 802.11-2007", 2007.

This should be update to IEEE Std 802.11-2012.

>    [IEEE-802.11u]

And this replaced with references to IEEE Std 802.11-2012.

-- 
Jouni Malinen                                            PGP id EFC895FA

---

From: Jouni Malinen <[email-masked]>
Date: Tue, 3 Apr 2012 11:45:25 +0300

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 3 Apr 2012 12:20:47 +0200

I also support this work and I would re-iterate the need to share
information about the development of this work (if it will be approved)
with the IEEE 802.1 and IEEE 802.11 WGs - including sending them an
announcement when the work will be adopted, and sending them the
document for review at WGLC. 

Regards,

Dan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of jouni korhonen
> Sent: Tuesday, April 03, 2012 9:37 AM
> To: [email-masked]; Bernard Aboba
> Subject: Re: [radext] 802.11u attributes for inclusion indraft-ietf-
> radext-ieee802ext
> 
> 
> > Find enclosed attributes that have been proposed for inclusion in
the
> next
> > <aaa-attributes-for-802-
> 11u.txt>_______________________________________________
> > radext mailing list
> > [email-masked]

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 3 Apr 2012 12:20:47 +0200

Regards,

Dan

the