Subject: [radext] #123: nesting depth

From: "radext issue tracker" <[email-masked]>
Date: Wed, 23 May 2012 14:05:44 -0000

#123: nesting depth

 In Section 2.3.1:

 > However, nesting depths of more than 4 are NOT RECOMMENDED.

 Where does this come from, why 4 and not 3 or 5? I mean, if this is for
 clarity and/or to avoid complexity, but it's more like a rule of thumb,
 than maybe it needs not be capitalized.

-- 
-------------------------+-------------------------------------------------
 Reporter:  dromasca@…   |      Owner:  draft-ietf-radext-radius-
     Type:  defect       |  extensions@…
 Priority:  major        |     Status:  new
Component:  radius-      |  Milestone:  milestone1
  extensions             |    Version:  1.0
 Severity:  In WG Last   |   Keywords:
  Call                   |
-------------------------+-------------------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/radext/trac/ticket/123>
radext <http://tools.ietf.org/radext/>

_______________________________________________
radext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/radext

---

From: "radext issue tracker" <[email-masked]>
Date: Wed, 23 May 2012 14:13:04 -0000

#123: nesting depth

Comment (by aland@…):

 The rule of thumb comes from a few areas.

 WiMAX / 3GPP has been using nested attributes.  They haven't seen a need
 for depths of more than 4, IIRC.  I can't think of many uses, either.

 Another is implementations.  (sadly)  Some implementations use 32-bit
 integers to refer to RADIUS attributes.  Encouraging unlimited nesting
 would require large changes to those implementations.

 Severity:  In WG Last   |  Resolution:
 Keywords:               |

Ticket URL: <http://trac.tools.ietf.org/wg/radext/trac/ticket/123#comment:1>
radext <http://tools.ietf.org/radext/>

---

From: "radext issue tracker" <[email-masked]>
Date: Wed, 23 May 2012 14:13:04 -0000

#123: nesting depth

Comment (by aland@…):

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 23 May 2012 16:30:27 +0200

I am not in favor of encouraging unlimited nesting. I question whether using capitalization is appropriate when the limitation does not seem to result from restriction in the protocol. 

Regards,

Dan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of radext issue tracker
> Sent: Wednesday, May 23, 2012 5:13 PM
> To: [email-masked];
> [email-masked]
> Cc: [email-masked]
> Subject: Re: [radext] #123: nesting depth
> 
> #123: nesting depth
> 
> 
> Comment (by aland@…):
> 
> Ticket URL:
> <http://trac.tools.ietf.org/wg/radext/trac/ticket/123#comment:1>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 23 May 2012 16:30:27 +0200

Regards,

Dan

---

From: Alan DeKok <[email-masked]>
Date: Wed, 23 May 2012 16:41:22 +0200

> I am not in favor of encouraging unlimited nesting. I question whether using capitalization is appropriate when the limitation does not seem to result from restriction in the protocol. 

  I'm open to changes.

  The text came about as a result of discussion on the WG list.

  Alan DeKok.

---

From: Alan DeKok <[email-masked]>
Date: Wed, 23 May 2012 16:41:22 +0200

I'm open to changes.

  Alan DeKok.