Subject: [radext] acct counters - ipv6 vs classes

From: Tassos Chatzithomaoglou <[email-masked]>
Date: Fri, 03 Aug 2012 12:51:25 -0700

There are already vendor implementations (which we already use in our 
network) using ipv6 acct attributes, probably based on 
draft-maglione-radext-ipv6-acct-extensions.
Any idea what happened to that draft?

I would like to see ipv6 acct counters being standardized as soon as 
possible (with very few changes if possible), but i also like the idea 
of flexible accounting based on classes 
(draft-winter-radext-fancyaccounting).

-- 
Tassos

---

From: Stefan Winter <[email-masked]>
Date: Fri, 03 Aug 2012 21:58:50 +0200

Hi,

> Any idea what happened to that draft?

Dropped off my radar a long time ago, TBH.

> (draft-winter-radext-fancyaccounting).

The beautiful thing is: if all you care about is IPv6, hard-wire your
NAS to send the string Acct-Traffic-Class-Name = "urn:ietf:ip:6" and put
your data into the TLV.

As simple as that, little to no implementation complexity; and if you
have a more configurable device that supports more traffic classes - go
ahead and use them with the appropriate label.

It would be a real shame to produce an RFC for a singleton of traffic
class if it's so easy to get a generic solution.

Greetings,

Stefan Winter

---

From: Alan DeKok <[email-masked]>
Date: Fri, 03 Aug 2012 13:07:14 -0700

> class if it's so easy to get a generic solution.

  I agree.

  Alan DeKok.

---

From: Leaf yeh <[email-masked]>
Date: Mon, 6 Aug 2012 07:50:42 +0000

Tassos - There are already vendor implementations (which we already use in our 
network) using ipv6 acct attributes, probably based on 
draft-maglione-radext-ipv6-acct-extensions.
Any idea what happened to that draft?

If your could get some time to read draft-yeh-radext-dual-stack-access-02 (expired, written in Mar. 2011), you will find that draft adopted the same attribute design in the traditional type space as that of draft-maglione. It is not only for the accounting of IPv6 access, but also for the accounting of IPv4/IPv6 dual-stack.

After IETF80, it was suggested per 2 facts:  a. The traditional type space is nearly exhausted (the above draft-yeh 12 new type codes for the traffic statistics).  We can try to use the extended type space defined in draft-ietf-radext-radius-extensions for this new accounting attribute of traffic statistics if we believe it is not so urgent;  b. There is new data-type, nested-TLV, defined for the extended type space can be used for grouping the Input-Octets, Output-Octets, Input-Packets, Output-Packets into 1 attribute;  (You can find those points in draft-winter-radext-fancyaccounting-00, though it sounds too fancy to me. http://www.ietf.org/mail-archive/web/radext/current/msg07685.html )

Tassos - I would like to see ipv6 acct counters being standardized as soon as 
possible (with very few changes if possible), but i also like the idea 
of flexible accounting based on classes 
(draft-winter-radext-fancyaccounting).

After this IETF84, I supposed the new suggestion will be that:  create a new date type of 'String in URN format' and its name tree  for the naming or definition of the traffic type. But the original requirement derived from BBF TR-187 is only asking for the separate reporting of traffic statistics for IPv4 and/or IPv6 in dual-stack scenarios.

Best Regards,
Leaf

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Tassos Chatzithomaoglou
Sent: Saturday, August 04, 2012 3:51 AM
To: [email-masked]
Subject: [radext] acct counters - ipv6 vs classes

-- 
Tassos

_______________________________________________
radext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/radext

---

From: Leaf yeh <[email-masked]>
Date: Mon, 6 Aug 2012 08:07:22 +0000

If you feel interested and insists, let's figure out how many name of the 'traffic type' you'd like to put into the naming tree of 'URN:ietf:radius-accouting':

my input for that (referred to RFC2141) is as follows:

URN:ietf:radius-accouting:stack-type:v4
URN:ietf:radius-accouting:stack-type:v6
URN:ietf:radius-accouting:stack-type:v4+v6

then, yours?

Best Regards,
Leaf

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Alan DeKok
Sent: Saturday, August 04, 2012 4:07 AM
To: Stefan Winter
Cc: [email-masked]
Subject: Re: [radext] acct counters - ipv6 vs classes

  I agree.

  Alan DeKok.

---

From: Maglione Roberta <[email-masked]>
Date: Wed, 8 Aug 2012 14:38:55 +0200

Hi Tassos,

> network) using ipv6 acct attributes,
That's correct some vendors already have them as VSA attributes

> probably based on

I presented this document a long time ago, but I received a negative feedback from the WG on the proposed approach, that's why I haven't posted any new update of this document.
A couple of other people are currently working on some alternative approaches to solve this problem.

Best regards,
Roberta

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Tassos Chatzithomaoglou
Sent: venerdì 3 agosto 2012 21.51
To: [email-masked]
Subject: [radext] acct counters - ipv6 vs classes

--
Tassos

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.