Subject: Re: (radius) Tagged attribute question

From: Barney Wolff <[email-masked]>
Date: Tue, 13 Apr 1999 10:24 EDT

In theory at least, the password is not restricted to ascii and might
include trailing null bytes, so an explicit length is required to
identify exactly what bytes are included in the password.  Of course,
that's just as true for user-password, but the weight of history precludes
changing that format.

Barney Wolff  <[email-masked]>

> From: "Darran Potter" <[email-masked]>
> Date: Tue, 13 Apr 1999 14:48:39 +0100
> 
> One last question, the plain text tunnel password length that is encrypted
> along with the password itself... what benefit does this provide?
-
To unsubscribe, email [email-masked]' with
'unsubscribe ietf-radius' in the body of the message.

---

From: Ignacio Goyret <[email-masked]>
Date: Tue, 13 Apr 1999 10:15:25 -0700

>> along with the password itself... what benefit does this provide?

There is one other reason: if you've obscured the password by padding it with
extra bytes, you will need to send the exact size of the password pre-padding.
Otherwise, it might be hard to guess. :-)

-