Subject: Re: [RAM] moving a discussion from various I* lists to [email-masked]

From: "Fergie" <[email-masked]>
Date: Thu, 21 Dec 2006 02:14:56 GMT

- -- "Chris L. Morrow" <[email-masked]> wrote:

>As a customer of some of the vendors I'd ask: "why do I not have that
>today? Why does it appear in testing that the 'latest' devices off the
>assembly line tip over dramatically at  500k or so routes?" Even setting
>this asside vendor engineers have said point-blank to our eng folks that
>there are serious problems scaling the current systems (hardware) and
>maintaining the current restrictions on convergence speed.
>
>I don't think that modeling the update rate increase/change over time has
>happened yet, and I don't think that modeling that against hardware
>capabilties has really happened either. So, I don't think that vendor
>folks are really in a position to express 'non-fear' about 10M routes in
>the table (and the associated churn rates that would come along with that
>increase).

I share your concern here -- although it certainly affects backbone
carriers more than it does leaf-node networks.

I find it curious, however, that with the plethora of router vendors
participating in the IETF process(es), none of them seem to be
forthcoming on this concern.

In other words, it would be nice to hear from the router what they
are doing to meet the obvious future needs here.

Cheers,

- - ferg

--
"Fergie", a.k.a. Paul Ferguson
 Engineering Architecture for the Internet
 fergdawg(at)netzero.net
 ferg's tech blog: http://fergdawg.blogspot.com/

_______________________________________________
RAM mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ram

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 21 Dec 2006 12:23:34 +0100

Fergie wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 

A question I asked a while back, and didn't get answered, is whether
anybody has a mathematical model of a hypothetical network with
an assumed number of PI sites (say 10 million) and a representative
topology of transit ISPs and core ISPs distributed across the
continents? And can run BGP4 convergence simulations on this model
for various assumed rates of access link outages, changes of
transit ISP, and the like?

If we can't model BGP dynamics at the scale we expect it to reach ten
or twenty years from now, our grasp on the problem remains weak.

    Brian

---

From: David Meyer <[email-masked]>
Date: Thu, 21 Dec 2006 07:00:06 -0800

> carriers more than it does leaf-node networks.

	As I mentioned in my response to Chris, we need to start
	looking at the nature of the burstiness of UPDATEs. I
	think that kind of research will help inform both our
	operational and architecture/protocol design concerns.

	--dmm

---

From: Ted Seely <[email-masked]>
Date: Thu, 21 Dec 2006 12:45:46 -0500 (EST)

> are doing to meet the obvious future needs here.

It all depends who you ask at the repective vendors.  Some folks will tell
you there is no problem, others will acknowledge that there is one, but
nobody is sure how to address solving it yet.

I guess thats what this list is for huh?  :)

-ted

>
> Cheers,
>
> - - ferg
>
> -----BEGIN PGP SIGNATURE-----
> Version: PGP Desktop 9.5.2 (Build 4075)
>
> wj8DBQFFie4Xq1pz9mNUZTMRAqIVAKCBSnuR6YUYjwESaC04UN1HUkuM9QCgiwQk
> 6nLrXR5Af7vIsyVLPdFXAkE=
> =EA/A
> -----END PGP SIGNATURE-----
>
>
>
> --

Ted Seely
Principal Network Design Engineer
Internet Engineering - SprintLink
(W) 703.689.6425
(M) 703.967.3289
AIM - wanpro00
Yahoo IM - tseely01

"can be maintained, upgraded, enhanced, and scaled without requiring
service interruption"