Subject: [RAM] Re: draft-baker-v6ops-13-multihoming-analysis-00

From: [email-masked]
Date: Thu, 7 Dec 2006 16:37:55 +0000

so... are we bringing back RFC 1897?

On Thu, Dec 07, 2006 at 08:33:37AM -0500, Fred Baker wrote:
> concatenating the ASN into the IP address would certainly be one way  
> of providing a scalable routing locator. Check the archives, and you  
> will find that at one time (perhaps a decade back) I suggested that  
> as a quick method for the initial assignment of addresses - simply  
> give every current AS a prefix numerically related to its AS number.  
> I don't believe that to be required for scalability, however, which  
> is why I don't bring it up in the document. What I do see as required  
> is the ability to limit the number of prefixes advertised to a number  
> comparable to the number of assigned AS numbers, and constrain those  
> to people who actually need an AS number from a BGP perspective.
> 
> We have been asked to move this conversation to [email-masked] aka  
> [email-masked].
> 
> On Dec 6, 2006, at 10:55 PM, Peter Sherbin wrote:
> 
> >Fred,
> >
> >More comments
> >p.3 says "Fortune 500" while p. 20 has "Fortune 1000".
> >p.18 above the diagram "the links from B<->A and B<->A were  
> >shorter", why two B<->A?
> >p.19 near the top "issues... relate to human stupidity". How about  
> >"human error"?
> >p.27 section 5. "From the author's perspective" when the draft has  
> >two authors.
> >
> >This is a good summary of what is going on plus projections. But  
> >overall it feels
> >that the current architecture constrains the market and it does not  
> >scale. The draft
> >illustrates the need for flexible PI addressing with the model such  
> >as "a service
> >domain. That domain could as easily be the customers of a  
> >cooperative as the
> >citizens of a government". Any given tax authority is a good proxy  
> >for such
> >cooperative and it could assume a mechanical function of the  
> >distribution and
> >management of PI.
> >
> >Providers would get through RIR an independent set of  
> >geographically rigid
> >aggregation points, eg. ASN. A new protocol could be needed to  
> >combine PI+ASN for
> >scalable routing(?)
> >
> >Thanks,
> >
> >Peter
> >
> >
> >
> >______________________________________________________________________ 
> >______________
> >Yahoo! Music Unlimited
> >Access over 1 million songs.
> >http://music.yahoo.com/unlimited

_______________________________________________
RAM mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ram

---

From: Peter Sherbin <[email-masked]>
Date: Thu, 7 Dec 2006 10:11:21 -0800 (PST)

>  so... are we bringing back RFC 1897?

Would it work to apply RFC 1897 as:
- ASN has 16 bits and there is a room for a larger ASN if needed
- EU would still get 128-bit IPv6 address with the leading 32 bits set to zero (to
be replaced with ASN at the network connection point)
- IPv4 is built in meaning that EU can keep their current IPv4 and put them right
into IPv6 easing the transition
- /32 provides big enough space to any EU

> > >aggregation points, eg. ASN. A new protocol could be needed to  

____________________________________________________________________________________
Need a quick answer? Get one in minutes from people who know.
Ask your question on www.Answers.yahoo.com

---

From: Fred Baker <[email-masked]>
Date: Thu, 7 Dec 2006 22:36:18 -0500

>  so... are we bringing back RFC 1897?

I'm not recommending that. Sounds like Peter might.