Subject: RE: Workshop report Re: [RAM] Re: Impending publication:draft-iab-raws-report-01.txt

From: "Azinger, Marla" <[email-masked]>
Date: Thu, 22 Mar 2007 05:55:34 -0400

Not that we have a fire to fight but ARIN members are already "thinking" about proposing policy to use subnetting with PA.  This would be bad as we all know, and because of this, I strongly feel it would be beneficial to hunker down and create a solution quickly AND with compitence.   Debating the time frame really is neither here nor there.  We just need to do it.

Thank you
Marla

-----Original Message-----
From: Chris L. Morrow [mailto:[email-masked]]
Sent: Thursday, March 22, 2007 2:41 AM
To: Tony Li
Cc: [email-masked]; [email-masked]
Subject: Re: Workshop report Re: [RAM] Re: Impending
publication:draft-iab-raws-report-01.txt

On Wed, 21 Mar 2007, Tony Li wrote:

> No one was claiming 'dire'.
>

just to clarify, what is 'dire'? (not asking tony specifically more of a
survey question) is 2 years 'dire'? 5 years? 10 years?

When looking at design/build/purchase/test/deploy/depreciate timeframes of
+7 years things get 'interesting' quickly.

thanks
-Chris

_______________________________________________
RAM mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ram

_______________________________________________
RAM mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ram

---

From: Jari Arkko <[email-masked]>
Date: Thu, 22 Mar 2007 12:04:31 +0100

> Not that we have a fire to fight but ARIN members are already "thinking" about proposing policy to use subnetting with PA.  This would be bad as we all know, and because of this, I strongly feel it…

+1

The hard part is doing the solution. Lets focus more on that.

Jari

---

From: Jari Arkko <[email-masked]>
Date: Thu, 22 Mar 2007 12:04:31 +0100

+1

Jari

---

From: Danny McPherson <[email-masked]>
Date: Thu, 22 Mar 2007 11:36:30 -0600

On Mar 22, 2007, at 5:04 AM, Jari Arkko wrote:

>
>> Not that we have a fire to fight but ARIN members are already  
>> "thinking" about proposing policy to use subnetting with PA.  This  
>> would be bad as we all know, and because of this, I strongly feel  
>> it would be beneficial to hunker down and create a solution  
>> quickly AND with compitence.   Debating the time frame really is  
>> neither here nor there.  We just need to do it
>
> +1
>

While I agree with this sentiment on one level, it concerns
me that we're not aiming at some common end goal (even
with accepting that it's a moving target).

Intermediate solutions are necessary (even if that means
dual stack, ships in the night, whatever)  but if they carry us
in a direction that diverges from the (an) end goal, even a
seemingly marginal degree, then they're little more than a
distraction and we'll wind up putting out another fire (or
at least smoke 'n fumes) in another decade.

I'm also of the opinion that while intermediate solutions that
impose network state are fine, if the end goal isn't aimed
at accommodating  the end to end principle, then it's off
track.

In the vein of grandmother quotes this week "If you aim at
nothin, you'll quite likely hit it!".

And if folks are going to project growth numbers they
should carefully consider what those devices are, as I'm
quite sure that when going from where we are today to,
say, e.g., 10B, some shifts in what constitutes the majority
of devices is certain.

-danny

---

From: "Chris L. Morrow" <[email-masked]>
Date: Thu, 22 Mar 2007 18:15:29 +0000 (GMT)

MIME-versioFrom [email-masked] Thu Mar 22 14:16:24 2007
From: Tony Li <[email-masked]>
Subject: Re: [RAM] Re: [Int-area] Please be more specific about the problem
Date: Thu, 22 Mar 2007 19:15:24 +0100
To: Eliot Lear <[email-masked]>
Cc: [email-masked], Noel Chiappa <[email-masked]>, [email-masked]

Eliot,

> is our primary concern control plane churn in the form of memory  
> bandwidth or memory size?

My primary concern at this point is memory latency in the RIB.  You  
should be careful to note the difference between bandwidth and  
latency and it's impact on performance.

Tony

---

From: "Chris L. Morrow" <[email-masked]>
Date: Thu, 22 Mar 2007 18:15:29 +0000 (GMT)

> > The hard part is doing the solution. Lets focus more on that.

Jari, I agree about the 'lets move forward on a solution' (whole heartedly
actually) but my question originally was to frame 'long term' and 'short
term' properly.

> with accepting that it's a moving target).

I was hoping that part of the goal included a rough timeframe :) I think
we can noddle around on this for a very long time, some timeframe to
bracket the work seems useful. Perhaps the IAB has that in mind? or in
it's process? or the IETF does? (have a built-in TTL for work I mean)

anyway.. forward progress, it's a good thing :)

n: 1.0

> > The hard part is doing the solution. Lets focus more on that.

Jari, I agree about the 'lets move forward on a solution' (whole heartedly
actually) but my question originally was to frame 'long term' and 'short
term' properly.

> with accepting that it's a moving target).

I was hoping that part of the goal included a rough timeframe :) I think
we can noddle around on this for a very long time, some timeframe to
bracket the work seems useful. Perhaps the IAB has that in mind? or in
it's process? or the IETF does? (have a built-in TTL for work I mean)

anyway.. forward progress, it's a good thing :)

---

From: Lixia Zhang <[email-masked]>
Date: Thu, 22 Mar 2007 15:43:17 -0700

Finally caught up this thread; I believe this msg by Chris is the  
last one on this subject line.
I've fixed all the editorial comments from Pekka Savola (Thanks Pekka!)

As far as I can tell, the consensus is to add to the end of abstract  
the following paragraph by Ross:

       Work on issues related to this workshop report is continuing,
       and this document does not intend to reflect the increased
       understanding of issues nor to discuss the range of potential
       solutions that may be the outcome of this ongoing work.

If no further comment, this will go in.

I understand that the official last-call ends on April 4th.

As Jari suggested, lets focus effort on the new work now.

Chris, got your suggestion on "some timeframe to bracket the work  
seems useful", seems to me a good suggestion both to IAB and to RRG  
for consideration.

Lixia
(with the report editor hat on)