Subject: Usage of role combination.

From: 江育誠 <[email-masked]>
Date: Mon, 7 May 2001 14:53:59 +0800

Hi,

    Excuse me, could anyone give an example of "role combination" ??
    I'm so confused about it.  Thanks a lot!

---
Yu-cheng Chiang
Network Communication Lab.
Institute for Information Industry ,Taiwan

---

From: 江育誠 <[email-masked]>
Date: Wed, 9 May 2001 16:08:01 +0800

Thanks so much!

I still have some problems.
I don't know clear how to achieve the "Role" concept by framework-PIB
tables.
When PDP applying policies to PEP, does PDP only need to know its
role-combination?
Or PDP also needs to know "Interface Capabilities Set Name (IfCapSetName)" ?

----- Original Message -----
From: Abdul Malick <[email-masked]>
To: 江育誠 <[email-masked]>
Sent: Wednesday, May 09, 2001 1:46 AM
Subject: Re: Usage of role combination.

> Hello Yu-cheng
> First i think you unserstand Role
> Role is a means to associate a set of policies to the entities to be
policy
> managed in a device based on the charecteristics (role) of the entities.
>
> Take for example a Router that has 4 interfaces i1, i2, i3 and i4
> Here the entities managed are the interfaces.
> Now you may have some policies that have to applied as per some
> characteristics(Role) of an interface
>
> We can define the characteristics of the interfaces as follows (Eg)
>        i1 is an ethernet(Role) port + Incoming (Role)   (Role Combination
is
> Ethernet + Incoming)
>        i2 is an ethernet(Role) port  + Outgoing (Role)    (Role
Combination
> is Ethernet + Outgoing)
>        i3 is a FR port(Role)
>        i4 is a ATM(Role) port
>
> Now we can define some policies P1, P2 , P3 , P4 and P5
> We can say that
>          P1and P2  are applicable for ethernet ports
>          P3 is appicable for FR ports
>          P4 for ATM ports
> If you see when we enforce the policies, P1 and P2 are automatically
> enforced on i1 and i2 and so on
> The advantage is that we need not define P1 and P2 separately for i1 and
i2
>
> Extending this idea if P5 is for Incoming ethernet ports ( Role Combo =
> Incoming + Ethernet) then it would be enforced on i1 only
>
> Hope this helps
>
> Regards
> Malick
>
>
>
>
>
> ----- Original Message -----
> From: "江育誠" <[email-masked]>
> To: <[email-masked]>
> Sent: Monday, May 07, 2001 12:23 PM
> Subject: Usage of role combination.
>
>
> > Hi,
> >