Subject: frwk pib 04 and diffserv pib 03 integration

From: "Da Silva, Pedro" <[email-masked]>
Date: Wed, 30 May 2001 14:17:47 +0100

In qosDataPathTable an entry is declared as:

qosDataPathEntry OBJECT-TYPE
    SYNTAX       QosDataPathEntry
    STATUS       current
    DESCRIPTION
       "An entry in the data path table describes  a  single
       data path in this device."
    PIB-INDEX { qosDataPathPrid }
    UNIQUENESS { qosDataPathRoles,
                 qosDataPathIfDirection }
    ::= { qosDataPathTable 1 }

QosDataPathEntry ::= SEQUENCE  {
    qosDataPathPrid           InstanceId,
    qosDataPathIfName         SnmpAdminString,
    qosDataPathRoles          RoleCombination,
    qosDataPathIfDirection    IfDirection,
    qosDataPathStart          Prid
}

The UNIQUENESS clause implies that there can be no duplicates of
roleCombo+direction entries.
So one cannot have the following:
Prid	IfName	Roles		Direction	Start
1	eth		finance	out		283
2	atm		finance	out		283

The same roleCombo+direction cannot be applied to more than one IfName.
Isn't this in contradiction with the frwk pib?
The frwkIfCapSetRoleComboTable allows a role to be associated with any
number of IfNames.

cheers,
Pedro

--
This communication contains confidential information intended solely for the use of the individual/s and/or entity or entities to whom it was intended to be addressed.  If you are not the intended recipient, be aware that any disclosure, copying, distribution, or use of the contents of this transmission is prohibited.  If you have received this communication in error, please contact the sender immediately, delete this communication from your system, and do not disclose its contents to any third party, or use its contents.  Any opinions expressed are solely those of the author and do not necessarily represent those of Orchestream Ltd or its group of companies unless otherwise specifically stated.

---

From: "Iliff, Tina" <[email-masked]>
Date: Wed, 30 May 2001 16:04:39 +0000

I agree.  I would suggest adding qosDataPathIfName to the UNIQUENESS clause.
It is possible to have a different START value associated with the same
Roles but different IfName and Direction.

--Tina Iliff

-----Original Message-----
From: Da Silva, Pedro [mailto:[email-masked]]
Sent: Wednesday, May 30, 2001 8:18 AM
To: [email-masked]
Subject: frwk pib 04 and diffserv pib 03 integration

cheers,
Pedro

--
This communication contains confidential information intended solely for the
use of the individual/s and/or entity or entities to whom it was intended to
be addressed.  If you are not the intended recipient, be aware that any
disclosure, copying, distribution, or use of the contents of this
transmission is prohibited.  If you have received this communication in
error, please contact the sender immediately, delete this communication from
your system, and do not disclose its contents to any third party, or use its
contents.  Any opinions expressed are solely those of the author and do not
necessarily represent those of Orchestream Ltd or its group of companies
unless otherwise specifically stated.

---

From: "Da Silva, Pedro" <[email-masked]>
Date: Wed, 30 May 2001 17:21:53 +0100

The problem with adding the IfName to the UNIQUENESS clause is that it leads
to duplicate information in the table.
Namely the relationship between roleCombo+direction and PathSart will be
duplicated for each IfName that has the same roleCombo+direction, as shown
in the example below.

Pedro

-----Original Message-----
From: Iliff, Tina [mailto:[email-masked]]
Sent: Wednesday, May 30, 2001 5:05 PM

--Tina Iliff

-----Original Message-----
From: Da Silva, Pedro [mailto:[email-masked]]
Sent: Wednesday, May 30, 2001 8:18 AM

cheers,
Pedro