Subject: RE: Charter questions

From: "Durham, David" <[email-masked]>
Date: Tue, 22 Jan 2002 14:35:28 -0800

> -----Original Message-----
> From: Bernard Aboba [mailto:[email-masked]]
> 
> > I think if you check the archive, there have been a number 
> of presentations
> > to the AAA WG on  the subject of the Bind PIB.
> 
> I have checked the IETF AAA WG proceedings. There was a 
> presentation from
> the AAARCH folks on data modelling, but none on the Bind PIB, 
> as far as I
> can tell. Can you provide more information on the meetings at 
> which this
> presentation was made? 
> 
[Dave] Yes, modeling was the one I recall. You are correct that this is not
the Bind PIB. However, the Bind PIB makes use of data modeling to achieve
its multi-protocol integration of resource allocation.

> > Likewise some of the authors would appear to be AAA people. 
> 
> Ah... the people involved were from AAARCH IRTF WG, *not* the 
> AAA WG. Was
> the Bind PIB perhaps presented in AAARCH? 
> 
> > So clearly the AAA WG should be aware of this work. 
> 
> I think you mean AAARCH IRTG WG, not AAA WG, right? 
> 
[Dave] Perhaps. Are these people somehow scorned by the AAA WG? Seems to me
there is participation in both.

> > As I recall (from being in the AAA audience when one of these
> > presentations were given) the work in question was 
> determined to be outside
> > the scope of that WG... 
> 
> Check the proceedings again. No such decision was made -- the WG
> did decide not to *mandate* support for data modelling, but left open
> including optional data modelling support, and encouraged further
> refinement of the SMIng proposals. 
> 
[Dave] The AAA WG choice to go with a flat AVP model precludes a data model
approach. These are two very different/contrary methodologies, and the WG is
currently proceeding with the former.

> > Juergen gave some
> > presentations and submitted an ID exactly to this end. This too was
> > determined to be out-of-scope and unrealistic from their time-line
> > perspective.
> 
> It wasn't determined to be out of scope -- the WG just decided not to
> mandate support for it. 
> 
[Dave] I do not understand how to interpret this statement.

---

From: Bernard Aboba <[email-masked]>
Date: Tue, 22 Jan 2002 14:45:50 -0800 (PST)

> there is participation in both.

The charters of AAARCH IRTF WG and AAA WG are very different, as are the
work items. Quite a few people go to both. But making a proposal to one
group does not automatically guarantee consideration by the
other. Although they both meet at IETF, the same people go to both, and
both publish RFCs, one is an IRTF WG and the other is an IETF WG. 

> [Dave] I do not understand how to interpret this statement. 

Juergen was encouraged to further develop the proposal, for inclusion as
an optional element. It was also discussed how alternate encodings might
be used for AVPs such as the QoS AVP.