Subject: Question on Encoding Framework Filters

From: Muralidhar S <[email-masked]>
Date: Thu, 24 Jan 2002 15:01:35 +0530

Hi,

We have some questions regarding the encoding of extend classes defined in
the
Framework Pib.

In draft-ietf-rap-frameworkpib-06.txt,  "frwkIpFilterEntry" extends
"frwkBaseFilterEntry".
What method should PDP use to create an instance of "frwkIpFilterEntry"?

1) Treat "frwkIpFilterEntry" and "frwkBaseFilterEntry" as a single object
and create
    single PRI. In this case PDP will download a single PRI for the filter.
OR

2) First create "frwkBaseFilterEntry" and then create "frwkIpFilterEntry".
    In this case PDP will download 2 PRI for a single filter, one PRID and
EPD for 
    "frwkBaseFilterEntry" followed by PRID and EPD for "frwkIpFilterEntry"
with 
    PRID for "frwkIpFilterEntry" having the InstanceId same as base entry?

murali
________________________
WebSpectrum Software Pvt. Ltd,                 
http://www.wsspl.com
________________________

---

From: "Bell, Carol A" <[email-masked]>
Date: Thu, 24 Jan 2002 07:15:48 -0800

Murali,

Method 2 is correct.

--Carol

-----Original Message-----
From: Muralidhar S [mailto:[email-masked]]
Sent: Thursday, January 24, 2002 1:32 AM
To: RapWG (E-mail)
Subject: Question on Encoding Framework Filters

Hi,

murali
________________________