Subject: A question about SPPI

From: <[email-masked]>
Date: Mon, 28 Jan 2002 14:08:11 -0500

In a PIB table, some attributes can be optional. Should the UNIQUENESS clause exclude optional attributes? In other words, can a UNIQUENESS clause contain any optional attributes?

Man Li

---

From: "Sahita, Ravi" <[email-masked]>
Date: Wed, 30 Jan 2002 15:50:17 -0800

Man Li,

The UNIQUENESS clause itself is optional. The SPPI does
not put any constraints on which attributes can be specified
in this clause other than - 
1.  The attribute named in the PIB-INDEX clause may not be 
    present in the UNIQUENESS clause.  
2. An attribute may not appear more than once in a UNIQUENESS 
   clause. 

So, yes, the UNIQUNESS clause can contain optional attributes
as long as it follows the rules above.

Hope that helps,
Ravi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, January 28, 2002 11:08 AM
To: [email-masked]
Subject: A question about SPPI

In a PIB table, some attributes can be optional. Should the UNIQUENESS
clause exclude optional attributes? In other words, can a UNIQUENESS clause
contain any optional attributes?

Man Li

---

From: "Sahita, Ravi" <[email-masked]>
Date: Thu, 31 Jan 2002 08:46:09 -0800

Pedro,

The notion of optional attributes is specific to the PIB PRC usage, 
and depending on that may or may not warrant inclusion of these 
attributes in the UNIQUENESS clause. 

If you have the case where a PRCs UNIQUENESS clause is composed of 
optional attributes only, that set may not give you a sufficient 
set to identify an instance uniquely, in which case the UNIQUENESS 
clause should be empty.

Cheers,
Ravi

-----Original Message-----
From: Da Silva, Pedro [mailto:[email-masked]] 
Sent: Thursday, January 31, 2002 3:08 AM
To: [email-masked]
Subject: RE: A question about SPPI

Man, Ravi,

The uniqueness clause also states that "The specified set of attributes
provide a necessary and sufficient set of values by which to identify an
instance of this PRC". As such does an optional attribute constitute a
necessary one for UNIQUENESS clauses? Also, considering the case where a
UNIQUENESS clause's set is composed of optional attributes only, does that
constitute a sufficient set by which to identify an instance of the PRC?

cheers,
Pedro

-----Original Message-----
From: Sahita, Ravi [mailto:[email-masked]]
Sent: Wednesday, January 30, 2002 11:50 PM
To: [email-masked]'; [email-masked]
Subject: RE: A question about SPPI

Man Li,

So, yes, the UNIQUNESS clause can contain optional attributes as long as it
follows the rules above.

Hope that helps,
Ravi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, January 28, 2002 11:08 AM
To: [email-masked]
Subject: A question about SPPI

Man Li